[hardy] Intel audio sounds awful

Bug #178504 reported by Alex Wauck on 2007-12-24
14
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I have the following Intel sound chipset:
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

It worked quite well under Gutsy, but it now sounds awful. The sound is "gravelly" or "staticy." Pure tones (generated by a gstreamer pipeline) sound fine, but others, like the "Experience Ubuntu" example video, sound awful. Might it have something to do with PulseAudio? I tried forcing mplayer to use ALSA and OSS, but I'm not sure if that will really make it bypass PulseAudio.

Alex Wauck (awauck) wrote :

Judging from /var/log/messages, it looks like the PulseAudio daemon cannot run with run with real-time scheduling because I am not in the pulse-rt group and PolicyKit won't give the daemon the necessary privileges. I will try adding myself to the pulse-rt group and see if that fixes it. The specific message (repeated quite a bit) is:

Dec 24 15:43:51 wasp pulseaudio[15121]: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
Dec 24 15:43:51 wasp pulseaudio[15121]: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit priviliges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
Dec 24 15:44:01 wasp pulseaudio[15132]: main.c: Called SUID root and real-time/high-priority scheduling was requested in the configuration. However, we lack the necessary priviliges:

Alex Wauck (awauck) wrote :

No luck. I now get

Dec 24 16:07:53 wasp pulseaudio[7210]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
Dec 24 16:07:53 wasp pulseaudio[7210]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted

Alex Wauck (awauck) wrote :

Here's one more thing I've tried: I stopped the pulseaudio daemon with pactl exit and played a sound file using mplayer -ao alsa, and it still sounds bad. I have confirmed that pulseaudio is not running when I run mplayer in this way. So, I suspect this is an ALSA regression, not necessarily a pulseaudio problem.

Alex Wauck (awauck) wrote :

Audio is fine on a fresh install of Alpha 2 on an ICH6 chipset, so this is definitely an ALSA problem.

Bossieman (leifsandvik) wrote :

I have a 00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03) and had to compile ALSA from source to get sound i Gutsy. No sound in HH alpha 2.

don hardaway (don-hardaway) wrote :

I have the same Intel 82801H also and no sound at all.

Alex Wauck (awauck) wrote :

I "fixed" my problem. If PCM is set higher than 47%, it's actually amplified (according to alsamixer). If I keep it a 0dB or less, then I can set Master as high as I want, and audio is great. Bossieman and don, check all your channels.

Alex Wauck (awauck) wrote :

Update: sound still sucks in AlienArena. I don't know if it's pushing PCM too high or what, but I never had issues with PCM on Gutsy.

Thom Pischke (thom-pischke) wrote :

Same card, absolutely no sound after upgrade to hardy, all was well on gutsy. Have a Dell Inspiron 1420n.

Thom Pischke (thom-pischke) wrote :

Full info from lspci on my audio card: 00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

Thom Pischke (thom-pischke) wrote :

Totem appears to just hang trying to play audio files. Gxine and VLC will play them, but no sound is produced.

Alex Wauck (awauck) wrote :

Update: it looks like setting PCM to 47% only make the problem less pronounced. It's still there.

Thom Pischke (thom-pischke) wrote :

After this morning's fresh boot, sound is now working with Flash and VLC. Totem still hangs but that's looking to be more an issue with totem than the sound architecture. Quality seems ok, even with PCM at 100% so I guess my comments in this issue can be disregarded.

don hardaway (don-hardaway) wrote :

I have the latest updates for Hardy and still no sound on my MBP.

Bossieman (leifsandvik) wrote :

Still no sound on my Zepto 6224W.
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
This card is very common on new laptops and I dont understand why it still doesnt work?

Typhoe (spamistrash) wrote :

Hi,

no sound at all on my notebook.
 lspci |grep Audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

It is a Lenovo Thinkpad R61.

In Gutsy, I can get sound after unmuting the sound and setting the volume controler to use the PCM and not the Microphone (which is the default after a fresh install)

In Hardy, I can't get any sound at all...

Regards.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in linux which provides the kernel for Hardy Heron.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Could you please add the output requested in the Reporting Sound Bugs section of https://wiki.ubuntu.com/DebuggingSoundProblems as separate attachments? Thanks in advance.

Changed in linux:
status: New → Incomplete
Typhoe (spamistrash) wrote :

Hi,

problem fixed for me in hardy now.

I still have to change the detected the sound device to be able to set the sound volume, but I have sound again.

Regards

Alex Wauck (awauck) wrote :

It seems to be fixed for me, too.

Alex Wauck (awauck) wrote :

Sound is fine for me. If anyone still has trouble, file another bug.

Changed in linux:
status: Incomplete → Fix Released
Artemis3 (artemis3) wrote :

No, this bug is still around. On a fresh install, it might sound fine. Messing with alsa and the sound mixer eventually turns this problem and its hell trying to set it right again.

I am sure there is a problem with alsa and alc861 and other "Intel HDA" chipsets.

Somewhere sound amplification (headphone mode?) is turned on, causing overdrive distortion (this should be a simple switch).

Playing with options for the snd-hda-intel module, and moving all the sliders and switches in the mixer (oss mode, because, alsamixer refuses to work) eventually fixes it, but its hard to find and many times i have failed and decided to reinstall alsa and pulseaudio. In fact i installed/uninstalled pulseaudio so many times it fails to work anymore...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers