Bluetooth: Redpine: Bionics: L2test transfer is failed to start in Ubuntu 18.04

Bug #1781895 reported by Siva Rebbagondla
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Bionic
Medium
Unassigned
linux-oem (Ubuntu)
Medium
Unassigned
Bionic
Undecided
Unassigned

Bug Description

SRU Justification
-----------------

Impact:
-------
     Bluetooth l2test is not getting started with rsi driver.

Test Case:
----------
     1. Insert redpine modules with dev_oper_mode=13/4/5/6/14.

     2. Check bluetooth device is created or not.
        $ hciconfig -a

     3. Insert other thirdparty module to run l2test.

     4. Enable piscan for both interfaces
        $ hciconfig -a hci0 piscan # lets say, hci0 is created for Redpine
        $ hciconfig -a hci1 piscan # lets say, hci1 is created for thirdparty BT device

     5. Open two terminals and then, start l2test with below commands.
        Terminal 1: Keep rsi module is in Transmit mode.
           $ l2test -i hci0 -s <hci1 BD address>
        Terminal 2: Keep third party device is in receive mode
           $ l2test -i hci1 -r

     6. l2test will not run and will fail after few seconds

Fix:
----
    skb->data is having some extra bytes rather than expected size , which is Incorrect. Hence, removed redundant bytes from skb using skb_trim().

Regression petential:
---------------------
    Ran L2test for 2 hours and didn't see any issue.

summary: - Bluetooth: Redpine: L2test transfer is not getting started
+ Bluetooth: Redpine: L2test transfer is failed to start
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1781895

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
summary: - Bluetooth: Redpine: L2test transfer is failed to start
+ Bluetooth: Redpine: Bionics: L2test transfer is failed to start in
+ Ubuntu 18.04
Revision history for this message
Joseph Salisbury (jsalisbury) wrote :
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Changed in linux (Ubuntu Bionic):
status: New → Triaged
importance: Undecided → Medium
Changed in linux (Ubuntu):
importance: Undecided → Medium
Changed in linux-oem (Ubuntu):
status: New → Confirmed
Changed in linux-oem (Ubuntu):
importance: Undecided → Medium
Revision history for this message
AceLan Kao (acelankao) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic
tags: added: verification-done-bionic
removed: verification-needed-bionic
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-oem - 4.15.0-1017.20

---------------
linux-oem (4.15.0-1017.20) bionic; urgency=medium

  * linux-oem: 4.15.0-1017.20 -proposed tracker (LP: #1787544)

  * Bluetooth: Redpine: Bionics: L2test transfer is failed to start in Ubuntu
    18.04 (LP: #1781895)
    - SAUCE: Bluetooth: btrsi: fix l2test data transfer issue

  * [Redpine] Upgrades to improve throughput and stability (LP: #1782070)
    - SAUCE: rsi: Fix for low throughput issue
    - SAUCE: rsi: Set wowlan flag while writing wowlan config parameters
    - SAUCE: rsi: Add debug support for wowlan wakeup confirmation
    - Bluetooth: btrsi: rework dependencies
    - rsi: fix error path handling in SDIO probe
    - rsi: Add null check for virtual interfaces in wowlan config
    - SAUCE: rsi: Fix for wowlan hibernate resume issue
    - SAUCE: rsi: Firmware assert (version 2)
    - SAUCE: rsi: Fix for WoWLAN wakeup in security mode.
    - SAUCE: rsi: Optimizing virtual interfaces
    - SAUCE: rsi: disable p2p device mode support

 -- Chia-Lin Kao (AceLan) <email address hidden> Fri, 17 Aug 2018 15:53:57 +0800

Changed in linux-oem (Ubuntu Bionic):
status: New → Fix Released
Changed in linux-oem (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers