Hardy 2.6.24-2.4 Freezes during Qemu Boot

Bug #178170 reported by Matt T. Proud on 2007-12-22
8
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I found while working with a Hardy install in Qemu 0.8.0-3ubuntu1 that the new Linux kernel 2.6.24-2.4 hangs on boot. The last two printks are ``Starting up ...'' and ``[0.000000] ACPI: no DMI BIOS year, acpi=force is required to enable ACPI.''

The interesting thing is that Hardy's early 2.6.22-14.46 kernel still boots fine.

If I have any additional details, I will include them.

Thank you for your report and helping to make Ubuntu better. Is your BIOS up to date? Also, care to maybe try booting with both "acpi=force" and if that doesn't help maybe try the exact opposite "acpi=off" ? Thanks.

Changed in linux:
status: New → Incomplete
Leonel Nunez (leonelnunez) wrote :

with today's update hardy's kernel 2.6.24-3
this is where it hangs but works with kernel 2.6.22-14

Hardy Alpha1 was actually released with the kernel from Gutsy. Alpha2 and subesquent releases have the newer 2.6.24 target. Can you comment if you tried any of the boot parameters?

I can confirm that neither acpi kernel boot parameters have any effect. I tried this again against 2.6.24-5-generic today.

Edward Betts (edwardbetts) wrote :

I was seeing this bug with earlier versions of hardy, but alpha 4 (http://cdimage.ubuntu.com/releases/hardy/alpha-4/hardy-desktop-i386.iso) boots fine under qemu, no oops.

RussNelson (nelson-crynwr) wrote :

Using the qemu in Feisty (1:0.9.1-0oh2feisty1) and attempting to boot Hardy beta (presumably the first beta because it has no number) gets to the graphical Ubuntu screen, with the cylon progress bar, then it clears the screen and prompts me with a busybox prompt (initramfs).

Here's the command line I'm using:
sudo qemu -cdrom ubuntu-8.04-beta-desktop-i386.iso /d2/x86-ubuntuhardy

I created the disk image using:
sudo qemu-img create /d2/x86-ubuntuhardy 40G

If I exit busybox, it starts right back up again.

Changed in linux:
status: Incomplete → New

Hi Russ,

Care to open a new bug report. It seems you are using a different version of Qemu as well as getting a different error than what the original bug reporter had.

Matt, can you comment if this is still an issue for you? Edward had commented that this was resolved after Hardy Alpha 4. Thanks.

Changed in linux:
status: New → Incomplete
Jonathan Thomas (echidnaman) wrote :

We are closing this bug report because it was reported fixed, as described in the previous comments. Please reopen it if you can still reproduce this bug, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers