coping files to cifs mounted directory causes general protection fault

Bug #1777364 reported by Martin Barlow on 2018-06-17
60
This bug affects 11 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

How to reproduce:

Copy some large files from local filesystem to CIFS mounted filesystem. After some gigabytes, it syslog will show "general protection fault" and mounted file system will become unresponsive.

How often does it occur:

Every time, after a few minutes or so.

Affected kernels:

Bionic 4.15.0-23-generic and forward. I also tried 4.15.18-041518-generic and 4.16.13-041613-generic from ubuntu archives an got similar GPF.
4.13.0-43-generic from ubuntu 17.10 not affected.

More information:

I have kerberos authenticated, autofs mounted, cifs
Mounted with:
type cifs (rw,relatime,vers=default,sec=krb5,cache=strict,username=root,uid=1100,forceuid,gid=0,noforcegid,addr=192.168.50.2,file_mode=0755,dir_mode=0755,soft,nounix,serverino,mapposix,rsize=1048576,wsize=1048576,echo_interval=60,actimeo=1)

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: linux-image-4.15.0-23-generic 4.15.0-23.25
ProcVersionSignature: Ubuntu 4.15.0-23.25-generic 4.15.18
Uname: Linux 4.15.0-23-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: mbarlow 2249 F.... pulseaudio
CurrentDesktop: GNOME
Date: Sun Jun 17 23:14:02 2018
DistributionChannelDescriptor:
 # This is a distribution channel descriptor
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-xenial-amd64-20160624-2
HibernationDevice: RESUME=UUID=25088f17-7123-46c8-bda4-362bcd9f986e
InstallationDate: Installed on 2017-11-26 (203 days ago)
InstallationMedia: Ubuntu 16.04 "Xenial" - Build amd64 LIVE Binary 20160624-10:47
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 0c45:670c Microdia
 Bus 001 Device 002: ID 0cf3:e300 Atheros Communications, Inc.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. XPS 13 9360
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-23-generic root=UUID=69170b9c-88cc-4e5b-83a8-c6a01d7b738b ro quiet splash vt.handoff=1
RelatedPackageVersions:
 linux-restricted-modules-4.15.0-23-generic N/A
 linux-backports-modules-4.15.0-23-generic N/A
 linux-firmware 1.173.1
SourcePackage: linux
UpgradeStatus: Upgraded to bionic on 2018-04-27 (51 days ago)
WifiSyslog:

dmi.bios.date: 02/26/2018
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 2.6.2
dmi.board.name: 06CC14
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr2.6.2:bd02/26/2018:svnDellInc.:pnXPS139360:pvr:rvnDellInc.:rn06CC14:rvrA00:cvnDellInc.:ct9:cvr:
dmi.product.family: XPS
dmi.product.name: XPS 13 9360
dmi.sys.vendor: Dell Inc.

Martin Barlow (martin-barlow) wrote :
Martin Barlow (martin-barlow) wrote :

GPF syslog attached.

Martin Barlow (martin-barlow) wrote :

client libraries of samba are 2:4.7.6+dfsg~ubuntu-0ubuntu2

description: updated

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.17 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.18-rc1

tags: added: kernel-da-key
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Martin Barlow (martin-barlow) wrote :

I grabbed the latest 4.18.0-041800rc1 and recreated it quickly

I attach the output from syslog. Let me know what else i can provide to be of assistance.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-bug-exists-upstream
Frits Jalvingh (fjalvingh) wrote :

Could be related to something in here:

https://bugs.archlinux.org/task/57474

Adding vers=1.0 in the mount line seems to fix the issue.

Martin Barlow (martin-barlow) wrote :

Nice catch. Thank you.

This indeed does seem to be a workaround. Forcing version 1.0 avoids the issue. Its not a proper fix however. Seems to be bug in higher versions.

From the man doc:

The default since v4.13.5 is for the client and server to negotiate the highest possible version greater than or equal to 2.1. In kernels prior to v4.13, the default was 1.0. For kernels between v4.13 and v4.13.5 the default is 3.0.

Moppers (moppers) wrote :

I just ran into this today.

The workaround only sort of works, because some of our newer devices don't support 1.0 out of the box for security reasons.

As this affects security I consider this of greater than "medium" importance.

Martin Barlow (martin-barlow) wrote :

I forced version 2.1 and i did NOT reproduce issue. I also forced 3.0 again, and issue occurred again.

So, it seems forcing 2.1 may also be workaround.

Martin Barlow (martin-barlow) wrote :

Actually, it just reoccurred on 2.1, then i dropped back to 2.0 and it reoccurred. Now back on 1.0 again.

zorlax (zorlax) wrote :

I've filed the same bug here, https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1811723 . Didn't find this one because I searched for the wrong terms, sorry about the duplicate.

On a personal note I'd like to add that I'm surprised this doesn't affect more people and even more so that it hasn't been fixed yet. I would have thought that being able to copy files, large and small, to and from a file-server was a pretty common usecase and a fundamental function in any OS.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
zorlax (zorlax) wrote :

Out of curiosity, for those affected by this how much RAM is there in your machines? My machine that crashes has 4GB but a machine at work also running bionic with ehem 128GB doesn't. That said samba behaves strange on it, sometimes file transfers just stop for no apparent reason.

Brad Figg (brad-figg) on 2019-07-24
tags: added: ubuntu-certified
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.