Temporal dithering and impaired graphical performance started appearing on Intel HD 530 graphics

Bug #1776642 reported by Patrick Wigmore on 2018-06-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I am experiencing a regression in linux-image-generic-hwe-16.04 with Intel HD Graphics 530 (Core i5-6600T), starting in 4.13.0-43 (considering only kernels which appear in my GRUB menu).

Some form of spatio-temporal dithering has been enabled. This is causing a shimmering effect and visible dithering patterns (like woven textile) which are noticeable on photographs and areas of similar colour. 1px borders in the UI can appear to have a "marching ants" effect.

The effect is visible under Xorg if the displayed colours are suitable to trigger it.

The effect is also visible in a virtual console (Ctrl+Alt+F1) if suitable colours are displayed, but it seems that the presence of the effect in virtual consoles predates its appearance under Xorg and the reporting of this bug, going back at least as far as 4.13.0-31, but with no reason to believe it does not go back further (besides lack of testing).

Reverting from 4.13.0-43 by booting 4.13.0-41 eliminates the temporal dithering in Xorg.

This occurs on a (presumed) 6bpp laptop LCD panel, so dithering is necessary, but in previous kernels only a form of spatial dithering is applied, which is less visually obvious.

Concurrent with the temporal dithering, I have also noticed general poor graphical performance with the affected kernels. E.g. 50fps and 60fps video playback is choppy, sometimes slow redraw and other graphical glitches on UI elements. Like the temporal dithering, these additional problems disappear if I revert to 4.13.0-41.
---
ApportVersion: 2.20.1-0ubuntu2.18
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: patrick 1976 F.... pulseaudio
DistroRelease: Ubuntu 16.04
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=72e179a8-b27c-42d3-9523-8f1cceacaa64
InstallationDate: Installed on 2016-09-16 (634 days ago)
InstallationMedia: Kubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
MachineType: PC Specialist Limited N350DW
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-45-generic root=UUID=deeef076-c1e1-47ec-8ee4-d3b56fa179f9 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 4.13.0-45.50~16.04.1-generic 4.13.16
RelatedPackageVersions:
 linux-restricted-modules-4.13.0-45-generic N/A
 linux-backports-modules-4.13.0-45-generic N/A
 linux-firmware 1.157.19
Tags: xenial xenial
Uname: Linux 4.13.0-45-generic x86_64
UnreportableReason: The report belongs to a package that is not installed.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lp lpadmin plugdev sambashare sudo vboxusers
_MarkForUpload: False
dmi.bios.date: 05/26/2016
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 5.11
dmi.board.asset.tag: Tag 12345
dmi.board.name: N350DW
dmi.board.vendor: CLEVO
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr5.11:bd05/26/2016:svnPCSpecialistLimited:pnN350DW:pvrNotApplicable:rvnCLEVO:rnN350DW:rvrNotApplicable:cvnNoEnclosure:ct10:cvrN/A:
dmi.product.family: Not Applicable
dmi.product.name: N350DW
dmi.product.version: Not Applicable
dmi.sys.vendor: PC Specialist Limited

summary: - Temporal dithering started appearing on Intel HD 540 graphics
+ Temporal dithering started appearing on Intel HD 530 graphics

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.17 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.17

affects: linux-hwe (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: artful kernel-da-key
tags: added: needs-bisect

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1776642

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected xenial
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

I can confirm that the temporal dithering is present when running mainline kernel 4.17.0-041700-generic.

tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Concurrent with the temporal dithering, I have also noticed general poor graphical performance with the affected kernels. E.g. 50fps and 60fps video playback is choppy, sometimes slow redraw and other graphical glitches on UI elements. Like the temporal dithering, these additional problems disappear if I revert to 4.13.0-41.

description: updated
summary: - Temporal dithering started appearing on Intel HD 530 graphics
+ Temporal dithering and poor graphical performance started appearing on
+ Intel HD 530 graphics
summary: - Temporal dithering and poor graphical performance started appearing on
- Intel HD 530 graphics
+ Temporal dithering and impaired graphical performance started appearing
+ on Intel HD 530 graphics

In 4.15.0-25-generic, the symptoms have changed. The objectionable temporal dithering persists in virtual terminals (e.g. Ctrl+Alt+F1) but under KDE Plasma 5 it has disappeared or become imperceptible, and high fps video playback is no longer choppy.

However, with this kernel, the blurring effect applied to semi-transparent Plasma widget backgrounds has stopped working (replaced with opaque background).

Under 4.18-rc3 from http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.18-rc3/ the symptoms appear identical to those under 4.15.0-25-generic.

I tested mainline 4.17, 4.17.2, 4.17.3, 4.17.4 and 4.18-rc2 from the kernel.ubuntu.com, which all displayed the original symptoms reported for this bug.

Correction/clarification: Previously, I failed to test whether the temporal dithering appeared in virtual consoles under 4.13.0-41. I only tested to see whether it affected virtual consoles on kernels where it also affected X. It turns out that the dithering has always been present in virtual consoles at least as far back as 4.13.0-31, but it did not appear under X until 4.13.0-43. I will amend the bug description to reflect this.

The issue with semi-transparent backgrounds in Plasma widgets may be unrelated, as this is now appearing under all kernels I've tried booting.

description: updated
description: updated

So, to summarise, the bug in regard to Xorg seems to be fixed in 4.15.0-25 and in 4.18-rc3. The bug appears to have always been present under virtual terminals (only tested as far back as 4.13.0-31.

I've marked this bug as fix released since that appears to be the case.
The issues I mentioned regarding semi-transparent backgrounds seem to be an unrelated bug #1780664 in mesa.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Paul F (pf1985) wrote :

Question link > https://askubuntu.com/questions/1190609/eye-strain-and-nausea-when-running-18-04-1-on-intel-i915-graphics

I have eye strain and headaches using Ubuntu which I believe is caused by temporal dithering being enabled. I have posted on AskUbuntu and it was suggested I update this bug report with some information.

*-display
       description: VGA compatible controller
       product: Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 12
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:26 memory:fb800000-fbbfffff memory:d0000000-dfffffff ioport:dc00(size=8) memory:c0000-dffff

Linux paul-Aspire-X3950 5.0.0-36-generic #39~18.04.1-Ubuntu SMP Tue Nov 12 11:09:50 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 12)

I would like the option to turn dithering off. I believe this can be performed using xrandr on Nvidia cards however no such solution is available for Intel.

Paul F, if you think you have found a bug, then you need to make a new, separate bug report under a new bug number, because your hardware is different and you are not discussing a regression in kernel 4.13.0-43, which is what this particular bug was about.

Here are some instructions for reporting kernel bugs in Ubuntu: https://wiki.ubuntu.com/Kernel/Bugs

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers