Intel 9462 bluetooth and wifi doesn't work

Bug #1776376 reported by guodi on 2018-06-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Besides the issue mentioned above,the keyboard is not completely suitable.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: linux-image-4.4.0-21-generic 4.4.0-21.37 [modified: boot/vmlinuz-4.4.0-21-generic]
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.18
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gjd 1940 F.... pulseaudio
CurrentDesktop: Unity
Date: Tue Jun 12 10:33:31 2018
HibernationDevice: RESUME=UUID=a93c190f-117c-44c6-8595-37cc0499c28b
InstallationDate: Installed on 2018-06-11 (0 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
IwConfig:
 enp3s0 no wireless extensions.

 lo no wireless extensions.
MachineType: Dell Inc. G3 3579
ProcFB: 0 EFI VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic.efi.signed root=UUID=7b8b7532-3642-4369-bfeb-04208cf72efc ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-4.4.0-21-generic N/A
 linux-backports-modules-4.4.0-21-generic N/A
 linux-firmware 1.157.19
RfKill:

SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/25/2018
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.1.0
dmi.board.name: 0JYXHN
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 10
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.1.0:bd05/25/2018:svnDellInc.:pnG33579:pvr:rvnDellInc.:rn0JYXHN:rvrA00:cvnDellInc.:ct10:cvr:
dmi.product.name: G3 3579
dmi.sys.vendor: Dell Inc.

guodi (guodi) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
AceLan Kao (acelankao) wrote :

9462 is a new chip and requires a bunch of patches which are in v4.12+
It's not possible to backport those patches to v4.4 kernel, so please upgrade your kernel to v4.15 and update to the latest linux-firmware package.

guodi (guodi) wrote :

Because of my academy,I have to stay at the platform Ubuntu 16.04 or older,upon which how could I upgrade kernel to v4.15 and update to the latest linux-firmware? What's your opinion? Thanks for your reply.

guodi (guodi) wrote :

I updated to kernel 4.15.0.23 and upgraded to firmware 1.157.19,but wireless network and bluetooth does still not work,so did the ethernet.I need your help.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers