Console blanking is not enabled by default in Ubuntu Server 18.04

Bug #1767568 reported by David R. Bergstein on 2018-04-28
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

My console display is DPMS capable, i.e., power management functions worked before upgrading from Ubuntu Server 16.0.4.4. Currently the display stays on 24x7 with idle keyboard input.

1) My release information is as follows:

Description: Ubuntu 18.04 LTS
Release: 18.04

2) I am not sure what package this issue is tied to. The current kernel appears to have DPMS support enabled, per the configuration file in /boot. If the kernel is responsible, below is the version I am running.

linux-generic:
Installed: 4.15.0.20.23

3) I expected to have DPMS support for my console as in the previous release of Ubuntu Server.

4) What happened instead is my monitor stays on all the time, without DPMS controlling it.
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version k4.15.0-20-generic.
AplayDevices: Error: [Errno 2] No such file or directory: 'aplay': 'aplay'
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord': 'arecord'
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/hwC1D3', '/dev/snd/hwC1D2', '/dev/snd/hwC1D1', '/dev/snd/hwC1D0', '/dev/snd/pcmC1D9p', '/dev/snd/pcmC1D8p', '/dev/snd/pcmC1D7p', '/dev/snd/pcmC1D3p', '/dev/snd/controlC1', '/dev/snd/by-path', '/dev/snd/hwC0D2', '/dev/snd/pcmC0D2c', '/dev/snd/pcmC0D1c', '/dev/snd/pcmC0D1p', '/dev/snd/pcmC0D0c', '/dev/snd/pcmC0D0p', '/dev/snd/controlC0', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
Card0.Amixer.info: Error: [Errno 2] No such file or directory: 'amixer': 'amixer'
Card0.Amixer.values: Error: [Errno 2] No such file or directory: 'amixer': 'amixer'
Card1.Amixer.info: Error: [Errno 2] No such file or directory: 'amixer': 'amixer'
Card1.Amixer.values: Error: [Errno 2] No such file or directory: 'amixer': 'amixer'
DistroRelease: Ubuntu 18.04
HibernationDevice: RESUME=UUID=ab9de6b4-cca0-4e5c-89d7-e706214c8f11
InstallationDate: Installed on 2014-07-23 (1378 days ago)
InstallationMedia: Ubuntu-Server 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.2)
MachineType: Gigabyte Technology Co., Ltd. X58A-UD5
Package: linux (not installed)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 nouveaufb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.15.0-20-generic root=UUID=5631d3aa-8dce-4306-a08d-4ab3753256ab ro
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
RelatedPackageVersions:
 linux-restricted-modules-4.15.0-20-generic N/A
 linux-backports-modules-4.15.0-20-generic N/A
 linux-firmware 1.173
RfKill: Error: [Errno 2] No such file or directory: 'rfkill': 'rfkill'
Tags: bionic apport-hook-error
Uname: Linux 4.15.0-20-generic x86_64
UnreportableReason: This report is about a package that is not installed.
UpgradeStatus: Upgraded to bionic on 2018-04-26 (4 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: False
dmi.bios.date: 03/11/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F5
dmi.board.name: X58A-UD5
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF5:bd03/11/2010:svnGigabyteTechnologyCo.,Ltd.:pnX58A-UD5:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnX58A-UD5:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: X58A-UD5
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1767568/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → linux (Ubuntu)
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.16 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.17-rc3

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: kernel-da-key
David R. Bergstein (dbergst) wrote :

Per the previous entry, I have retested for this issue with upstream kernel 4.16.6-041606-generic. No change in DPMS behavior was observed, i.e., power save for the monitor does not seem to be enabled.

tags: added: kernel-bug-exists-upstream

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1767568

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: bionic

After running the apport-collect command I was unable to log in to launchpad from the text based browser running on the server. If someone can advise how I can manually collect the desired logs I would be happy to post them.

apport information

tags: added: apport-collected apport-hook-error
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

After revisiting this issue I was able to find a solution, via the setterm command. This is based on the guidance posted at https://superuser.com/questions/152347/change-linux-console-screen-blanking-behavior

For my system I created a new file in /etc/rc.local with the following contents:

#!/bin/bash
setterm -blank 5

Followed by the following command to register rc.local in systemd:

sudo systemctl enable rc.local

Alternatively, I could have set a boot parameter:
consoleblank=Y (Y in seconds, 0 to disable) to the kernel commandline by adding it to the parameter lists in /etc/default/grub, either GRUB_CMDLINE_LINUX or GRUB_CMDLINE_LINUX_DEFAULT

In any event console blanking does work now and this bug can probably be closed.

Ivan Baldo (ibaldo) wrote :

But DPMS is working for you?
Because it is not working for me...
The console gets blanked, but the monitor stays on unnecessarily.
Thanks for the info!

Lopess (lopess) wrote :

DPMS isn't working for me too on 18.04 x64 server (on 16.04 worked with no problem).

Lopess (lopess) on 2018-11-01
Changed in linux (Ubuntu):
assignee: nobody → Lopess (lopess)
assignee: Lopess (lopess) → nobody
Kai-Heng Feng (kaihengfeng) wrote :

What graphics do you use?

Hyacin75 (hyacin75) wrote :

I'm experiencing this same issue on a Dell 7577 (laptop), it has got a GTX 1060 MaxQ, but I believe the internal display (which is where I am experiencing and trying to resolve this same issue) is running off the Intel HD Graphics 630.

Hyacin75 (hyacin75) wrote :

Actually, my apologies, I am not (and I can't figure out how to edit my last comment, if it is possible) ...

I was in 18.04 Workstation with GUI disabled when I was adding consoleblank to GRUB_CMDLINE_LINUX_DEFAULT - that wasn't working at all in Server though, so I tried adding it to GRUB_CMDLINE_LINUX and I am AMAZED to see that the display is actually OFF for the first time in 3-4 weeks I've been fighting with all this. No issues here, please disregard my previous comment!

Hyacin75 (hyacin75) wrote :

As soon as I hit post on that last comment the display lit up again, so it's "blank" but not "off" - so I AM having the issue, and will stop spamming now, sorry.

Lopess (lopess) wrote :

The problem concerns ubuntu 18.04 and 17.10. My configuration - Ubuntu 18.04 x64 server running on ASUS P9D-E/4L (Aspeed AST2300). On 16.04 DPMS worked with no problem.

JoseStefan (josestefan) wrote :

The problem seems present in 19.04. My monitor stays ON, exactly as described in this bug.

And not much work seems to have been done on this bug?

Is the rc.local fix good enough for blanking, or actual monitor stand by?

Moe importantly, could we find exactly on what file or package 16.04 differs from 18.04 so we can revert, or improve the change properly.

I guess we might need to fine grain those change increments, to find which is the first Ubuntu version where this took place. 16.04 vs 16.10 vs 17.04 vs 17.10 vs 18.04

Does installing with live-server vs alternate have any effect on this?

Some of these questions are answered easily, and I guess I can start trying clean installs of various Ubuntu servers. too see which is the first to break. IDK when I'll start, so anyone is also welcome to do so.

JoseStefan (josestefan) wrote :

my First test:
Ubuntu 16.04.6 LTS, with all the updates
no HWE, might try that later.

So far it works fine. Some time after boot the monitor went to standby.

At one point, after using the arrow key to wake it up. It blanked but didn't go into standby, so the monitor was on but full black. I wonder if it was because the login prompt had some input? I could wake it up and login normally.

Then I logged out and waited, and it went to standby like it was supposed to. I quite haven't figured out what happened then

I have noticed that the /etc/kbd/config is present on 16.04, I believe it was missing on 18.04. I'm still digging further.

JoseStefan (josestefan) wrote :

Ubuntu 16.04.6 LTS + HWE
doesn't seem to do the DPMS

I'm testing it again, because I have to wait a lot between tests to be 100% sure.

I don't know the exact time for it to trigger, so I don't sit there waiting. I just reboot, go do something else, and check back after a while.

I won't report back on this configuration unless the results are different. Next test should be 16.10.

So far the issue seems kernel related? Maybe default build options?

And /etc/kbd/config seems to be for something else. The time configured there was 30 mins, I changed it to 1 minute and didn't get the results I expected.

JoseStefan (josestefan) wrote :

Summary of my tests
WORKS:
* Ubuntu 16.04.6 LTS (xenial), clean install and after updates as well
* Ubuntu 16.10 (Yakkety Yak), clean install and after updates as well

FAILS: (no DPMS)
* Ubuntu 16.04.6 LTS (xenial), with HWE kernel
* Ubuntu 17.04 (Zesty Zapus)

I tried some APT pinning to test kernel combinations:
WORKS:
* Ubuntu 17.04 (Zesty Zapus), with kernel from 16.10 using apt pinning.
FAILS:
* Ubuntu 16.10 (Yakkety Yak), with kernel from 17.04 using apt pinning.

So I'm convinced it's something in the kernel package. Could be the options the kernels are compiled with, or something upstream?

JoseStefan (josestefan) wrote :

The following "fix" seems to be the cause of this bug. Link below:
https://bugs.launchpad.net/ubuntu/+source/kbd/+bug/869017

Robie Basak (racb) on 2019-07-21
summary: - Console DPMS Nonfunctional in Ubuntu Server 18.04
+ Console DPMS is not enabled by default in Ubuntu Server 18.04

Thank you for taking the time to write this up and helping to make Ubuntu better.

As far as I understand, some of you consider this to be a matter of the default configuration shipped by Ubuntu, rather than kernel DPMS functionality itself not working when configured to do so.

Others seem to be reporting that kernel DPMS functionality does not work at all.

I'm unclear which is which, but the original reporter described this problem as solved in comment 24 and that was based on the default configuration, not on non-functional blanking as required when configured. On that basis, I'm marking this particular bug, as reported and suggested by the original reporter, as Invalid.

If you have a problem getting some specific blanking functionality to work *when configured to do so*, please file a new, separate bug for that, making it clear what you think isn't working (blanking or DPMS) and describing exactly how you have configured your system such that you believe it should work.

If you object to Ubuntu's *default configuration* as changed in the resolution to bug 869017, then please start a discussion on that on the mailing list (https://lists.ubuntu.com/mailman/listinfo/ubuntu-server) or on the community forum (https://community.ubuntu.com/c/server) and, following discussion, the Ubuntu Server Team will make a final decision on what the default should be (I'm claiming this decision for the Ubuntu Server Team since this is clearly a server question since it's outside the scope of Ubuntu Desktop). You can file a bug to have the default changed if you like, but since we already made the decision to change the default in bug 869017, we're only going to mark it Won't Fix pending further discussion as a decision was already previously made. Otherwise we'll just end up flip-flopping between defaults every release, which is clearly bad for everyone. The better approach would be to seek consensus considering both sides which would be better done in a general discussion and not a bug that presumes a conclusion by only considering one side of the discussion.

Robie Basak (racb) on 2019-07-21
Changed in linux (Ubuntu):
status: Confirmed → Invalid
Charles Wilkins (cg-chas) wrote :

To Robie Basak, specifically with regards to #37.

The title of this bug already specified particularly that Console DPMS is not working. This bug report already was not about simply console blanking.

I understand that the original reporter said that he got it working with setterm, but as by convention these bug reports often require verification from others in order to get any attention, it seems only reasonable that after many have said that the DPMS power saving is what is not working, while simple blanking and leaving the monitor on is what is currently happening, that this bug should not have been marked invalid.

As many others have pointed out, Console DPMS power saving is not working in 18.04. It is clear after reading this thread as well as a few basic tests with setterm that nobody has working Console DPMS power saving at all in Ubuntu 18.04.

If this is only a matter of default settings as you seem to have concluded that it is, then please specify which optional setting re-enables Console DPMS power saving, because the following does NOT work on any of my Ubuntu 18.04 installations (as well as several others in this bug report) beyond mere blanking and leaving the monitor on:

in grub.cfg
consoleblank=600

setterm --powersave powerdown
setterm --powerdown 10

If this is just a kernel option that is no longer the default setting, then it should be specified here, in this bug report, what the appropriate change is to revert back to a very mature working functionality.

Robie Basak (racb) wrote :

> I understand that the original reporter said that he got it working with setterm, but as by convention these bug reports often require verification from others in order to get any attention, it seems only reasonable that after many have said that the DPMS power saving is what is not working, while simple blanking and leaving the monitor on is what is currently happening, that this bug should not have been marked invalid.

I disagree. The reporter accidentally conflated DPMS with the intentional screen blanking change we made. This muddles every subsequent comment. As the reporter said that the problem was resolved, clearly it is the bug subject that was mistaken. The bug status is correct for the original problem the reporter had intended to report.

If instead you think the reporter thought they were reporting was actually something else, and the bug subject was correct, then I guess that's self-consistent and you're entitled to think that, but this is only going to lead to further confusion.

I suggest you file a separate bug if you think that there is a bug in DPMS. Please make sure to use an appropriate bug subject and a clear explanation in the bug description (steps to reproduce, expected behaviour, actual behaviour, etc) and then hopefully there will be clarity on exactly what you are reporting and then the community can determine the correct status of your issue as any outcome emerges.

summary: - Console DPMS is not enabled by default in Ubuntu Server 18.04
+ Console blanking is not enabled by default in Ubuntu Server 18.04
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers