Comment 0 for bug 1762693

When my computer boots with the most recent kernel 4.13.0-38-generic, I don't have a working network connection. ethtool reports that my network interface doesn't have a connection:

martin@dogmeat ~ % cat ethtool.txt
Settings for eth0:
        Supported ports: [ TP ]
        Supported link modes: 10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes: 10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Speed: Unknown!
        Duplex: Unknown! (255)
        Port: Twisted Pair
        PHYAD: 2
        Transceiver: internal
        Auto-negotiation: on
        MDI-X: Unknown (auto)
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000007 (7)
                               drv probe link
        Link detected: no

dmesg contains suspicious e1000e error messages:

martin@dogmeat ~ % tail -n 40 dmesg.txt
[ 20.211715] Could not find valid key in user session keyring for sig specified in mount option: [459a10809c211381]
[ 20.211716] One or more global auth toks could not properly register; rc = [-2]
[ 20.211717] Error parsing options; rc = [-2]
[ 25.824466] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
[ 25.969587] e1000e 0000:00:1f.6 eth0: changing MTU from 1500 to 1492
[ 30.034472] e1000e 0000:00:1f.6 eth0: changing MTU from 1492 to 1500
[ 35.808558] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
[ 35.939670] e1000e 0000:00:1f.6 eth0: changing MTU from 1500 to 1492
[ 40.037526] e1000e 0000:00:1f.6 eth0: changing MTU from 1492 to 1500
[ 46.048494] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
[ 46.263237] e1000e 0000:00:1f.6 eth0: changing MTU from 1500 to 1492
[ 51.022052] e1000e 0000:00:1f.6 eth0: changing MTU from 1492 to 1500
[ 51.244686] ahci 0000:00:17.0: port does not support device sleep
[ 56.800544] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
[ 56.935347] e1000e 0000:00:1f.6 eth0: changing MTU from 1500 to 1492
[ 61.036903] e1000e 0000:00:1f.6 eth0: changing MTU from 1492 to 1500
[ 67.040536] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
[ 67.199669] e1000e 0000:00:1f.6 eth0: changing MTU from 1500 to 1492
[ 72.038713] e1000e 0000:00:1f.6 eth0: changing MTU from 1492 to 1500
[ 78.048576] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
[ 78.170825] e1000e 0000:00:1f.6 eth0: changing MTU from 1500 to 1492
[ 83.038119] e1000e 0000:00:1f.6 eth0: changing MTU from 1492 to 1500
[ 88.800521] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
[ 88.938939] e1000e 0000:00:1f.6 eth0: changing MTU from 1500 to 1492
[ 93.021350] e1000e 0000:00:1f.6 eth0: changing MTU from 1492 to 1500
[ 99.040543] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
[ 99.163603] e1000e 0000:00:1f.6 eth0: changing MTU from 1500 to 1492
[ 104.038668] e1000e 0000:00:1f.6 eth0: changing MTU from 1492 to 1500
[ 110.048532] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
[ 110.191137] e1000e 0000:00:1f.6 eth0: changing MTU from 1500 to 1492
[ 115.022823] e1000e 0000:00:1f.6 eth0: changing MTU from 1492 to 1500
[ 120.800524] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
[ 120.910537] e1000e 0000:00:1f.6 eth0: changing MTU from 1500 to 1492
[ 125.019509] e1000e 0000:00:1f.6 eth0: changing MTU from 1492 to 1500
[ 131.040530] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
[ 131.164741] e1000e 0000:00:1f.6 eth0: changing MTU from 1500 to 1492
[ 136.039268] e1000e 0000:00:1f.6 eth0: changing MTU from 1492 to 1500
[ 142.048536] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
[ 142.186891] e1000e 0000:00:1f.6 eth0: changing MTU from 1500 to 1492
[ 147.038361] e1000e 0000:00:1f.6 eth0: changing MTU from 1492 to 1500

Everything works fine when I boot Linux 4.13.0-37-generic.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: linux-image-4.13.0-38-generic 4.13.0-38.43
ProcVersionSignature: Ubuntu 4.13.0-38.43-generic 4.13.16
Uname: Linux 4.13.0-38-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.7
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: martin 2756 F.... pulseaudio
CurrentDesktop: MATE
Date: Tue Apr 10 11:34:19 2018
EcryptfsInUse: Yes
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: System manufacturer System Product Name
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-38-generic root=UUID=8ee32f29-87ea-4229-8807-35171b6dfeed ro quiet splash nomdmonddf nomdmonisw nomdmonddf nomdmonisw nomdmonddf nomdmonisw nomdmonddf nomdmonisw vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-4.13.0-38-generic N/A
 linux-backports-modules-4.13.0-38-generic N/A
 linux-firmware 1.169.3
RfKill:

SourcePackage: linux
UpgradeStatus: Upgraded to artful on 2018-01-23 (76 days ago)
dmi.bios.date: 09/20/2016
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 2002
dmi.board.asset.tag: Default string
dmi.board.name: H170-PRO/USB 3.1
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Default string
dmi.chassis.type: 3
dmi.chassis.vendor: Default string
dmi.chassis.version: Default string
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr2002:bd09/20/2016:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnH170-PRO/USB3.1:rvrRevX.0x:cvnDefaultstring:ct3:cvrDefaultstring:
dmi.product.family: To be filled by O.E.M.
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer