ISST-LTE:KVM:Ubuntu18.04:BostonLC:boslcp3:boslcp3g3:Guest conosle hangs after hotplug CPU add operation.

Bug #1759723 reported by bugproxy on 2018-03-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Ubuntu-power-systems project
Critical
Canonical Kernel Team
linux (Ubuntu)
Critical
Canonical Kernel Team
Bionic
Critical
Canonical Kernel Team

Bug Description

Problem Description:
===================
Performed HOTPLUG cpu attach operation for the guest and guest console becomes unresponsive.

Steps to re-create:
==================
1. updated boslcp3 host BMC :116 & PNOR: 20180302 levels

2. Installed Ubuntu1804 on boslcp3 host & guests with trap issue fixes

root@boslcp3:/home# uname -a
Linux boslcp3 4.15.0-12-generic #13+leo20180320 SMP Tue Mar 20 13:10:42 CDT 2018 ppc64le ppc64le ppc64le GNU/Linux
root@boslcp3:/home# uname -r
4.15.0-12-generic

root@boslcp3g3:/kte/tools/setup.d# uname -a
Linux boslcp3g3 4.15.0-12-generic #13+leo20180320 SMP Tue Mar 20 13:10:42 CDT 2018 ppc64le ppc64le ppc64le GNU/Linux
root@boslcp3g3:/kte/tools/setup.d# uname -r
4.15.0-12-generic

3. Started HTX & stress-ng for on guest for 10-15 min

4. Cleaned up the tests to perform hot-plug and ensure enough memory and cpu was there (killed all Process using kill)

5. Performed cpu hot-plug and guest went into hung state

Before Hotplug:

root@boslcp3:~# virsh dumpxml boslcp3g3 | grep vcpu
  <vcpu placemen

Hotplug add CPU:

root@boslcp3:~# virsh setvcpus boslcp3g3 48 --live

dumpxml:

root@boslcp3:~# virsh dumpxml boslcp3g3 | grep cpu
  <vcpu placement='static' current='48'>64</vcpu>
  <vcpus>
    <vcpu id='0' enabled='yes' hotpluggable='no' order='1'/>
    <vcpu id='1' enabled='yes' hotpluggable='no' order='1'/>
    <vcpu id='2' enabled='yes' hotpluggable='no' order='1'/>
    <vcpu id='3' enabled='yes' hotpluggable='no' order='1'/>
    <vcpu id='4' enabled='yes' hotpluggable='no' order='2'/>
    <vcpu id='5' enabled='yes' hotpluggable='no' order='2'/>
    <vcpu id='6' enabled='yes' hotpluggable='no' order='2'/>
    <vcpu id='7' enabled='yes' hotpluggable='no' order='2'/>
    <vcpu id='8' enabled='yes' hotpluggable='no' order='3'/>
    <vcpu id='9' enabled='yes' hotpluggable='no' order='3'/>
    <vcpu id='10' enabled='yes' hotpluggable='no' order='3'/>
    <vcpu id='11' enabled='yes' hotpluggable='no' order='3'/>
    <vcpu id='12' enabled='yes' hotpluggable='no' order='4'/>
    <vcpu id='13' enabled='yes' hotpluggable='no' order='4'/>
    <vcpu id='14' enabled='yes' hotpluggable='no' order='4'/>
    <vcpu id='15' enabled='yes' hotpluggable='no' order='4'/>
    <vcpu id='16' enabled='yes' hotpluggable='no' order='5'/>
    <vcpu id='17' enabled='yes' hotpluggable='no' order='5'/>
    <vcpu id='18' enabled='yes' hotpluggable='no' order='5'/>
    <vcpu id='19' enabled='yes' hotpluggable='no' order='5'/>
    <vcpu id='20' enabled='yes' hotpluggable='no' order='6'/>
    <vcpu id='21' enabled='yes' hotpluggable='no' order='6'/>
    <vcpu id='22' enabled='yes' hotpluggable='no' order='6'/>
    <vcpu id='23' enabled='yes' hotpluggable='no' order='6'/>
    <vcpu id='24' enabled='yes' hotpluggable='no' order='7'/>
    <vcpu id='25' enabled='yes' hotpluggable='no' order='7'/>
    <vcpu id='26' enabled='yes' hotpluggable='no' order='7'/>
    <vcpu id='27' enabled='yes' hotpluggable='no' order='7'/>
    <vcpu id='28' enabled='yes' hotpluggable='no' order='8'/>
    <vcpu id='29' enabled='yes' hotpluggable='no' order='8'/>
    <vcpu id='30' enabled='yes' hotpluggable='no' order='8'/>
    <vcpu id='31' enabled='yes' hotpluggable='no' order='8'/>
    <vcpu id='32' enabled='yes' hotpluggable='yes' order='9'/>
    <vcpu id='33' enabled='yes' hotpluggable='yes' order='9'/>
    <vcpu id='34' enabled='yes' hotpluggable='yes' order='9'/>
    <vcpu id='35' enabled='yes' hotpluggable='yes' order='9'/>
    <vcpu id='36' enabled='yes' hotpluggable='yes' order='10'/>
    <vcpu id='37' enabled='yes' hotpluggable='yes' order='10'/>
    <vcpu id='38' enabled='yes' hotpluggable='yes' order='10'/>
    <vcpu id='39' enabled='yes' hotpluggable='yes' order='10'/>
    <vcpu id='40' enabled='yes' hotpluggable='yes' order='11'/>
    <vcpu id='41' enabled='yes' hotpluggable='yes' order='11'/>
    <vcpu id='42' enabled='yes' hotpluggable='yes' order='11'/>
    <vcpu id='43' enabled='yes' hotpluggable='yes' order='11'/>
    <vcpu id='44' enabled='yes' hotpluggable='yes' order='12'/>
    <vcpu id='45' enabled='yes' hotpluggable='yes' order='12'/>
    <vcpu id='46' enabled='yes' hotpluggable='yes' order='12'/>
    <vcpu id='47' enabled='yes' hotpluggable='yes' order='12'/>
    <vcpu id='48' enabled='no' hotpluggable='yes'/>
    <vcpu id='49' enabled='no' hotpluggable='yes'/>
    <vcpu id='50' enabled='no' hotpluggable='yes'/>
    <vcpu id='51' enabled='no' hotpluggable='yes'/>
    <vcpu id='52' enabled='no' hotpluggable='yes'/>
    <vcpu id='53' enabled='no' hotpluggable='yes'/>
    <vcpu id='54' enabled='no' hotpluggable='yes'/>
    <vcpu id='55' enabled='no' hotpluggable='yes'/>
    <vcpu id='56' enabled='no' hotpluggable='yes'/>
    <vcpu id='57' enabled='no' hotpluggable='yes'/>
    <vcpu id='58' enabled='no' hotpluggable='yes'/>
    <vcpu id='59' enabled='no' hotpluggable='yes'/>
    <vcpu id='60' enabled='no' hotpluggable='yes'/>
    <vcpu id='61' enabled='no' hotpluggable='yes'/>
    <vcpu id='62' enabled='no' hotpluggable='yes'/>
    <vcpu id='63' enabled='no' hotpluggable='yes'/>
  </vcpus>
  <cpu mode='host-model' check='partial'>
  </cpu>
root@boslcp3:~#

6. After this operation, guest becomes unrepsonsive as below

root@boslcp3g3:~# [ 3626.140773] INFO: task jbd2/vda2-8:584 blocked for more than 120 seconds.
[ 3626.146375] Tainted: G W 4.15.0-12-generic #13+leo20180320
[ 3626.146457] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[ 3626.146624] INFO: task systemd-journal:665 blocked for more than 120 seconds.
[ 3626.146699] Tainted: G W 4.15.0-12-generic #13+leo20180320
[ 3626.146768] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[ 3626.146939] INFO: task rs:main Q:Reg:1995 blocked for more than 120 seconds.
[ 3626.147016] Tainted: G W 4.15.0-12-generic #13+leo20180320
[ 3626.147088] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[ 3626.147285] INFO: task kworker/u128:2:57691 blocked for more than 120 seconds.
[ 3626.147361] Tainted: G W 4.15.0-12-generic #13+leo20180320
[ 3626.147434] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[ 3626.147622] INFO: task smbd:1449 blocked for more than 120 seconds.
[ 3626.147686] Tainted: G W 4.15.0-12-generic #13+leo20180320
[ 3626.147760] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[ 3626.147875] INFO: task smbd:1452 blocked for more than 120 seconds.
[ 3626.147937] Tainted: G W 4.15.0-12-generic #13+leo20180320
[ 3626.148010] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[ 3626.148110] INFO: task smbd:1454 blocked for more than 120 seconds.
[ 3626.148173] Tainted: G W 4.15.0-12-generic #13+leo20180320
[ 3626.148245] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[ 3626.148344] INFO: task cron:1461 blocked for more than 120 seconds.
[ 3626.148406] Tainted: G W 4.15.0-12-generic #13+leo20180320
[ 3626.148488] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.

root@boslcp3g3:~#
root@boslcp3g3:~# ps -ef | grep stress-ng
[ 3746.978098] INFO: task jbd2/vda2-8:584 blocked for more than 120 seconds.
[ 3746.978221] Tainted: G W 4.15.0-12-generic #13+leo20180320
[ 3746.978301] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[ 3746.978447] INFO: task systemd-journal:665 blocked for more than 120 seconds.
[ 3746.978534] Tainted: G W 4.15.0-12-generic #13+leo20180320
[ 3746.978607] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[ 4446.361899] systemd[1]: Failed to start Journal Service.
[ 4897.632142] systemd[1]: Failed to start Journal Service.

^Z
^X
^C
^Z
^X
^C

7. ping to boslcp3g3 is fine but guest console is not repsonding

[ipjoga@kte (AUS) ~]$ ping boslcp3g3
PING boslcp3g3.isst.aus.stglabs.ibm.com (10.33.12.73) 56(84) bytes of data.
64 bytes from boslcp3g3.isst.aus.stglabs.ibm.com (10.33.12.73): icmp_seq=1 ttl=64 time=0.182 ms
64 bytes from boslcp3g3.isst.aus.stglabs.ibm.com (10.33.12.73): icmp_seq=2 ttl=64 time=0.196 ms
^C

8. Took dump for the guest, attache vmcore & other logs.

Thanks to the Linux block community, I'm now aware of two commits that should fix this issue.

https://github.com/torvalds/linux/commit/20e4d813931961fe26d26a1e98b3aba6ec00b130

 blk-mq: simplify queue mapping & schedule with each possisble CPU

 The previous patch assigns interrupt vectors to all possible CPUs, so
 now hctx can be mapped to possible CPUs, this patch applies this fact
 to simplify queue mapping & schedule so that we don't need to handle
 CPU hotplug for dealing with physical CPU plug & unplug. With this
 simplication, we can work well on physical CPU plug & unplug, which
 is a normal use case for VM at least.

 Make sure we allocate blk_mq_ctx structures for all possible CPUs, and
 set hctx->numa_node for possible CPUs which are mapped to this hctx. And
 only choose the online CPUs for schedule.

https://github.com/torvalds/linux/commit/84676c1f21e8ff54befe985f4f14dc1edc10046b

 genirq/affinity: assign vectors to all possible CPUs

 Currently we assign managed interrupt vectors to all present CPUs. This
 works fine for systems were we only online/offline CPUs. But in case of
 systems that support physical CPU hotplug (or the virtualized version of
 it) this means the additional CPUs covered for in the ACPI tables or on
 the command line are not catered for. To fix this we'd either need to
 introduce new hotplug CPU states just for this case, or we can start
 assining vectors to possible but not present CPUs.

CVE References

Default Comment by Bridge

tags: added: architecture-ppc64le bugnameltc-165988 severity-critical targetmilestone-inin1804

Default Comment by Bridge

Default Comment by Bridge

Changed in ubuntu:
assignee: nobody → Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage)
affects: ubuntu → linux (Ubuntu)
Changed in ubuntu-power-systems:
status: New → Triaged
importance: Undecided → Critical
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
tags: added: triage-g
Seth Forshee (sforshee) on 2018-03-29
Changed in linux (Ubuntu):
status: New → Fix Committed
Changed in ubuntu-power-systems:
status: Triaged → Fix Committed

------- Comment From <email address hidden> 2018-04-03 07:59 EDT-------
(In reply to comment #27)
> (In reply to comment #26)
> > Hello Indira,
> >
> > > Can you please built your patch on top this of above kernel so that our test
> > > machine will run with latest kernel as other guests.
> >
> > Here you are:
> > https://apps.na.collabserv.com/files/app#/folder/cf465396-9498-43dc-9b16-
> > 364a24c67033/
> >
> > It applies all commits from
> > https://bugzilla.linux.ibm.com/show_bug.cgi?id=166023#c9 but rebased on
> > 4.15.0-13-generic.
> >
> > Thanks
>
> Also, the following commits were included:
>
> 20e4d8139319 blk-mq: simplify queue mapping & schedule with each possisble
> CPU
> 7df938fbc4ee blk-mq: turn WARN_ON in __blk_mq_run_hw_queue into printk
> 84676c1f21e8 genirq/affinity: assign vectors to all possible CPUs

Hi Jose,

I have applied the above patch on latest kernel on boslcp3g3 guest and did not hit with guest hung issue with 50+ l hours of regression run.

root@boslcp3g3:~# uname -a
Linux boslcp3g3 4.15.10+ #5 SMP Wed Mar 28 10:36:18 CDT 2018 ppc64le ppc64le ppc64le GNU/Linux
root@boslcp3g3:~# uname -r
4.15.10+

Thanks & Regards,
Indira

Default Comment by Bridge

Default Comment by Bridge

Default Comment by Bridge

------- Comment From <email address hidden> 2018-04-03 09:21 EDT-------
Hi Indira,

Excelent news. The backport is already merged into Ubuntu, so it should be available in the next bionic update.

Thank you

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-04-10 07:24 EDT-------
Hi Jose,

Is this fix available in official ubutnu1804 build

Regards,
Indira

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-04-10 12:56 EDT-------
Hello Indira!

Not yet. I just checked the most recent upstream version and the code fix isn't there. I'll keep my eye on the next updates.

Launchpad Janitor (janitor) wrote :
Download full text (40.4 KiB)

This bug was fixed in the package linux - 4.15.0-15.16

---------------
linux (4.15.0-15.16) bionic; urgency=medium

  * linux: 4.15.0-15.16 -proposed tracker (LP: #1761177)

  * FFe: Enable configuring resume offset via sysfs (LP: #1760106)
    - PM / hibernate: Make passing hibernate offsets more friendly

  * /dev/bcache/by-uuid links not created after reboot (LP: #1729145)
    - SAUCE: (no-up) bcache: decouple emitting a cached_dev CHANGE uevent

  * Ubuntu18.04:POWER9:DD2.2 - Unable to start a KVM guest with default machine
    type(pseries-bionic) complaining "KVM implementation does not support
    Transactional Memory, try cap-htm=off" (kvm) (LP: #1752026)
    - powerpc: Use feature bit for RTC presence rather than timebase presence
    - powerpc: Book E: Remove unused CPU_FTR_L2CSR bit
    - powerpc: Free up CPU feature bits on 64-bit machines
    - powerpc: Add CPU feature bits for TM bug workarounds on POWER9 v2.2
    - powerpc/powernv: Provide a way to force a core into SMT4 mode
    - KVM: PPC: Book3S HV: Work around transactional memory bugs in POWER9
    - KVM: PPC: Book3S HV: Work around XER[SO] bug in fake suspend mode
    - KVM: PPC: Book3S HV: Work around TEXASR bug in fake suspend state

  * Important Kernel fixes to be backported for Power9 (kvm) (LP: #1758910)
    - powerpc/mm: Fixup tlbie vs store ordering issue on POWER9

  * Ubuntu 18.04 - IO Hang on some namespaces when running HTX with 16
    namespaces (Bolt / NVMe) (LP: #1757497)
    - powerpc/64s: Fix lost pending interrupt due to race causing lost update to
      irq_happened

  * fwts-efi-runtime-dkms 18.03.00-0ubuntu1: fwts-efi-runtime-dkms kernel module
    failed to build (LP: #1760876)
    - [Packaging] include the retpoline extractor in the headers

linux (4.15.0-14.15) bionic; urgency=medium

  * linux: 4.15.0-14.15 -proposed tracker (LP: #1760678)

  * [Bionic] mlx4 ETH - mlnx_qos failed when set some TC to vendor
    (LP: #1758662)
    - net/mlx4_en: Change default QoS settings

  * AT_BASE_PLATFORM in AUXV is absent on kernels available on Ubuntu 17.10
    (LP: #1759312)
    - powerpc/64s: Fix NULL AT_BASE_PLATFORM when using DT CPU features

  * Bionic update to 4.15.15 stable release (LP: #1760585)
    - net: dsa: Fix dsa_is_user_port() test inversion
    - openvswitch: meter: fix the incorrect calculation of max delta_t
    - qed: Fix MPA unalign flow in case header is split across two packets.
    - tcp: purge write queue upon aborting the connection
    - qed: Fix non TCP packets should be dropped on iWARP ll2 connection
    - sysfs: symlink: export sysfs_create_link_nowarn()
    - net: phy: relax error checking when creating sysfs link netdev->phydev
    - devlink: Remove redundant free on error path
    - macvlan: filter out unsupported feature flags
    - net: ipv6: keep sk status consistent after datagram connect failure
    - ipv6: old_dport should be a __be16 in __ip6_datagram_connect()
    - ipv6: sr: fix NULL pointer dereference when setting encap source address
    - ipv6: sr: fix scheduling in RCU when creating seg6 lwtunnel state
    - mlxsw: spectrum_buffers: Set a minimum quota for CPU port traffic
    - net: phy: Tell caller result ...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-power-systems:
status: Fix Committed → Fix Released
Seth Forshee (sforshee) wrote :

I think the patches from this bug are causing a problem. See LP: #1765232 for details.

I've identified a number of upstream fixes for these patches, listed on that bug. We are days out from release though, and the last of them (d3056812e7df "genirq/affinity: Spread irq vectors among present CPUs as far as possible") will require backporting or additional commits. We don't have a lot of time to get testing on this.

As I read the description of this bug, the issue can be summed up as, "stress the system, do CPU hotplug, then the system becomes unresponsive." The other issue is summarized as, "my system hangs during boot." Since the latter will prevent installation of 18.04 I regard it as the more serious issue.

Given all of this, I'm strongly inclined towards reverting these patches for the release, then we can look at SRU-ing them along with all necessary fixes. If the issue here is more serious than my reading of it (i.e. it will prevent booting and installation of 18.04) please speak up ASAP.

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-04-21 14:38 EDT-------
Hello Seth,

Without those patches CPU hoplug doesn't work but the issue related on https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1765232 looks more urgent yet. I agree to revert it if necessary.

Thanks

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-04-21 15:14 EDT-------
Hi Seth,

Just another point is that it's related (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1765232) to kernel 4.15.0-15 but as per comment #11 these patches were applied in 4.15.0-16.

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-04-21 15:29 EDT-------
Ah, forget it, it's in 4.15.0-15.16 not 4.15.0-16. Anyway, you can revert it if required.

Thank you

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-04-27 16:54 EDT-------
I was told to write a small documentation describing what happens without the two patches mentioned in my comment #20.

We basically lose the ability to hotplug/unplug CPUs into virtual machines. Considering that blk-mq enqueue tasks using 'for_each_present_cpu()' (that iterates over CPUs in systems that don't support CPU hotplug - refer to those patches for technical details) we can also have problems if tasks are scheduled to CPUs present but not online.

So I suggest to *not* run VMs with extra CPUs to be hotplugged later, like:

-smp 8,sockets=1,cores=2,threads=8,maxcpus=16

or

<vcpu placement='static' current='8'>16</vcpu>

If we want a guest with 16 CPUs it's better to define it beforehand, for instance:

-smp 16,sockets=1,cores=2,threads=8

or

<vcpu placement='static'>16</vcpu>

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-05-09 18:03 EDT-------
addendum: According to my last investigation[1] the problem is in the blk_mq only. If we don't use blk_mq devices we can hotplug and hot-unplug CPUs without any problem.

[1] https://bugzilla.linux.ibm.com/show_bug.cgi?id=167294 comments 47, 48, and 49.

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-05-10 10:19 EDT-------
As per my comment in https://bugzilla.linux.ibm.com/show_bug.cgi?id=167294#c50, the build from
https://apps.na.collabserv.com/files/app#/folder/4e205b7a-8126-4d09-8a3e-4bec14c051f2/ fixes this issue.

Changed in linux (Ubuntu Bionic):
status: New → In Progress
Changed in ubuntu-power-systems:
status: Fix Released → Fix Committed
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-05-16 10:11 EDT-------
Patch set was resent to Canonical mailing list by Ziviani.

Frank Heimes (frank-heimes) wrote :

Please always attach patches to the LP bug - this is the central tool for bug activity and would allow everybody involved to find everything at one place.

Frank Heimes (frank-heimes) wrote :

(just for completeness reasons)
Patches that were sent over:
https://lists.ubuntu.com/archives/kernel-team/2018-May/thread.html#92233

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-06-07 10:38 EDT-------
Hello Frank,

Just to reinforce what Ziviani told in some comments before, the issue being discussed here, even though affecting CPU hot plug on Power, is not specifically related to Power. The issue we are seeing with CPU hot plug is just a side effect of a more serious bug in blk_mq.

The blk_mq problem that the patches pointed in this issue fix is a general blk_mq issue affecting all platforms that use this infrastructure. My understanding is that there has been lots of bug fixing in this area upstream lately.

Changed in linux (Ubuntu Bionic):
status: In Progress → Fix Committed
Manoj Iyer (manjo) wrote :

These patches were accepted and are in route for 18.04.1.

Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic

Hello IBM,

Could you please verify the fix(es) with the Bionic kernel currently in -proposed?

Thank you.

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-06-20 15:22 EDT-------
Hello,

From the the development side it looks very good: both hotplug and hot unplug are working good.

Thank you very much,

Ziviani

bugproxy (bugproxy) on 2018-06-20
tags: added: verification-done-bionic
removed: verification-needed-bionic
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-06-22 05:45 EDT-------
Hi,

We have verified this bug on "4.15.0-24-generic #26-Ubuntu" kernel, it's working fine.

root@boslcp4:~# uname -a
Linux boslcp4 4.15.0-24-generic #26-Ubuntu SMP Wed Jun 13 08:43:33 UTC 2018 ppc64le ppc64le ppc64le GNU/Linux
root@boslcp4:~#

Thanks

Manoj Iyer (manjo) on 2018-06-25
Changed in linux (Ubuntu):
assignee: Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage) → Canonical Kernel Team (canonical-kernel-team)
Changed in linux (Ubuntu Bionic):
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
Changed in linux (Ubuntu):
importance: Undecided → Critical
Changed in linux (Ubuntu Bionic):
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :
Download full text (49.5 KiB)

This bug was fixed in the package linux - 4.15.0-24.26

---------------
linux (4.15.0-24.26) bionic; urgency=medium

  * linux: 4.15.0-24.26 -proposed tracker (LP: #1776338)

  * Bionic update: upstream stable patchset 2018-06-06 (LP: #1775483)
    - drm: bridge: dw-hdmi: Fix overflow workaround for Amlogic Meson GX SoCs
    - i40e: Fix attach VF to VM issue
    - tpm: cmd_ready command can be issued only after granting locality
    - tpm: tpm-interface: fix tpm_transmit/_cmd kdoc
    - tpm: add retry logic
    - Revert "ath10k: send (re)assoc peer command when NSS changed"
    - bonding: do not set slave_dev npinfo before slave_enable_netpoll in
      bond_enslave
    - ipv6: add RTA_TABLE and RTA_PREFSRC to rtm_ipv6_policy
    - ipv6: sr: fix NULL pointer dereference in seg6_do_srh_encap()- v4 pkts
    - KEYS: DNS: limit the length of option strings
    - l2tp: check sockaddr length in pppol2tp_connect()
    - net: validate attribute sizes in neigh_dump_table()
    - llc: delete timers synchronously in llc_sk_free()
    - tcp: don't read out-of-bounds opsize
    - net: af_packet: fix race in PACKET_{R|T}X_RING
    - tcp: md5: reject TCP_MD5SIG or TCP_MD5SIG_EXT on established sockets
    - net: fix deadlock while clearing neighbor proxy table
    - team: avoid adding twice the same option to the event list
    - net/smc: fix shutdown in state SMC_LISTEN
    - team: fix netconsole setup over team
    - packet: fix bitfield update race
    - tipc: add policy for TIPC_NLA_NET_ADDR
    - pppoe: check sockaddr length in pppoe_connect()
    - vlan: Fix reading memory beyond skb->tail in skb_vlan_tagged_multi
    - amd-xgbe: Add pre/post auto-negotiation phy hooks
    - sctp: do not check port in sctp_inet6_cmp_addr
    - amd-xgbe: Improve KR auto-negotiation and training
    - strparser: Do not call mod_delayed_work with a timeout of LONG_MAX
    - amd-xgbe: Only use the SFP supported transceiver signals
    - strparser: Fix incorrect strp->need_bytes value.
    - net: sched: ife: signal not finding metaid
    - tcp: clear tp->packets_out when purging write queue
    - net: sched: ife: handle malformed tlv length
    - net: sched: ife: check on metadata length
    - llc: hold llc_sap before release_sock()
    - llc: fix NULL pointer deref for SOCK_ZAPPED
    - net: ethernet: ti: cpsw: fix tx vlan priority mapping
    - virtio_net: split out ctrl buffer
    - virtio_net: fix adding vids on big-endian
    - KVM: s390: force bp isolation for VSIE
    - s390: correct module section names for expoline code revert
    - microblaze: Setup dependencies for ASM optimized lib functions
    - commoncap: Handle memory allocation failure.
    - scsi: mptsas: Disable WRITE SAME
    - cdrom: information leak in cdrom_ioctl_media_changed()
    - m68k/mac: Don't remap SWIM MMIO region
    - block/swim: Check drive type
    - block/swim: Don't log an error message for an invalid ioctl
    - block/swim: Remove extra put_disk() call from error path
    - block/swim: Rename macros to avoid inconsistent inverted logic
    - block/swim: Select appropriate drive on device open
    - block/swim: Fix array bounds check
    - block/swim: Fix IO error at end of medium
    -...

Changed in linux (Ubuntu Bionic):
status: Fix Committed → Fix Released
Changed in ubuntu-power-systems:
status: Fix Committed → Fix Released
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2019-02-04 12:00 EDT-------
*** Bug 167294 has been marked as a duplicate of this bug. ***

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.