Important Kernel fixes to be backported for Power9 (kvm)

Bug #1758910 reported by bugproxy on 2018-03-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Ubuntu-power-systems project
Critical
Canonical Kernel Team
linux (Ubuntu)
Critical
Seth Forshee
Bionic
Critical
Seth Forshee

Bug Description

== Comment: #0 - Satheesh Rajendran <email address hidden> - 2018-03-26 02:18:44 ==
---Problem Description---
Important Kernel fixes to be backported for Power9 (kvm)

Contact Information = <email address hidden>

---uname output---
4.15.0-13-generic

Machine Type = power9 boston 2.2 (pvr 004e 1202)

---Debugger---
A debugger is not configured

---Steps to Reproduce---
 Following upstream patches are need to be backported for Power9 KVM to function well.

* Emulation of VMX loads and stores for MMIO.

09f984961c13 KVM: PPC: Book3S: Add MMIO emulation for VMX instructions
6df3877fc962 KVM: PPC: Book3S: Fix compile error that occurs with some gcc versions (needed once 09f984961c13 is in)

* Other important fixes.

05f2bb0313a2 KVM: PPC: Book3S HV: Fix handling of secondary HPTEG in HPT resizing code
790a9df5fbef KVM: PPC: Book3S HV: Make HPT resizing work on POWER9
a8b48a4dccea KVM: PPC: Book3S HV: Fix trap number return from __kvmppc_vcore_entry

https://git.kernel.org/pub/scm/linux/kernel/git/powerpc/linux.git/commit/?h=fixes&id=ff6781fd1bb404d8a551c02c35c70cec1da17ff1
https://git.kernel.org/pub/scm/linux/kernel/git/powerpc/linux.git/commit/?h=fixes&id=e4b79900222b8cccd4da4a7a89581f0e1b764ed2
and
https://git.kernel.org/pub/scm/linux/kernel/git/powerpc/linux.git/commit/?h=fixes&id=a5d4b5891c2f1f865a2def1eb0030f534e77ff86

Stack trace output:
 no

Oops output:
 no

System Dump Info:
  The system is not configured to capture a system dump.

*Additional Instructions for <email address hidden>:
-Attach sysctl -a output output to the bug.

------- Comment From <email address hidden> 2018-03-26 08:50 EDT-------
Gustavo is already involved on the email thread that originated this; assigning to him.

In the thread Paul Mackerras also mentions others fixes. Pasting here for reference.

"""
I went through all the KVM PPC patches since 4.15 and checked whether each one was in Ubuntu as of the Ubuntu-4.15.0-12.13 tag. The ones that aren't in there that we want are:

* Allow HPT guests on P9 DD2.2 without requiring indep_threads_mode=N.

6964e6a4e489 KVM: PPC: Book3S HV: Do SLB load/unload with guest LPCR value loaded
cda4a1473313 KVM: PPC: Book3S HV: Fix duplication of host SLB entries (needed once 6964e6a4e489 is in)
00608e1f007e KVM: PPC: Book3S HV: Allow HPT and radix on the same core for POWER9 v2.2

* Memory management fixes.

c3856aeb2940 KVM: PPC: Book3S HV: Fix handling of large pages in radix page fault handler
debd574f4195 KVM: PPC: Book3S HV: Fix VRMA initialization with 2MB or 1GB memory backing

* Emulation of VMX loads and stores for MMIO.

09f984961c13 KVM: PPC: Book3S: Add MMIO emulation for VMX instructions
6df3877fc962 KVM: PPC: Book3S: Fix compile error that occurs with some gcc versions (needed once 09f984961c13 is in)

* Other important fixes.

05f2bb0313a2 KVM: PPC: Book3S HV: Fix handling of secondary HPTEG in HPT resizing code
790a9df5fbef KVM: PPC: Book3S HV: Make HPT resizing work on POWER9
a8b48a4dccea KVM: PPC: Book3S HV: Fix trap number return from __kvmppc_vcore_entry
Paul.
"""

tags: added: architecture-ppc64le bugnameltc-166023 severity-critical targetmilestone-inin---
Changed in ubuntu:
assignee: nobody → Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage)
affects: ubuntu → linux (Ubuntu)
Changed in ubuntu-power-systems:
importance: Undecided → Critical
status: New → Triaged
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
tags: added: triage-g
Changed in linux (Ubuntu):
importance: Undecided → Critical
status: New → Triaged
Changed in linux (Ubuntu Bionic):
assignee: Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage) → Canonical Kernel Team (canonical-kernel-team)
tags: added: kernel-da-key
Seth Forshee (sforshee) on 2018-03-27
Changed in linux (Ubuntu Bionic):
assignee: Canonical Kernel Team (canonical-kernel-team) → Seth Forshee (sforshee)
status: Triaged → In Progress
Seth Forshee (sforshee) wrote :

It looks like we probably also should include 6df3877fc962 "KVM: PPC: Book3S: Fix compile error that occurs with some gcc versions" as it is a fix for 09f984961c13.

a8b48a4dccea does not apply cleanly, at minimum it seems to depend on changes from:

commit 6964e6a4e4894c707e42d51d9d30683c57f43201
Author: Paul Mackerras <email address hidden>
Date: Thu Jan 11 14:51:02 2018 +1100

    KVM: PPC: Book3S HV: Do SLB load/unload with guest LPCR value loaded

Can IBM please advise whether we should also take this commit, or else provide a backport of a8b48a4dccea to 4.15? Thanks!

Changed in linux (Ubuntu Bionic):
status: In Progress → Incomplete
Seth Forshee (sforshee) wrote :

Bah, I see that 6964e6a4e489 was requested on bug 1759045. However it also has a patch that seems to indicate 09f984961c13 (requested on this bug) is a dependency ...

I'll try to sort out the ordering of the commits between these two bugs. It would be helpful if future requests could try to sort out these sorts of dependencies beforehand so we don't end up with these tangled cross-dependencies between bugs.

Seth Forshee (sforshee) wrote :

Actually it turns out that most of the commits requested here are also requested on the other bug ...

bugproxy (bugproxy) on 2018-03-27
tags: removed: bugnameltc-166023 kernel-da-key severity-critical triage-g
Seth Forshee (sforshee) wrote :

Every one of these except the last three (the ones from the powerpc tree) are on the other bug, so I'm going to commit them as part of that one. That bug also includes the additional fix I identified.

The last one, a5d4b5891c2f1f865a2def1eb0030f534e77ff86, does not apply and seems to be missing prerequisite patches. I'm going to hold off applying these three patches, please advise of the full list of patches necessary to apply this commit. Thanks!

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-03-28 13:20 EDT-------
HI Seth,

Yes, there is a overlap of commits. In case of #1759045 we are bringing up those ones quickly to the next beta freeze on April.

Breno tested a built package with all of those patches on top of the master branch.

tags: added: bugnameltc-166023 severity-critical
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-03-28 15:03 EDT-------
Seth,

Thank you for your efforts.

I have backported the a5d4b5891c2f1f865a2def1eb0030f534e77ff86 here https://github.com/walbon/ubuntu-bionic/commit/5c358941045cf6de2949059b0d3ca04c9ab13460

Would you like that I send to ubuntu kernel maillist this backport as a PATCH?

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-03-29 18:11 EDT-------
*** Bug 165741 has been marked as a duplicate of this bug. ***

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-04-03 09:16 EDT-------
(In reply to comment #15)
> Seth,
>
> Thank you for your efforts.
>
> I have backported the a5d4b5891c2f1f865a2def1eb0030f534e77ff86 here
> https://github.com/walbon/ubuntu-bionic/commit/
> 5c358941045cf6de2949059b0d3ca04c9ab13460
>
> Would you like that I send to ubuntu kernel maillist this backport as a
> PATCH?

Please advise where we on this. Thanks!

Changed in linux (Ubuntu Bionic):
status: Incomplete → Confirmed
Seth Forshee (sforshee) wrote :

It looks like we've already applied ff6781fd1bb404d8a551c02c35c70cec1da17ff1 and e4b79900222b8cccd4da4a7a89581f0e1b764ed2 from other bugs. So now we're only missing the backport of a5d4b5891c2f1f865a2def1eb0030f534e77ff86.

Seth Forshee (sforshee) wrote :

Applied the backport to bionic/master-next, thanks!

Changed in linux (Ubuntu Bionic):
status: Confirmed → Fix Committed
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-04-03 15:24 EDT-------
Hi Seth,

Thank you, I see all of those patches already on the master-next branch.

bugproxy (bugproxy) on 2018-04-05
tags: added: targetmilestone-inin1804
removed: targetmilestone-inin---
Changed in ubuntu-power-systems:
status: Triaged → Fix Committed
Manoj Iyer (manjo) on 2018-04-05
tags: added: triage-a
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-04-10 06:42 EDT-------
I think we are good to close this tracker bugzilla, given that all requested KVM fixes are now available with 4.15.0-15.16 and above.

Thank you.

Launchpad Janitor (janitor) wrote :
Download full text (40.4 KiB)

This bug was fixed in the package linux - 4.15.0-15.16

---------------
linux (4.15.0-15.16) bionic; urgency=medium

  * linux: 4.15.0-15.16 -proposed tracker (LP: #1761177)

  * FFe: Enable configuring resume offset via sysfs (LP: #1760106)
    - PM / hibernate: Make passing hibernate offsets more friendly

  * /dev/bcache/by-uuid links not created after reboot (LP: #1729145)
    - SAUCE: (no-up) bcache: decouple emitting a cached_dev CHANGE uevent

  * Ubuntu18.04:POWER9:DD2.2 - Unable to start a KVM guest with default machine
    type(pseries-bionic) complaining "KVM implementation does not support
    Transactional Memory, try cap-htm=off" (kvm) (LP: #1752026)
    - powerpc: Use feature bit for RTC presence rather than timebase presence
    - powerpc: Book E: Remove unused CPU_FTR_L2CSR bit
    - powerpc: Free up CPU feature bits on 64-bit machines
    - powerpc: Add CPU feature bits for TM bug workarounds on POWER9 v2.2
    - powerpc/powernv: Provide a way to force a core into SMT4 mode
    - KVM: PPC: Book3S HV: Work around transactional memory bugs in POWER9
    - KVM: PPC: Book3S HV: Work around XER[SO] bug in fake suspend mode
    - KVM: PPC: Book3S HV: Work around TEXASR bug in fake suspend state

  * Important Kernel fixes to be backported for Power9 (kvm) (LP: #1758910)
    - powerpc/mm: Fixup tlbie vs store ordering issue on POWER9

  * Ubuntu 18.04 - IO Hang on some namespaces when running HTX with 16
    namespaces (Bolt / NVMe) (LP: #1757497)
    - powerpc/64s: Fix lost pending interrupt due to race causing lost update to
      irq_happened

  * fwts-efi-runtime-dkms 18.03.00-0ubuntu1: fwts-efi-runtime-dkms kernel module
    failed to build (LP: #1760876)
    - [Packaging] include the retpoline extractor in the headers

linux (4.15.0-14.15) bionic; urgency=medium

  * linux: 4.15.0-14.15 -proposed tracker (LP: #1760678)

  * [Bionic] mlx4 ETH - mlnx_qos failed when set some TC to vendor
    (LP: #1758662)
    - net/mlx4_en: Change default QoS settings

  * AT_BASE_PLATFORM in AUXV is absent on kernels available on Ubuntu 17.10
    (LP: #1759312)
    - powerpc/64s: Fix NULL AT_BASE_PLATFORM when using DT CPU features

  * Bionic update to 4.15.15 stable release (LP: #1760585)
    - net: dsa: Fix dsa_is_user_port() test inversion
    - openvswitch: meter: fix the incorrect calculation of max delta_t
    - qed: Fix MPA unalign flow in case header is split across two packets.
    - tcp: purge write queue upon aborting the connection
    - qed: Fix non TCP packets should be dropped on iWARP ll2 connection
    - sysfs: symlink: export sysfs_create_link_nowarn()
    - net: phy: relax error checking when creating sysfs link netdev->phydev
    - devlink: Remove redundant free on error path
    - macvlan: filter out unsupported feature flags
    - net: ipv6: keep sk status consistent after datagram connect failure
    - ipv6: old_dport should be a __be16 in __ip6_datagram_connect()
    - ipv6: sr: fix NULL pointer dereference when setting encap source address
    - ipv6: sr: fix scheduling in RCU when creating seg6 lwtunnel state
    - mlxsw: spectrum_buffers: Set a minimum quota for CPU port traffic
    - net: phy: Tell caller result ...

Changed in linux (Ubuntu Bionic):
status: Fix Committed → Fix Released
Manoj Iyer (manjo) on 2018-04-16
Changed in ubuntu-power-systems:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers