Backlight does not work on a MacBookAir3,2

Bug #1758496 reported by victor on 2018-03-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Backlight control does not work and there are no entries in /sys/class/backlight. When I boot my system with the option GRUB_CMDLINE_LINUX_DEFAULT="acpi_backlight=vendor" I can change the brightness with the command xrandr on a terminal.

I attach all the system information about this problem.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: linux-image-4.13.0-37-generic 4.13.0-37.42
ProcVersionSignature: Ubuntu 4.13.0-37.42-generic 4.13.13
Uname: Linux 4.13.0-37-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.7
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: victor 2932 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
Date: Sat Mar 24 07:22:05 2018
InstallationDate: Installed on 2018-03-04 (19 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20180105.1)
MachineType: Apple Inc. MacBookAir3,2
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
ProcFB: 0 nouveaufb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-37-generic.efi.signed root=UUID=dd2bcce2-7d14-4df7-b7c8-6aea4fbb9c13 ro acpi_backlight=vendor
RelatedPackageVersions:
 linux-restricted-modules-4.13.0-37-generic N/A
 linux-backports-modules-4.13.0-37-generic N/A
 linux-firmware 1.169.3
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/18/10
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBA31.88Z.0061.B01.1011181342
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-942C5DF58193131B
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookAir3,2
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-942C5DF58193131B
dmi.modalias: dmi:bvnAppleInc.:bvrMBA31.88Z.0061.B01.1011181342:bd11/18/10:svnAppleInc.:pnMacBookAir3,2:pvr1.0:rvnAppleInc.:rnMac-942C5DF58193131B:rvrMacBookAir3,2:cvnAppleInc.:ct10:cvrMac-942C5DF58193131B:
dmi.product.family: MacBook
dmi.product.name: MacBookAir3,2
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

victor (vicgarpe) wrote :
tags: added: brightness
victor (vicgarpe) wrote :

The output of: ls /sys/class/backlight > backlight is nothing

victor (vicgarpe) wrote :
victor (vicgarpe) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
victor (vicgarpe) wrote :

acpixtract acpidump.txt
iasl -d DSDT.dat

victor (vicgarpe) wrote :
victor (vicgarpe) wrote :
victor (vicgarpe) wrote :
Joseph Salisbury (jsalisbury) wrote :

Did this issue start happening after an update/upgrade? Was there a prior kernel version where you were not having this particular problem?

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.16 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.16-rc7

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Kai-Heng Feng (kaihengfeng) wrote :

When you use "acpi_backlight=vendor", is /sys/class/backlight still empty?

victor (vicgarpe) wrote :

Yes jsalisbury, this issue started happening after an upgrade. Sorry, I'm not sure ... from 16.10 to 17.4 could be ...
Ok, many thanks. I have not enought time, but I'll try to test the latest upstream kernel.

victor (vicgarpe) wrote :

Yes kaihengfeng. Now, my GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=Linux acpi_backlight=vendor" and /sys/class/backlight still empty. Today I've updated the laptop and the kernel is 4.13.0-38-generic and the problem still happening.

I hope in this week, I can change my kernel to test this solution. Thanks kaihengfeng.

Kai-Heng Feng (kaihengfeng) wrote :

acpi_osi=Linux is not necessary.

victor (vicgarpe) wrote :

I've test the latest v4.16 with this errors during installation:

[...]
dpkg: problemas de dependencias impiden la configuración de linux-headers-4.16.0-041600-generic:
 linux-headers-4.16.0-041600-generic depende de linux-headers-4.16.0-041600; sin embargo:
  El paquete `linux-headers-4.16.0-041600' no está instalado.

[...]
Running depmod.
update-initramfs: deferring update (hook will be called later)
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.16.0-041600-generic /boot/vmlinuz-4.16.0-041600-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.16.0-041600-generic /boot/vmlinuz-4.16.0-041600-generic
ERROR (dkms apport): kernel package linux-headers-4.16.0-041600-generic is not supported
Error! Bad return status for module build on kernel: 4.16.0-041600-generic (x86_64)
Consult /var/lib/dkms/fwts-efi-runtime-dkms/17.09.00/build/make.log for more information.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.16.0-041600-generic /boot/vmlinuz-4.16.0-041600-generic

The system don't boot up. But I could try the brightness keys and they worked! How can I solve my problem? Do I have to wait for ubuntu version 18.04?

Kai-Heng Feng (kaihengfeng) wrote :

I don't quite understand. If you can't boot under v4.16, how did you test it?

victor (vicgarpe) wrote :

Because, the system boot up but it stops and freezes due to problem with (nouveau) graphics. When the system is frozen it still allows me to test the brightness keys. Unfortunately with the frozen system I can not access a terminal or use it in any way.
(Sorry for my painful use of the language ...)

Kai-Heng Feng (kaihengfeng) wrote :

I guess you can avoid the issue by using kernel parameter "nomodeset"

victor (vicgarpe) wrote :

Today I reinstalled my laptop with a Ubuntu 17.10 and the system show the same problem. When the first boot finised I looked for the files on the /sys/class/backlight folder but this folder was empty. I changed /etc/default/grub with GRUB_CMDLINE_LINUX_DEFAULT="nomodeset acpi_backlight=vendor" as Kaihengfeng said. I ran update-grub and reboot, with the same result; /sys/class/backlight folder is empty. The brightness keys don't work. What can I do?

The laptop is working but I have problems when I work on a room with hight level of light.

victor (vicgarpe) wrote :

Again, I test the 4.16 kernel with the parameter "nomodese". As Kaihengfeng guessed the system boot but the problem still there; /sys/class/backlight folder was empty. My second test was boot again with 4.16 without "nomodeset" parameter in the grub file and the results were others. As I expected the system was frozen and in this last test the brightness keys didn't work.
It smells like a problem betwen my firmware and the kernel.
I can do more test to find the problem.

Kai-Heng Feng (kaihengfeng) wrote :

This commit [1] might solve it. Can you git it a try?

[1] https://github.com/torvalds/linux/commit/53fa1f6e8a5958da698a31edf366ffe90596b490

victor (vicgarpe) wrote :

Thanks Kaihenfeng! I try it from [2], but /sys/class/backlight still empty. Ops! ...

[2] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.17-rc3/

Kai-Heng Feng (kaihengfeng) wrote :

Please file an upstream bug at https://bugzilla.kernel.org/
Product: ACPI
Component: Power-Video

victor (vicgarpe) wrote :

Ok! Thanks kaihengfeng! I'll do it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.