[Acer AO532h] hibernate/resume failure

Bug #1758384 reported by Bill Hammond on 2018-03-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I put the computer in hibernation using sudo pm-hibernate. Computer seemed to go into hibernation normally but didn't wake up properly. System hibernates properly under Artful. Disk has a proper 2gb swap partition.

ProblemType: KernelOops
DistroRelease: Ubuntu 18.04
Package: linux-image-4.15.0-12-generic 4.15.0-12.13 [modified: boot/vmlinuz-4.15.0-12-generic]
ProcVersionSignature: Ubuntu 4.15.0-12.13-generic 4.15.7
Uname: Linux 4.15.0-12-generic x86_64
Annotation: This occurred during a previous hibernation, and prevented the system from resuming properly.
ApportVersion: 2.20.8-0ubuntu10
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ka1ssr 1005 F.... pulseaudio
Date: Fri Mar 23 12:36:52 2018
DuplicateSignature: hibernate/resume:Acer AO532h:V1.26
ExecutablePath: /usr/share/apport/apportcheckresume
Failure: hibernate/resume
HibernationDevice: RESUME=UUID=600f4807-bc16-448c-9a8f-bf5330a75d9e
InstallationDate: Installed on 2018-03-23 (0 days ago)
InstallationMedia: Xubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180323)
InterpreterPath: /usr/bin/python3.6
MachineType: Acer AO532h
ProcCmdline: /usr/bin/python3 /usr/share/apport/apportcheckresume
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-12-generic root=UUID=d2c54fce-ed1a-4448-b75b-94fad1b35afd ro quiet splash vt.handoff=1
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
Python3Details: /usr/bin/python3.6, Python 3.6.5rc1, python3-minimal, 3.6.4-1
PythonDetails: /usr/bin/python2.7, Python 2.7.14+, python-minimal, 2.7.14-4
RelatedPackageVersions:
 linux-restricted-modules-4.15.0-12-generic N/A
 linux-backports-modules-4.15.0-12-generic N/A
 linux-firmware 1.173
SourcePackage: linux
Title: [Acer AO532h] hibernate/resume failure
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 04/28/2011
dmi.bios.vendor: Acer
dmi.bios.version: V1.26
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: AO532h
dmi.board.vendor: Acer
dmi.board.version: V1.26
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.26
dmi.modalias: dmi:bvnAcer:bvrV1.26:bd04/28/2011:svnAcer:pnAO532h:pvrV1.26:rvnAcer:rnAO532h:rvrV1.26:cvnAcer:ct10:cvrV1.26:
dmi.product.family: Intel_Mobile
dmi.product.name: AO532h
dmi.product.version: V1.26
dmi.sys.vendor: Acer

Bill Hammond (ka1ssr) wrote :
tags: removed: need-duplicate-check

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Did this issue start happening after an update/upgrade? Was there a prior kernel version where you were not having this particular problem?

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.16 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.16-rc7

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Bill Hammond (ka1ssr) wrote :

I currently have two hard drives that I swap with this netbook. One drive contains Xubuntu 17.10 running the 4.13.0-37 kernel. This installation hibernates and recovers with no problems.

The other drive is for development. As of now, it has the latest daily build (20180328) installed. It looks like it goes into hibernation okay but doesn't wake up properly.

I installed the kernel you referred to, but the bug is still there.

I'm kind of new to bug reporting, so my apologies if I'm leaving something out.

Bill Hammond (ka1ssr) on 2018-03-28
tags: added: kernel-bug-exists-upstream
description: updated
Bill Hammond (ka1ssr) on 2018-03-28
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Kai-Heng Feng (kaihengfeng) wrote :

Don't use pm-hibernate. Try `systemctl hibernate`.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Bill Hammond (ka1ssr) wrote :

Tried systemctl hibernate. Still no joy.

Kai-Heng Feng (kaihengfeng) wrote :

Please find the first bad -rc kernel in [0] that introduce the bug.

It should be either v4.14-rc* or v4.15-rc*.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/

Bill Hammond (ka1ssr) wrote :

Kernel 4.14-rc1 doesn't hibernate properly in Xubuntu 18.04. However, Hibernation works fine when this kernal is running in Artful 17.10.1.

Kai-Heng Feng (kaihengfeng) wrote :

Can you attach both dmesg under 18.04 and 17.10, when hibernation fails to resume?

Bill Hammond (ka1ssr) wrote :

Which kernel should I use?

Kai-Heng Feng (kaihengfeng) wrote :

The default kernel for 17.10 is 4.13 based, the default kernel for 18.04 is 4.15 based.

Bill Hammond (ka1ssr) wrote :

Attaching the dmesg from 17.10.1. 18.04 will be posted shortly.

Bill Hammond (ka1ssr) wrote :

Attaching the dmesg from 18.04.

Kai-Heng Feng (kaihengfeng) wrote :

I guess 4.15.0-10-generic can successfully hibernate?

Bill Hammond (ka1ssr) wrote :

Yes, 4.15.0-10 hibernates under 17.10.1.

Kai-Heng Feng (kaihengfeng) wrote :

Is it the same one as LP: #1769297?

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers