Redpine: WiFi scan stopping issue observed with BLE

Bug #1757435 reported by Amitkumar Karwar on 2018-03-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Critical
Unassigned
Xenial
Critical
RITIK RAWAT

Bug Description

SRU Justification:
------------------

Impact:
   WiFi scan stopping issue observed with BLE

Test case:
   1) Any PC (Ubuntu Desktop): setup iBeacon advertiser
   2) Caracalla 3003 (Ubuntu Server/Core) run:
        ./scan.sh
         By default WiFi supplicant will run on Caracalla
         You can check the WiFi scan results by using below command
            iw dev wlan0 scan

         After 24hrs successful regression, we are unable to get the WiFi scan results by giving the above command

Fix:
   Resolve this by waiting for the confirmation for a management packet from firmware.

Regression potential:
    Below stress tests are conducted to ensure there is no issue in WiFi scan
    BLE Scan + WLAN scan
    BT Scan + WLAN scan
    BLE scan + WLAN connected

Attached are BLE scripts.

This bug is for tracking purposes only, please don't triage.

Amitkumar Karwar (amitkarwar) wrote :

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1757435

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
description: updated
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → Critical
Changed in linux (Ubuntu Xenial):
status: New → Triaged
Changed in linux (Ubuntu):
status: Confirmed → Triaged
Changed in linux (Ubuntu Xenial):
importance: Undecided → Critical
description: updated
description: updated
description: updated
description: updated
description: updated
Stefan Bader (smb) on 2018-04-23
Changed in linux (Ubuntu Xenial):
status: Triaged → Fix Committed
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-xenial' to 'verification-done-xenial'. If the problem still exists, change the tag 'verification-needed-xenial' to 'verification-failed-xenial'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-xenial
tags: added: verification-done-xenial
removed: verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 4.4.0-122.146

---------------
linux (4.4.0-122.146) xenial; urgency=medium

  * linux: 4.4.0-122.146 -proposed tracker (LP: #1766264)

  * Redpine: WiFi scan stopping issue observed with BLE (LP: #1757435)
    - SAUCE: Redpine: resolve wifi scan stop issue in stress tests

 -- Stefan Bader <email address hidden> Mon, 23 Apr 2018 16:25:01 +0200

Changed in linux (Ubuntu Xenial):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Xenial):
assignee: nobody → RITIK RAWAT (ritikrawat04)
Brad Figg (brad-figg) on 2019-07-24
tags: added: cscc
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments