[Bionic][ARM64] enable ROCE and HNS3 driver support for hip08 SoC

Bug #1756097 reported by Manoj Iyer on 2018-03-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Critical
Canonical Kernel Team
Bionic
Critical
Canonical Kernel Team

Bug Description

The following patches were cleanly cherry-picked from 4.16-rc to bionic to enable ROCE and HNS3 driver support for hip08 SoC based arm64 reference board.

Fuyun Liang (19):
      net: hns3: cleanup mac auto-negotiation state query
      net: hns3: fix for getting auto-negotiation state in hclge_get_autoneg
      net: hns3: add Asym Pause support to phy default features
      net: hns3: fix for updating fc_mode_last_time
      net: hns3: fix for setting MTU
      net: hns3: fix for changing MTU
      net: hns3: add MTU initialization for hardware
      net: hns3: fix for not setting pause parameters
      net: hns3: add ethtool_ops.get_coalesce support to PF
      net: hns3: add ethtool_ops.set_coalesce support to PF
      net: hns3: refactor interrupt coalescing init function
      net: hns3: refactor GL update function
      net: hns3: remove unused GL setup function
      net: hns3: change the unit of GL value macro
      net: hns3: add int_gl_idx setup for TX and RX queues
      net: hns3: add support for get_regs
      net: hns3: add manager table initialization for hardware
      net: hns3: add get/set_coalesce support to VF
      net: hns3: add int_gl_idx setup for VF

Huazhong Tan (1):
      net: hns: Fix for variable may be used uninitialized warnings

Jason Gunthorpe (1):
      RDMA/hns: Fix endian problems around imm_data and rkey

Jian Shen (18):
      net: hns3: Add ethtool interface for vlan filter
      net: hns3: Disable VFs change rxvlan offload status
      net: hns3: Unify the strings display of packet statistics
      net: hns3: Fix spelling errors
      net: hns3: Remove repeat statistic of rx_errors
      net: hns3: Modify the update period of packet statistics
      net: hns3: Mask the packet statistics query when NIC is down
      net: hns3: Fix an error of total drop packet statistics
      net: hns3: Fix a loop index error of tqp statistics query
      net: hns3: Fix an error macro definition of HNS3_TQP_STAT
      net: hns3: Remove a useless member of struct hns3_stats
      net: hns3: Add packet statistics of netdev
      net: hns3: Fix a response data read error of tqp statistics query
      net: hns3: Add more packet size statisctics
      net: hns3: add feature check when feature changed
      net: hns3: check for NULL function pointer in hns3_nic_set_features
      net: hns3: add ethtool -p support for fiber port
      net: hns3: add net status led support for fiber port
Manoj Iyer (1):
      UBUNTU: [Config]: enable CONFIG_HNS3_HCLGEVF as module.

Peng Li (19):
      net: hns3: add support to query tqps number
      net: hns3: add support to modify tqps number
      net: hns3: change the returned tqp number by ethtool -x
      net: hns3: free the ring_data structrue when change tqps
      net: hns3: get rss_size_max from configuration but not hardcode
      net: hns3: add a mask initialization for mac_vlan table
      net: hns3: add vlan offload config command
      net: hns3: add ethtool related offload command
      net: hns3: add handling vlan tag offload in bd
      net: hns3: add support for set_pauseparam
      net: hns3: add support to update flow control settings after autoneg
      net: hns3: add support for querying advertised pause frame by ethtool ethx
      net: hns3: Increase the default depth of bucket for TM shaper
      net: hns3: change TM sched mode to TC-based mode when SRIOV enabled
      net: hns3: remove redundant semicolon
      Revert "net: hns3: Add packet statistics of netdev"
      net: hns3: report the function type the same line with hns3_nic_get_stats64
      net: hns3: add ethtool_ops.get_channels support for VF
      net: hns3: remove TSO config command from VF driver

Salil Mehta (12):
      net: hns3: Refactor of the reset interrupt handling logic
      net: hns3: Add reset service task for handling reset requests
      net: hns3: Refactors the requested reset & pending reset handling code
      net: hns3: Add HNS3 VF IMP(Integrated Management Proc) cmd interface
      net: hns3: Add mailbox support to VF driver
      net: hns3: Add HNS3 VF HCL(Hardware Compatibility Layer) Support
      net: hns3: Add HNS3 VF driver to kernel build framework
      net: hns3: Unified HNS3 {VF|PF} Ethernet Driver for hip08 SoC
      net: hns3: Add mailbox support to PF driver
      net: hns3: Change PF to add ring-vect binding & resetQ to mailbox
      net: hns3: Add mailbox interrupt handling to PF driver
      net: hns3: converting spaces into tabs to avoid checkpatch.pl warning
Yixian Liu (4):
      RDMA/hns: Refactor eq code for hip06
      RDMA/hns: Add eq support of hip08
      RDMA/hns: Add detailed comments for mb() call
      RDMA/hns: Fix QP state judgement before sending work requests

kbuild test robot (1):
      net: hns3: hns3_get_channels() can be static

oulijun (12):
      RDMA/hns: Add rq inline data support for hip08 RoCE
      RDMA/hns: Update the usage of sr_max and rr_max field
      RDMA/hns: Set access flags of hip08 RoCE
      RDMA/hns: Filter for zero length of sge in hip08 kernel mode
      RDMA/hns: Assign dest_qp when deregistering mr
      RDMA/hns: Assign the correct value for tx_cqn
      RDMA/hns: Create gsi qp in hip08
      RDMA/hns: Add gsi qp support for modifying qp in hip08
      RDMA/hns: Fill sq wqe context of ud type in hip08
      RDMA/hns: Assign zero for pkey_index of wc in hip08
      RDMA/hns: Update the verbs of polling for completion
      RDMA/hns: Set the guid for hip08 RoCE device

CVE References

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1756097

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: bionic
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Seth Forshee (sforshee) on 2018-03-16
Changed in linux (Ubuntu Bionic):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (32.6 KiB)

This bug was fixed in the package linux - 4.15.0-13.14

---------------
linux (4.15.0-13.14) bionic; urgency=medium

  * linux: 4.15.0-13.14 -proposed tracker (LP: #1756408)

  * devpts: handle bind-mounts (LP: #1755857)
    - SAUCE: devpts: hoist out check for DEVPTS_SUPER_MAGIC
    - SAUCE: devpts: resolve devpts bind-mounts
    - SAUCE: devpts: comment devpts_mntget()
    - SAUCE: selftests: add devpts selftests

  * [bionic][arm64] d-i: add hisi_sas_v3_hw to scsi-modules (LP: #1756103)
    - d-i: add hisi_sas_v3_hw to scsi-modules

  * [Bionic][ARM64] enable ROCE and HNS3 driver support for hip08 SoC
    (LP: #1756097)
    - RDMA/hns: Refactor eq code for hip06
    - RDMA/hns: Add eq support of hip08
    - RDMA/hns: Add detailed comments for mb() call
    - RDMA/hns: Add rq inline data support for hip08 RoCE
    - RDMA/hns: Update the usage of sr_max and rr_max field
    - RDMA/hns: Set access flags of hip08 RoCE
    - RDMA/hns: Filter for zero length of sge in hip08 kernel mode
    - RDMA/hns: Fix QP state judgement before sending work requests
    - RDMA/hns: Assign dest_qp when deregistering mr
    - RDMA/hns: Fix endian problems around imm_data and rkey
    - RDMA/hns: Assign the correct value for tx_cqn
    - RDMA/hns: Create gsi qp in hip08
    - RDMA/hns: Add gsi qp support for modifying qp in hip08
    - RDMA/hns: Fill sq wqe context of ud type in hip08
    - RDMA/hns: Assign zero for pkey_index of wc in hip08
    - RDMA/hns: Update the verbs of polling for completion
    - RDMA/hns: Set the guid for hip08 RoCE device
    - net: hns3: Refactor of the reset interrupt handling logic
    - net: hns3: Add reset service task for handling reset requests
    - net: hns3: Refactors the requested reset & pending reset handling code
    - net: hns3: Add HNS3 VF IMP(Integrated Management Proc) cmd interface
    - net: hns3: Add mailbox support to VF driver
    - net: hns3: Add HNS3 VF HCL(Hardware Compatibility Layer) Support
    - net: hns3: Add HNS3 VF driver to kernel build framework
    - net: hns3: Unified HNS3 {VF|PF} Ethernet Driver for hip08 SoC
    - net: hns3: Add mailbox support to PF driver
    - net: hns3: Change PF to add ring-vect binding & resetQ to mailbox
    - net: hns3: Add mailbox interrupt handling to PF driver
    - net: hns3: add support to query tqps number
    - net: hns3: add support to modify tqps number
    - net: hns3: change the returned tqp number by ethtool -x
    - net: hns3: free the ring_data structrue when change tqps
    - net: hns3: get rss_size_max from configuration but not hardcode
    - net: hns3: add a mask initialization for mac_vlan table
    - net: hns3: add vlan offload config command
    - net: hns3: add ethtool related offload command
    - net: hns3: add handling vlan tag offload in bd
    - net: hns3: cleanup mac auto-negotiation state query
    - net: hns3: fix for getting auto-negotiation state in hclge_get_autoneg
    - net: hns3: add support for set_pauseparam
    - net: hns3: add support to update flow control settings after autoneg
    - net: hns3: add Asym Pause support to phy default features
    - net: hns3: add support for querying advertised pause frame by ethtool ethx
    - net:...

Changed in linux (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers