[Bionic][ARM64] PCI and SAS driver patches for hip08 SoCs

Bug #1756094 reported by Manoj Iyer on 2018-03-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Critical
Canonical Kernel Team
Bionic
Critical
Canonical Kernel Team

Bug Description

Following patches are required to boot and install Bionic on hip08 soc based server reference board.

Bjorn Helgaas (4):
      PCI/ASPM: Calculate LTR_L1.2_THRESHOLD from device characteristics
      PCI/ASPM: Enable Latency Tolerance Reporting when supported
      PCI/ASPM: Unexport internal ASPM interfaces
      PCI: Make PCI_SCAN_ALL_PCIE_DEVS work for Root as well as Downstream Ports

Keith Busch (2):
      PCI/AER: Return error if AER is not supported
      PCI/DPC: Enable DPC only if AER is available

Rafael J. Wysocki (2):
      PM / core: Add LEAVE_SUSPENDED driver flag
      PCI / PM: Support for LEAVE_SUSPENDED driver flag

Tyler Baicar (1):
      PCI/AER: Skip recovery callbacks for correctable errors from ACPI APEI

Wei Yongjun (1):
      scsi: hisi_sas: make local symbol host_attrs static

Xiang Chen (8):
      scsi: hisi_sas: fix dma_unmap_sg() parameter
      scsi: hisi_sas: modify hisi_sas_dev_gone() for reset
      scsi: hisi_sas: change ncq process for v3 hw
      scsi: hisi_sas: add some print to enhance debugging
      scsi: hisi_sas: fix SAS_QUEUE_FULL problem while running IO
      scsi: hisi_sas: re-add the lldd_port_deformed()
      scsi: hisi_sas: add v3 hw suspend and resume
      scsi: hisi_sas: fix a bug in hisi_sas_dev_gone()

Xiaofei Tan (11):
      scsi: hisi_sas: relocate clearing ITCT and freeing device
      scsi: hisi_sas: optimise port id refresh function
      scsi: hisi_sas: some optimizations of host controller reset
      scsi: hisi_sas: add an mechanism to do reset work synchronously
      scsi: hisi_sas: add RAS feature for v3 hw
      scsi: hisi_sas: improve int_chnl_int_v2_hw() consistency with v3 hw
      scsi: hisi_sas: add v2 hw port AXI error handling support
      scsi: hisi_sas: use an general way to delay PHY work
      scsi: hisi_sas: do link reset for some CHL_INT2 ints
      scsi: hisi_sas: judge result of internal abort
      scsi: hisi_sas: add internal abort dev in some places
chenxiang (4):
      scsi: ata: enhance the definition of SET MAX feature field value
      scsi: hisi_sas: Change frame type for SET MAX commands
      UBUNTU: SAUCE: scsi: hisi_sas: config for hip08 ES
      UBUNTU: SAUCE: scsi: hisi_sas: export device table of v3 hw to userspace

CVE References

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1756094

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: bionic
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Seth Forshee (sforshee) on 2018-03-16
Changed in linux (Ubuntu Bionic):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (32.6 KiB)

This bug was fixed in the package linux - 4.15.0-13.14

---------------
linux (4.15.0-13.14) bionic; urgency=medium

  * linux: 4.15.0-13.14 -proposed tracker (LP: #1756408)

  * devpts: handle bind-mounts (LP: #1755857)
    - SAUCE: devpts: hoist out check for DEVPTS_SUPER_MAGIC
    - SAUCE: devpts: resolve devpts bind-mounts
    - SAUCE: devpts: comment devpts_mntget()
    - SAUCE: selftests: add devpts selftests

  * [bionic][arm64] d-i: add hisi_sas_v3_hw to scsi-modules (LP: #1756103)
    - d-i: add hisi_sas_v3_hw to scsi-modules

  * [Bionic][ARM64] enable ROCE and HNS3 driver support for hip08 SoC
    (LP: #1756097)
    - RDMA/hns: Refactor eq code for hip06
    - RDMA/hns: Add eq support of hip08
    - RDMA/hns: Add detailed comments for mb() call
    - RDMA/hns: Add rq inline data support for hip08 RoCE
    - RDMA/hns: Update the usage of sr_max and rr_max field
    - RDMA/hns: Set access flags of hip08 RoCE
    - RDMA/hns: Filter for zero length of sge in hip08 kernel mode
    - RDMA/hns: Fix QP state judgement before sending work requests
    - RDMA/hns: Assign dest_qp when deregistering mr
    - RDMA/hns: Fix endian problems around imm_data and rkey
    - RDMA/hns: Assign the correct value for tx_cqn
    - RDMA/hns: Create gsi qp in hip08
    - RDMA/hns: Add gsi qp support for modifying qp in hip08
    - RDMA/hns: Fill sq wqe context of ud type in hip08
    - RDMA/hns: Assign zero for pkey_index of wc in hip08
    - RDMA/hns: Update the verbs of polling for completion
    - RDMA/hns: Set the guid for hip08 RoCE device
    - net: hns3: Refactor of the reset interrupt handling logic
    - net: hns3: Add reset service task for handling reset requests
    - net: hns3: Refactors the requested reset & pending reset handling code
    - net: hns3: Add HNS3 VF IMP(Integrated Management Proc) cmd interface
    - net: hns3: Add mailbox support to VF driver
    - net: hns3: Add HNS3 VF HCL(Hardware Compatibility Layer) Support
    - net: hns3: Add HNS3 VF driver to kernel build framework
    - net: hns3: Unified HNS3 {VF|PF} Ethernet Driver for hip08 SoC
    - net: hns3: Add mailbox support to PF driver
    - net: hns3: Change PF to add ring-vect binding & resetQ to mailbox
    - net: hns3: Add mailbox interrupt handling to PF driver
    - net: hns3: add support to query tqps number
    - net: hns3: add support to modify tqps number
    - net: hns3: change the returned tqp number by ethtool -x
    - net: hns3: free the ring_data structrue when change tqps
    - net: hns3: get rss_size_max from configuration but not hardcode
    - net: hns3: add a mask initialization for mac_vlan table
    - net: hns3: add vlan offload config command
    - net: hns3: add ethtool related offload command
    - net: hns3: add handling vlan tag offload in bd
    - net: hns3: cleanup mac auto-negotiation state query
    - net: hns3: fix for getting auto-negotiation state in hclge_get_autoneg
    - net: hns3: add support for set_pauseparam
    - net: hns3: add support to update flow control settings after autoneg
    - net: hns3: add Asym Pause support to phy default features
    - net: hns3: add support for querying advertised pause frame by ethtool ethx
    - net:...

Changed in linux (Ubuntu Bionic):
status: Fix Committed → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic
Andy Whitcroft (apw) on 2019-02-14
tags: added: kernel-fixup-verification-needed-bionic
removed: verification-needed-bionic
Brad Figg (brad-figg) on 2019-02-14
tags: added: verification-needed-bionic
Andy Whitcroft (apw) wrote :

This bug was erroneously marked for verification in bionic; verification is not required and verification-needed-bionic is being removed.

tags: removed: verification-needed-bionic
tags: added: verification-done-bionic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers