Allow hugepage backing for "p8compat" mode kvm guests

Bug #1754206 reported by bugproxy on 2018-03-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Ubuntu-power-systems project
High
Canonical Kernel Team
linux (Ubuntu)
High
Canonical Kernel Team
Bionic
High
Canonical Kernel Team

Bug Description

== Comment: #0 - JENIFER HOPPER <email address hidden> - 2018-03-06 15:23:56 ==
+++ This bug was initially created as a clone of Bug #165320 +++

---Problem Description---
Paul Mackerras posted a patch to allow for hugepage backing of Hash guest(s) on a Radix host:
http://patchwork.ozlabs.org/patch/880302/
" KVM: PPC: Book3S HV: Fix VRMA initialization with 2MB or 1GB memory backing "

With a 1GB backing in the Radix host, this patch allows the Hash guest to boot and allocate and use 16MB hugepages if needed (since backing page size must be larger than guest hugepage size).

Once this is accepted upstream we should get it included in Ubuntu so that p8compat guests can use hugepages.

Contact Information = <email address hidden>

---uname output---
Ubuntu 18.04

Machine Type = 5104-22C

---Debugger---
A debugger is not configured

---Steps to Reproduce---
 Back p8compat guest w/ 1GB hugepages, see that 16MB hugepages are available to reserve and use inside the guest.

== Comment: #2 - JENIFER HOPPER <email address hidden> - 2018-03-07 10:43:36 ==
The patch is now in Paul's upstream tree:
https://git.kernel.org/pub/scm/linux/kernel/git/paulus/powerpc.git/commit/?h=kvm-ppc-fixes-4.16-1&id=debd574f4195e205ba505b25e19b2b797f4bcd94

bugproxy (bugproxy) on 2018-03-08
tags: added: architecture-ppc64le bugnameltc-165400 severity-high targetmilestone-inin---
Changed in ubuntu:
assignee: nobody → Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage)
affects: ubuntu → kernel-package (Ubuntu)
Changed in ubuntu-power-systems:
importance: Undecided → High
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
tags: added: triage-g
affects: kernel-package (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
importance: Medium → High
tags: added: bionic kernel-da-key
Manoj Iyer (manjo) on 2018-03-12
Changed in linux (Ubuntu Bionic):
assignee: Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage) → Canonical Kernel Team (canonical-kernel-team)
Changed in ubuntu-power-systems:
status: New → Triaged
Changed in linux (Ubuntu Bionic):
status: Triaged → Fix Committed
bugproxy (bugproxy) on 2018-03-27
tags: added: targetmilestone-inin1804
removed: targetmilestone-inin---
Manoj Iyer (manjo) on 2018-04-05
Changed in ubuntu-power-systems:
status: Triaged → Fix Committed

------- Comment From <email address hidden> 2018-04-08 19:49 EDT-------
Can some one tell me this fix is made available in "-proposed" build at least for test to validate?

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-04-08 23:12 EDT-------
(In reply to comment #5)
> Can some one tell me this fix is made available in "-proposed" build at
> least for test to validate?

With the below kernel, I am able to boot P8 guests with 16M hugepages - 1G backed in Host

# uname -a
Linux ltc-boston122 4.15.0-15-generic #16-Ubuntu SMP Wed Apr 4 13:57:51 UTC 2018 ppc64le ppc64le ppc64le GNU/Linux

In guest
-----------
root@ubuntu:~# cat /proc/meminfo
...
HugePages_Total: 10
HugePages_Free: 10
HugePages_Rsvd: 0
HugePages_Surp: 0
Hugepagesize: 16384 kB

root@ubuntu:~# uname -a
Linux ubuntu 4.4.0-116-generic #140-Ubuntu SMP Mon Feb 12 21:22:24 UTC 2018 ppc64le ppc64le ppc64le GNU/Linux

- Harish

Launchpad Janitor (janitor) wrote :
Download full text (40.4 KiB)

This bug was fixed in the package linux - 4.15.0-15.16

---------------
linux (4.15.0-15.16) bionic; urgency=medium

  * linux: 4.15.0-15.16 -proposed tracker (LP: #1761177)

  * FFe: Enable configuring resume offset via sysfs (LP: #1760106)
    - PM / hibernate: Make passing hibernate offsets more friendly

  * /dev/bcache/by-uuid links not created after reboot (LP: #1729145)
    - SAUCE: (no-up) bcache: decouple emitting a cached_dev CHANGE uevent

  * Ubuntu18.04:POWER9:DD2.2 - Unable to start a KVM guest with default machine
    type(pseries-bionic) complaining "KVM implementation does not support
    Transactional Memory, try cap-htm=off" (kvm) (LP: #1752026)
    - powerpc: Use feature bit for RTC presence rather than timebase presence
    - powerpc: Book E: Remove unused CPU_FTR_L2CSR bit
    - powerpc: Free up CPU feature bits on 64-bit machines
    - powerpc: Add CPU feature bits for TM bug workarounds on POWER9 v2.2
    - powerpc/powernv: Provide a way to force a core into SMT4 mode
    - KVM: PPC: Book3S HV: Work around transactional memory bugs in POWER9
    - KVM: PPC: Book3S HV: Work around XER[SO] bug in fake suspend mode
    - KVM: PPC: Book3S HV: Work around TEXASR bug in fake suspend state

  * Important Kernel fixes to be backported for Power9 (kvm) (LP: #1758910)
    - powerpc/mm: Fixup tlbie vs store ordering issue on POWER9

  * Ubuntu 18.04 - IO Hang on some namespaces when running HTX with 16
    namespaces (Bolt / NVMe) (LP: #1757497)
    - powerpc/64s: Fix lost pending interrupt due to race causing lost update to
      irq_happened

  * fwts-efi-runtime-dkms 18.03.00-0ubuntu1: fwts-efi-runtime-dkms kernel module
    failed to build (LP: #1760876)
    - [Packaging] include the retpoline extractor in the headers

linux (4.15.0-14.15) bionic; urgency=medium

  * linux: 4.15.0-14.15 -proposed tracker (LP: #1760678)

  * [Bionic] mlx4 ETH - mlnx_qos failed when set some TC to vendor
    (LP: #1758662)
    - net/mlx4_en: Change default QoS settings

  * AT_BASE_PLATFORM in AUXV is absent on kernels available on Ubuntu 17.10
    (LP: #1759312)
    - powerpc/64s: Fix NULL AT_BASE_PLATFORM when using DT CPU features

  * Bionic update to 4.15.15 stable release (LP: #1760585)
    - net: dsa: Fix dsa_is_user_port() test inversion
    - openvswitch: meter: fix the incorrect calculation of max delta_t
    - qed: Fix MPA unalign flow in case header is split across two packets.
    - tcp: purge write queue upon aborting the connection
    - qed: Fix non TCP packets should be dropped on iWARP ll2 connection
    - sysfs: symlink: export sysfs_create_link_nowarn()
    - net: phy: relax error checking when creating sysfs link netdev->phydev
    - devlink: Remove redundant free on error path
    - macvlan: filter out unsupported feature flags
    - net: ipv6: keep sk status consistent after datagram connect failure
    - ipv6: old_dport should be a __be16 in __ip6_datagram_connect()
    - ipv6: sr: fix NULL pointer dereference when setting encap source address
    - ipv6: sr: fix scheduling in RCU when creating seg6 lwtunnel state
    - mlxsw: spectrum_buffers: Set a minimum quota for CPU port traffic
    - net: phy: Tell caller result ...

Changed in linux (Ubuntu Bionic):
status: Fix Committed → Fix Released
Manoj Iyer (manjo) on 2018-04-23
Changed in ubuntu-power-systems:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers