CAPI Flash (cxlflash) update

Bug #1752672 reported by bugproxy on 2018-03-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Ubuntu-power-systems project
Medium
Canonical Kernel Team
linux (Ubuntu)
Medium
Canonical Kernel Team
Bionic
Medium
Canonical Kernel Team

Bug Description

This is a feature for capi flash (cxlflash) inside the kernel.

We have upstreamed the below 38 patches but they are not in the maintainers tree yet. I anticipate them to be available by Friday this week. I dont want to miss the boat for 18.04 feature code cutoff. Can you please suggest if I should submit these patches as SAUCE patches or can it be pulled from mainstream once maintainer pulls it in ?

8d34234b7e44caa489bb7e684ead1f13b74faf72 cxlflash: Preserve number of interrupts for master contexts
8f20948fde0a06a283b39c3646c8060b62319875 cxlflash: Avoid clobbering context control register value
44569c367471bd57916798a701ad1c7250ec93fb cxlflash: Add argument identifier names
9e63cdb74178a02fa76c3896c2e38479148e60bf cxlflash: Introduce OCXL backend
0aa60ffb7ca4ce3f5cb33231d9358ab9f0ae9ec4 cxlflash: Hardware AFU for OCXL
f9e6817464036867a6994732c3b8b873b6fdc530 cxlflash: Read host function configuration
f1718592638ef1e3486ded07ba9aebf784b03db3 cxlflash: Setup function acTag range
77ece8688ed48e693bbdfef7b856ed146dac5838 cxlflash: Read host AFU configuration
6491b3338076c8a71f70c326aeacf7ecde139124 cxlflash: Setup AFU acTag range
90fbea09364d3a32b6b2b0fbbd56c4fbaabe5400 cxlflash: Setup AFU PASID
16e8be014d2efa0f7e713d5e7cfae9348eaab6fd cxlflash: Adapter context support for OCXL
2d431a892b91f9f004a8b6413d990c55dac6ac16 cxlflash: Use IDR to manage adapter contexts
d0dd47f71da4a9f37cfd2eced36f85c2751fcdf5 cxlflash: Support adapter file descriptors for OCXL
1719110f42503bcac6962daf4492cec3c16c325f cxlflash: Support adapter context discovery
e9ff19884da98139427e23c8ce3bed7614427fed cxlflash: Support image reload policy modification
5706f2a40306b2fe5ffae6fa1eacc81afed3fa11 cxlflash: MMIO map the AFU
99b7d36979c67708851f8058c9fb6e412d32577b cxlflash: Support starting an adapter context
d8e72cf527fed71641dd011dff13fbd1e5fad2da cxlflash: Support process specific mappings
8cc796025b082c13c1ec3db620e9f23f6082726a cxlflash: Support AFU state toggling
9e0d9716935bdf9e2c24d3c27ae8be1756eff46e cxlflash: Support reading adapter VPD data
b37e0fdd868e47221e706be4d51c66e5e9224f20 cxlflash: Setup function OCXL link
099858c80b956752693e0d3bb8f01618a11d48dc cxlflash: Setup OCXL transaction layer
5b1a1f3d49ee4b41778e41bf8147febc885df381 cxlflash: Support process element lifecycle
0e3e9fbfada4506620610497cdc6ce0a0b3cdff2 cxlflash: Support AFU interrupt management
ff7388a91f3739c5420b16f20d74644f5da9b03a cxlflash: Support AFU interrupt mapping and registration
cfa71c77fd9e440b1d8f105151eaf30aff5f3241 cxlflash: Support starting user contexts
270a401d0901eeb736b1da4fd728006ae4d40145 cxlflash: Support adapter context polling
302ce17cba275e295803a2a2aad83debfd02cf5d cxlflash: Support adapter context reading
cc8640bac30541ddc453834d5956ced223ed0020 cxlflash: Support adapter context mmap and release
a071c05a8cab915a3a7d11a87b06da00bc5bc7d5 cxlflash: Support file descriptor mapping
eb01b23138c73967c17c04e79ab4c5df4649984e cxlflash: Introduce object handle fop
c6a2e3b15bd5a6f85472eac54fede0cffcd6d4e5 cxlflash: Setup LISNs for user contexts
bbfdb7e4d852d213b3b474185918a94aabecad7f cxlflash: Setup LISNs for master contexts
e8d361505cef408ec3afb5f0cf1e4c3fd7f6150b cxlflash: Update synchronous interrupt status bits
dc8e5211cbd6457f618bc49df7e769895b6996bc cxlflash: Introduce OCXL context state machine
9c5567f5e9c92a9f94f7790b2dd905235bc9842c cxlflash: Register for translation errors
96cacd8347f27d258bae75d796cc1f523724a37a cxlflash: Support AFU reset
966a6e64ddd9624999d895fffab190c7d2f96c85 cxlflash: Enable OCXL operations

<<< The above is from my local git tree but it has been already sent to linux-scsi mailing list >>>

bugproxy (bugproxy) on 2018-03-01
tags: added: architecture-ppc64le bugnameltc-163818 severity-medium targetmilestone-inin1804
Changed in ubuntu:
assignee: nobody → Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage)
affects: ubuntu → linux (Ubuntu)
Changed in ubuntu-power-systems:
importance: Undecided → Medium
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
tags: added: triage-g

------- Comment on attachment From <email address hidden> 2018-03-01 13:47 EDT-------

Attaching the proposed patches that have been sent to community.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
tags: added: kernel-da-key
Changed in ubuntu-power-systems:
status: New → Triaged
Manoj Iyer (manjo) on 2018-03-05
Changed in linux (Ubuntu Bionic):
assignee: Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage) → Canonical Kernel Team (canonical-kernel-team)
Seth Forshee (sforshee) wrote :

There are significant conflicts when trying to apply these patches to 4.15, likely due to changes in 4.16. Can you advise which additional patches are needed? Thanks!

Changed in linux (Ubuntu Bionic):
status: Triaged → Incomplete

------- Comment From <email address hidden> 2018-03-20 22:19 EDT-------
Sorry about the trouble...Here are the missing patches from 4.16 that are needed before applying the 38 patches.

96cf727fe8f102bf92150b741db71ee39fb8c521 scsi: cxlflash: Reset command ioasc
b070545db112e4c815fbfce25449495eff20c170 scsi: cxlflash: Update cxl-specific arguments to generic cookie
af2047ec00bfd61b46b653e856dcf1e0bc567619 scsi: cxlflash: Explicitly cache number of interrupts per context
8762353106c4376deabd76473e1bd7ba36dd529c scsi: cxlflash: Remove embedded CXL work structures
0df69c6024cd089144d3b38f12352899dd4e40b1 scsi: cxlflash: Adapter context init can return error
25b8e08e83b5bc58967aae566730548f407c0439 scsi: cxlflash: Staging to support future accelerators

Please let me know if you still have problems with these patches.

Seth Forshee (sforshee) on 2018-03-27
Changed in linux (Ubuntu Bionic):
status: Incomplete → In Progress
Seth Forshee (sforshee) on 2018-03-27
Changed in linux (Ubuntu Bionic):
status: In Progress → Fix Committed
Manoj Iyer (manjo) on 2018-04-05
Changed in ubuntu-power-systems:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (40.4 KiB)

This bug was fixed in the package linux - 4.15.0-15.16

---------------
linux (4.15.0-15.16) bionic; urgency=medium

  * linux: 4.15.0-15.16 -proposed tracker (LP: #1761177)

  * FFe: Enable configuring resume offset via sysfs (LP: #1760106)
    - PM / hibernate: Make passing hibernate offsets more friendly

  * /dev/bcache/by-uuid links not created after reboot (LP: #1729145)
    - SAUCE: (no-up) bcache: decouple emitting a cached_dev CHANGE uevent

  * Ubuntu18.04:POWER9:DD2.2 - Unable to start a KVM guest with default machine
    type(pseries-bionic) complaining "KVM implementation does not support
    Transactional Memory, try cap-htm=off" (kvm) (LP: #1752026)
    - powerpc: Use feature bit for RTC presence rather than timebase presence
    - powerpc: Book E: Remove unused CPU_FTR_L2CSR bit
    - powerpc: Free up CPU feature bits on 64-bit machines
    - powerpc: Add CPU feature bits for TM bug workarounds on POWER9 v2.2
    - powerpc/powernv: Provide a way to force a core into SMT4 mode
    - KVM: PPC: Book3S HV: Work around transactional memory bugs in POWER9
    - KVM: PPC: Book3S HV: Work around XER[SO] bug in fake suspend mode
    - KVM: PPC: Book3S HV: Work around TEXASR bug in fake suspend state

  * Important Kernel fixes to be backported for Power9 (kvm) (LP: #1758910)
    - powerpc/mm: Fixup tlbie vs store ordering issue on POWER9

  * Ubuntu 18.04 - IO Hang on some namespaces when running HTX with 16
    namespaces (Bolt / NVMe) (LP: #1757497)
    - powerpc/64s: Fix lost pending interrupt due to race causing lost update to
      irq_happened

  * fwts-efi-runtime-dkms 18.03.00-0ubuntu1: fwts-efi-runtime-dkms kernel module
    failed to build (LP: #1760876)
    - [Packaging] include the retpoline extractor in the headers

linux (4.15.0-14.15) bionic; urgency=medium

  * linux: 4.15.0-14.15 -proposed tracker (LP: #1760678)

  * [Bionic] mlx4 ETH - mlnx_qos failed when set some TC to vendor
    (LP: #1758662)
    - net/mlx4_en: Change default QoS settings

  * AT_BASE_PLATFORM in AUXV is absent on kernels available on Ubuntu 17.10
    (LP: #1759312)
    - powerpc/64s: Fix NULL AT_BASE_PLATFORM when using DT CPU features

  * Bionic update to 4.15.15 stable release (LP: #1760585)
    - net: dsa: Fix dsa_is_user_port() test inversion
    - openvswitch: meter: fix the incorrect calculation of max delta_t
    - qed: Fix MPA unalign flow in case header is split across two packets.
    - tcp: purge write queue upon aborting the connection
    - qed: Fix non TCP packets should be dropped on iWARP ll2 connection
    - sysfs: symlink: export sysfs_create_link_nowarn()
    - net: phy: relax error checking when creating sysfs link netdev->phydev
    - devlink: Remove redundant free on error path
    - macvlan: filter out unsupported feature flags
    - net: ipv6: keep sk status consistent after datagram connect failure
    - ipv6: old_dport should be a __be16 in __ip6_datagram_connect()
    - ipv6: sr: fix NULL pointer dereference when setting encap source address
    - ipv6: sr: fix scheduling in RCU when creating seg6 lwtunnel state
    - mlxsw: spectrum_buffers: Set a minimum quota for CPU port traffic
    - net: phy: Tell caller result ...

Changed in linux (Ubuntu Bionic):
status: Fix Committed → Fix Released
Changed in ubuntu-power-systems:
status: Fix Committed → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic
Andy Whitcroft (apw) on 2019-02-14
tags: added: kernel-fixup-verification-needed-bionic
removed: verification-needed-bionic
Brad Figg (brad-figg) on 2019-02-14
tags: added: verification-needed-bionic
Andy Whitcroft (apw) wrote :

This bug was erroneously marked for verification in bionic; verification is not required and verification-needed-bionic is being removed.

tags: removed: verification-needed-bionic
tags: added: verification-done-bionic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers