Bionic update to v4.15.7 stable release

Bug #1752317 reported by Thadeu Lima de Souza Cascardo on 2018-02-28
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Thadeu Lima de Souza Cascardo
Bionic
Medium
Thadeu Lima de Souza Cascardo

Bug Description

SRU Justification

    Impact:
       The upstream process for stable tree updates is quite similar
       in scope to the Ubuntu SRU process, e.g., each patch has to
       demonstrably fix a bug, and each patch is vetted by upstream
       by originating either directly from a mainline/stable Linux tree or
       a minimally backported form of that patch. The v4.15.7 upstream stable
       patch set is now available. It should be included in the Ubuntu
       kernel as well.

       git://git.kernel.org/

    TEST CASE: TBD

       The following patches from the v4.15.7 stable release shall be applied:

netfilter: drop outermost socket lock in getsockopt()
arm64: mm: don't write garbage into TTBR1_EL1 register
kconfig.h: Include compiler types to avoid missed struct attributes
MIPS: boot: Define __ASSEMBLY__ for its.S build
xtensa: fix high memory/reserved memory collision
scsi: ibmvfc: fix misdefined reserved field in ibmvfc_fcp_rsp_info
MIPS: Drop spurious __unused in struct compat_flock
cfg80211: fix cfg80211_beacon_dup
i2c: designware: must wait for enable
i2c: bcm2835: Set up the rising/falling edge delays
X.509: fix BUG_ON() when hash algorithm is unsupported
X.509: fix NULL dereference when restricting key with unsupported_sig
PKCS#7: fix certificate chain verification
PKCS#7: fix certificate blacklisting
extcon: int3496: process id-pin first so that we start with the right status
genirq/matrix: Handle CPU offlining proper
RDMA/uverbs: Protect from races between lookup and destroy of uobjects
RDMA/uverbs: Protect from command mask overflow
RDMA/uverbs: Fix bad unlock balance in ib_uverbs_close_xrcd
RDMA/uverbs: Fix circular locking dependency
RDMA/uverbs: Sanitize user entered port numbers prior to access it
iio: adc: stm32: fix stm32h7_adc_enable error handling
iio: srf08: fix link error "devm_iio_triggered_buffer_setup" undefined
iio: buffer: check if a buffer has been set up when poll is called
iio: adis_lib: Initialize trigger before requesting interrupt
Kbuild: always define endianess in kconfig.h
x86/apic/vector: Handle vector release on CPU unplug correctly
x86/oprofile: Fix bogus GCC-8 warning in nmi_setup()
mm, swap, frontswap: fix THP swap if frontswap enabled
mm: don't defer struct page initialization for Xen pv guests
uapi/if_ether.h: move __UAPI_DEF_ETHHDR libc define
irqchip/gic-v3: Use wmb() instead of smb_wmb() in gic_raise_softirq()
irqchip/mips-gic: Avoid spuriously handling masked interrupts
PCI/cxgb4: Extend T3 PCI quirk to T4+ devices
net: thunderbolt: Tear down connection properly on suspend
net: thunderbolt: Run disconnect flow asynchronously when logout is received
ohci-hcd: Fix race condition caused by ohci_urb_enqueue() and io_watchdog_func()
usb: ohci: Proper handling of ed_rm_list to handle race condition between usb_kill_urb() and finish_unlinks()
arm64: Remove unimplemented syscall log message
arm64: Disable unhandled signal log messages by default
arm64: cpufeature: Fix CTR_EL0 field definitions
Add delay-init quirk for Corsair K70 RGB keyboards
drm/edid: Add 6 bpc quirk for CPT panel in Asus UX303LA
usb: host: ehci: use correct device pointer for dma ops
usb: dwc3: gadget: Set maxpacket size for ep0 IN
usb: dwc3: ep0: Reset TRB counter for ep0 IN
usb: phy: mxs: Fix NULL pointer dereference on i.MX23/28
usb: ldusb: add PIDs for new CASSY devices supported by this driver
Revert "usb: musb: host: don't start next rx urb if current one failed"
usb: gadget: f_fs: Process all descriptors during bind
usb: gadget: f_fs: Use config_ep_by_speed()
usb: renesas_usbhs: missed the "running" flag in usb_dmac with rx path
drm/cirrus: Load lut in crtc_commit
drm/atomic: Fix memleak on ERESTARTSYS during non-blocking commits
drm: Handle unexpected holes in color-eviction
drm/amdgpu: disable MMHUB power gating on raven
drm/amdgpu: fix VA hole handling on Vega10 v3
drm/amdgpu: Add dpm quirk for Jet PRO (v2)
drm/amdgpu: only check mmBIF_IOV_FUNC_IDENTIFIER on tonga/fiji
drm/amdgpu: add atpx quirk handling (v2)
drm/amdgpu: Avoid leaking PM domain on driver unbind (v2)
drm/amdgpu: add new device to use atpx quirk
arm64: __show_regs: Only resolve kernel symbols when running at EL1
drm/i915/breadcrumbs: Ignore unsubmitted signalers
microblaze: fix endian handling
Linux 4.15.7

CVE References

tags: added: kernel-stable-tracking-bug
description: updated
Changed in linux (Ubuntu Bionic):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Thadeu Lima de Souza Cascardo (cascardo)
Changed in linux (Ubuntu Bionic):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (40.0 KiB)

This bug was fixed in the package linux - 4.15.0-12.13

---------------
linux (4.15.0-12.13) bionic; urgency=medium

  * linux: 4.15.0-12.13 -proposed tracker (LP: #1754059)

  * CONFIG_EFI=y on armhf (LP: #1726362)
    - [Config] CONFIG_EFI=y on armhf, reconcile secureboot EFI settings

  * ppc64el: Support firmware disable of RFI flush (LP: #1751994)
    - powerpc/pseries: Support firmware disable of RFI flush
    - powerpc/powernv: Support firmware disable of RFI flush

  * [Feature] CFL/CNL (PCH:CNP-H): New GPIO Commit added (GPIO Driver needed)
    (LP: #1751714)
    - gpio / ACPI: Drop unnecessary ACPI GPIO to Linux GPIO translation
    - pinctrl: intel: Allow custom GPIO base for pad groups
    - pinctrl: cannonlake: Align GPIO number space with Windows

  * [Feature] Add xHCI debug device support in the driver (LP: #1730832)
    - usb: xhci: Make some static functions global
    - usb: xhci: Add DbC support in xHCI driver
    - [Config] USB_XHCI_DBGCAP=y for commit mainline dfba2174dc42.

  * [SRU] Lenovo E41 Mic mute hotkey is not responding (LP: #1753347)
    - platform/x86: ideapad-laptop: Increase timeout to wait for EC answer

  * headset mic can't be detected on two Dell machines (LP: #1748807)
    - ALSA: hda - Fix a wrong FIXUP for alc289 on Dell machines

  * hisi_sas: Add disk LED support (LP: #1752695)
    - scsi: hisi_sas: directly attached disk LED feature for v2 hw

  * [Feature] [Graphics]Whiskey Lake (Coffelake-U 4+2) new PCI Device ID adds
    (LP: #1742561)
    - drm/i915/cfl: Adding more Coffee Lake PCI IDs.

  * [Bug] [USB Function][CFL-CNL PCH]Stall Error and USB Transaction Error in
    trace, Disable of device-initiated U1/U2 failed and rebind failed: -517
    during suspend/resume with usb storage. (LP: #1730599)
    - usb: Don't print a warning if interface driver rebind is deferred at resume

  * retpoline: ignore %cs:0xNNN constant indirections (LP: #1752655)
    - [Packaging] retpoline -- elide %cs:0xNNNN constants on i386
    - [Config] retpoline -- clean up i386 retpoline files

  * hisilicon hibmc regression due to ea642c3216cb ("drm/ttm: add io_mem_pfn
    callback") (LP: #1738334)
    - drm/ttm: add ttm_bo_io_mem_pfn to check io_mem_pfn

  * [Asus UX360UA] battery status in unity-panel is not changing when battery is
    being charged (LP: #1661876) // AC adapter status not detected on Asus
    ZenBook UX410UAK (LP: #1745032)
    - ACPI / battery: Add quirk for Asus UX360UA and UX410UAK

  * ASUS UX305LA - Battery state not detected correctly (LP: #1482390)
    - ACPI / battery: Add quirk for Asus GL502VSK and UX305LA

  * [18.04 FEAT] Automatically detect layer2 setting in the qeth device driver
    (LP: #1747639)
    - s390/diag: add diag26c support for VNIC info
    - s390/qeth: support early setup for z/VM NICs

  * Bionic update to v4.15.7 stable release (LP: #1752317)
    - netfilter: drop outermost socket lock in getsockopt()
    - arm64: mm: don't write garbage into TTBR1_EL1 register
    - kconfig.h: Include compiler types to avoid missed struct attributes
    - MIPS: boot: Define __ASSEMBLY__ for its.S build
    - xtensa: fix high memory/reserved memory collision
    - scsi: ibmvfc: fix misde...

Changed in linux (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers