[Feature]Update Ubuntu 18.04 lpfc FC driver with 32/64GB HBA support and bug fixes

Bug #1752182 reported by laurie barry on 2018-02-27
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Seth Forshee
Bionic
High
Seth Forshee

Bug Description

This is a placeholder bugzilla that will list all commit ids needed for Broadcom Emulex FC 32/64GB new hardware support and all bug fixes available upstream.

Note the lpfc FC driver commit list will include NVMe patches for ease of maintainability vs. upstream but we ask that you not build NVMe FC since we do not intend to support NVMe FC on 18.04 (4.15 kernel) at this time due to all of the unmet upper layer dependencies.

Laurie Barry

CVE References

Dick Kennedy (dick-kennedy) wrote :
Download full text (3.3 KiB)

We don't have access to ubuntu's git tree so I will base this list assuming that ubuntu is starting with the 4.15-r6 kernel that is the stable kernel on kernel.org?
The last lpfc commit in 4.15.6 was " Fix after bad bar setup", the last version bump for lpfc was 11.4.0.4. These are the commit ids from Martins 4.17/scsi-queue branch for lpfc. the transport changes should be in a different bz.

 6ddcf0a30adc5080504ca66f474101e7ad247dd7
 9816ef6ecbc102b9bcbb1d83e12c7fb19924f38c
 c73455e1b5ef165aed82e36ae04e74a71d2d7d5b
 81b96eda5ff8077873072facd20b9d85a80c61bd
 8a5ca109a306db0e4ccb6f43af376c899faee652
 422c4cb7e9d6eaff09ef3d6782819c0e2741fbba
 d73154ba3294e02de01cb60effe938c68621fe32
 d33d0eb28b883b09a48a7d608640e9aeecd9edbf
 07d494f7533e6d9c22931f6e4a2e048560063081
 bcb24f6577b9461267f350d11e1bb6dda470f241
 b7e50c536e8e4c6d4c74a1d54a0ce33edbf9dd0a
        4938250ebdb89bd7ed9e4735ac705403fcd1e832
 3b5bde69bcf91d75e75d6b0ca9ab6346d0744137
        add9d6be3d650bf897b1c3feadabcf42e216acdb
 3386f4bdd243ad5a9094d390297602543abe9902
 c3725bdcdf28f5e2f3a78b69e9dd010f49284a09
 81e6a63728a409ae0e0061c1dc5adb4a85cc4869
 cf1a1d3e2d88af49472014db0c82779b4fe85455
 ba48077f23d29218c25e057b037c0813f78de94c
 cbc5de1b8a0f67beeafa9e474803709368f55175
        b95e29b75d3eebf989907c848f3b10eb5a0117fa
        a51e41b671f18b4387b7150f64e1578729776302
 9de416ac67b54d666327ba927a190f4b7259f4a0
 e06351a002214d152142906a546006e3446d1ef7
        3fd78355cdd59dbfec60e03a539378e3e3498c38
        4b056682d8812af30c6e6022f653b75abe2f26c7
        2f7005debea691ee83b575ed089eba80081c8bc3
        b996ce39960e6239d3d30745749b0b17239cadce
        5c665aeb65aa066775763e59110ba4f5b5917bb6
        8fd03fd17ff903abf91583344aaea2043cbccdad
        b6b996b6cdeecf7e1646c87422e04e446ddce124 Tree wide patch
        c828a8920307185b7194b575731e8387c99a5a67 Tree wide patch
 6cbaefb4bf2ce6746e49c972289702133b347ffa Tree wide patch
 04673e38f56b30cd39b1fa0f386137d818b17781
        c176ffa0841c632593c5007f1d1c9ed126481daa
        281d61902ffbab47901f8616a38a45144627dd9e
 8ae337013674d5c1e803429356b85cba2ce12067
 6e8e1c14c61e54253098521127cd5ac0b959dd32
 2c3b2a8f652566c5b35d945f0c8146555d2062ec
        91455b850956bc13708a074bd1400f54aae74890
 411de511c6943554cdc4173c3f522029db2f75c7
 64bf009933bc84a7fb44ff50f86af0201b8be0c3
        161df4f09987ae2e9f0f97f0b38eee298b4a39ff
 2289e9598dde9705400559ca2606fb8c145c34f0
        a5ff06817eb86d022bc11993850a42732d7e6979
 c1dd9111b7f78a90bccd2e4abb9b9bb6319a4c64
 20aefac3a9a23b56db43f1fe1b3ae72c87e39137
        8d731d1aa993c44fcf4de0dbd42059e00cf37102
        45634a86ca6e98dbcaddb763f8e90ad243057789
        815a9c437617e221842d12b3366ff6911b3df628
 6e9d2f1667ea12bd2f997a7529fb41cce8e0036d
 128bddacc4dd7c86070e1e0534687e3083a89d52
 b71413dd01bbf302236cfb61df44702ea838dd75
 9dd35425a50c667ae2b6c2cda201425ed2d3fd25
 27d6ac0a6e830043bd5db89fee8adddb41ada2f7
        1351e69fc6db30e186295f1c9495d03cef6a01a2
        c238b9b6eae399e81d36382b09c2e969c154b7ee
 fbd8a6ba65443a8a79183edd9c2e1ad302339063
 7365f6fdbba559f7e814519fafe6e4956f68b6be
        1feb8204a12ed7987bffa75311754edc1367680f
        0bc2b7c5317bd51df571e9d1131547901215f6c9
        4e565cf041...

Read more...

Jeff Lane (bladernr) wrote :

Moved this to a kernel bug as these are driver patches that go into the kernel, not the open-iscsi package.

affects: open-iscsi (Ubuntu) → linux (Ubuntu)

Excellent!

*Laurie Barry*
Software Program Manager | Emulex Connectivity Division
office/soft phone: 978-719-1503 | mobile: 603-930-1771
200 Brickstone Square | Andover, MA 01810
<email address hidden> | broadcom.com

On Wed, Feb 28, 2018 at 11:37 AM, Jeff Lane <email address hidden>
wrote:

> Moved this to a kernel bug as these are driver patches that go into the
> kernel, not the open-iscsi package.
>
> ** Package changed: open-iscsi (Ubuntu) => linux (Ubuntu)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1752182
>
> Title:
> Update Ubuntu 18.04 lpfc FC driver with 32/64GB HBA support and bug
> fixes
>
> Status in linux package in Ubuntu:
> New
>
> Bug description:
> This is a placeholder bugzilla that will list all commit ids needed
> for Broadcom Emulex FC 32/64GB new hardware support and all bug fixes
> available upstream.
>
> Note the lpfc FC driver commit list will include NVMe patches for ease
> of maintainability vs. upstream but we ask that you not build NVMe FC
> since we do not intend to support NVMe FC on 18.04 (4.15 kernel) at
> this time due to all of the unmet upper layer dependencies.
>
> Laurie Barry
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/
> 1752182/+subscriptions
>

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1752182

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: bionic

This is a feature request, logs for debugging are not necessary.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
summary: - Update Ubuntu 18.04 lpfc FC driver with 32/64GB HBA support and bug
- fixes
+ [Feature]Update Ubuntu 18.04 lpfc FC driver with 32/64GB HBA support and
+ bug fixes
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
importance: Medium → Wishlist
tags: added: kernel-da-key
Changed in linux (Ubuntu Bionic):
importance: Wishlist → High
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
Seth Forshee (sforshee) wrote :

I'm working on this, and I've found that we need an additional commit from linux-next to fix a build error on 32-bit architectures.

4c06619fc4da scsi: lpfc: use __raw_writeX on DPP copies

There are several other fixes there, I haven't looked at each of them in detail but this one at least looks pretty important:

917d59ac5e26 scsi: lpfc: Add missing unlock in WQ full logic

I've added these two to my list; can you please let us know if there are any additional fixes we should get from linux-next? Thanks!

Changed in linux (Ubuntu Bionic):
assignee: Canonical Kernel Team (canonical-kernel-team) → Seth Forshee (sforshee)
status: Triaged → In Progress
laurie barry (laurie-barry) wrote :

Seth,

Thank you for you note, this patch was updated by the upstream SCSI maintainer after we submitted it. We are agree with this modification, please pull it in.

thank you
Laurie

Dick Kennedy (dick-kennedy) wrote :

Yes those patches are needed. They are good. You should include them

Seth Forshee (sforshee) on 2018-03-16
Changed in linux (Ubuntu Bionic):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (32.6 KiB)

This bug was fixed in the package linux - 4.15.0-13.14

---------------
linux (4.15.0-13.14) bionic; urgency=medium

  * linux: 4.15.0-13.14 -proposed tracker (LP: #1756408)

  * devpts: handle bind-mounts (LP: #1755857)
    - SAUCE: devpts: hoist out check for DEVPTS_SUPER_MAGIC
    - SAUCE: devpts: resolve devpts bind-mounts
    - SAUCE: devpts: comment devpts_mntget()
    - SAUCE: selftests: add devpts selftests

  * [bionic][arm64] d-i: add hisi_sas_v3_hw to scsi-modules (LP: #1756103)
    - d-i: add hisi_sas_v3_hw to scsi-modules

  * [Bionic][ARM64] enable ROCE and HNS3 driver support for hip08 SoC
    (LP: #1756097)
    - RDMA/hns: Refactor eq code for hip06
    - RDMA/hns: Add eq support of hip08
    - RDMA/hns: Add detailed comments for mb() call
    - RDMA/hns: Add rq inline data support for hip08 RoCE
    - RDMA/hns: Update the usage of sr_max and rr_max field
    - RDMA/hns: Set access flags of hip08 RoCE
    - RDMA/hns: Filter for zero length of sge in hip08 kernel mode
    - RDMA/hns: Fix QP state judgement before sending work requests
    - RDMA/hns: Assign dest_qp when deregistering mr
    - RDMA/hns: Fix endian problems around imm_data and rkey
    - RDMA/hns: Assign the correct value for tx_cqn
    - RDMA/hns: Create gsi qp in hip08
    - RDMA/hns: Add gsi qp support for modifying qp in hip08
    - RDMA/hns: Fill sq wqe context of ud type in hip08
    - RDMA/hns: Assign zero for pkey_index of wc in hip08
    - RDMA/hns: Update the verbs of polling for completion
    - RDMA/hns: Set the guid for hip08 RoCE device
    - net: hns3: Refactor of the reset interrupt handling logic
    - net: hns3: Add reset service task for handling reset requests
    - net: hns3: Refactors the requested reset & pending reset handling code
    - net: hns3: Add HNS3 VF IMP(Integrated Management Proc) cmd interface
    - net: hns3: Add mailbox support to VF driver
    - net: hns3: Add HNS3 VF HCL(Hardware Compatibility Layer) Support
    - net: hns3: Add HNS3 VF driver to kernel build framework
    - net: hns3: Unified HNS3 {VF|PF} Ethernet Driver for hip08 SoC
    - net: hns3: Add mailbox support to PF driver
    - net: hns3: Change PF to add ring-vect binding & resetQ to mailbox
    - net: hns3: Add mailbox interrupt handling to PF driver
    - net: hns3: add support to query tqps number
    - net: hns3: add support to modify tqps number
    - net: hns3: change the returned tqp number by ethtool -x
    - net: hns3: free the ring_data structrue when change tqps
    - net: hns3: get rss_size_max from configuration but not hardcode
    - net: hns3: add a mask initialization for mac_vlan table
    - net: hns3: add vlan offload config command
    - net: hns3: add ethtool related offload command
    - net: hns3: add handling vlan tag offload in bd
    - net: hns3: cleanup mac auto-negotiation state query
    - net: hns3: fix for getting auto-negotiation state in hclge_get_autoneg
    - net: hns3: add support for set_pauseparam
    - net: hns3: add support to update flow control settings after autoneg
    - net: hns3: add Asym Pause support to phy default features
    - net: hns3: add support for querying advertised pause frame by ethtool ethx
    - net:...

Changed in linux (Ubuntu Bionic):
status: Fix Committed → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic
laurie barry (laurie-barry) wrote :

Verified by Broadcom Emulex. Thank you
Laurie

Jeff Lane (bladernr) wrote :

Tag change to verification-done-bionic per Laurie/Broadcom's update.

tags: added: verification-done-bionic
removed: verification-needed-bionic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers