Serious problems with XFS immediatelly following clean install

Bug #175214 reported by david wood on 2007-12-10
6
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xfs

I performed a clean install with the Gutsy alternate image.

I set up 1 partition on two SATA drives in a RAID 0 config, then set up LVM on md0, then created swap, root (75G), and home (~700G) partitions. Root and home were formatted with XFS.

I experienced strange but 100% repeatable problems in this configuration. Switching to ext3 completely cured them.

Problems:

Adept segfaults
package install/integrity issues
segfaults of random applications (kate, software-properties-kde, etc)

I re-ran this install several times with XFS thinking it was a hardware problem, incompatibility, or playing with other issues. Finally after reinstalling on the same LVM logical volumes with a simple ext3 reformat eliminated all issues.

Recommend attempts to reproduce! If this isn't just me, XFS should be struck from the list of choices in the installer until it can be made safe... Just lucky I noticed problems before I started trusting the FS to hold data...

Hardware:
Intel Core 2 X9650 cpu
Asus Maximus Formula Intel X38 mobo, used onboard sata...

Soren Hansen (soren) wrote :

"Recommend attempts to reproduce!" ??? You're the one reporting the bug, so you're the one who should be explaining how to reproduce the problem. I use XFS everywhere and all is working fine, so it's not a case of xfs being completely broken.

david wood (david-wood) wrote :

Yes, my recommendation is for others to try to reproduce the bug, to see where or if it manifests. Is it just me? Is it just a problem with this kernel version on my particular (4-core) CPU? Is it a 64 vs. 32 bit thing?

If you have any questions about the details I gave for reproducing it from my own system, please let me know.

Obviously if XFS never worked, no one would use it - no one is suggesting that. Unfortunately the truth is far worse, that it works _almost_ all the time, and the shape of that almost is the problem we need to solve.

We'd really appreciate it if you could test with the upcoming Hardy Heron Alpha2 release. It's scheduled to come out Dec 20. It will have a newer version of the kernel, 2.6.24. Unfortunately, the Hardy Heron Alpha1 LiveCD was released with the older 2.6.22 kernel. If you could just verify if the issue still exists with the newer 2.6.24 kernel, that would be great. I'll update this report when Alpha2 is ready. Thanks.

Changed in linux:
status: New → Incomplete

Hardy Heron Alpha2 was recently released. It contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha2 release from http://cdimage.ubuntu.com/releases/hardy/alpha-2/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/hardy/alpha2 . Thanks!

david wood (david-wood) wrote :

OK. I'll fire up a spare HD and give this a go.

david wood (david-wood) wrote :

OK. Burned Hardy Alpha 2 AMD64 Alternate Install CD and ran a test install against a clean drive, following the recipe above. The new installer failed before I could even run this test, while attempting to bootstrap base...

...debootstrap: /usr/sbin/debootstrap:
...debootstrap: /usr/sbin/debootstrap: 317:
...debootstrap: /usr/sbin/debootstrap: cannot create /target/test-dev-null/: No such device or address
...debootstrap: /usr/sbin/debootstrap:
...debootstrap: /usr/sbin/debootstrap: E: NOEXEC
...debootstrap: /usr/sbin/debootstrap: EF: Cannot install into target /target mounted with noexec or nodev

Checked mount and saw

/dev/mapper/mainvg-rootlv on /target type xfs (rw,ikeep,noquota)

Would you like me to open a separate bug?

I wonder if this is a more mundane installer regression, or if there's some new issue with XFS and special files. I'm not sure how common a choice XFS is for a root filesystem? Then again, there is no documentation to that effect, and no warnings in the installer one way or another.

If you can. please open a new report regarding the new install issue you are seeing. Feel free to reference the new report in a comment here. Thanks!

david wood (david-wood) wrote :

Thanks, Leann. This is done (Bug #180157). Please let me know if you can think of any other way I can assist.

Sylvain Falardeau (sylvainf) wrote :

We have the same problem with a Gutsy (7.10) with two brand new Dell Vostro 1500. sda1 in ext3 (/boot), sda5 in xfs (/) and sda6 swap. We got some file truncations in some libraries on one machine. We did "aptitude reinstall..." of the package and it fixed the situation. After that, the second machine libc6.so was truncated. A "reinstall" did not work and the machine crashed. When I mean truncated, it does not mean zero bytes but smaller than the original file.

We tried to reinstall the two machines in ext3 only, and they seems stable. On one machine, we installed VMWare server version 1 and installed a Gutsy VM with XFS (install from CD). After the last update/upgrade/reboot, the XFS filesystem had some truncation issues. We do not know what cause the problem but it seems to happen quickly after install.

The kernel is 2.6.22-14-server.

Connor Imes (ckimes) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Jonathan Thomas (echidnaman) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers