Bionic daily build - nouveau: Direct firmware load for nouveau/nve7_fuc084 failed with error -2

Bug #1751497 reported by pavel bursa on 2018-02-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-firmware (Ubuntu)
Undecided
Unassigned

Bug Description

[ 136.559610] nouveau 0000:01:00.0: Direct firmware load for nouveau/nve7_fuc084 failed with error -2

Hello,
from time to time I find this annoying messages in dmesg in various Ubuntu versions (I believe since 16.04 or 16.10 up until now, including Bionic Beaver daily build). From time to time, the gdm3 crashes. The current HW/SW setup will be described below. I cannot replicate the situation, but it happens. See the excerpt from dmesg output below.

 [ 9.386558] IPv6: ADDRCONF(NETDEV_UP): enp3s0: link is not ready
[ 9.399079] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input12
[ 9.399134] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input13
[ 9.399208] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input14
[ 9.399274] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input15
[ 12.312741] r8169 0000:03:00.0 enp3s0: link up
[ 12.312748] IPv6: ADDRCONF(NETDEV_CHANGE): enp3s0: link becomes ready
[ 13.439863] rfkill: input handler disabled
[ 15.125569] nf_conntrack: default automatic helper assignment has been turned off for security reasons and CT-based firewall rule not found. Use the iptables CT target to attach helpers instead.
[ 136.559610] nouveau 0000:01:00.0: Direct firmware load for nouveau/nve7_fuc084 failed with error -2
[ 136.559618] nouveau 0000:01:00.0: Direct firmware load for nouveau/nve7_fuc084d failed with error -2
[ 136.559619] nouveau 0000:01:00.0: msvld: unable to load firmware data
[ 136.559622] nouveau 0000:01:00.0: msvld: init failed, -19
[ 1376.746130] lp: driver loaded but no devices found
[ 1376.756790] st: Version 20160209, fixed bufsize 32768, s/g segs 256
[ 1381.398605] do_IRQ: 1.37 No irq handler for vector
rr

HW setup:
Asrock Extreme 6 Z97
Intel(R) Core(TM) i3-4160 CPU @ 3.60GHz, 3563 MHz
nVidia GK107 [GeForce GT 640]

SW setup:
Linux bionic 4.15.0-10-generic #11-Ubuntu SMP Tue Feb 13 18:23:35 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

root@bionic:~# lsmod | grep nouveau
nouveau 1716224 5
i2c_algo_bit 16384 1 nouveau
ttm 106496 1 nouveau
drm_kms_helper 167936 1 nouveau
mxm_wmi 16384 1 nouveau
drm 401408 8 nouveau,ttm,drm_kms_helper
wmi 24576 2 mxm_wmi,nouveau
video 40960 1 nouveau

affects: chromium-browser (Ubuntu) → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1751497

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: bionic
Seth Forshee (sforshee) wrote :

The missing firmware seems to be something which can be extracted from nvidia binary drivers but is not distributed via an open source license, therefore we cannot distribute the firmware in linux-firmware.

https://nouveau.freedesktop.org/wiki/VideoAcceleration/

However, the feature connected to this firmware seems to be video decode acceleration so I don't see any reason to think that the gdm3 crashes are connected to these missing firmware messages.

Anyway, setting the linux-firmware task to "won't fix" as there's nothing we can do about it.

Changed in linux-firmware (Ubuntu):
status: New → Won't Fix
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Elvis (return-desender) wrote :

confirmed in xubuntu 18.04

Linux bart 4.15.0-20-generic #21-Ubuntu SMP Tue Apr 24 06:16:15 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

[261304.111515] nouveau 0000:04:00.0: Direct firmware load for nouveau/nva8_fuc084 failed with error -2
[261304.111529] nouveau 0000:04:00.0: Direct firmware load for nouveau/nva8_fuc084d failed with error -2
[261304.111532] nouveau 0000:04:00.0: msvld: unable to load firmware data
[261304.111538] nouveau 0000:04:00.0: msvld: init failed, -19
[340065.706109] perf: interrupt took too long (9727 > 9721), lowering kernel.perf_event_max_sample_rate to 20500
[348688.301567] nouveau 0000:04:00.0: fb: trapped read at 01008bc04c on channel -1 [3fee0000 unknown] engine 06 [BAR] client 08 [PFIFO_READ] subclient 01 [IN] reason 00000002 [PAGE_NOT_PRESENT]
[348698.597698] nouveau 0000:04:00.0: Direct firmware load for nouveau/nva8_fuc084 failed with error -2
[348698.597714] nouveau 0000:04:00.0: Direct firmware load for nouveau/nva8_fuc084d failed with error -2
[348698.597717] nouveau 0000:04:00.0: msvld: unable to load firmware data
[348698.597723] nouveau 0000:04:00.0: msvld: init failed, -19

Elvis

pavel bursa (bursap) wrote :

confirmed in Ubuntu 18.10 daily build from 9 sept 2018

Linux cuttlefish 4.17.0-9-generic #10-Ubuntu SMP Wed Aug 22 13:33:37 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

    9.595924] IPv6: ADDRCONF(NETDEV_UP): enp0s25: link is not ready
[ 9.808153] IPv6: ADDRCONF(NETDEV_UP): enp0s25: link is not ready
[ 9.811132] IPv6: ADDRCONF(NETDEV_UP): enp3s0: link is not ready
[ 9.918233] r8169 0000:03:00.0 enp3s0: link down
[ 9.918344] IPv6: ADDRCONF(NETDEV_UP): enp3s0: link is not ready
[ 12.862862] r8169 0000:03:00.0 enp3s0: link up
[ 12.862868] IPv6: ADDRCONF(NETDEV_CHANGE): enp3s0: link becomes ready
[ 14.868315] rfkill: input handler disabled
[ 36.984425] nouveau 0000:01:00.0: Direct firmware load for nouveau/nve7_fuc084 failed with error -2
[ 36.984432] nouveau 0000:01:00.0: Direct firmware load for nouveau/nve7_fuc084d failed with error -2
[ 36.984433] nouveau 0000:01:00.0: msvld: unable to load firmware data
[ 36.984437] nouveau 0000:01:00.0: msvld: init failed, -19

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers