ubuntu_unionmount_overlayfs_suite failed with Bionic kernel

Bug #1751243 reported by Po-Hsu Lin on 2018-02-23
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Kleber Sacilotto de Souza
linux (Ubuntu)
Medium
Unassigned
Bionic
Undecided
Kleber Sacilotto de Souza

Bug Description

This issue can be found on different architectures of the Bionic kernel.

Steps:
 1. git clone --depth=1 git://kernel.ubuntu.com/ubuntu/autotest-client-tests -b master-next
 2. git clone --depth=1 git://kernel.ubuntu.com/ubuntu/autotest
 3. rm -fr autotest/client/tests
 4. ln -sf ~/autotest-client-tests autotest/client/tests
 5. AUTOTEST_PATH=/home/ubuntu/autotest sudo -E autotest/client/autotest-local --verbose autotest/client/tests/ubuntu_unionmount_overlayfs_suite/control

Result:
  * Command:
      ./run --ov
  Exit status: 1
  Duration: 0.465664863586

  stdout:
  ***
  *** ./run --ov --ts=0 open-plain
  ***
  TEST open-plain.py:10: Open O_RDONLY
  /mnt/a/foo100: File unexpectedly on union layer

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: linux-image-4.15.0-10-generic 4.15.0-10.11
ProcVersionSignature: Ubuntu 4.15.0-10.11-generic 4.15.3
Uname: Linux 4.15.0-10-generic s390x
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
AlsaDevices: Error: command ['ls', '-l', '/dev/snd/'] failed with exit code 2: ls: cannot access '/dev/snd/': No such file or directory
AplayDevices: Error: [Errno 2] No such file or directory: 'aplay': 'aplay'
ApportVersion: 2.20.8-0ubuntu10
Architecture: s390x
ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord': 'arecord'
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
CurrentDmesg:

Date: Fri Feb 23 09:57:36 2018
HibernationDevice: RESUME=UUID=caaee9b2-6bc1-4c8e-b26c-69038c092091
IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig': 'iwconfig'
Lspci:

Lsusb: Error: command ['lsusb'] failed with exit code 1:
PciMultimedia:

ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=C
 SHELL=/bin/bash
ProcFB: Error: [Errno 2] No such file or directory: '/proc/fb'
ProcKernelCmdLine: root=UUID=c7d7bbcb-a039-4ead-abfe-7672dea0add4 crashkernel=196M
RelatedPackageVersions:
 linux-restricted-modules-4.15.0-10-generic N/A
 linux-backports-modules-4.15.0-10-generic N/A
 linux-firmware 1.171
RfKill: Error: [Errno 2] No such file or directory: 'rfkill': 'rfkill'
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)

Po-Hsu Lin (cypressyew) wrote :
tags: added: amd64 ppc64el

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1751243

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
tags: added: kernel-da-key
Po-Hsu Lin (cypressyew) wrote :

Can be reproduced on AWS Bionic kernel as well.

Po-Hsu Lin (cypressyew) wrote :

Affecting B-KVM kernel as well (4.15.0-1004.4)

Changed in linux (Ubuntu Bionic):
assignee: nobody → Kleber Sacilotto de Souza (kleber-souza)
Changed in linux (Ubuntu Bionic):
status: New → In Progress

A fix is needed only on the testsuite for unionmount.

Changed in linux (Ubuntu Bionic):
status: In Progress → Invalid
Changed in linux (Ubuntu):
status: Triaged → Invalid
Changed in ubuntu-kernel-tests:
status: New → In Progress
assignee: nobody → Kleber Sacilotto de Souza (kleber-souza)
description: updated

Fix applied to the autotest-client-tests repo.

Changed in ubuntu-kernel-tests:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers