Ubuntu 18.04 - Include latest ibmvnic fixes in Ubuntu kernel

Bug #1748517 reported by bugproxy on 2018-02-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Ubuntu-power-systems project
High
Canonical Kernel Team
linux (Ubuntu)
High
Thadeu Lima de Souza Cascardo

Bug Description

We have a number of patches to submit to Canonical for inclusion in the their release kernel for Ubuntu 18.04.

So far, most of these patches are upstream in Linus' tree, with some in Dave M's net-next tree. According to the ubuntu-bionic tree, the latest patch included is 8388a6cf ("ibmvnic: Set state UP"). If that's true, we'll need about 15 or more patches. There may be more coming down the pipe soon as well.

Here is a tentative patch list with commit hash and name:

1. 69d08dc Allocate and request vpd in init_resources
2. e791380 Revert to previous mtu when unsupported value requested
3. 896d869 Modify buffer size and number of queues on failover
4. a0dca10 Fix IPv6 packet descriptors
5. f689794 Fix IP offload control buffer
6. 3d16613 Fix pending MAC address changes
7. 09fb35ead58c Don't handle RX interrupts when not up
8. 4eb50ceb5c15 Include header descriptor support for ARP packets
9. 269431e737d2 Increase maximum number of RX/TX queues
10. d45cc3a43c43 Rename IBMVNIC_MAX_TX_QUEUES to IBMVNIC_MAX_QUEUES
11. f743106ec140 fix dma_mapping_error call
12. 4e6759be28e4 Feature implementation of Vital Product Data (VPD)?
13. 37798d021131 Add vnic client data to login buffer
14. 2a1bf5111197 Fix failover error path for non-fatal resets
15. c26eba03e407 Update reset infrastructure to support tunable parameters
16. aa0bf8510dac Let users change net device features
17. fdb061056f57 Enable TSO support
18. 154820563dd4 Enable scatter-gather support

These should apply cleanly, but I'll check on that.

Thanks!

====
Here is a tarball of patches. I also included this patch:

https://git.kernel.org/pub/scm/linux/kernel/git/davem/net-next.git/commit/?id=f813614f531114db796ad66ced75c5dc8db7aa3a

====
Additional patches that we would like to have included:

https://marc.info/?l=linux-netdev&m=151803103818174&w=2
("[PATCH net-next] ibmvnic: queue reset when CRQ gets closed during reset")

https://marc.info/?l=linux-netdev&m=151796813926975&w=2
("[PATCH net] ibmvnic: Fix rx queue cleanup for non-fatal resets")

https://marc.info/?l=linux-netdev&m=151631440609769&w=2
("[PATCH net v2 1/3] ibmvnic: Modify buffer size and number of queues on failover")

https://marc.info/?l=linux-netdev&m=151631444309775&w=2
("[PATCH net v2 2/3] ibmvnic: Revert to previous mtu when unsupported value requested")

https://marc.info/?l=linux-netdev&m=151631448809782&w=2
("[PATCH net v2 3/3] ibmvnic: Allocate and request vpd in init_resources")

https://git.kernel.org/pub/scm/linux/kernel/git/davem/net-next.git/commit/?id=d45cc3a43c43f867668bdd7ace12b1e6aa68bf46
("ibmvnic: Rename IBMVNIC_MAX_TX_QUEUES to IBMVNIC_MAX_QUEUES")

https://git.kernel.org/pub/scm/linux/kernel/git/davem/net-next.git/commit/?id=269431e737d29da0f496b60188a580822d290a37
("ibmvnic: Increase maximum number of RX/TX queues")

https://git.kernel.org/pub/scm/linux/kernel/git/davem/net-next.git/commit/?id=4eb50ceb5c156a166c0b00ac27f0ff3a0943cdfb
("ibmvnic: Include header descriptor support for ARP packets")

https://marc.info/?l=linux-netdev&m=151796813526938&w=2
 [PATCH net] ibmvnic: Ensure that buffers are NULL after free

CVE References

Default Comment by Bridge

tags: added: architecture-ppc64le bugnameltc-163890 severity-high targetmilestone-inin1804
Changed in ubuntu:
assignee: nobody → Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage)
affects: ubuntu → linux (Ubuntu)
Changed in ubuntu-power-systems:
importance: Undecided → High
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)

------- Comment From <email address hidden> 2018-02-09 14:29 EDT-------
Two additional patches to include.

https://marc.info/?l=linux-netdev&m=151819808111130&w=2
[PATCH net] ibmvnic: Reset long term map ID counter

https://marc.info/?l=linux-netdev&m=151820439213764&w=2
[PATCH] ibmvnic: Remove skb->protocol checks in ibmvnic_xmit

Manoj Iyer (manjo) on 2018-02-12
Changed in linux (Ubuntu):
assignee: Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage) → Canonical Kernel Team (canonical-kernel-team)
tags: added: triage-g
Changed in linux (Ubuntu):
importance: Undecided → High
Manoj Iyer (manjo) on 2018-02-12
Changed in ubuntu-power-systems:
status: New → Triaged
Changed in linux (Ubuntu):
status: New → Triaged
tags: added: kernel-da-key

I will work on this patchset early tomorrow.

Changed in linux (Ubuntu):
assignee: Canonical Kernel Team (canonical-kernel-team) → Thadeu Lima de Souza Cascardo (cascardo)
status: Triaged → In Progress

Applied already from 4.15:

1. 69d08dc Allocate and request vpd in init_resources
2. e791380 Revert to previous mtu when unsupported value requested
3. 896d869 Modify buffer size and number of queues on failover
4. a0dca10 Fix IPv6 packet descriptors
5. f689794 Fix IP offload control buffer
6. 3d16613 Fix pending MAC address changes
11. f743106ec140 fix dma_mapping_error call
12. 4e6759be28e4 Feature implementation of Vital Product Data (VPD)?
13. 37798d021131 Add vnic client data to login buffer
14. 2a1bf5111197 Fix failover error path for non-fatal resets
15. c26eba03e407 Update reset infrastructure to support tunable parameters
16. aa0bf8510dac Let users change net device features
17. fdb061056f57 Enable TSO support
18. 154820563dd4 Enable scatter-gather support

Present in v4.16-rc1:

7. 09fb35ead58c Don't handle RX interrupts when not up
8. 4eb50ceb5c15 Include header descriptor support for ARP packets
9. 269431e737d2 Increase maximum number of RX/TX queues
10. d45cc3a43c43 Rename IBMVNIC_MAX_TX_QUEUES to IBMVNIC_MAX_QUEUES

Two additional patches to include.

https://marc.info/?l=linux-netdev&m=151819808111130&w=2
[PATCH net] ibmvnic: Reset long term map ID counter

commit faefaa97215a0c05105d7ae180fe1a3b5979ad1f on v4.16-rc1

https://marc.info/?l=linux-netdev&m=151820439213764&w=2
[PATCH] ibmvnic: Remove skb->protocol checks in ibmvnic_xmit

commit 2fa56a494484f19e06bf4f3464b2155a92beafac on v4.16-rc1

https://marc.info/?l=linux-netdev&m=151803103818174&w=2
("[PATCH net-next] ibmvnic: queue reset when CRQ gets closed during reset")
ec95dffa408f0

https://marc.info/?l=linux-netdev&m=151796813926975&w=2
("[PATCH net] ibmvnic: Fix rx queue cleanup for non-fatal resets")
3468656fd7599

https://marc.info/?l=linux-netdev&m=151796813526938&w=2
 [PATCH net] ibmvnic: Ensure that buffers are NULL after free
b0992eca00c49

f813614f53111 ibmvnic: Wait for device response when changing MAC
a107311d7fdf6 ibmvnic: fix firmware version when no firmware level has been provided by the VIOS server
21a2545bbea02 ibmvnic: fix empty firmware version and errors cleanup

These three have also gone into v4.16-rc1. I will look into these as well.

Cascardo.

a2c0f039bbd0f ibmvnic: Fix early release of login buffer
abe27a885d9e6 ibmvnic: Check for NULL skb's in NAPI poll routine
d0869c0071e40 ibmvnic: Clean RX pool buffers during device close
4b9b0f0135050 ibmvnic: Free RX socket buffer in case of adapter error
6e4842ddfc2b0 ibmvnic: Fix NAPI structures memory leak
34f0f4e3f4881 ibmvnic: Fix login buffer memory leaks
cc85c02edfe48 ibmvnic: Wait until reset is complete to set carrier on

And these ones from net/master.

Seth Forshee (sforshee) on 2018-02-27
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Changed in ubuntu-power-systems:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (40.0 KiB)

This bug was fixed in the package linux - 4.15.0-12.13

---------------
linux (4.15.0-12.13) bionic; urgency=medium

  * linux: 4.15.0-12.13 -proposed tracker (LP: #1754059)

  * CONFIG_EFI=y on armhf (LP: #1726362)
    - [Config] CONFIG_EFI=y on armhf, reconcile secureboot EFI settings

  * ppc64el: Support firmware disable of RFI flush (LP: #1751994)
    - powerpc/pseries: Support firmware disable of RFI flush
    - powerpc/powernv: Support firmware disable of RFI flush

  * [Feature] CFL/CNL (PCH:CNP-H): New GPIO Commit added (GPIO Driver needed)
    (LP: #1751714)
    - gpio / ACPI: Drop unnecessary ACPI GPIO to Linux GPIO translation
    - pinctrl: intel: Allow custom GPIO base for pad groups
    - pinctrl: cannonlake: Align GPIO number space with Windows

  * [Feature] Add xHCI debug device support in the driver (LP: #1730832)
    - usb: xhci: Make some static functions global
    - usb: xhci: Add DbC support in xHCI driver
    - [Config] USB_XHCI_DBGCAP=y for commit mainline dfba2174dc42.

  * [SRU] Lenovo E41 Mic mute hotkey is not responding (LP: #1753347)
    - platform/x86: ideapad-laptop: Increase timeout to wait for EC answer

  * headset mic can't be detected on two Dell machines (LP: #1748807)
    - ALSA: hda - Fix a wrong FIXUP for alc289 on Dell machines

  * hisi_sas: Add disk LED support (LP: #1752695)
    - scsi: hisi_sas: directly attached disk LED feature for v2 hw

  * [Feature] [Graphics]Whiskey Lake (Coffelake-U 4+2) new PCI Device ID adds
    (LP: #1742561)
    - drm/i915/cfl: Adding more Coffee Lake PCI IDs.

  * [Bug] [USB Function][CFL-CNL PCH]Stall Error and USB Transaction Error in
    trace, Disable of device-initiated U1/U2 failed and rebind failed: -517
    during suspend/resume with usb storage. (LP: #1730599)
    - usb: Don't print a warning if interface driver rebind is deferred at resume

  * retpoline: ignore %cs:0xNNN constant indirections (LP: #1752655)
    - [Packaging] retpoline -- elide %cs:0xNNNN constants on i386
    - [Config] retpoline -- clean up i386 retpoline files

  * hisilicon hibmc regression due to ea642c3216cb ("drm/ttm: add io_mem_pfn
    callback") (LP: #1738334)
    - drm/ttm: add ttm_bo_io_mem_pfn to check io_mem_pfn

  * [Asus UX360UA] battery status in unity-panel is not changing when battery is
    being charged (LP: #1661876) // AC adapter status not detected on Asus
    ZenBook UX410UAK (LP: #1745032)
    - ACPI / battery: Add quirk for Asus UX360UA and UX410UAK

  * ASUS UX305LA - Battery state not detected correctly (LP: #1482390)
    - ACPI / battery: Add quirk for Asus GL502VSK and UX305LA

  * [18.04 FEAT] Automatically detect layer2 setting in the qeth device driver
    (LP: #1747639)
    - s390/diag: add diag26c support for VNIC info
    - s390/qeth: support early setup for z/VM NICs

  * Bionic update to v4.15.7 stable release (LP: #1752317)
    - netfilter: drop outermost socket lock in getsockopt()
    - arm64: mm: don't write garbage into TTBR1_EL1 register
    - kconfig.h: Include compiler types to avoid missed struct attributes
    - MIPS: boot: Define __ASSEMBLY__ for its.S build
    - xtensa: fix high memory/reserved memory collision
    - scsi: ibmvfc: fix misde...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-power-systems:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers