[18.04 FEAT] Automatically detect layer2 setting in the qeth device driver

Bug #1747639 reported by bugproxy on 2018-02-06
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
Medium
Canonical Kernel Team
linux (Ubuntu)
Undecided
Seth Forshee

Bug Description

Follow-on of https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1541544
Now we have an enhancement as part of kernel 4.16.

CVE References

bugproxy (bugproxy) on 2018-02-06
tags: added: architecture-s39064 bugnameltc-139628 severity-medium targetmilestone-inin1810
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → linux (Ubuntu)
Changed in ubuntu-z-systems:
importance: Undecided → Medium
status: New → Triaged
assignee: nobody → Canonical Foundations Team (canonical-foundations)
summary: - [18.10 FEAT] Automatically detect layer2 setting in the qeth device
+ [18.04 FEAT] Automatically detect layer2 setting in the qeth device
driver

------- Comment From <email address hidden> 2018-02-06 08:14 EDT-------
change target to 18.04, git-commits will be provided.

tags: added: targetmilestone-inin1804
removed: targetmilestone-inin1810
Frank Heimes (frank-heimes) wrote :

So far I'm not sure if that will effect the (d-i) installer as well or not...

Changed in ubuntu-z-systems:
assignee: Canonical Foundations Team (canonical-foundations) → Canonical Kernel Team (canonical-kernel-team)
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-02-06 09:32 EDT-------
Requires (and applies cleanly onto 4.15.y):

commit f22237f61d2f19760b3799ee798d7dc30cdc0785
Author: Julian Wiedmann <email address hidden>
Date: Wed Dec 27 17:44:30 2017 +0100

s390/diag: add diag26c support for VNIC info

With subcode 0x24, diag26c returns all sorts of VNIC-related information.

Signed-off-by: Julian Wiedmann <email address hidden>
Acked-by: Martin Schwidefsky <email address hidden>
Signed-off-by: David S. Miller <email address hidden>

commit 615dff228368109ce18b628d6bd1b01ad6ef2f74
Author: Julian Wiedmann <email address hidden>
Date: Wed Dec 27 17:44:31 2017 +0100

s390/qeth: support early setup for z/VM NICs

The transport mode that a z/VM NIC is configured in, must match the
hypervisor-internal network which the NIC is coupled to.

To get this right automatically, have qeth issue a diag26c hypervisor call
that provides all sorts of information for a specific VNIC.
With z/VM update VM65918, this also includes the VNIC's required
transport mode.

Signed-off-by: Julian Wiedmann <email address hidden>
Signed-off-by: David S. Miller <email address hidden>

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-02-06 13:33 EDT-------
One thing worth mentioning - when testing this functionality, please do make sure that your z/VM host has the PTF for APAR VM65918 applied.

Frank Heimes (frank-heimes) wrote :

Okay, anything special needed for the use with LPARs - a special/minimal MCL level?

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-02-06 15:00 EDT-------
Hi Frank - this item is only for z/VM NICs (ie. "Virt.NIC QDIO").

Any NIC available in LPAR (ie. OSA, HiperSockets) either
a) already gets its transport layer auto-configured by qeth (OSM, OSN), or
b) is dual-transport capable, so there is no "right" layer that qeth could auto-config.

Frank Heimes (frank-heimes) wrote :

Hi Julian - well, thx for clarification. Still had in mind the question during installation.

tags: added: kernel-da-key
information type: Private → Public
bugproxy (bugproxy) on 2018-02-26
tags: removed: bugnameltc-139628 kernel-da-key severity-medium
tags: added: kernel-da-key severity-medium
Seth Forshee (sforshee) on 2018-02-27
Changed in linux (Ubuntu):
assignee: Skipper Bug Screeners (skipper-screen-team) → Seth Forshee (sforshee)
status: New → Fix Committed
Changed in ubuntu-z-systems:
status: Triaged → Fix Committed
bugproxy (bugproxy) on 2018-02-27
tags: added: bugnameltc-139628
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-02-28 04:02 EDT-------
Hello Seth (long time no see!),
I peeked into bionic/master-next - any chance you could cherry-pick the second patch (615dff228368) from comment #3 as well? Thanks!

Hi, Julian.

I picked it up and pushed to master-next.

Thanks.
Cascardo.

Launchpad Janitor (janitor) wrote :
Download full text (40.0 KiB)

This bug was fixed in the package linux - 4.15.0-12.13

---------------
linux (4.15.0-12.13) bionic; urgency=medium

  * linux: 4.15.0-12.13 -proposed tracker (LP: #1754059)

  * CONFIG_EFI=y on armhf (LP: #1726362)
    - [Config] CONFIG_EFI=y on armhf, reconcile secureboot EFI settings

  * ppc64el: Support firmware disable of RFI flush (LP: #1751994)
    - powerpc/pseries: Support firmware disable of RFI flush
    - powerpc/powernv: Support firmware disable of RFI flush

  * [Feature] CFL/CNL (PCH:CNP-H): New GPIO Commit added (GPIO Driver needed)
    (LP: #1751714)
    - gpio / ACPI: Drop unnecessary ACPI GPIO to Linux GPIO translation
    - pinctrl: intel: Allow custom GPIO base for pad groups
    - pinctrl: cannonlake: Align GPIO number space with Windows

  * [Feature] Add xHCI debug device support in the driver (LP: #1730832)
    - usb: xhci: Make some static functions global
    - usb: xhci: Add DbC support in xHCI driver
    - [Config] USB_XHCI_DBGCAP=y for commit mainline dfba2174dc42.

  * [SRU] Lenovo E41 Mic mute hotkey is not responding (LP: #1753347)
    - platform/x86: ideapad-laptop: Increase timeout to wait for EC answer

  * headset mic can't be detected on two Dell machines (LP: #1748807)
    - ALSA: hda - Fix a wrong FIXUP for alc289 on Dell machines

  * hisi_sas: Add disk LED support (LP: #1752695)
    - scsi: hisi_sas: directly attached disk LED feature for v2 hw

  * [Feature] [Graphics]Whiskey Lake (Coffelake-U 4+2) new PCI Device ID adds
    (LP: #1742561)
    - drm/i915/cfl: Adding more Coffee Lake PCI IDs.

  * [Bug] [USB Function][CFL-CNL PCH]Stall Error and USB Transaction Error in
    trace, Disable of device-initiated U1/U2 failed and rebind failed: -517
    during suspend/resume with usb storage. (LP: #1730599)
    - usb: Don't print a warning if interface driver rebind is deferred at resume

  * retpoline: ignore %cs:0xNNN constant indirections (LP: #1752655)
    - [Packaging] retpoline -- elide %cs:0xNNNN constants on i386
    - [Config] retpoline -- clean up i386 retpoline files

  * hisilicon hibmc regression due to ea642c3216cb ("drm/ttm: add io_mem_pfn
    callback") (LP: #1738334)
    - drm/ttm: add ttm_bo_io_mem_pfn to check io_mem_pfn

  * [Asus UX360UA] battery status in unity-panel is not changing when battery is
    being charged (LP: #1661876) // AC adapter status not detected on Asus
    ZenBook UX410UAK (LP: #1745032)
    - ACPI / battery: Add quirk for Asus UX360UA and UX410UAK

  * ASUS UX305LA - Battery state not detected correctly (LP: #1482390)
    - ACPI / battery: Add quirk for Asus GL502VSK and UX305LA

  * [18.04 FEAT] Automatically detect layer2 setting in the qeth device driver
    (LP: #1747639)
    - s390/diag: add diag26c support for VNIC info
    - s390/qeth: support early setup for z/VM NICs

  * Bionic update to v4.15.7 stable release (LP: #1752317)
    - netfilter: drop outermost socket lock in getsockopt()
    - arm64: mm: don't write garbage into TTBR1_EL1 register
    - kconfig.h: Include compiler types to avoid missed struct attributes
    - MIPS: boot: Define __ASSEMBLY__ for its.S build
    - xtensa: fix high memory/reserved memory collision
    - scsi: ibmvfc: fix misde...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-z-systems:
status: Fix Committed → Fix Released
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-03-15 09:00 EDT-------
IBM Bugzilla status -> closed; Fix Released with bionic

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers