No audio over HDMI on XPS M1330 and XPS M1530

Bug #174696 reported by Martin Polden on 2007-12-07
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Audio over HDMI does not appear to work in Ubuntu 7.10. When connecting my Dell XPS M1330 to a LCD-TV (LG 37LC42) the picture is fine and I can configure it through nvidia-settings, but when playing audio it's coming from my laptop instead of the TV. Audio over HDMI works fine in Vista.

Output from lspci:
martin@xps:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:01.0 PCI bridge: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port (rev 0c)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Contoller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 02)
00:1c.5 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 6 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f2)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8400M GS (rev a1)
03:01.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
03:01.1 Generic system peripheral [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
03:01.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 12)
03:01.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
03:01.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)
09:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5906M Fast Ethernet PCI Express (rev 02)
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

Output from aplay -l:
martin@xps:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: STAC92xx Digital [STAC92xx Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Changed in dell:
importance: Undecided → Medium
status: New → Confirmed
Changed in dell:
importance: Medium → High

Just adding a note that I'm reassigning the Ubuntu Hardy kernel source package from 'linux-source-2.6.24' to just 'linux'. Beginning with the Hardy release the package naming convention changed from linux-source-2.6.x to just linux. Sorry for any confusion.

Hi Martin,

I see that this report has been opened against the Hardy kernel but the description seems comment that you're running Gutsy. Care to try a Hardy Alpha release? The Hardy Heron Alpha series contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha release from http://cdimage.ubuntu.com/releases/hardy/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/ . Thanks!

Changed in linux:
status: New → Incomplete
Martin Polden (martin-polden) wrote :

I tried testing it with the LiveCD, but it's not possible because the video card (nVidia 8400M GS) on M1330 requires a restricted driver for HDMI to work, which can't be installed unless Ubuntu is installed on the hard drive.

Per Osbeck (perosb) wrote :

Isn't this due to the fact that ALSA doesn't support audio over hdmi until 1.0.16? Which is now in Hardy but Gutsy still have 1.0.14.

Per Osbeck (perosb) wrote :

Though on my Gutsy is seem to show up as a device even tough alsa is 1.0.14. Don't know yet if there is any audio from it or not:

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC882 Analog [ALC882 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC882 Digital [ALC882 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 0: ATI HDMI [ATI HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

raphael (raphoun) wrote :

Hi,

I have a xps m1530 with hardy and i have the same problem, no sound over HDMI.

raphael@xps:~$ aplay -l
**** Liste des PLAYBACK périphériques ****
carte 0: Intel [HDA Intel], périphérique 0 : STAC92xx Analog [STAC92xx Analog]
  Sous-périphériques: 1/1
  Sous-périphérique: #0: subdevice #0

uname -r : 2.6.24-12-generic

I tried with alsa 1.0.16 with no success..., someone know when is it going to work?

phamti (tinmanemail-reg) wrote :

I just tried with Ubuntu 8.04 beta that I downloaded yesterday.

- Dell XPS M1330
- video card NVIDIA GeForce 8400M GS
- LCD Sharp TV (LG 42D72U)

I can hear sound coming from the laptop. Am not what to switch my sound output to be for HDMI. I just right-clicked on the sound try icon chose Volume Control, File, Change Device and tried
- 0: HDA Intel (Alsa mixer)
- 1: SigmaTel STAC9228 (OSS Mixer)
- 2: Playback: ALSA PCM on front:0 (STAC92xx Analog) via DMA (PulseAudio Mixer)
- 3: Capture: Monitor Source of ALSA PCM on front:0 (STAC92xx Analog) via DMA (PulseAudio Mixer)
- 4: Capture: ALSA PCM on front:0 (STAC92xx Analog) via DMA (PulseAudio Mixer)

None of them seemed to work.

tin@stinky:~$ uname -r
2.6.24-12-generic

tin@stinky:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged
Mario Limonciello (superm1) wrote :

This fix has been committed to linux-ubuntu-modules:
http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-hardy-lum.git;a=commitdiff;h=324fb7ac90178563754128b1199754a7f85c5345

Additional support may be necessary from your graphics driver.

Changed in linux:
status: Triaged → Fix Committed
Changed in dell:
status: Confirmed → Fix Committed
Changed in dell:
status: Fix Committed → Fix Released
Changed in linux:
status: Fix Committed → Fix Released

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Motin (motin) wrote :

As a note, one still needs to:

1. Enable the IEC958 switch in the volume control (double click the volume panel icon to get there - and select Settings and check the IEC958 option if you don't have the switch visible from the start)
2. Select "HDA Intel STAC92xx Digital" as the option for Multimedia in the sound settings option

... in order to actually get sound from movies etc to go through the cable.

Worked wonders for me on Intrepid.

Source: http://ubuntuforums.org/showthread.php?t=689390&page=2

Jerone Young (jerone) wrote :

@Motin
         What happens if you kill pulse audio, then try it? Run "killall pulseaudio" the try to get sound out put.

Mtt.Castelli (mtt.castelli) wrote :

This bug is still present now in 12.04 LTS, 2013, at least over Intel GPU version of XPS.

Changed in somerville:
importance: Undecided → High
status: New → Fix Released
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1306056

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers