108 and 109 kernel hangs

Bug #1742502 reported by Joey Stanford on 2018-01-10
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned
Xenial
High
Unassigned

Bug Description

Overnight I had 2 of 12 16.04 servers brick with the 108 kernel. They also do not work with 109. They work fine with 104. The other 10 worked fine on both 108 and 109.

All are hosted on VMWARE. The two broken ones stop at the same place. I was able to go back to the 104 kernel to get them working and pin the kernel version.

Just for fun, I set zswap.enabled=0 and they both crashed with kthread starved for jiffies. They are both multi-processor with lots of ram and disk.

I have a task from the Ubuntu Kernel team to try this with 'nopti'. I'll report back.

Joey Stanford (joey) wrote :
tags: added: pti
Changed in linux (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in linux (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → High
Joey Stanford (joey) wrote :

booting on 109 with nopti works! Good call Leann.

tags: added: kernel-key
Joey Stanford (joey) wrote :

Additional info in hopes it proves useful.

On the hung boots, there is no recorded output to disk unfortunately.

This is what's installed on the machine running 108 nopti:
jstanford@www:~$ dpkg -l linux* |grep ii
ii linux-base 4.0ubuntu1 all Linux image base package
ii linux-firmware 1.157.14 all Firmware for Linux kernel drivers
ii linux-generic 4.4.0.109.114 amd64 Complete Generic Linux kernel and headers
ii linux-headers-4.4.0-104 4.4.0-104.127 all Header files related to Linux kernel version 4.4.0
ii linux-headers-4.4.0-104-generic 4.4.0-104.127 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii linux-headers-4.4.0-108 4.4.0-108.131 all Header files related to Linux kernel version 4.4.0
ii linux-headers-4.4.0-108-generic 4.4.0-108.131 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii linux-headers-4.4.0-109 4.4.0-109.132 all Header files related to Linux kernel version 4.4.0
ii linux-headers-4.4.0-109-generic 4.4.0-109.132 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii linux-headers-generic 4.4.0.109.114 amd64 Generic Linux kernel headers
ii linux-image-4.4.0-104-generic 4.4.0-104.127 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii linux-image-4.4.0-108-generic 4.4.0-108.131 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii linux-image-4.4.0-109-generic 4.4.0-109.132 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii linux-image-extra-4.4.0-104-generic 4.4.0-104.127 amd64 Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
ii linux-image-extra-4.4.0-108-generic 4.4.0-108.131 amd64 Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
ii linux-image-extra-4.4.0-109-generic 4.4.0-109.132 amd64 Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
ii linux-image-generic 4.4.0.109.114 amd64 Generic Linux kernel image

Joey Stanford (joey) wrote :

112 kernel has the same issue. Adding nopti allows it to boot.
What's different: It stops after zswap loading.

Joseph Salisbury (jsalisbury) wrote :

Can you see if this bug still occurs with the 116 kernel in -proposed?

https://launchpad.net/ubuntu/+source/linux/4.4.0-116.140

Joey Stanford (joey) wrote :

Joe,

116 puts VMWARE into a loop. It forces a hard reboot somewhere during the init process (scrolls by too fast). If I had NOPTI it boots normally. So I would say, no, 116 does not fix this.

tags: added: kernel-da-key
removed: kernel-key
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers