sprs test from kvm-unit-tests will hang on PowerPC

Bug #1740017 reported by Po-Hsu Lin on 2017-12-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned

Bug Description

We have switched our kvm-unit-test test suite from archive tarball to upstream repo recently.
And now the sprs test will hang on the ppc64le system.

12/24 04:18:33 DEBUG| utils:0153| [stdout] MIGRATION=yes TESTNAME=sprs TIMEOUT=90s ACCEL= ./powerpc/run powerpc/sprs.elf -smp 1 -append '-w'

It was failing with this test with the version of our archived tarball
bug 1723904 (but still failing on Xenial, and 4.10 kernel on Xenail, therefore it has something to do with the qemu on Zesty.)

Po-Hsu Lin (cypressyew) on 2017-12-25
description: updated

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1740017

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Po-Hsu Lin (cypressyew) on 2017-12-25
description: updated
Po-Hsu Lin (cypressyew) on 2017-12-25
description: updated
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
tags: added: kernel-da-key
Po-Hsu Lin (cypressyew) on 2018-02-14
tags: added: artful
Po-Hsu Lin (cypressyew) on 2018-02-23
tags: added: bionic
summary: - sprs test from kvm-unit-tests will hang on Zesty PowerPC
+ sprs test from kvm-unit-tests will hang on PowerPC
Sean Feole (sfeole) wrote :

very old bug, with no action on it, marking bug as incomplete and will
close in 5 days if no update.

Changed in ubuntu-kernel-tests:
status: New → Incomplete
Changed in linux (Ubuntu):
status: Triaged → Incomplete
Po-Hsu Lin (cypressyew) wrote :
Changed in ubuntu-kernel-tests:
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Po-Hsu Lin (cypressyew) wrote :

Test will get skipped in Cosmic:
   SKIP sprs (test marked as manual run only)

Po-Hsu Lin (cypressyew) on 2019-05-03
Changed in ubuntu-kernel-tests:
status: Confirmed → Fix Released
Changed in linux (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers