[A] KVM module in 4.13 no longer supports old Intel CPUs

Bug #1738982 reported by Fabian Grünbichler
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

== SRU Justification ==

Impact: systems with CPUs lacking virtual NMI support are no longer able to load the kvm_intel module, and thus not able to use KVM functionality

Fix: cherry-pick re-introducing support for software NMI support

Regression Potential: applied upstream in 4.15 and 4.14.3, tested and verified by multiple people

--

the original dropping of support was (functionally) reverted after upstream got notified of how many CPUs were actually affected

see https://lkml.kernel.org/r/<email address hidden> for upstream patch re-introducing support
see https://lkml.kernel.org/r/<email address hidden> for the original upstream patch dropping support and following discusison

I'll send an SRU patch.

Changed in linux (Ubuntu):
status: New → Confirmed
Revision history for this message
Fabian Grünbichler (f-gruenbichler) wrote :

patch sent

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers