touchpad not working

Bug #1738491 reported by gm on 2017-12-15
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

chuwi Lapbook Air touch pad not working

gm (sux) wrote :

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1738491

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
gm (sux) on 2017-12-15
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: patch
Joseph Salisbury (jsalisbury) wrote :

Did this issue start happening after an update/upgrade? Was there a prior kernel version where you were not having this particular problem?

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.15 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.15-rc4

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
gm (sux) wrote :

kernel-bug-exists-upstream

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
gm (sux) wrote :

Sorry I didn't mention that this is a new laptop which according to the forums show that now who has managed to install Ubuntu onto the laptop cannot get the touchpad working. I have tried v4.15 with no luck.
Are you able to help. I hate having to use w10 when I don't have access to a mouse.
Cheers

Kai-Heng Feng (kaihengfeng) wrote :

Please run `apport-collect 1738491`.

David Franko (lavjamanxd) wrote :

Hi, maybe this helps something
Someone mentioned on other forums that maybe Hans de Goede's patch ( https://patchwork.kernel.org/patch/10046575/ ) could fix that problem,
but unfortunately it does not, i compiled a kernel which contains his fix but it does not solve the problem.

What i've found

+#define I2C_VENDOR_ID_HANTICK 0x0911
+#define I2C_PRODUCT_ID_HANTICK_5288 0x5288

this two product and vendor id is the same on this notebook too.

libinput list-devices recognizes/lists the device
but when im trying to cat /dev/input/eventx, then it has no data in it

Thanks for the efforts

Kai-Heng Feng (kaihengfeng) wrote :

Is it the same one as LP: #1728244?

David Franko (lavjamanxd) wrote :

Maybe, the device is similar to ours, but they were able to get some movement from the touchpad and we dont.

I collected some logs (sorry, i dont have ubuntu now, i tried again with mainline kernel).

David Franko (lavjamanxd) wrote :
David Franko (lavjamanxd) wrote :
David Franko (lavjamanxd) wrote :
David Franko (lavjamanxd) wrote :
Kai-Heng Feng (kaihengfeng) wrote :

Does your touchpad works after suspend/resume on Linux v4.15?

David Franko (lavjamanxd) wrote :

Well, i tried that one but i cant get back the device from suspended state.

Also checked if the touchpad hardware works, on windows 10, it was working until the latest insider update, they just broke it somehow.

I'm gonna somehow try to check that suspend/resume.

David Franko (lavjamanxd) wrote :

Okay, i created a respinned ubuntu 16.04 iso with a mainline kernel(4.15.0rc9)

So if i just push the suspend button instead of closing the lid, i can wake up the device.
And the touchpad starts working after waking up.
Movement works
Tap works
Left/Right button not

Looks like this issue is really the same as the other bugreport what you mentioned

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers