powerpc/powernv: Flush console before platform error reboot

Bug #1735159 reported by bugproxy on 2017-11-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Ubuntu-power-systems project
High
Canonical Kernel Team
linux (Ubuntu)
High
Joseph Salisbury
Zesty
High
Joseph Salisbury
Artful
High
Joseph Salisbury

Bug Description

== SRU Justification ==
IBM unrecovered MCE and HMI errors are sent through a special restart OPAL
call to log the platform error. The downside is that they don't go
through normal Linux crash paths, so they don't give much information
to the Linux console.

IBM is requesting to have the commit b746e3e01e70d23ef53dcde1203ab78a1b7ac514
in the Zesty kernel.

Commit b746e3e01e70d2 is in mainline as of 4.14-rc1.

Breno Leitao from IBM did a backport of this commit.

== Fix ==
commit b746e3e01e70d23ef53dcde1203ab78a1b7ac514
Author: Nicholas Piggin <email address hidden>
Date: Wed Jul 19 16:59:10 2017 +1000

    powerpc/powernv: Flush console before platform error reboot

== Regression Potential ==
This patch is specific to powerpc, and it has been backported, reviewed and
tested by IBM.

== Test Case ==
A test kernel was built with this patch and tested by the original bug reporter.
The bug reporter states the test kernel resolved the bug.

Default Comment by Bridge

tags: added: architecture-ppc64le bugnameltc-161870 severity-high targetmilestone-inin---
Changed in ubuntu:
assignee: nobody → Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage)
affects: ubuntu → linux (Ubuntu)
Changed in ubuntu-power-systems:
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
importance: Undecided → High
tags: added: triage-g
Changed in linux (Ubuntu):
importance: Undecided → High
status: New → In Progress
assignee: Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage) → Joseph Salisbury (jsalisbury)
Changed in linux (Ubuntu Zesty):
importance: Undecided → High
Changed in linux (Ubuntu Zesty):
status: New → In Progress
assignee: nobody → Joseph Salisbury (jsalisbury)
Changed in ubuntu-power-systems:
status: New → In Progress
Joseph Salisbury (jsalisbury) wrote :

I built a Zesty test kernel with your back port. The test kernel can be downloaded from:
http://kernel.ubuntu.com/~jsalisbury/lp1735159/

Can you test this kernel and see if it resolves this bug?

Breno Leitão (breno-leitao) wrote :

Joseph,

I tested this kernel and it works fine without any seen regression. Thanks for the kernel:

# uname -a
Linux cake 4.10.0-40-generic #44~lp1735159 SMP Wed Nov 29 16:04:16 UTC 2017 ppc64le ppc64le ppc64le GNU/Linux

description: updated
tags: added: kernel-da-key
Manoj Iyer (manjo) wrote :

Since 4.10 was replaced with 4.13 kernel version for linux-hwe, would it make sense to backport this patch to 4.13 (Artful) ? Could you (jsalisbury) please add Artful as a target series to track?

no longer affects: ubuntu-power-systems/ubuntu-17.10
Manoj Iyer (manjo) on 2018-02-05
Changed in linux (Ubuntu Zesty):
status: In Progress → Won't Fix
no longer affects: ubuntu-power-systems/ubuntu-17.10
Joseph Salisbury (jsalisbury) wrote :

An artful bug task has been added. I'll get the Artful SRU request sent out as well.

Changed in linux (Ubuntu Artful):
importance: Undecided → High
status: New → In Progress
assignee: nobody → Joseph Salisbury (jsalisbury)
Joseph Salisbury (jsalisbury) wrote :

Hi Breno,

It looks like you submitted the SRU request for Zesty. Do you want to submit the request for Artful as well, or do you want me to do it?

------- Comment From <email address hidden> 2018-02-05 12:31 EDT-------
Hi Joseph,

> Hi Breno,
>
> It looks like you submitted the SRU request for Zesty. Do you want to
> submit the request for Artful as well, or do you want me to do it?

Good catch, we need this for Artful as well, since the commit just made 4.14, so, we need to backport to 4.13.

Would you mind doing it, please?

Thank you,
Breno

Changed in linux (Ubuntu Artful):
status: In Progress → Fix Committed
Manoj Iyer (manjo) on 2018-03-05
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Changed in ubuntu-power-systems:
status: In Progress → Fix Committed
Stefan Bader (smb) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-artful' to 'verification-done-artful'. If the problem still exists, change the tag 'verification-needed-artful' to 'verification-failed-artful'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-artful
Launchpad Janitor (janitor) wrote :
Download full text (18.9 KiB)

This bug was fixed in the package linux - 4.13.0-38.43

---------------
linux (4.13.0-38.43) artful; urgency=medium

  * linux: 4.13.0-38.43 -proposed tracker (LP: #1755762)

  * Servers going OOM after updating kernel from 4.10 to 4.13 (LP: #1748408)
    - i40e: Fix memory leak related filter programming status
    - i40e: Add programming descriptors to cleaned_count

  * [SRU] Lenovo E41 Mic mute hotkey is not responding (LP: #1753347)
    - platform/x86: ideapad-laptop: Increase timeout to wait for EC answer

  * fails to dump with latest kpti fixes (LP: #1750021)
    - kdump: write correct address of mem_section into vmcoreinfo

  * headset mic can't be detected on two Dell machines (LP: #1748807)
    - ALSA: hda/realtek - Support headset mode for ALC215/ALC285/ALC289
    - ALSA: hda - Fix headset mic detection problem for two Dell machines
    - ALSA: hda - Fix a wrong FIXUP for alc289 on Dell machines

  * CIFS SMB2/SMB3 does not work for domain based DFS (LP: #1747572)
    - CIFS: make IPC a regular tcon
    - CIFS: use tcon_ipc instead of use_ipc parameter of SMB2_ioctl
    - CIFS: dump IPC tcon in debug proc file

  * i2c-thunderx: erroneous error message "unhandled state: 0" (LP: #1754076)
    - i2c: octeon: Prevent error message on bus error

  * hisi_sas: Add disk LED support (LP: #1752695)
    - scsi: hisi_sas: directly attached disk LED feature for v2 hw

  * EDAC, sb_edac: Backport 1 patch to Ubuntu 17.10 (Fix missing DIMM sysfs
    entries with KNL SNC2/SNC4 mode) (LP: #1743856)
    - EDAC, sb_edac: Fix missing DIMM sysfs entries with KNL SNC2/SNC4 mode

  * [regression] Colour banding and artefacts appear system-wide on an Asus
    Zenbook UX303LA with Intel HD 4400 graphics (LP: #1749420)
    - drm/edid: Add 6 bpc quirk for CPT panel in Asus UX303LA

  * DVB Card with SAA7146 chipset not working (LP: #1742316)
    - vmalloc: fix __GFP_HIGHMEM usage for vmalloc_32 on 32b systems

  * [Asus UX360UA] battery status in unity-panel is not changing when battery is
    being charged (LP: #1661876) // AC adapter status not detected on Asus
    ZenBook UX410UAK (LP: #1745032)
    - ACPI / battery: Add quirk for Asus UX360UA and UX410UAK

  * ASUS UX305LA - Battery state not detected correctly (LP: #1482390)
    - ACPI / battery: Add quirk for Asus GL502VSK and UX305LA

  * support thunderx2 vendor pmu events (LP: #1747523)
    - perf pmu: Extract function to get JSON alias map
    - perf pmu: Pass pmu as a parameter to get_cpuid_str()
    - perf tools arm64: Add support for get_cpuid_str function.
    - perf pmu: Add helper function is_pmu_core to detect PMU CORE devices
    - perf vendor events arm64: Add ThunderX2 implementation defined pmu core
      events
    - perf pmu: Add check for valid cpuid in perf_pmu__find_map()

  * lpfc.ko module doesn't work (LP: #1746970)
    - scsi: lpfc: Fix loop mode target discovery

  * Ubuntu 17.10 crashes on vmalloc.c (LP: #1739498)
    - powerpc/mm/book3s64: Make KERN_IO_START a variable
    - powerpc/mm/slb: Move comment next to the code it's referring to
    - powerpc/mm/hash64: Make vmalloc 56T on hash

  * ethtool -p fails to light NIC LED on HiSilicon D05 systems (LP: #1748567)
    - net...

Changed in linux (Ubuntu Artful):
status: Fix Committed → Fix Released
Manoj Iyer (manjo) wrote :

Marking bionic as fix-released since the patch identified here is already in master.
b746e3e01e70 powerpc/powernv: Flush console before platform error reboot

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-power-systems:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers