Kernel Update Causes HDMI Port to Stop Working

Bug #1734084 reported by Niall Newman on 2017-11-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

After upgrading the kernel on my Ubuntu 17.04 laptop from linux-image-4.13.0-16-generic to linux-image-4.13.0-17-generic the HDMI port was no longer recognised by the system causing the external display to stop working.
Reverting the kernel to linux-image-4.13.0-16-generic fixes the issue.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: linux-image-4.13.0-17-generic (not installed)
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.5
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: linus 2762 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
Date: Thu Nov 23 09:17:32 2017
HibernationDevice: RESUME=UUID=864b1d5d-3e65-4d95-b439-941a5825c74f
InstallationDate: Installed on 2017-10-18 (35 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170926)
MachineType: Dell Inc. Latitude E7470
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.13.0-16-generic.efi.signed root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-4.13.0-16-generic N/A
 linux-backports-modules-4.13.0-16-generic N/A
 linux-firmware 1.169
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/02/2017
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.16.4
dmi.board.name: 0T6HHJ
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.16.4:bd06/02/2017:svnDellInc.:pnLatitudeE7470:pvr:rvnDellInc.:rn0T6HHJ:rvrA00:cvnDellInc.:ct9:cvr:
dmi.product.family: Latitude
dmi.product.name: Latitude E7470
dmi.sys.vendor: Dell Inc.

Niall Newman (linusdev) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.14 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.14

Changed in linux (Ubuntu):
importance: Undecided → High
status: Confirmed → Incomplete
tags: added: needs-bisect
Niall Newman (linusdev) wrote :

I tested with the latest upstream v4.14 kernels and the issue appears to be fixed.

Kind regards,
Niall

tags: added: kernel-fixed-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Can you also test the latest 4.13 upstream stable kernel, to see if the fix was also cc'd to stable?

http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.13.16/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers