Ubuntu 17.10: Include patch "crypto: vmx - Use skcipher for ctr fallback"

Bug #1732978 reported by bugproxy on 2017-11-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Ubuntu-power-systems project
High
Canonical Kernel Team
linux (Ubuntu)
Medium
Joseph Salisbury
Artful
Medium
Joseph Salisbury
Bionic
Medium
Joseph Salisbury

Bug Description

== SRU Justification ==
Artful uses the 4.13 kernel which has an issue with the fallback cipher for
CTR mode. Commit e666d4e9ceec fixes this problem by using a new structure
for the generic ciphers.

This commit is also needed in Bionic until it gets rebased to 4.15.

Commit e666d4e9ceec was added to mainline in v4.15-rc2

== Fix ==
commit e666d4e9ceec94c0a88c94b7db31d56474da43b3
Author: Paulo Flabiano Smorigo <email address hidden>
Date: Mon Oct 16 20:54:19 2017 -0200

    crypto: vmx - Use skcipher for ctr fallback

== Regression Potential ==
This commit is specific to crypto, and adds a new structure for the generic ciphers.

== Test Case ==
A test kernel was built with this patch and tested by the original bug reporter.
The bug reporter states the test kernel resolved the bug.

== Original Bug Desription: ==
== Comment: #0 - Paulo Flabiano Smorigo <email address hidden> - 2017-11-17 10:29:14 ==
Ubuntu 17.10 uses linux kernel 4.13 witch has a problem with the fallback cipher for CTR mode. The commit bellow fixes this problem by using the new structure for the generic ciphers. Please add it to the kernel package.

https://git.kernel.org/pub/scm/linux/kernel/git/herbert/crypto-2.6.git/commit/?id=e666d4e9ceec94c0a88c94b7db31d56474da43b3

== Comment: #1 - VIPIN K. PARASHAR <email address hidden> - 2017-11-17 13:38:05 ==
(In reply to comment #0)
> Ubuntu 17.10 uses linux kernel 4.13 witch has a problem with the fallback
> cipher for CTR mode. The commit bellow fixes this problem by using the new
> structure for the generic ciphers. Please add it to the kernel package.
>
> https://git.kernel.org/pub/scm/linux/kernel/git/herbert/crypto-2.6.git/
> commit/?id=e666d4e9ceec94c0a88c94b7db31d56474da43b3

Which is commit e666d4e9ceec94

commit e666d4e9ceec94c0a88c94b7db31d56474da43b3
Author: Paulo Flabiano Smorigo <email address hidden>
Date: Mon Oct 16 20:54:19 2017 -0200

    crypto: vmx - Use skcipher for ctr fallback

    Signed-off-by: Paulo Flabiano Smorigo <email address hidden>
    Signed-off-by: Herbert Xu <email address hidden>

Its available with 4.14 kernel.

Hello Canonical,

Please include commit e666d4e9ceec94 - "crypto: vmx - Use skcipher for ctr fallback"
with Ubuntu 17.10 kernel.

bugproxy (bugproxy) on 2017-11-17
tags: added: architecture-ppc64le bugnameltc-161493 severity-high targetmilestone-inin1710
Changed in ubuntu:
assignee: nobody → Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage)
affects: ubuntu → linux (Ubuntu)
tags: added: kernel-da-key
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in linux (Ubuntu Artful):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Joseph Salisbury (jsalisbury)
Changed in linux (Ubuntu):
assignee: Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage) → Joseph Salisbury (jsalisbury)
Changed in ubuntu-power-systems:
importance: Undecided → Medium
status: New → Triaged
importance: Medium → High
Manoj Iyer (manjo) on 2017-11-20
tags: added: triage-g
Changed in linux (Ubuntu):
status: Triaged → In Progress
Changed in linux (Ubuntu Artful):
status: Triaged → In Progress
bugproxy (bugproxy) on 2017-11-20
tags: removed: bugnameltc-161493 kernel-da-key severity-high triage-g
tags: added: triage-g
Joseph Salisbury (jsalisbury) wrote :

I built a 17.10 test kernel with a pick of commit e666d4e9ceec94. The test kernel can be downloaded from:

http://kernel.ubuntu.com/~jsalisbury/lp1732978/

Can you test this kernel and see if it resolves this bug?

Manoj Iyer (manjo) on 2017-11-21
Changed in ubuntu-power-systems:
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
Changed in ubuntu-power-systems:
status: Triaged → In Progress
Changed in ubuntu-power-systems:
status: In Progress → Incomplete
Paulo F. Smorigo (pfsmorigo) wrote :

Did a test with ipsec using kernel 4.13.0-16_4.13.0-16.19 and it's working fine. Thanks!

Manoj Iyer (manjo) on 2018-01-22
Changed in ubuntu-power-systems:
status: Incomplete → In Progress
Changed in linux (Ubuntu Artful):
status: In Progress → Fix Committed
Changed in ubuntu-power-systems:
status: In Progress → Fix Committed
Manoj Iyer (manjo) on 2018-03-05
Changed in linux (Ubuntu Bionic):
status: In Progress → Fix Committed
Stefan Bader (smb) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-artful' to 'verification-done-artful'. If the problem still exists, change the tag 'verification-needed-artful' to 'verification-failed-artful'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-artful
Launchpad Janitor (janitor) wrote :
Download full text (18.9 KiB)

This bug was fixed in the package linux - 4.13.0-38.43

---------------
linux (4.13.0-38.43) artful; urgency=medium

  * linux: 4.13.0-38.43 -proposed tracker (LP: #1755762)

  * Servers going OOM after updating kernel from 4.10 to 4.13 (LP: #1748408)
    - i40e: Fix memory leak related filter programming status
    - i40e: Add programming descriptors to cleaned_count

  * [SRU] Lenovo E41 Mic mute hotkey is not responding (LP: #1753347)
    - platform/x86: ideapad-laptop: Increase timeout to wait for EC answer

  * fails to dump with latest kpti fixes (LP: #1750021)
    - kdump: write correct address of mem_section into vmcoreinfo

  * headset mic can't be detected on two Dell machines (LP: #1748807)
    - ALSA: hda/realtek - Support headset mode for ALC215/ALC285/ALC289
    - ALSA: hda - Fix headset mic detection problem for two Dell machines
    - ALSA: hda - Fix a wrong FIXUP for alc289 on Dell machines

  * CIFS SMB2/SMB3 does not work for domain based DFS (LP: #1747572)
    - CIFS: make IPC a regular tcon
    - CIFS: use tcon_ipc instead of use_ipc parameter of SMB2_ioctl
    - CIFS: dump IPC tcon in debug proc file

  * i2c-thunderx: erroneous error message "unhandled state: 0" (LP: #1754076)
    - i2c: octeon: Prevent error message on bus error

  * hisi_sas: Add disk LED support (LP: #1752695)
    - scsi: hisi_sas: directly attached disk LED feature for v2 hw

  * EDAC, sb_edac: Backport 1 patch to Ubuntu 17.10 (Fix missing DIMM sysfs
    entries with KNL SNC2/SNC4 mode) (LP: #1743856)
    - EDAC, sb_edac: Fix missing DIMM sysfs entries with KNL SNC2/SNC4 mode

  * [regression] Colour banding and artefacts appear system-wide on an Asus
    Zenbook UX303LA with Intel HD 4400 graphics (LP: #1749420)
    - drm/edid: Add 6 bpc quirk for CPT panel in Asus UX303LA

  * DVB Card with SAA7146 chipset not working (LP: #1742316)
    - vmalloc: fix __GFP_HIGHMEM usage for vmalloc_32 on 32b systems

  * [Asus UX360UA] battery status in unity-panel is not changing when battery is
    being charged (LP: #1661876) // AC adapter status not detected on Asus
    ZenBook UX410UAK (LP: #1745032)
    - ACPI / battery: Add quirk for Asus UX360UA and UX410UAK

  * ASUS UX305LA - Battery state not detected correctly (LP: #1482390)
    - ACPI / battery: Add quirk for Asus GL502VSK and UX305LA

  * support thunderx2 vendor pmu events (LP: #1747523)
    - perf pmu: Extract function to get JSON alias map
    - perf pmu: Pass pmu as a parameter to get_cpuid_str()
    - perf tools arm64: Add support for get_cpuid_str function.
    - perf pmu: Add helper function is_pmu_core to detect PMU CORE devices
    - perf vendor events arm64: Add ThunderX2 implementation defined pmu core
      events
    - perf pmu: Add check for valid cpuid in perf_pmu__find_map()

  * lpfc.ko module doesn't work (LP: #1746970)
    - scsi: lpfc: Fix loop mode target discovery

  * Ubuntu 17.10 crashes on vmalloc.c (LP: #1739498)
    - powerpc/mm/book3s64: Make KERN_IO_START a variable
    - powerpc/mm/slb: Move comment next to the code it's referring to
    - powerpc/mm/hash64: Make vmalloc 56T on hash

  * ethtool -p fails to light NIC LED on HiSilicon D05 systems (LP: #1748567)
    - net...

Changed in linux (Ubuntu Artful):
status: Fix Committed → Fix Released
Manoj Iyer (manjo) wrote :

Marking bionic as fix-released since the patch identified here is already in master.
e666d4e9ceec crypto: vmx - Use skcipher for ctr fallback

Changed in linux (Ubuntu Bionic):
status: Fix Committed → Fix Released
Changed in ubuntu-power-systems:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers