The HDMI audio can't work on all Geminilake machines we have (Dell laptops or desktops)

Bug #1731091 reported by Hui Wang
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Critical
Hui Wang
linux (Ubuntu)
Critical
Hui Wang
linux-oem (Ubuntu)
Critical
Unassigned

Bug Description

I have filed a bugzilla bug to track this issue: https://bugzilla.kernel.org/show_bug.cgi?id=197785

We have several Geminilake laptop and desktop machines, on these
machines, the HW configs are same and are as shown below:

the HDA controller: 00:0e.0 Audio device [0403]: Intel Corporation
Device [8086:3198] (rev 01)
the HDMI codec: Vendor Id: 0x8086280d
VGA controller: 00:02.0 VGA compatible controller [0300]: Intel
Corporation Device [8086:3184] (rev 01) (prog-if 00 [VGA controller])

The problem is if we boot the system without plugging the HDMI monitor,
the Linux kernel can't find HDMI codec at all. If we plug the HDMI
monitor before booting up, the kernel can find the HDMI codec, but there
are many errors (as shown below) and the HDMI audio can't play any sound.

Codec: Intel Geminilake HDMI
Address: 2
AFG Function Id: 0x1 (unsol 0)
Vendor Id: 0x8086280d
Subsystem Id: 0x80860101
Revision Id: 0x100000
No Modem Function Group found
Default PCM:
N/A
Default Amp-In caps: N/A
Default Amp-Out caps: N/A
State of AFG node 0x01:
   Power: setting=UNKNOWN, actual=UNKNOWN, Error, Clock-stop-OK,
Setting-reset
Invalid AFG subtree
--endcollapse--

[ 25.504069] snd_hda_intel 0000:00:0e.0: azx_get_response timeout,
switching to polling mode: last cmd=0x20bf8100
[ 26.516125] snd_hda_intel 0000:00:0e.0: No response from codec,
disabling MSI: last cmd=0x20bf8100
[ 27.528058] snd_hda_intel 0000:00:0e.0: azx_get_response timeout,
switching to single_cmd mode: last cmd=0x20bf8100
[ 27.528259] azx_single_wait_for_response: 12 callbacks suppressed
[ 27.547927] snd_hda_codec_hdmi hdaudioC0D2: Unable to sync register
0x2f0d00. -5

Revision history for this message
Hui Wang (hui.wang) wrote :
tags: added: originate-from-1718368 somerville
Changed in hwe-next:
importance: Undecided → Critical
Changed in linux (Ubuntu):
importance: Undecided → Critical
Changed in hwe-next:
assignee: nobody → Hui Wang (hui.wang)
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1731091

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Timo Aaltonen (tjaalton)
Changed in linux-oem (Ubuntu):
status: New → Triaged
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Hui Wang (hui.wang)
Changed in linux-oem (Ubuntu):
importance: Undecided → Critical
Changed in linux (Ubuntu):
status: Triaged → Fix Committed
Changed in hwe-next:
status: New → Fix Committed
Changed in linux-oem (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (23.4 KiB)

This bug was fixed in the package linux-oem - 4.13.0-1008.9

---------------
linux-oem (4.13.0-1008.9) xenial; urgency=low

  * Reading HDA audio capability register crashes the kernel (LP: #1730261)
    - ALSA: hda: Abort capability probe at invalid register read

  * The HDMI audio can't work on all Geminilake machines we have (Dell laptops
    or desktops) (LP: #1731091)
    - SAUCE: drm/i915: Track minimum acceptable cdclk instead of "minimum
      dotclock"
    - SAUCE: drm/i915: Consolidate max_cdclk_freq check in
      intel_crtc_compute_min_cdclk()
    - SAUCE: drm/i915: set minimum CD clock to twice the BCLK.

  * Backport support for Intel Coffee Lake (LP: #1729842)
    - drm/i915: Fix PCH names for KBP and CNP.
    - drm/i915: Stop using long platform names on clock gating functions.
    - drm/i915/cnp: Wa 1181: Fix Backlight issue
    - drm/i915/cnp: Don't touch other PCH clock gating bits.
    - drm/i915/cnp: Display Wa #1179: WaHardHangonHotPlug
    - drm/i915/cfl: Coffee Lake works on Kaby Lake PCH.
    - drm/i915/cfl: Remove alpha support protection.

  * headset mic can't work on laptops with the codec alc236 (LP: #1729500)
    - ALSA: hda/realtek - Add support for ALC236/ALC3204
    - ALSA: hda - fix headset mic problem for Dell machines with alc236

  * Miscellaneous Ubuntu changes
    - [Config] Sync with master
    - [Packaging] Bump debhelper to 9
    - [Config] Sync annotations with master
    - [Packaging] d-i: Drop kernel-versions diff
    - [Packaging] Add aufs-dkms Provides
    - Rebase to 4.13.0-17.20
    - [Config] update configs following rebase to 4.13.0-17.20
    - [Config] Ignore modules turned built-in

  [ Ubuntu: 4.13.0-17.20 ]

  * linux: 4.13.0-17.20 -proposed tracker (LP: #1728927)
  * thunderx2 ahci errata workaround needs additional delays (LP: #1724117)
    - SAUCE: ahci: thunderx2: stop engine fix update
  * usb 3-1: 2:1: cannot get freq at ep 0x1 (LP: #1708499)
    - ALSA: usb-audio: Add sample rate quirk for Plantronics C310/C520-M
  * Plantronics Blackwire C520-M - Cannot get freq at ep 0x1, 0x81
    (LP: #1709282)
    - ALSA: usb-audio: Add sample rate quirk for Plantronics C310/C520-M
  * TSC_DEADLINE incorrectly disabled inside virtual guests (LP: #1724912)
    - x86/apic: Silence "FW_BUG TSC_DEADLINE disabled due to Errata" on CPUs
      without the feature
    - x86/apic: Silence "FW_BUG TSC_DEADLINE disabled due to Errata" on
      hypervisors
  * x86/apic: Update TSC_DEADLINE quirk with additional SKX stepping
    (LP: #1724612)
    - x86/apic: Update TSC_DEADLINE quirk with additional SKX stepping
  * [Artful] Add support for Dell/Wyse 3040 audio codec (LP: #1723916)
    - SAUCE: ASoC: rt5670: Add support for Wyse 3040
  * [Artful] Some Dell Monitors Doesn't Work Well with Dell/Wyse 3040
    (LP: #1723915)
    - SAUCE: drm/i915: Workaround for DP DPMS D3 on Dell monitor
  * [Artful] Support headset mode for DELL WYSE (LP: #1723913)
    - SAUCE: ALSA: hda/realtek - Add support headset mode for DELL WYSE
  * Touchpad and TrackPoint Dose Not Work on Lenovo X1C6 and X280 (LP: #1723986)
    - SAUCE: Input: synaptics-rmi4 - RMI4 can also use SMBUS version 3
    - SAUCE: Input: synaptics - Lenov...

Changed in linux-oem (Ubuntu):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu):
status: Fix Committed → Triaged
Changed in hwe-next:
status: Fix Committed → Triaged
Hui Wang (hui.wang)
Changed in linux (Ubuntu):
status: Triaged → Fix Released
Changed in hwe-next:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.