netplan breaks Xen VIF driver

Bug #1729573 reported by Dan Streetman on 2017-11-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Zesty
Undecided
Unassigned
Artful
Undecided
Unassigned
Bionic
Undecided
Unassigned
nplan (Ubuntu)
High
Dan Streetman
Xenial
Undecided
Mathieu Trudel-Lapierre
Zesty
Undecided
Mathieu Trudel-Lapierre
Artful
High
Mathieu Trudel-Lapierre
Bionic
High
Dan Streetman

Bug Description

[Impact]

Some network interfaces on a Xen guest are broken by new behavior introduced by netplan. On a Xen guest instance, when netplan is run to 'apply' its configuration, under certain circumstances netplan will try to "reset" the interface by unbinding and then re-binding the interface driver from the interface, by using the sysfs "bind" and "unbind" functions of the driver. Normally, this results in the interface being released and then fully re-initialized by the driver.

However the Xen VIF driver breaks when this is done. The internal Xen backend state of the interface remains in 'closed' state after the driver re-connects to the interface, and attempts to open and use the interface result in a kernel Oops in the Xen VIF driver.

To users, it appears that the interface is unusable because it has an all 0 mac address; but if the mac is manually set and the interface brought up the driver Oopses as mentioned above.

This problem makes booting painful because of very long timeouts waiting for all network interfaces to start, and affected Xen VIF interfaces will of course never complete startup.

[Fix]

No fix yet. Upstream kernel does not appear fixed.

[Test Case]

Create a guest instance under a Xen hypervisor (e.g. an AWS instance) that has Ubuntu Artful 17.10 installed. Use only a single interface at first when creating it. Then once it is ready, attach a second network interface to the instance. From inside the instance, configure the new interface in netplan (i.e. add a /etc/netplan/ config for it). Make sure the new interface is down (netplan does not appear to unbind/bind interfaces that are up), and then run:

$ sudo netplan apply

or for debug,

$ sudo netplan --debug apply

this will unbind and re-bind the second interface, which will then have all-0 mac, and will be unusable, as described above.

[Regression Potential]

Changes to the Xen VIF driver can result in unusable network interfaces, or problems while using Xen VIF interfaces.

[Other Info]

Problem appears to exist upstream also.

Dan Streetman (ddstreet) on 2017-11-02
Changed in linux (Ubuntu):
status: New → In Progress
assignee: nobody → Dan Streetman (ddstreet)
importance: Undecided → High
Changed in linux (Ubuntu Artful):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Dan Streetman (ddstreet)
tags: added: sts sts-sponsor
tags: removed: sts-sponsor
Dan Streetman (ddstreet) wrote :

switching this bug over to netplan, as there are already several nic drivers blacklisted from the "replugging" in netplan, due to them not supporting (or breaking) unbinding/rebinding.

Changed in linux (Ubuntu Artful):
status: In Progress → Won't Fix
Changed in linux (Ubuntu Bionic):
status: In Progress → Won't Fix
Changed in nplan (Ubuntu Artful):
importance: Undecided → High
Changed in nplan (Ubuntu Bionic):
importance: Undecided → High
Changed in nplan (Ubuntu Artful):
status: New → In Progress
Changed in nplan (Ubuntu Bionic):
status: New → In Progress
assignee: nobody → Dan Streetman (ddstreet)
Changed in nplan (Ubuntu Artful):
assignee: nobody → Dan Streetman (ddstreet)
Dan Streetman (ddstreet) on 2017-11-08
Changed in linux (Ubuntu):
assignee: Dan Streetman (ddstreet) → nobody
Changed in linux (Ubuntu Artful):
assignee: Dan Streetman (ddstreet) → nobody
Changed in linux (Ubuntu Bionic):
assignee: Dan Streetman (ddstreet) → nobody
Changed in linux (Ubuntu Xenial):
status: New → Won't Fix
Changed in linux (Ubuntu Zesty):
status: New → Won't Fix
Changed in linux (Ubuntu):
importance: High → Wishlist
Changed in linux (Ubuntu Artful):
importance: High → Wishlist
Changed in linux (Ubuntu Bionic):
importance: High → Wishlist
importance: Wishlist → Undecided
Changed in linux (Ubuntu Artful):
importance: Wishlist → Undecided
Changed in linux (Ubuntu):
importance: Wishlist → Undecided
status: In Progress → Won't Fix
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nplan - 0.32

---------------
nplan (0.32) bionic; urgency=medium

  * src/nm.c: better handle the UUID generation; the order of iterating
    through interaces may affect things here. Also make sure the tests catch
    a null UUID.

 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 14 Nov 2017 08:53:51 -0500

Changed in nplan (Ubuntu Bionic):
status: In Progress → Fix Released

Hello Dan, or anyone else affected,

Accepted nplan into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nplan/0.32~17.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nplan (Ubuntu Zesty):
status: New → Fix Committed
tags: added: verification-needed verification-needed-zesty
Łukasz Zemczak (sil2100) wrote :

Hello Dan, or anyone else affected,

Accepted nplan into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nplan/0.32~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nplan (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
Dan Streetman (ddstreet) wrote :

Zesty:

ubuntu@ip-172-31-53-199:~$ dpkg -l | grep nplan
ii nplan 0.23~17.04.1 amd64 YAML network configuration abstraction for various backends
ubuntu@ip-172-31-53-199:~$ ip l show eth1
4: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 12:f6:8a:ee:fc:96 brd ff:ff:ff:ff:ff:ff
ubuntu@ip-172-31-53-199:~$ sudo netplan --debug apply
** (generate:1349): DEBUG: Processing input file //etc/netplan/10-ifupdown.yaml..
** (generate:1349): DEBUG: starting new processing pass
** (generate:1349): DEBUG: eth0: setting default backend to 1
** (generate:1349): DEBUG: Generating output files..
** (generate:1349): DEBUG: NetworkManager: definition eth0 is not for us (backend 1)
DEBUG:netplan generated networkd configuration exists, restarting networkd
DEBUG:no netplan generated NM configuration exists
DEBUG:device eth0 operstate is up, not replugging
DEBUG:netplan triggering .link rules for eth0
DEBUG:device lo operstate is unknown, not replugging
DEBUG:netplan triggering .link rules for lo
DEBUG:replug eth1: unbinding vif-2 from /sys/bus/xen/drivers/vif
DEBUG:replug eth1: rebinding vif-2 to /sys/bus/xen/drivers/vif
ubuntu@ip-172-31-53-199:~$ ip l show eth1
5: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:00:00:00:00:00 brd ff:ff:ff:ff:ff:ff

ubuntu@ip-172-31-53-199:~$ dpkg -l | grep nplan
ii nplan 0.32~17.04.1 amd64 YAML network configuration abstraction for various backends
ubuntu@ip-172-31-53-199:~$ ip l show eth1
3: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 12:f6:8a:ee:fc:96 brd ff:ff:ff:ff:ff:ff
ubuntu@ip-172-31-53-199:~$ sudo netplan --debug apply
** (generate:1282): DEBUG: Processing input file //etc/netplan/10-ifupdown.yaml..
** (generate:1282): DEBUG: starting new processing pass
** (generate:1282): DEBUG: eth0: setting default backend to 1
** (generate:1282): DEBUG: Generating output files..
** (generate:1282): DEBUG: NetworkManager: definition eth0 is not for us (backend 1)
DEBUG:netplan generated networkd configuration exists, restarting networkd
DEBUG:no netplan generated NM configuration exists
DEBUG:replug eth1: xen:vif fails on rebinding, ignoring
DEBUG:netplan triggering .link rules for eth1
DEBUG:device lo operstate is unknown, not replugging
DEBUG:netplan triggering .link rules for lo
DEBUG:device eth0 operstate is up, not replugging
DEBUG:netplan triggering .link rules for eth0
ubuntu@ip-172-31-53-199:~$ ip l show eth1
3: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 12:f6:8a:ee:fc:96 brd ff:ff:ff:ff:ff:ff

Dan Streetman (ddstreet) wrote :

xenial build 32~16.04.1 failed for all archs; looks like a typo in one of the python test cases.

https://launchpad.net/ubuntu/+source/nplan/0.32~16.04.1

https://launchpadlibrarian.net/346856943/buildlog_ubuntu-xenial-amd64.nplan_0.32~16.04.1_BUILDING.txt.gz

/usr/bin/pyflakes3 src/netplan tests/generate.py tests/cli.py tests/integration.py
tests/integration.py:1030:46: invalid syntax
        if (self.backend == "NetworkManager")
                                             ^
Makefile:24: recipe for target 'check' failed
make[1]: *** [check] Error 1
make[1]: Leaving directory '/<<PKGBUILDDIR>>'
dh_auto_test: make -j1 check returned exit code 2
debian/rules:4: recipe for target 'build' failed
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2

tags: added: verification-done-zesty verification-failed-xenial
removed: verification-needed-xenial verification-needed-zesty
tags: added: verification-failed
removed: verification-needed
tags: removed: verification-failed
Dan Streetman (ddstreet) on 2017-11-29
Changed in nplan (Ubuntu Artful):
assignee: Dan Streetman (ddstreet) → Mathieu Trudel-Lapierre (cyphermox)
Changed in nplan (Ubuntu Zesty):
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
Changed in nplan (Ubuntu Xenial):
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
Brian Murray (brian-murray) wrote :

Hello Dan, or anyone else affected,

Accepted nplan into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nplan/0.32~16.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-xenial
removed: verification-failed-xenial
Dan Streetman (ddstreet) wrote :

Xenial:

ubuntu@ip-172-31-60-65:~$ dpkg -l | grep nplan
ii nplan 0.23~16.04.1 amd64 YAML network configuration abstraction for various backends
ubuntu@ip-172-31-60-65:~$ ip l show eth1
3: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 12:f6:8a:ee:fc:96 brd ff:ff:ff:ff:ff:ff
ubuntu@ip-172-31-60-65:~$ sudo netplan --debug apply
sudo: unable to resolve host ip-172-31-60-65
** (generate:2495): DEBUG: Processing input file //etc/netplan/10-ifupdown.yaml..
** (generate:2495): DEBUG: starting new processing pass
** (generate:2495): DEBUG: eth0: setting default backend to 1
** (generate:2495): DEBUG: Generating output files..
** (generate:2495): DEBUG: NetworkManager: definition eth0 is not for us (backend 1)
DEBUG:netplan generated networkd configuration exists, restarting networkd
DEBUG:no netplan generated NM configuration exists
DEBUG:device lo operstate is unknown, not replugging
DEBUG:netplan triggering .link rules for lo
DEBUG:device eth0 operstate is up, not replugging
DEBUG:netplan triggering .link rules for eth0
DEBUG:replug eth1: unbinding vif-1 from /sys/bus/xen/drivers/vif
DEBUG:replug eth1: rebinding vif-1 to /sys/bus/xen/drivers/vif
ubuntu@ip-172-31-60-65:~$ ip l show eth1
4: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:00:00:00:00:00 brd ff:ff:ff:ff:ff:ff

ubuntu@ip-172-31-60-65:~$ dpkg -l | grep nplan
ii nplan 0.32~16.04.2 amd64 YAML network configuration abstraction for various backends
ubuntu@ip-172-31-60-65:~$ ip l show eth1
3: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 12:f6:8a:ee:fc:96 brd ff:ff:ff:ff:ff:ff
ubuntu@ip-172-31-60-65:~$ sudo netplan --debug apply
sudo: unable to resolve host ip-172-31-60-65
** (generate:1980): DEBUG: Processing input file //etc/netplan/10-ifupdown.yaml..
** (generate:1980): DEBUG: starting new processing pass
** (generate:1980): DEBUG: eth0: setting default backend to 1
** (generate:1980): DEBUG: Generating output files..
** (generate:1980): DEBUG: NetworkManager: definition eth0 is not for us (backend 1)
DEBUG:netplan generated networkd configuration exists, restarting networkd
DEBUG:no netplan generated NM configuration exists
DEBUG:device lo operstate is unknown, not replugging
DEBUG:netplan triggering .link rules for lo
DEBUG:device eth0 operstate is up, not replugging
DEBUG:netplan triggering .link rules for eth0
DEBUG:replug eth1: xen:vif fails on rebinding, ignoring
DEBUG:netplan triggering .link rules for eth1
ubuntu@ip-172-31-60-65:~$ ip l show eth1
3: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 12:f6:8a:ee:fc:96 brd ff:ff:ff:ff:ff:ff

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Łukasz Zemczak (sil2100) wrote :

Hello Dan, or anyone else affected,

Accepted nplan into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nplan/0.32~17.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nplan (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-artful
removed: verification-done
Łukasz Zemczak (sil2100) wrote :

Hello Dan, or anyone else affected,

Accepted nplan into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nplan/0.32~16.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed-xenial
removed: verification-done-xenial
Dan Streetman (ddstreet) wrote :

artful:

ubuntu@ip-172-31-58-142:~$ lsb_release -r
Release: 17.10
ubuntu@ip-172-31-58-142:~$ dpkg -l|grep nplan
ii nplan 0.30 amd64 YAML network configuration abstraction for various backends
ubuntu@ip-172-31-58-142:~$ ip l show eth1
3: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 12:f6:8a:ee:fc:96 brd ff:ff:ff:ff:ff:ff
ubuntu@ip-172-31-58-142:~$ sudo netplan --debug apply
** (generate:7935): DEBUG: Processing input file //etc/netplan/10-ifupdown.yaml..
** (generate:7935): DEBUG: starting new processing pass
** (generate:7935): DEBUG: eth0: setting default backend to 1
** (generate:7935): DEBUG: Generating output files..
** (generate:7935): DEBUG: NetworkManager: definition eth0 is not for us (backend 1)
DEBUG:netplan generated networkd configuration exists, restarting networkd
DEBUG:no netplan generated NM configuration exists
DEBUG:replug eth1: unbinding vif-1 from /sys/bus/xen/drivers/vif
DEBUG:replug eth1: rebinding vif-1 to /sys/bus/xen/drivers/vif
DEBUG:device lo operstate is unknown, not replugging
DEBUG:netplan triggering .link rules for lo
DEBUG:device eth0 operstate is up, not replugging
DEBUG:netplan triggering .link rules for eth0
ubuntu@ip-172-31-58-142:~$ ip l show eth1
4: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:00:00:00:00:00 brd ff:ff:ff:ff:ff:ff

ubuntu@ip-172-31-58-142:~$ lsb_release -r
Release: 17.10
ubuntu@ip-172-31-58-142:~$ dpkg -l|grep nplan
ii nplan 0.32~17.10.1 amd64 YAML network configuration abstraction for various backends
ubuntu@ip-172-31-58-142:~$ ip l show eth1
4: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 12:f6:8a:ee:fc:96 brd ff:ff:ff:ff:ff:ff
ubuntu@ip-172-31-58-142:~$ sudo netplan --debug apply
** (generate:1267): DEBUG: Processing input file //etc/netplan/10-ifupdown.yaml..
** (generate:1267): DEBUG: starting new processing pass
** (generate:1267): DEBUG: eth0: setting default backend to 1
** (generate:1267): DEBUG: Generating output files..
** (generate:1267): DEBUG: NetworkManager: definition eth0 is not for us (backend 1)
DEBUG:netplan generated networkd configuration exists, restarting networkd
DEBUG:no netplan generated NM configuration exists
DEBUG:device eth0 operstate is up, not replugging
DEBUG:netplan triggering .link rules for eth0
DEBUG:device lo operstate is unknown, not replugging
DEBUG:netplan triggering .link rules for lo
DEBUG:replug eth1: xen:vif fails on rebinding, ignoring
DEBUG:netplan triggering .link rules for eth1
ubuntu@ip-172-31-58-142:~$ ip l show eth1
4: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 12:f6:8a:ee:fc:96 brd ff:ff:ff:ff:ff:ff

tags: added: verification-done-artful
removed: verification-needed-artful
Dan Streetman (ddstreet) wrote :

xenial:

ubuntu@ip-172-31-52-172:~$ lsb_release -r
Release: 16.04
ubuntu@ip-172-31-52-172:~$ dpkg -l|grep nplan
ii nplan 0.23~16.04.1 amd64 YAML network configuration abstraction for various backends
ubuntu@ip-172-31-52-172:~$ ip l show eth1
3: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 12:f6:8a:ee:fc:96 brd ff:ff:ff:ff:ff:ff
ubuntu@ip-172-31-52-172:~$ sudo netplan --debug apply
** (generate:3891): DEBUG: Processing input file //etc/netplan/10-ifupdown.yaml..
** (generate:3891): DEBUG: starting new processing pass
** (generate:3891): DEBUG: eth0: setting default backend to 1
** (generate:3891): DEBUG: Generating output files..
** (generate:3891): DEBUG: NetworkManager: definition eth0 is not for us (backend 1)
DEBUG:netplan generated networkd configuration exists, restarting networkd
DEBUG:no netplan generated NM configuration exists
DEBUG:device lo operstate is unknown, not replugging
DEBUG:netplan triggering .link rules for lo
DEBUG:device eth0 operstate is up, not replugging
DEBUG:netplan triggering .link rules for eth0
DEBUG:replug eth1: unbinding vif-1 from /sys/bus/xen/drivers/vif
DEBUG:replug eth1: rebinding vif-1 to /sys/bus/xen/drivers/vif
ubuntu@ip-172-31-52-172:~$ ip l show eth1
4: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:00:00:00:00:00 brd ff:ff:ff:ff:ff:ff

ubuntu@ip-172-31-52-172:~$ lsb_release -r
Release: 16.04
ubuntu@ip-172-31-52-172:~$ dpkg -l|grep nplan
ii nplan 0.32~16.04.3 amd64 YAML network configuration abstraction for various backends
ubuntu@ip-172-31-52-172:~$ ip l show eth1
3: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 12:f6:8a:ee:fc:96 brd ff:ff:ff:ff:ff:ff
ubuntu@ip-172-31-52-172:~$ sudo netplan --debug apply
sudo: unable to resolve host ip-172-31-52-172
** (generate:1317): DEBUG: Processing input file //etc/netplan/10-ifupdown.yaml..
** (generate:1317): DEBUG: starting new processing pass
** (generate:1317): DEBUG: eth0: setting default backend to 1
** (generate:1317): DEBUG: Generating output files..
** (generate:1317): DEBUG: NetworkManager: definition eth0 is not for us (backend 1)
DEBUG:netplan generated networkd configuration exists, restarting networkd
DEBUG:no netplan generated NM configuration exists
DEBUG:device lo operstate is unknown, not replugging
DEBUG:netplan triggering .link rules for lo
DEBUG:device eth0 operstate is up, not replugging
DEBUG:netplan triggering .link rules for eth0
DEBUG:replug eth1: xen:vif fails on rebinding, ignoring
DEBUG:netplan triggering .link rules for eth1
ubuntu@ip-172-31-52-172:~$ ip l show eth1
3: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 12:f6:8a:ee:fc:96 brd ff:ff:ff:ff:ff:ff

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nplan - 0.32~17.10.1

---------------
nplan (0.32~17.10.1) artful; urgency=medium

  * Backport 0.32 to Ubuntu 17.10. (LP: #1713142)

nplan (0.32) bionic; urgency=medium

  * src/nm.c: better handle the UUID generation; the order of iterating
    through interaces may affect things here. Also make sure the tests catch
    a null UUID.

nplan (0.31) bionic; urgency=medium

  [ Mathieu Trudel-Lapierre ]
  * src/nm.c: generate a UUID for a connection only as needed; when we're
    dealing with NM VLANs. (LP: #1712921)
  * debian/tests/autostart: Make the autostart test more verbose and avoid
    failing right from the start when systemd-networkd is disabled.
    (LP: #1699371)
  * tests/integration.py: bump the NetworkManager timeout for settling to
    120 seconds, autopkgtest infrastructure tends to be a little slow for the
    network device configuration to be applied and noticed by NM.
    (LP: #1699371)

  [ Dimitri John Ledkov ]
  * Reload udevd to invalidate configuration cache of .rules/.link files
    as generate step may have changed them. LP: #1669564

  [ Dan Streetman ]
  * Add another interface driver exception to netplan replug to prevent unbind
    of the Xen VIF interfaces. (LP: #1729573)

 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 23 Nov 2017 12:30:51 -0500

Changed in nplan (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for nplan has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Mark Thomas (markthomas) wrote :

I just tested this with a 20171220 daily build of 17.10 in us-east-1, in a custom VPC, and it appears to be working fine.

Launchpad Janitor (janitor) wrote :
Download full text (5.3 KiB)

This bug was fixed in the package nplan - 0.32~16.04.3

---------------
nplan (0.32~16.04.3) xenial; urgency=medium

  * tests/integration.py: Really fix skipping test_routes_v6 for the NM
    backend.

nplan (0.32~16.04.2) xenial; urgency=medium

  * tests/integration.py: Fix test_routes_v6 that I clobbered when I re-applied
    the skip rules for 16.04 after merging in 0.32.

nplan (0.32~16.04.1) xenial; urgency=medium

  * Backport netplan 0.32 to 16.04. (LP: #1713142)
  * debian/control: Depend on systemd (>= 229-4ubuntu20) for the PrimarySlave
    feature backported in that revision.
  * tests/integration.py: Skip tests that are still not yet supported in xenial

nplan (0.32) bionic; urgency=medium

  * src/nm.c: better handle the UUID generation; the order of iterating
    through interaces may affect things here. Also make sure the tests catch
    a null UUID.

nplan (0.31) bionic; urgency=medium

  [ Mathieu Trudel-Lapierre ]
  * src/nm.c: generate a UUID for a connection only as needed; when we're
    dealing with NM VLANs. (LP: #1712921)
  * debian/tests/autostart: Make the autostart test more verbose and avoid
    failing right from the start when systemd-networkd is disabled.
    (LP: #1699371)
  * tests/integration.py: bump the NetworkManager timeout for settling to
    120 seconds, autopkgtest infrastructure tends to be a little slow for the
    network device configuration to be applied and noticed by NM.
    (LP: #1699371)

  [ Dimitri John Ledkov ]
  * Reload udevd to invalidate configuration cache of .rules/.link files
    as generate step may have changed them. LP: #1669564

  [ Dan Streetman ]
  * Add another interface driver exception to netplan replug to prevent unbind
    of the Xen VIF interfaces. (LP: #1729573)

nplan (0.30) artful; urgency=medium

  * Add an "optional" syntax node for now to all devices. This is unimplemented
    for now, but intended to allow users to mark some devices as optional: to
    make sure they do not delay boot when configured. (LP: #1664844)

nplan (0.29) artful; urgency=medium

  * Fix autopkgtests in a world where /run/NetworkManager/conf.d already
    exists. nplan is enabled by default, so it might well have the directory
    already created on the filesystem.

nplan (0.28) artful; urgency=medium

  * Revert 56cd3eec which disabled IPv6 Router Advertisements by default. It
    broke default network config in LXD and was contrary to the defaults used
    by the kernel. Reopens LP: 1655440. (LP: #1717404)
  * Add "accept-ra:" key for all device types; this will default to OFF but
    allow users to disable processing Router Advertisements when required by
    their network setup. (LP: #1655440)

nplan (0.27) artful; urgency=medium

  [ Mathieu Trudel-Lapierre ]
  * Fix crash in systemd generator if called by an user on the command-line
  * coverage: fix exclusions to properly not cover our "never reached defaults"

  [ Dimitri John Ledkov ]
  * tests/integration.py: In teardown, stop systemd-networkd.socket.
  * src/networkd.c: Set UseMTU=true by default, whenever DHCP is in use.
    (LP: #1717471)
  * tests/integration.py: fix resolved detection.

nplan (0.26) artful; urgency=medium

 ...

Read more...

Changed in nplan (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.8 KiB)

This bug was fixed in the package nplan - 0.32~17.04.1

---------------
nplan (0.32~17.04.1) zesty; urgency=medium

  * Backport 0.32 to 17.04. (LP: #1713142)

nplan (0.32) bionic; urgency=medium

  * src/nm.c: better handle the UUID generation; the order of iterating
    through interaces may affect things here. Also make sure the tests catch
    a null UUID.

nplan (0.31) bionic; urgency=medium

  [ Mathieu Trudel-Lapierre ]
  * src/nm.c: generate a UUID for a connection only as needed; when we're
    dealing with NM VLANs. (LP: #1712921)
  * debian/tests/autostart: Make the autostart test more verbose and avoid
    failing right from the start when systemd-networkd is disabled.
    (LP: #1699371)
  * tests/integration.py: bump the NetworkManager timeout for settling to
    120 seconds, autopkgtest infrastructure tends to be a little slow for the
    network device configuration to be applied and noticed by NM.
    (LP: #1699371)

  [ Dimitri John Ledkov ]
  * Reload udevd to invalidate configuration cache of .rules/.link files
    as generate step may have changed them. LP: #1669564

  [ Dan Streetman ]
  * Add another interface driver exception to netplan replug to prevent unbind
    of the Xen VIF interfaces. (LP: #1729573)

nplan (0.30) artful; urgency=medium

  * Add an "optional" syntax node for now to all devices. This is unimplemented
    for now, but intended to allow users to mark some devices as optional: to
    make sure they do not delay boot when configured. (LP: #1664844)

nplan (0.29) artful; urgency=medium

  * Fix autopkgtests in a world where /run/NetworkManager/conf.d already
    exists. nplan is enabled by default, so it might well have the directory
    already created on the filesystem.

nplan (0.28) artful; urgency=medium

  * Revert 56cd3eec which disabled IPv6 Router Advertisements by default. It
    broke default network config in LXD and was contrary to the defaults used
    by the kernel. Reopens LP: 1655440. (LP: #1717404)
  * Add "accept-ra:" key for all device types; this will default to OFF but
    allow users to disable processing Router Advertisements when required by
    their network setup. (LP: #1655440)

nplan (0.27) artful; urgency=medium

  [ Mathieu Trudel-Lapierre ]
  * Fix crash in systemd generator if called by an user on the command-line
  * coverage: fix exclusions to properly not cover our "never reached defaults"

  [ Dimitri John Ledkov ]
  * tests/integration.py: In teardown, stop systemd-networkd.socket.
  * src/networkd.c: Set UseMTU=true by default, whenever DHCP is in use.
    (LP: #1717471)
  * tests/integration.py: fix resolved detection.

nplan (0.26) artful; urgency=medium

  * Bonding:
    - Add support for specifying a primary slave. (LP: #1709135)
  * Rebind:
    - Fix brcmfmac harder. Treat any 'brcmfmac' driver as not supporting
      rebind. (LP: #1712224)
  * Autopkgtests:
    - Add allow-stderr. Systemd now bleats about a the networkd socket still
      being around and enabled when we restart the service; but we don't need
      to care since we're /restarting/ the service to load the new config.
    - Fix the autostart package to be more sensible: we don't really care if
 ...

Read more...

Changed in nplan (Ubuntu Zesty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers