Elantech touchpad unresponsive in Ubuntu 17.10

Bug #1726934 reported by Tyler McLean on 2017-10-24
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I have upgraded to Ubuntu 17.10 on my Asus Vivobook X505BA laptop and with the upgrade to Wayland full-time, all of the elantech issues from a few years back are coming back with a vengeance. Upon upgrade, my trackpad is no longer functional and I am forced to use an external mouse. I don't have an extra mouse that I can just drag around with the laptop, nor do I wish to purchase one to use when I have a trackpad on the laptop itself. Dmesg doesn't show anything about the driver failing to load and syslog shows nothing either. I know this is a common issue with this kind of trackpad but I hope to see a fix soon so I can go back to using Ubuntu normally

affects: gnome-control-center (Ubuntu) → wayland (Ubuntu)
affects: wayland (Ubuntu) → libinput (Ubuntu)
Daniel van Vugt (vanvugt) wrote :

It sounds more like a kernel issue if the touchpad's not working at all.

If you install and run 'sudo evtest', is the touchpad device listed and testable? (try also in a separate VT login - Ctrl+Alt+F4)

Changed in libinput (Ubuntu):
status: New → Incomplete

Hey Daniel,

When I run 'sudo evtest' my touchpad is listed as "ELAN1200:00 04F3:303E Touchpad", but when I try to test it, not input is read like it would be for something like my keyboard or any other device. I placed this bug under libinput since this bug was not present in Ubuntu 17.04 which did not use Gnome Wayland as its default compositor. Mind you, 17.04 wasn't exactly great for using the touchpad to begin with as it would occasionally cut out altogether and become as useless as it is not until a restart but at least I would be able to use it again after the restart. Since my upgrade to 17.10, and the reinstall that followed when the upgrade didn't work, I have not been able to use my touchpad at all, hence I believe it has to do with the input system on Wayland. My touchpad also does not work in separate VT logins.

Changed in libinput (Ubuntu):
status: Incomplete → Fix Released
Daniel van Vugt (vanvugt) wrote :

Please try VT switching to VT4 (Ctrl+Alt+F4), log in and retest with 'evtest'. If you continue to get no results then that's a kernel bug. Because Wayland and libinput are not part of the equation when you're testing the kernel directly.

P.S. Also check if your laptop keyboard has a function key for disabling/enabling the touchpad. It might simply be disabled in hardware (for reasons unknown).

affects: libinput (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Fix Released → Incomplete
Daniel van Vugt (vanvugt) wrote :

Looking at photos of the Asus Vivobook X505BA keyboard it looks like F9 (or fn+F9) is the key combo to disable/enable the touchpad.

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.14 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.14-rc7

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: kernel-da-key

Testing the upstream kernel has solved my problems. My mouse is now more buttery smooth than it is on Windows. Multitouch is fully functional and no touchpad cutoffs have happened since the update.

tags: added: artful kernel kernel-fixed-upstream
removed: kernel-da-key libinput not touchpad wayland working
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
drops@noop.pl (drops-r) wrote :

The same touchpad in Fujitsu E557 it completly not recognized. I tried with with upstream kernel 4.14.0-041400rc7-generic and after upgrade do 17.10 even 'cat /proc/bus/input/devices' doesn't show my touchpad. But after I wake up my laptop from suspend mode, magically my touchpad started works.
I: Bus=0011 Vendor=0002 Product=000e Version=0000
N: Name="ETPS/2 Elantech Touchpad"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input20
U: Uniq=
H: Handlers=mouse1 event17
B: PROP=1
B: EV=b
B: KEY=e420 30000 0 0 0 0
B: ABS=661800011000003

Kai-Heng Feng (kaihengfeng) wrote :

drops-r,

It's a different issue. Please file a new bug.

Daniel van Vugt (vanvugt) wrote :

drops-r, please open a new bug for your issue.

Eugene Savelov (savelov) wrote :

I have the same asus x505ba, and although in latest kernel touchpad started working better, it still stops working after some time (10-15 mins).

Kai-Heng Feng (kaihengfeng) wrote :

When this issue happens, do `apport-collect 1726934`

ApportVersion: 2.20.7-0ubuntu3.6
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: mikhail 1048 F.... pulseaudio
 /dev/snd/controlC0: mikhail 1048 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 17.10
InstallationDate: Installed on 2017-10-22 (71 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
MachineType: ASUSTeK COMPUTER INC. X505BA
Package: linux (not installed)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
ProcFB: 0 amdgpudrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-22-generic.efi.signed root=UUID=346c6d11-8a1f-4d8e-bec3-523a1beb0e9b ro quiet splash
ProcVersionSignature: Ubuntu 4.13.0-22.25-generic 4.13.13
RelatedPackageVersions:
 linux-restricted-modules-4.13.0-22-generic N/A
 linux-backports-modules-4.13.0-22-generic N/A
 linux-firmware 1.169.2
Tags: wayland-session artful
Uname: Linux 4.13.0-22-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 06/27/2017
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: X505BA.303
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: X505BA
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrX505BA.303:bd06/27/2017:svnASUSTeKCOMPUTERINC.:pnX505BA:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnX505BA:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.family: X
dmi.product.name: X505BA
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

tags: added: apport-collected wayland-session

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Eugene Savelov (savelov) wrote :

this is output of evtest - worked for 18 mins, but finally stopped, these are the last lines -
Event: time 1514812803.354344, -------------- SYN_REPORT ------------
Event: time 1514812803.354927, type 3 (EV_ABS), code 53 (ABS_MT_POSITION_X), value 1868
Event: time 1514812803.354927, type 3 (EV_ABS), code 54 (ABS_MT_POSITION_Y), value 750
Event: time 1514812803.354927, -------------- SYN_REPORT ------------
Event: time 1514812803.368057, type 3 (EV_ABS), code 53 (ABS_MT_POSITION_X), value 1872
Event: time 1514812803.368057, type 3 (EV_ABS), code 54 (ABS_MT_POSITION_Y), value 781
Event: time 1514812803.368057, -------------- SYN_REPORT ------------
Event: time 1514812803.381777, type 3 (EV_ABS), code 53 (ABS_MT_POSITION_X), value 1883
Event: time 1514812803.381777, type 3 (EV_ABS), code 54 (ABS_MT_POSITION_Y), value 851
Event: time 1514812803.381777, -------------- SYN_REPORT ------------
Event: time 1514812803.382357, type 3 (EV_ABS), code 53 (ABS_MT_POSITION_X), value 1888
Event: time 1514812803.382357, type 3 (EV_ABS), code 54 (ABS_MT_POSITION_Y), value 895
Event: time 1514812803.382357, -------------- SYN_REPORT ------------
Event: time 1514812803.485414, type 3 (EV_ABS), code 57 (ABS_MT_TRACKING_ID), value -1
Event: time 1514812803.485414, type 3 (EV_ABS), code 47 (ABS_MT_SLOT), value 1
Event: time 1514812803.485414, type 3 (EV_ABS), code 57 (ABS_MT_TRACKING_ID), value -1
Event: time 1514812803.485414, type 1 (EV_KEY), code 330 (BTN_TOUCH), value 0
Event: time 1514812803.485414, type 1 (EV_KEY), code 333 (BTN_TOOL_DOUBLETAP), value 0
Event: time 1514812803.485414, -------------- SYN_REPORT ------------

Eugene Savelov (savelov) wrote :

currently my touchpad is detected by hid-multitouch module - and I assume I need to add ELAN1200:00 04F3:303E Touchpad to elan_i2c module instead, right?

Kai-Heng Feng (kaihengfeng) wrote :

It should be fixed by latest mainline kernel.
Currently there is a patch missing in Artful kernel.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers