Ubuntu often stops when starting up

Bug #172563 reported by Simon on 2007-11-28
8
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I installed Ubuntu 7.10 a few days ago. And it often stops when it starts up. It usually happens when the progress bar appears. The yellow color fills a little of the bar and then it stops. I have to restart several times before the login diaglogue box appears. My platform is AMD Athlon64 3000+ and NVIDIA nForce 570 ultra. I'm just wondering why this continue happens.

Simon (simonin2062) on 2007-11-28
description: updated
Koen Beek (koen-beek) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at [WWW] https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in usplashu.

Saivann Carignan (oxmosys) wrote :

Thanks for your bug report.

The problem that you get sounds like a Linux kernel problem ( some people experience this problem with nvidia SATA controllers ). Can you try to reproduce the boot problem with quiet
and splash option disabled? You can do this by following these steps :

1. Reboot your computer
2. Just after the BIOS screen, if the Grub boot menu does not appear, press the Esc key to make it appear before the short countdown finishes.
3. Press "e" to edit the boot options
4. Go to the line that start with "kernel" and press "e" again
5. Remove "quiet" and "splash"
6. Press "b" to boot your computer with the modified parameters.

You will now see all the outputs from the Linux kernel during the boot time before Xserver is started. If the boot process is stopped, you should see error/suspect outputs. Can you copy these outputs here in that bug report?

Can you open a terminal and copy that command : lspci -nnvv > lspci-nnvv.txt
This will create a lspci-nnvv.txt file that you can attach to this bug report.

If you have some additionnal place on your hard drive, you may want to try the latest ubuntu Hardy alpha 4 release which fixed various bugs like your one. If you can confirm that it is fixed in Hardy, you won't have to do all previous steps. Thanks for your contribution to ubuntu.

Changed in usplash:
assignee: nobody → saivann
status: New → Incomplete
Saivann Carignan (oxmosys) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Also, you might want to try if latest Hardy final release fixes the bug you describe in this bug report. Thanks again!

Changed in usplash:
assignee: saivann → nobody
status: Incomplete → Invalid
Simon (simonin2062) wrote :

In fact, after some automatic update, this problem was partly solved. I don't know what update made the contribution.
But it still occurred about every 20 or 30 times' startup. When it happened, I need to wait for about 3-5 minutes. Then the login in window appears, but usually with no sound. When I logged in, I usually found there's neither internet connection nor sound. So I need to restart. After restart, it returned to normal.
So, I guess the problem would probably be the compatibility between Ubuntu 7.10 and the sound card and network card integrated in my ASUS M2N-E motherboard.
Thank you for your concern about the problem I reported.

Changed in usplash:
status: Invalid → New
Saivann Carignan (oxmosys) wrote :

Simon : Can you try to upgrade to latest Hardy release and look if this bug still persist? And if the bug persist, can you edit your /boot/grub/menu.lst and remove all "splash" and "quiet" entries? This will remove usplash from your boot so you'll be able to see if the bug persist when usplash is disabled, your boot process will look ugly but you will have a lot of informations about what's going on, including kernel messages about the problem if you can still reproduce it.

Changed in usplash:
assignee: nobody → saivann
status: New → Incomplete
Robert Bernecky (bernecky) wrote :

I have the same problem. The system stalls at during reboot at "waiting for root file system",
and eventually (a minute or two later) drops into "initramfs"(?).

This often happens when the system does a soft reboot.
After power-on, I usually have to reboot 2 or 3 times before it takes off.
Looks like race condition of some sort.

I'm running on a two-core Opteron, with latest Hardy fixes as of 2008-05-04.

Let me know what help I can provide here, as the failure is relatively frequent,
although I do not know how to reproduce it at will.

Robert Bernecky (bernecky) wrote :

My box is an NVIDIA SATA box, too.

Robert Bernecky (bernecky) wrote :

uname -r:

2.6.24-16-generic

I'm attaching /var/log/syslog.0 and dmesg from current boot.
I realize this may not help, inasmuch as this reboot obviously worked...

Robert Bernecky (bernecky) wrote :
Robert Bernecky (bernecky) wrote :

I see a few things in the above attachments:

 I'm going to try to enable the IOMMU at 64MB, if it's not already enabled.

I also note that the boot could not find DSDT.aml, but am not sure
what to do about that.

Robert Bernecky (bernecky) wrote :

I got it to fail again; It looks like IOMMU was already set in the BIOS, as far as I can see...

After the above stall completes, we end up in initramfs, with the following message:

ATA_ID[4112] main: HDIO_GET_IDENTITY failed for /dev/.tmp-8-16

Saivann Carignan (oxmosys) wrote :

Robert Bernecky : Thanks for the informations you provide. Since your issue seems to be different (but similar) to the issues that Simon gets, can you open a new bug report for the "linux" package concerning the problems you get, including a detailed description of your bug and these informations :

    *uname -a > uname-a.log
    *cat /proc/version_signature > version.log
    *(the dmesg log that you previously attached in that bug)
    *sudo lspci -vvnn > lspci-vvnn.log

If you copy the link of your new bug report here, I will be able to subscribe myself and change the status to make sure that your bug gets a good visibility.

Robert Bernecky (bernecky) wrote :

Saivann: I've introduced a new bug report #227003, reproducing my experience with this
fault.

Thanks,. Robert

Simon (simonin2062) wrote :

Saivann: I'm so sorry that these days, I was too busy to upgrade the whole system to Hardy. Maybe we could just leave it now, as it seems to happen quite rarely now.

Sorry again.

Saivann Carignan (oxmosys) wrote :

Simon : Thanks for your fast answer. I will let the status of the bug report to incomplete. If you get some time to upgrade to Hardy, think about this bug ;) Thanks for the informations you provided so far.

Changed in usplash:
assignee: saivann → nobody
Robert Bernecky (bernecky) wrote :

This is on two up-to-date Hardy systems, both with Nvidia chipsets on ASUS motherboards, with SATA hard drives.

One system absolutely refused to boot after the Hardy upgrade. This did not make me very happy.
The other system stalls in the initramfs world about 2 times out of 3 on a power-on or reboot sequence.

What did make me happy was a crude workaround (which I do NOT consider a proper fix), of
adding "all_generic_ide" to the boot stanza in /boot/grub/menu.lst:

kernel /boot/vmlinuz-2.6.24-18-generic root=UUID=1e3fbd55-5dfa-4cee-b9c7-8bc8bd3982ff ro splash all_generic_ide

The hang has not happened since then. I have no idea of the impact of this change on performance, etc.

See also bug #222176 and #227003

Robert Bernecky (bernecky) wrote :

I upgraded the ASUS m/b BIOS per my comments in bug#227176, and
the problems went away. I consider this problem resolved, at least on my box.

Simon (simonin2062) wrote :

I updated my system to Hardy one week ago. And the problem above haven't happened yet.

Even before I upgraded the system, once the Kernel had got an automatic upgrade, the startup process never stoped like before.

Thanks! I think this problem has been solved.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers