Bluetooth and Wifi: coexistence Problem

Bug #1721271 reported by John Tanner on 2017-10-04
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Linux
Unknown
Unknown
linux (Ubuntu)
Medium
Unassigned

Bug Description

I'm currently running kernel 4.13.0-12 on Ubuntu 17.10 (daily) and have noticed that with my Intel Corporation Wireless 8260 (rev 3a) there appears to be a problem with buetooth and wifi coexistence.

Unless I disable bluetooth and/or wifi I am unable to connect to the opposite to which I have disabled.

Adding:

options iwlwifi bt_coex_active=0 swcrypto=1 11n_disable=8

To:

/etc/modprobe.d/iwlwifi.conf

Solve the problem. This is a reversion to less functionality as on earlier kernels (default kernel on 17.04) this did not occur.

This would appear to be a problem that has previously been identified with earlier versions of the Intel hardware (see https://wiki.debian.org/iwlwifi#Troubleshooting) but not with the 8260.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: linux-image-4.13.0-12-generic 4.13.0-12.13 [modified: boot/vmlinuz-4.13.0-12-generic]
ProcVersionSignature: Ubuntu 4.13.0-12.13-generic 4.13.3
Uname: Linux 4.13.0-12-generic x86_64
ApportVersion: 2.20.7-0ubuntu2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jdtanner 1141 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
Date: Wed Oct 4 15:44:16 2017
InstallationDate: Installed on 2017-10-03 (0 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Beta amd64 (20170930)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 8087:0a2b Intel Corp.
 Bus 001 Device 002: ID 05c8:03a2 Cheng Uei Precision Industry Co., Ltd (Foxlink)
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Timi TM1613
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-12-generic root=UUID=a5c4f10c-8a3a-4c18-b858-a72fd6c5aa2c ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-4.13.0-12-generic N/A
 linux-backports-modules-4.13.0-12-generic N/A
 linux-firmware 1.168
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/28/2016
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: A06
dmi.board.asset.tag: No Asset Tag
dmi.board.name: TM1613
dmi.board.vendor: Timi
dmi.board.version: A06
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Timi
dmi.chassis.version: A06
dmi.modalias: dmi:bvnInsydeCorp.:bvrA06:bd10/28/2016:svnTimi:pnTM1613:pvrA06:rvnTimi:rnTM1613:rvrA06:cvnTimi:ct10:cvrA06:
dmi.product.family: Timibook
dmi.product.name: TM1613
dmi.product.version: A06
dmi.sys.vendor: Timi

description: updated

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Further digging suggests that this bus is not present in kernel 4.12.14

Checked latest upstream kernel...bug exists

tags: added: kernel-bug-exists-upstream
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report[0]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

Please follow the instructions on the wiki page[0]. The first step is to email the appropriate mailing list. If no response is received, then a bug may be opened on bugzilla.kernel.org.

Once this bug is reported upstream, please add the tag: 'kernel-bug-reported-upstream'.

[0] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
status: Incomplete → Triaged

Bug opened on bugzilla.kernel.org as I couldn't figure out the website that you linked to (mostly an incomplete wiki).

Cheers.

tags: added: kernel-bug-reported-upstream
Simon P. (simpre) wrote :

I have a very similar problem to the one described above by John Tanner, so I thought I would add my information here instead of opening a new bug report.
My bluetooth is not working as long as I am connected to a Wifi - I cannot pair with new devices, send or receive files. I can connect to a wireless network without any problems while having bluetooth active - but bluetooth is not working any more then.
Furthermore I noticed that my Laptop is shown as "Bluemoon universal Bluetooth" on my phone instead of the proper device name.

tags: added: apport-collected

ApportVersion: 2.20.7-0ubuntu2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: simon 1286 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 17.10
EcryptfsInUse: Yes
InstallationDate: Installed on 2017-09-30 (9 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170926)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 004: ID 138a:0017 Validity Sensors, Inc. Fingerprint Reader
 Bus 001 Device 003: ID 04ca:7058 Lite-On Technology Corp.
 Bus 001 Device 010: ID 8087:0a2b Intel Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: LENOVO 20F5S0EU00
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-12-generic root=UUID=b09604a7-81d8-4279-9464-c078eda9f057 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 4.13.0-12.13-generic 4.13.3
RelatedPackageVersions:
 linux-restricted-modules-4.13.0-12-generic N/A
 linux-backports-modules-4.13.0-12-generic N/A
 linux-firmware 1.169
Tags: artful wayland-session
Uname: Linux 4.13.0-12-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo vboxusers
_MarkForUpload: True
dmi.bios.date: 09/01/2017
dmi.bios.vendor: LENOVO
dmi.bios.version: R02ET59W (1.32 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20F5S0EU00
dmi.board.vendor: LENOVO
dmi.board.version: NO DPK
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.modalias: dmi:bvnLENOVO:bvrR02ET59W(1.32):bd09/01/2017:svnLENOVO:pn20F5S0EU00:pvrThinkPadX260:rvnLENOVO:rn20F5S0EU00:rvrNODPK:cvnLENOVO:ct10:cvrNone:
dmi.product.family: ThinkPad X260
dmi.product.name: 20F5S0EU00
dmi.product.version: ThinkPad X260
dmi.sys.vendor: LENOVO

apport information

Simon P. (simpre) wrote : CRDA.txt

apport information

apport information

apport information

apport information

Simon P. (simpre) wrote : Lspci.txt

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Simon P. (simpre) wrote : RfKill.txt

apport information

Simon P. (simpre) wrote : UdevDb.txt

apport information

apport information

Tim Ruffing (8-public) wrote :

I'm pretty convinced that the linked upstream bug is different. It's a regression between 4.13 and 4.14, but this here is a regression between 4.12 and 4.13. Also the upstream bug does not mention bluetooth at all. Could you open a new upstream bug?

Erki Hallingu (erkiha) wrote :

I think this is the upstream bug: https://bugzilla.kernel.org/show_bug.cgi?id=197147, matches exactly my symptoms, Issue is present from kernel 4.13 upward.

Tim Ruffing (8-public) wrote :

Ah I see, yes. This issue here refers to https://bugzilla.kernel.org/show_bug.cgi?id=197137 instead, see above...

This bug has now been resolved upstream in the latest bluetooth firmware. Ubuntu firmware (when linux-firmware is updated) will carry this fix.

Please see:

https://bugzilla.kernel.org/show_bug.cgi?id=197147

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.