linux 4.13.0-13.14 ADT test failure with linux 4.13.0-13.14

Bug #1720779 reported by Seth Forshee on 2017-10-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Colin Ian King
Bionic
High
Colin Ian King

Bug Description

Testing failed on:
    amd64: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful-canonical-kernel-team-bootstrap/artful/amd64/l/linux/20171001_175518_8c658@/log.gz

ubuntu_stress_smoke_test is failing on amd64. It looks like stress-ng might be terminating during the procfs test.

17:41:42 DEBUG| [stdout] procfs STARTING
17:52:47 INFO | ERROR ubuntu_stress_smoke_test.stress-smoke-test ubuntu_stress_smoke_test.stress-smoke-test timestamp=1506880367 localtime=Oct 01 17:52:47 Test subprocess failed rc=9
17:52:49 INFO | END ERROR ubuntu_stress_smoke_test.stress-smoke-test ubuntu_stress_smoke_test.stress-smoke-test timestamp=1506880368 localtime=Oct 01 17:52:48

Seth Forshee (sforshee) on 2017-10-02
tags: added: kernel-adt-failure
description: updated
Seth Forshee (sforshee) on 2017-10-02
description: updated

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1720779

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
importance: Undecided → High
assignee: nobody → Colin Ian King (colin-king)
status: Incomplete → In Progress
Colin Ian King (colin-king) wrote :
Download full text (3.3 KiB)

Oops captured:

[ 207.012643] BUG: unable to handle kernel NULL pointer dereference at 0000000000000010
[ 207.012786] IP: memcpy_erms+0x6/0x10
[ 207.012787] PGD 0
[ 207.012787] P4D 0

[ 207.012788] Oops: 0000 [#1] SMP
[ 207.012789] Modules linked in: binfmt_misc snd_hda_codec_generic ppdev snd_hda_intel kvm_intel snd_hda_codec snd_hda_core kvm irqbypass snd_hwdep snd_pcm snd_timer snd joydev input_leds serio_raw soundcore qemu_fw_cfg mac_hid i2c_piix4 parport_pc parport ib_iser rdma_cm iw_cm ib_cm ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi ip_tables x_tables autofs4 btrfs raid10 raid456 async_raid6_recov async_memcpy async_pq async_xor async_tx xor raid6_pq libcrc32c raid1 raid0 multipath linear crct10dif_pclmul crc32_pclmul ghash_clmulni_intel pcbc floppy aesni_intel aes_x86_64 crypto_simd glue_helper cryptd psmouse qxl ttm drm_kms_helper syscopyarea virtio_blk sysfillrect sysimgblt fb_sys_fops drm virtio_net pata_acpi
[ 207.012813] CPU: 0 PID: 3205 Comm: Not tainted 4.13.0-13-generic #14
[ 207.012813] Hardware name: QEMU Standard PC (i440FX + PIIX, 1996), BIOS 1.10.2-1ubuntu1 04/01/2014
[ 207.012814] task: ffff90c4f511ae80 task.stack: ffffb69082aec000
[ 207.012815] RIP: 0010:memcpy_erms+0x6/0x10
[ 207.012815] RSP: 0018:ffffb69082aefe08 EFLAGS: 00010286
[ 207.012816] RAX: ffff90c4f9da92d8 RBX: 0000000000000001 RCX: 0000000000000001
[ 207.012816] RDX: 0000000000000001 RSI: 0000000000000010 RDI: ffff90c4f9da92d8
[ 207.012816] RBP: ffffb69082aefe20 R08: ffff90c4ffc1f3e0 R09: ffff90c4fb003c80
[ 207.012817] R10: ffff90c4f9da92d8 R11: ffff90c4f511ae80 R12: 0000000000000010
[ 207.012817] R13: 0000000000000000 R14: 0000000000000000 R15: 0000000000000010
[ 207.012818] FS: 00007f3b161e9740(0000) GS:ffff90c4ffc00000(0000) knlGS:0000000000000000
[ 207.012818] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[ 207.012819] CR2: 0000000000000010 CR3: 0000000132952000 CR4: 00000000001406f0
[ 207.012822] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[ 207.012822] DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400
[ 207.012822] Call Trace:
[ 207.012825] ? kmemdup+0x31/0x40
[ 207.012827] security_setprocattr+0x6b/0x330
[ 207.012829] ? _copy_from_user+0x36/0x70
[ 207.012831] proc_pid_attr_write+0xdf/0x120
[ 207.012832] __vfs_write+0x18/0x40
[ 207.012833] vfs_write+0xb5/0x1a0
[ 207.012834] SyS_write+0x55/0xc0
[ 207.012836] entry_SYSCALL_64_fastpath+0x1e/0xa9
[ 207.012837] RIP: 0033:0x7f3b14ff1cc0
[ 207.012837] RSP: 002b:00007ffe18c71af0 EFLAGS: 00000293 ORIG_RAX: 0000000000000001
[ 207.012838] RAX: ffffffffffffffda RBX: 0000000000000008 RCX: 00007f3b14ff1cc0
[ 207.012838] RDX: 0000000000000000 RSI: 00007ffe18c72b80 RDI: 0000000000000008
[ 207.012838] RBP: 0000000000000008 R08: 0000000000000000 R09: 00007f3b161e9740
[ 207.012839] R10: 0000000000000000 R11: 0000000000000293 R12: 00007ffe18c71b80
[ 207.012839] R13: 0000000000000a6b R14: 00007ffe18c72b80 R15: 00007f3b161fa000
[ 207.012840] Code: 90 90 90 90 90 eb 1e 0f 1f 00 48 89 f8 48 89 d1 48 c1 e9 03 83 e2 07 f3 48 a5 89 d1 f3 a4 c3 66 0f 1f 44 00 00 48 89 f8 48 89 d1 <f3> a4 c3 0f 1f 80 00 00 00 00 48 89 f8 48 ...

Read more...

Colin Ian King (colin-king) wrote :

The following code reproduces the bug:

#include <stdio.h>
#include <unistd.h>
#include <sys/types.h>
#include <sys/stat.h>
#include <sys/mman.h>
#include <fcntl.h>

int main(void)
{
        char path[1024];
        int fd;
        const pid_t pid = getpid();
        char buffer[1];

        snprintf(path, sizeof(path), "/proc/%d/task/%d/attr/context", pid, pid);

        fd = open(path, O_RDWR);
        if (fd >= 0) {
                (void)write(fd, buffer, 0);
                (void)close(fd);
        }
}

Colin Ian King (colin-king) wrote :

Suspect it is commit ab5e2f3f4601f6dc0d10014864f1efcf5cd047ff

    UBUNTU: SAUCE: LSM stacking: provide prctl interface for setting context

Will bisect.

Colin Ian King (colin-king) wrote :

OK, ignore the comment above. It's a simple buglet causes when the buffer in the write has a length of zero and we should be checking for that and returning -EINVAL on the invalid write length.

Launchpad Janitor (janitor) wrote :
Download full text (16.2 KiB)

This bug was fixed in the package linux - 4.13.0-15.16

---------------
linux (4.13.0-15.16) artful; urgency=low

  * linux: 4.13.0-15.16 -proposed tracker (LP: #1721373)

  * Boot regression on POWER9 (LP: #1721391)
    - Revert "crypto/nx: Add P9 NX support for 842 compression engine"
    - Revert "crypto/nx: Add P9 NX specific error codes for 842 engine"
    - Revert "crypto/nx: Use kzalloc for workmem allocation"
    - Revert "crypto/nx: Add nx842_add_coprocs_list function"
    - Revert "crypto/nx: Create nx842_delete_coprocs function"
    - Revert "crypto/nx: Create nx842_configure_crb function"
    - Revert "crypto/nx: Rename nx842_powernv_function as icswx function"
    - Revert "UBUNTU: [Config] CONFIG_PPC_VAS=y"
    - Revert "powerpc/powernv/vas: Define copy/paste interfaces"
    - Revert "powerpc/powernv/vas: Define vas_tx_win_open()"
    - Revert "powerpc/powernv/vas: Define vas_win_close() interface"
    - Revert "powerpc/powernv/vas: Define vas_rx_win_open() interface"
    - Revert "powerpc/powernv/vas: Define helpers to alloc/free windows"
    - Revert "powerpc/powernv/vas: Define helpers to init window context"
    - Revert "powerpc/powernv/vas: Define helpers to access MMIO regions"
    - Revert "powerpc/powernv/vas: Define vas_init() and vas_exit()"
    - Revert "powerpc/powernv: Move GET_FIELD/SET_FIELD to vas.h"
    - Revert "powerpc/powernv/vas: Define macros, register fields and structures"
    - Revert "powerpc/powernv: Enable PCI peer-to-peer"
    - Revert "powerpc/powernv: Add support to set power-shifting-ratio"
    - Revert "powerpc/powernv: Add support for powercap framework"
    - Revert "powerpc/perf: Add nest IMC PMU support"
    - Revert "powerpc/powernv: Detect and create IMC device"
    - Revert "powerpc/powernv: Add IMC OPAL APIs"

  * smartpqi patches for Artful (LP: #1721381)
    - scsi: smartpqi: add pqi reset quiesce support
    - scsi: smartpqi: enhance BMIC cache flush
    - scsi: smartpqi: update pqi passthru ioctl
    - scsi: smartpqi: cleanup doorbell register usage.
    - scsi: smartpqi: update kexec and power down support
    - scsi: smartpqi: add in new controller ids
    - scsi: smartpqi: change driver version to 1.1.2-125

  * CONFIG_DEBUG_FS is not enabled by "make zfcpdump_defconfig" with Ubuntu
    17.10 (kernel 4.13) (LP: #1719290)
    - SAUCE: s390: update zfcpdump_defconfig

  * [Feature] PXE boot with Intel Omni-Path (LP: #1712031)
    - d-i: Add hfi1 to nic-modules

  * [Feature]CNL:New device IDs for CNL (LP: #1685729)
    - pinctrl: intel: Add Intel Cannon Lake PCH-H pin controller support

linux (4.13.0-14.15) artful; urgency=low

  * linux: 4.13.0-14.15 -proposed tracker (LP: #1721122)

  * [Artful] ltp rwtest - Unable to handle kernel paging request at virtual
    address (LP: #1721067)
    - arm64: mm: Use READ_ONCE when dereferencing pointer to pte table

  * linux 4.13.0-13.14 ADT test failure with linux 4.13.0-13.14 (LP: #1720779)
    - SAUCE: LSM stacking: check for invalid zero sized writes

  * Add installer support for Broadcom BCM573xx network drivers. (LP: #1720466)
    - d-i: Add bnxt_en to nic-modules.

  * Miscellaneous Ubuntu changes
    - [Packaging] Include arch/arm6...

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Changed in linux (Ubuntu Bionic):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (35.7 KiB)

This bug was fixed in the package linux - 4.15.0-19.20

---------------
linux (4.15.0-19.20) bionic; urgency=medium

  * linux: 4.15.0-19.20 -proposed tracker (LP: #1766021)

  * Kernel 4.15.0-15 breaks Dell PowerEdge 12th Gen servers (LP: #1765232)
    - Revert "blk-mq: simplify queue mapping & schedule with each possisble CPU"
    - Revert "genirq/affinity: assign vectors to all possible CPUs"

linux (4.15.0-18.19) bionic; urgency=medium

  * linux: 4.15.0-18.19 -proposed tracker (LP: #1765490)

  * [regression] Ubuntu 18.04:[4.15.0-17-generic #18] KVM Guest Kernel:
    meltdown: rfi/fallback displacement flush not enabled bydefault (kvm)
    (LP: #1765429)
    - powerpc/pseries: Fix clearing of security feature flags

  * signing: only install a signed kernel (LP: #1764794)
    - [Packaging] update to Debian like control scripts
    - [Packaging] switch to triggers for postinst.d postrm.d handling
    - [Packaging] signing -- switch to raw-signing tarballs
    - [Packaging] signing -- switch to linux-image as signed when available
    - [Config] signing -- enable Opal signing for ppc64el
    - [Packaging] printenv -- add signing options

  * [18.04 FEAT] Sign POWER host/NV kernels (LP: #1696154)
    - [Packaging] signing -- add support for signing Opal kernel binaries

  * Please cherrypick s390 unwind fix (LP: #1765083)
    - s390/compat: fix setup_frame32

  * Ubuntu 18.04 installer does not detect any IPR based HDD/RAID array [S822L]
    [ipr] (LP: #1751813)
    - d-i: move ipr to storage-core-modules on ppc64el

  * drivers/gpu/drm/bridge/adv7511/adv7511.ko missing (LP: #1764816)
    - SAUCE: (no-up) rename the adv7511 drm driver to adv7511_drm

  * Miscellaneous Ubuntu changes
    - [Packaging] Add linux-oem to rebuild test blacklist.

linux (4.15.0-17.18) bionic; urgency=medium

  * linux: 4.15.0-17.18 -proposed tracker (LP: #1764498)

  * Eventual OOM with profile reloads (LP: #1750594)
    - SAUCE: apparmor: fix memory leak when duplicate profile load

linux (4.15.0-16.17) bionic; urgency=medium

  * linux: 4.15.0-16.17 -proposed tracker (LP: #1763785)

  * [18.04] [bug] CFL-S(CNP)/CNL GPIO testing failed (LP: #1757346)
    - [Config]: Set CONFIG_PINCTRL_CANNONLAKE=y

  * [Ubuntu 18.04] USB Type-C test failed on GLK (LP: #1758797)
    - SAUCE: usb: typec: ucsi: Increase command completion timeout value

  * Fix trying to "push" an already active pool VP (LP: #1763386)
    - SAUCE: powerpc/xive: Fix trying to "push" an already active pool VP

  * hisi_sas: Revert and replace SAUCE patches w/ upstream (LP: #1762824)
    - Revert "UBUNTU: SAUCE: scsi: hisi_sas: export device table of v3 hw to
      userspace"
    - Revert "UBUNTU: SAUCE: scsi: hisi_sas: config for hip08 ES"
    - scsi: hisi_sas: modify some register config for hip08
    - scsi: hisi_sas: add v3 hw MODULE_DEVICE_TABLE()

  * Realtek card reader - RTS5243 [VEN_10EC&DEV_5260] (LP: #1737673)
    - misc: rtsx: Move Realtek Card Reader Driver to misc
    - updateconfigs for Realtek Card Reader Driver
    - misc: rtsx: Add support for RTS5260
    - misc: rtsx: Fix symbol clashes

  * Mellanox [mlx5] [bionic] UBSAN: Undefined behaviour in
    ./include/linux/net_dim.h (LP: #1...

Changed in linux (Ubuntu Bionic):
status: Fix Committed → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic
Andy Whitcroft (apw) on 2019-02-14
tags: added: kernel-fixup-verification-needed-bionic
removed: verification-needed-bionic
Andy Whitcroft (apw) wrote :

This bug was erroneously marked for verification in bionic; verification is not required and verification-needed-bionic is being removed.

tags: added: verification-done-bionic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers