Cannot wake-up from sleep mode

Bug #1720622 reported by Hadrien on 2017-10-01
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Since Ubuntu 17.10 (development version) my computer can go to sleep mode but it cannot wake up. It used to work fine with Ubuntu 17.04

I tried with both Gnome and Unity. The computer correctly goes to sleep mode. I can hear the power management unit specific click when it's done.

If I try to wake up the computer (by using the power button, as I used to do on 17.04), some devices wake up like the keyboard and the mouse, but the monitor stays off.

/proc/version_signature: Ubuntu 4.13.0-12.13-generic 4.13.3

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: linux-image-4.13.0-12-generic 4.13.0-12.13
ProcVersionSignature: Ubuntu 4.13.0-12.13-generic 4.13.3
Uname: Linux 4.13.0-12-generic x86_64
ApportVersion: 2.20.7-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: hadrien 1559 F.... pulseaudio
 /dev/snd/controlC1: hadrien 1559 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
Date: Sun Oct 1 12:37:04 2017
EcryptfsInUse: Yes
InstallationDate: Installed on 2017-01-03 (270 days ago)
InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.2)
IwConfig:
 enp3s0 no wireless extensions.

 lo no wireless extensions.
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 046d:c318 Logitech, Inc. Illuminated Keyboard
 Bus 001 Device 004: ID 1532:0101 Razer USA, Ltd Copperhead Mouse
 Bus 001 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: MSI MS-7971
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcFB: 0 amdgpudrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-12-generic root=UUID=6ed824e6-8d9c-4383-913b-ca2bd564bfcb ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-4.13.0-12-generic N/A
 linux-backports-modules-4.13.0-12-generic N/A
 linux-firmware 1.168
RfKill:

SourcePackage: linux
UpgradeStatus: Upgraded to artful on 2017-09-30 (1 days ago)
dmi.bios.date: 12/21/2016
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1.H0
dmi.board.asset.tag: Default string
dmi.board.name: Z170-A PRO (MS-7971)
dmi.board.vendor: MSI
dmi.board.version: 1.0
dmi.chassis.asset.tag: Default string
dmi.chassis.type: 3
dmi.chassis.vendor: MSI
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1.H0:bd12/21/2016:svnMSI:pnMS-7971:pvr1.0:rvnMSI:rnZ170-APRO(MS-7971):rvr1.0:cvnMSI:ct3:cvr1.0:
dmi.product.family: Default string
dmi.product.name: MS-7971
dmi.product.version: 1.0
dmi.sys.vendor: MSI

Hadrien (psydk) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.14 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.14-rc3

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Hadrien (psydk) wrote :

I tried with Linux 4.14.0-041400rc3-generic, the problem is still there unfortunately.

I attached a piece of /var/log/kern.log when I did the suspend/resume.

Interesting parts:

Oct 3 21:03:28 c18 kernel: [ 62.519787] [drm:amdgpu_vce_ring_test_ring [amdgpu]] *ERROR* amdgpu: ring 14 test failed
Oct 3 21:03:28 c18 kernel: [ 62.519795] [drm:amdgpu_resume_phase2 [amdgpu]] *ERROR* resume of IP block <vce_v3_0> failed -110
Oct 3 21:03:28 c18 kernel: [ 62.519803] [drm:amdgpu_device_resume [amdgpu]] *ERROR* amdgpu_resume failed (-110).
Oct 3 21:03:28 c18 kernel: [ 62.519806] dpm_run_callback(): pci_pm_resume+0x0/0xb0 returns -110
Oct 3 21:03:28 c18 kernel: [ 62.519806] PM: Device 0000:01:00.0 failed to resume async: error -110

and:

Oct 3 21:04:21 c18 kernel: [ 115.155901] [drm:atom_op_jump [amdgpu]] *ERROR* atombios stuck in loop for more than 5secs aborting
Oct 3 21:04:21 c18 kernel: [ 115.155912] [drm:amdgpu_atom_execute_table_locked [amdgpu]] *ERROR* atombios stuck executing BFFC (len 116, WS 0, PS 0) @ 0xC049
Oct 3 21:04:21 c18 kernel: [ 115.155955] amdgpu 0000:01:00.0: ffff9ffe950e2800 unpin not necessary

It seems that my AMD RX 480 is causing the problem. I wonder who should be contacted to get more help about this hardware/driver.

Kai-Heng Feng (kaihengfeng) wrote :

My RX480 does not have this issue on v4.13-rc3. Here's the lspci output:
$ lspci -vvnn -s 27:00.0
27:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480] [1002:67df] (rev c7) (prog-if 00 [VGA controller])
        Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Radeon RX 480 [1002:0b37]
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 58
        Region 0: Memory at e0000000 (64-bit, prefetchable) [size=256M]
        Region 2: Memory at f0000000 (64-bit, prefetchable) [size=2M]
        Region 4: I/O ports at e000 [size=256]
        Region 5: Memory at fe800000 (32-bit, non-prefetchable) [size=256K]
        Expansion ROM at 000c0000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: amdgpu
        Kernel modules: amdgpu

You need to file an upstream bug at https://bugzilla.freedesktop.org/

Hadrien (psydk) wrote :

We have mostly the same lspci output, Kai Heng. I attach a picture of the comparison.

I'm going to visit https://bugzilla.freedesktop.org/ and hopefully someone will understand what is happening with that bug.

Please note that I reinstalled Ubuntu 17.10 completely (the first time was an upgrade from 17.04) to eliminate any residual component that may interfere with the test. The results are the same.

I also tried sleep mode from an USB live flash drive installation of Ubuntu 17.10. The result is a bit different: on wake-up, the monitor powers on and displays the desktop, but the desktop is frozen and only a corrupted mouse cursor can be moved.

Hadrien (psydk) wrote :
Pierre Equoy (pieq) wrote :

Hi Hadrien,

I'm facing the exact same issue with my RX 580. At first I thought it was a Wayland problem but as you describe, the same issue happens with Xorg.

Good news: Ubuntu 17.10 will receive Kernel 4.3.11 [1]

Not sure when though, but we should get it sooner rather than later :)

[1] https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1731961

Hadrien (psydk) wrote :

Oh, that's good news. Thank you for the feedback, Pierre.

Po-Hsu Lin (cypressyew) on 2017-11-17
Changed in linux (Ubuntu):
status: Incomplete → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.