Upgrade to 4.13.0-11.12 in artful amd64 VM breaks display on wayland

Bug #1718679 reported by Olivier Tilloy on 2017-09-21
78
This bug affects 14 people
Affects Status Importance Assigned to Milestone
linux (Fedora)
Fix Released
Undecided
linux (Ubuntu)
High
Seth Forshee

Bug Description

I have a virtualbox VM running artful which I upgrade every day. Today when upgrading from kernel 4.12.0-12.13 to 4.13.0-11.12, after a reboot gdm3 failed to display the login screen. All I got was a black screen, but I could access a virtual terminal.

Downgrading the kernel back to 4.12.0-12.13 fixed the issue.

jibel suggested to trying disabling wayland in gdm (by uncommenting #WaylandEnable=false in /etc/gdm3/custom.conf), and that did the trick too, but only X11 sessions were available of course.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: linux-image-4.13.0-11-generic 4.13.0-11.12
ProcVersionSignature: Ubuntu 4.13.0-11.12-generic 4.13.1
Uname: Linux 4.13.0-11-generic x86_64
ApportVersion: 2.20.7-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/pcmC0D0c: ubuntu 1726 F...m pulseaudio
 /dev/snd/pcmC0D0p: ubuntu 1726 F...m pulseaudio
 /dev/snd/controlC0: ubuntu 1726 F.... pulseaudio
 /dev/snd/timer: ubuntu 1726 f.... pulseaudio
Date: Thu Sep 21 15:40:40 2017
InstallationDate: Installed on 2017-06-07 (106 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170606.1)
IwConfig:
 enp0s3 no wireless extensions.

 lo no wireless extensions.
Lsusb:
 Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: innotek GmbH VirtualBox
ProcFB: 0 vboxdrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-11-generic root=UUID=e23963bd-97af-4402-b681-376a6fcaae62 ro quiet splash
RelatedPackageVersions:
 linux-restricted-modules-4.13.0-11-generic N/A
 linux-backports-modules-4.13.0-11-generic N/A
 linux-firmware 1.168
RfKill:

SourcePackage: linux
StagingDrivers: vboxvideo
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.board.name: VirtualBox
dmi.board.vendor: Oracle Corporation
dmi.board.version: 1.2
dmi.chassis.type: 1
dmi.chassis.vendor: Oracle Corporation
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:rvnOracleCorporation:rnVirtualBox:rvr1.2:cvnOracleCorporation:ct1:cvr:
dmi.product.family: Virtual Machine
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH

Olivier Tilloy (osomon) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: wayland
Seth Forshee (sforshee) wrote :

I've reproduced this. Attaching the journal from within the VM. There are some warnings from gnome in there, not sure what to make of most of them. These did jump out at me though.

Sep 21 10:55:00 ubuntu-test gnome-shell[917]: Failed to apply DRM plane transform 0: Invalid argument
Sep 21 10:55:00 ubuntu-test gnome-shell[917]: Failed to apply DRM plane transform 0: Invalid argument
Sep 21 10:55:00 ubuntu-test gnome-shell[917]: Failed to apply DRM plane transform 0: Invalid argument
Sep 21 10:55:00 ubuntu-test org.gnome.Shell.desktop[917]: Disabling glamor and dri3, EGL setup failed
Sep 21 10:55:00 ubuntu-test org.gnome.Shell.desktop[917]: Failed to initialize glamor, falling back to sw

Seth Forshee (sforshee) wrote :

So it seems to be the vboxvideo driver that was added to 4.13, if I blacklist that the gdm login screen appears. So a temporary workaround is to add a file named /etc/modprobe.d/vbox.conf with the contents 'blacklist vboxvideo'.

Changed in linux (Ubuntu):
assignee: nobody → Seth Forshee (sforshee)
importance: Undecided → High
Kev Bowring (flocculant) wrote :

Just for information - as I run Xubuntu

I can get vbox to boot iso to a desktop - but once there mouse in virtual machine doesn't work.

dpkg -l *wayland* |grep ii
ii libwayland-bin 1.14.0-1
ii libwayland-client0:amd64 1.14.0-1
ii libwayland-cursor0:amd64 1.14.0-1
ii libwayland-dev:amd64 1.14.0-1
ii libwayland-egl1-mesa:amd64 17.2.1-0ubuntu1
ii libwayland-server0:amd64 1.14.0-1
ii wayland-protocols 1.10-1

tags: added: rls-aa-incoming

On Fri, Sep 22, 2017 at 06:45:01AM -0000, Kev Bowring wrote:
> Just for information - as I run Xubuntu
>
> I can get vbox to boot iso to a desktop - but once there mouse in
> virtual machine doesn't work.

Does blacklisting vboxvideo inside the VM help, as described in comment
#4 (note you have to reboot after adding the vbox.conf file, I forgot to
mention that)? If not then would you please open a new bug and subscribe
me to the bug.

Is this a regression that just appeared with the 4.13 kernel update?

Thanks!

Seth Forshee (sforshee) wrote :

I also tested 4.14-rc1 and the same problem exists there.

Seth Forshee (sforshee) wrote :

I've pushed a commit to disable the vboxvideo staging driver for now.

Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
Olivier Tilloy (osomon) wrote :

Confirmed, blacklisting the vboxvideo driver fixes the issue.

DjznBR (djzn-br) wrote :

If you blacklist the vboxvideo driver, you lose the full-screen and the hardware acceleration. You forgot to mention that. I recommend pressing RIGHT SHIFT and get into GRUB menu, choose kernel 4.12 and then install synaptic, uninstall kernel 4.13 and lock version 4.12 until this is resolved. This bug appeared today around here. It's a bug in the kernel.

Seth Forshee (sforshee) wrote :

On Sat, Sep 23, 2017 at 01:08:57AM -0000, DjznBR wrote:
> If you blacklist the vboxvideo driver, you lose the full-screen and the
> hardware acceleration. You forgot to mention that. I recommend pressing
> RIGHT SHIFT and get into GRUB menu, choose kernel 4.12 and then install
> synaptic, uninstall kernel 4.13 and lock version 4.12 until this is
> resolved. This bug appeared today around here. It's a bug in the kernel.

The vboxvideo driver from the virtualbox add-ons seems to work fine,
it's only the driver in the kernel staging drivers that seems to have
problems. If you install the add-ons then remove the blacklist you'll
get full-screen and acceleration back.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1718679

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :
Download full text (7.8 KiB)

This bug was fixed in the package linux - 4.13.0-12.13

---------------
linux (4.13.0-12.13) artful; urgency=low

  * linux: 4.13.0-12.13 -proposed tracker (LP: #1718980)

  * [Feature] SKX: Support crystall ridge / far / near memory indication in PEBS
    (LP: #1591813)
    - perf/x86: Move Nehalem PEBS code to flag
    - perf/x86: Fix data source decoding for Skylake

  * Upgrade to 4.13.0-11.12 in artful amd64 VM breaks display on wayland
    (LP: #1718679)
    - [Config] CONFIG_DRM_VBOXVIDEO=n

  * ipmmu-vmsa driver breaks arm64 boots (LP: #1718734)
    - [Config] Disable CONFIG_IPMMU_VMSA on arm64

  * Vlun resize request could fail with cxlflash driver (LP: #1713575)
    - scsi: cxlflash: Fix vlun resize failure in the shrink path

  * multipath -ll is not showing the disks which are actually multipath
    (LP: #1718397)
    - fs: aio: fix the increment of aio-nr and counting against aio-max-nr

  * [Feature] Crystal Ridge - BTT - Rework error clearing (LP: #1704350)
    - libnvdimm, btt: fix a missed NVDIMM_IO_ATOMIC case in the write path
    - libnvdimm, btt: refactor map entry operations with macros
    - libnvdimm, btt: ensure that flags were also unchanged during a map_read
    - libnvdimm, btt: cache sector_size in arena_info
    - libnvdimm: fix potential deadlock while clearing errors
    - libnvdimm, btt: rework error clearing

  * [Feature] Crystal Ridge - have 4k DAX faults use a common zero page
    (LP: #1704439)
    - mm: add vm_insert_mixed_mkwrite()
    - dax: relocate some dax functions
    - dax: use common 4k zero page for dax mmap reads
    - dax: remove DAX code from page_cache_tree_insert()
    - dax: move all DAX radix tree defs to fs/dax.c

  * [bug] 17.10: CDP test fail on platform of Purley-2S/4S/Neoncity,BDW-
    de/ep/ex, (LP: #1716843)
    - SAUCE: (no-up) x86/intel_rdt: Fix cdp info directory files issue

  * [featue] GPIO support for Denverton (LP: #1591829)
    - pinctrl: intel: Add Intel Denverton pin controller support

  * ETPS/2 Elantech Touchpad inconsistently detected (Gigabyte P57W laptop)
    (LP: #1594214)
    - Input: i8042 - add Gigabyte P57 to the keyboard reset table

  * autopkgtest profile fails to build on armhf (LP: #1717920)
    - [Packaging] autopkgtest -- disable d-i when dropping flavours

  * Artful update to v4.13.3 stable release (LP: #1718412)
    - Revert "net: use lib/percpu_counter API for fragmentation mem accounting"
    - Revert "net: fix percpu memory leaks"
    - gianfar: Fix Tx flow control deactivation
    - vhost_net: correctly check tx avail during rx busy polling
    - ip6_gre: update mtu properly in ip6gre_err
    - udp: drop head states only when all skb references are gone
    - ipv6: fix memory leak with multiple tables during netns destruction
    - ipv6: fix typo in fib6_net_exit()
    - sctp: fix missing wake ups in some situations
    - tcp: fix a request socket leak
    - ip_tunnel: fix setting ttl and tos value in collect_md mode
    - f2fs: let fill_super handle roll-forward errors
    - f2fs: check hot_data for roll-forward recovery
    - x86/fsgsbase/64: Fully initialize FS and GS state in start_thread_common
    - x86/fsgsbase/64: Report FSBASE and GSBA...

Read more...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released

Description of problem:

Doing upgrade from fedora 26 workstation to fedora 27 on virtualbox
After the upgrade i got a black screen after the os start. Console are accessible and useable.

Additional info:
I have the same issue if i launch a workstation fedora 27 live image on virtualbox. The work around is to start the live image with basic graphic mode, do the installation and after the reboot the install work find without black screen.

Same issue from fedora 25 workstation to fedora 27

I can reproduce this issue with today's Fedora-27-20171015.n.0 Workstation Live compose

https://fedoraproject.org/wiki/Changes/VirtualBox_Guest_Integration

Ubuntu disabled the new upstreamed VirtualBox drivers in the Linux 4.13 kernel for Ubuntu 17.10 because of a similar issue.

CONFIG_DRM_VBOXVIDEO=n https://launchpad.net/bugs/1718679

Proposed as a Blocker for 27-final by Fedora user jbicha using the blocker tracking app because:

 This is a regression from Fedora 26 and VirtualBox is a popular way to use Fedora desktop.

https://fedoraproject.org/wiki/Changes/VirtualBox_Guest_Integration

Contingency mechanism: The proposal owner will remove the VirtualBox Guest Additions package from the default package list for the Workstation product if it is not working properly
Contingency deadline: Beta Freeze

This is fixed by this Fedora kernel commit:

http://pkgs.fedoraproject.org/cgit/rpms/kernel.git/commit/?h=f27&id=1a4bd40a9207ac83009e8f827cb08c84c3d2aa09

We are just waiting for the kernel team to kick of a new build, once that is done this is resolved.

I can confirm the fix in Ubuntu (cherry-picked from your patch)

kernel-4.13.8-300.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-aa9927961f

Discussed during the 2017-10-23 blocker review meeting: [1]

The decision to classify this bug as a RejectedBlocker and an AcceptedFreezeException was made as vbox isn't one of the officially-blocking virt technologies and a workaround is available. This is widely used however, and so warrants a FreezeException.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2017-10-23/f27-blocker-review.2017-10-23-16.00.txt

kernel-4.13.8-300.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Pushed to stable, closing.

Changed in linux (Fedora):
importance: Unknown → Undecided
status: Unknown → Fix Released

Today's workstation live Fedora-27-20171026.n.0 compose works great. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.