[Ubuntu 17.10] POWER9 - Base - Integrate P9 VAS (Virtual Accelerator Switchboard) support in kernel

Bug #1718293 reported by bugproxy on 2017-09-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Ubuntu-power-systems project
High
Canonical Server Team
linux (Ubuntu)
Undecided
Ubuntu on IBM Power Systems Bug Triage

Bug Description

This feature request is used to submit kernel changes needed for adding VAS (Virtual Accelerator Switchboard) support. VAS interface allows kernel or user space to communicate with any accelerator (Ex: NX). kernel changes will be to open a window/ channel with accelerator and communicate with copy / paste facility.

CVE References

bugproxy (bugproxy) on 2017-09-19
tags: added: architecture-ppc64le bugnameltc-140093 severity-high targetmilestone-inin1710
Changed in ubuntu:
assignee: nobody → Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage)
affects: ubuntu → linux (Ubuntu)
Frank Heimes (frank-heimes) wrote :

Looks like patches are needed, please point to the public commits/links ...

Changed in ubuntu-power-systems:
importance: Undecided → High
assignee: nobody → Canonical Server Team (canonical-server)

------- Comment From <email address hidden> 2017-09-21 07:38 EDT-------
Need those patches that I'm providing its backport.

2392c8c8c045 powerpc/powernv/vas: Define copy/paste interfaces
5239af679a07 powerpc/powernv/vas: Define vas_tx_win_open()
98271d419869 powerpc/powernv/vas: Define vas_win_close() interface
62c4eda4fabe powerpc/powernv/vas: Define vas_rx_win_open() interface
bbfe59f8a705 powerpc/powernv/vas: Define helpers to alloc/free windows
b25b33ac18b3 powerpc/powernv/vas: Define helpers to init window context
180fe15a8299 powerpc/powernv/vas: Define helpers to access MMIO regions
4dea2d1a927c powerpc/powernv/vas: Define vas_init() and vas_exit()
b6622a339e86 powerpc/powernv: Move GET_FIELD/SET_FIELD to vas.h
967689141eb3 powerpc/powernv/vas: Define macros, register fields and structures

Seth Forshee (sforshee) on 2017-09-28
Changed in linux (Ubuntu):
status: New → Fix Committed
Changed in ubuntu-power-systems:
status: New → Fix Committed
Breno Leitão (breno-leitao) wrote :

There is an indication that the tree artful master-next kernel is broken on POWER9 and it seems to be related to this patchset. I am looking at it, maybe we will need to revert it.

Launchpad Janitor (janitor) wrote :
Download full text (16.2 KiB)

This bug was fixed in the package linux - 4.13.0-15.16

---------------
linux (4.13.0-15.16) artful; urgency=low

  * linux: 4.13.0-15.16 -proposed tracker (LP: #1721373)

  * Boot regression on POWER9 (LP: #1721391)
    - Revert "crypto/nx: Add P9 NX support for 842 compression engine"
    - Revert "crypto/nx: Add P9 NX specific error codes for 842 engine"
    - Revert "crypto/nx: Use kzalloc for workmem allocation"
    - Revert "crypto/nx: Add nx842_add_coprocs_list function"
    - Revert "crypto/nx: Create nx842_delete_coprocs function"
    - Revert "crypto/nx: Create nx842_configure_crb function"
    - Revert "crypto/nx: Rename nx842_powernv_function as icswx function"
    - Revert "UBUNTU: [Config] CONFIG_PPC_VAS=y"
    - Revert "powerpc/powernv/vas: Define copy/paste interfaces"
    - Revert "powerpc/powernv/vas: Define vas_tx_win_open()"
    - Revert "powerpc/powernv/vas: Define vas_win_close() interface"
    - Revert "powerpc/powernv/vas: Define vas_rx_win_open() interface"
    - Revert "powerpc/powernv/vas: Define helpers to alloc/free windows"
    - Revert "powerpc/powernv/vas: Define helpers to init window context"
    - Revert "powerpc/powernv/vas: Define helpers to access MMIO regions"
    - Revert "powerpc/powernv/vas: Define vas_init() and vas_exit()"
    - Revert "powerpc/powernv: Move GET_FIELD/SET_FIELD to vas.h"
    - Revert "powerpc/powernv/vas: Define macros, register fields and structures"
    - Revert "powerpc/powernv: Enable PCI peer-to-peer"
    - Revert "powerpc/powernv: Add support to set power-shifting-ratio"
    - Revert "powerpc/powernv: Add support for powercap framework"
    - Revert "powerpc/perf: Add nest IMC PMU support"
    - Revert "powerpc/powernv: Detect and create IMC device"
    - Revert "powerpc/powernv: Add IMC OPAL APIs"

  * smartpqi patches for Artful (LP: #1721381)
    - scsi: smartpqi: add pqi reset quiesce support
    - scsi: smartpqi: enhance BMIC cache flush
    - scsi: smartpqi: update pqi passthru ioctl
    - scsi: smartpqi: cleanup doorbell register usage.
    - scsi: smartpqi: update kexec and power down support
    - scsi: smartpqi: add in new controller ids
    - scsi: smartpqi: change driver version to 1.1.2-125

  * CONFIG_DEBUG_FS is not enabled by "make zfcpdump_defconfig" with Ubuntu
    17.10 (kernel 4.13) (LP: #1719290)
    - SAUCE: s390: update zfcpdump_defconfig

  * [Feature] PXE boot with Intel Omni-Path (LP: #1712031)
    - d-i: Add hfi1 to nic-modules

  * [Feature]CNL:New device IDs for CNL (LP: #1685729)
    - pinctrl: intel: Add Intel Cannon Lake PCH-H pin controller support

linux (4.13.0-14.15) artful; urgency=low

  * linux: 4.13.0-14.15 -proposed tracker (LP: #1721122)

  * [Artful] ltp rwtest - Unable to handle kernel paging request at virtual
    address (LP: #1721067)
    - arm64: mm: Use READ_ONCE when dereferencing pointer to pte table

  * linux 4.13.0-13.14 ADT test failure with linux 4.13.0-13.14 (LP: #1720779)
    - SAUCE: LSM stacking: check for invalid zero sized writes

  * Add installer support for Broadcom BCM573xx network drivers. (LP: #1720466)
    - d-i: Add bnxt_en to nic-modules.

  * Miscellaneous Ubuntu changes
    - [Packaging] Include arch/arm6...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-power-systems:
status: Fix Committed → Fix Released
bugproxy (bugproxy) on 2017-10-11
tags: added: targetmilestone-inin1804
removed: targetmilestone-inin1710
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-03-21 14:14 EDT-------
Reopening this feature request.

We had an issue with paste instruction which is disabled in < DD 2.2. Now tested VAS/NX successfully with the upstream kernel on DD 2.2. All patches that are needed for VAS enablement included in 4.14 and 4.15.

VAS functionality will work only on DD 2.2 and later. So skiboot 5.10 or later is needed to use VAS/NX842.

Andrew Cloke (andrew-cloke) wrote :

Could you please raise this as a refresh issue, referencing the existing closed issue if necessary?
Many thanks.

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-03-24 22:17 EDT-------
VAS functionality is tested with NX842 compression/decompression on 18.04 kernel (4.15.7)

Frank Heimes (frank-heimes) wrote :

To sum it up:
- the feature is integrated in 18.04
- we have skiboot | 5.10~rc4-1 in 18.04
- it was successfully tested on 18.04
- and the targetmilestone was recently changed from 1710 to 1804 (the title is still 17.10)
So if I interpret all this correctly the ticket is correctly marked as Fix Released and an additional ticket doesn't need to be opened, because the target release for Power 9 is 18.04 anyway?
Please confirm - thx.

bugproxy (bugproxy) on 2018-05-17
tags: added: targetmilestone-inin1810
removed: targetmilestone-inin1804
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers