Kernel panic - not syncing: Fatal exception in interrupt

Bug #1703091 reported by Joao Luis on 2017-07-08
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)

Bug Description

I have a Clevo P150SM laptop. Recently, I have frequent kernel panics "Fatal exception in interrupt".

  Screenshot at

(I will try to upload the screenshot of the console once I have a bug number).

It happened the 1st time kernel 4.4.0-83 was installed and since yesterday's package updates was
happening almost all the time.

Today (the next morning) kernel 4.4.0-83 is booting fine.

The symptons are simular to bug 1702164

(Sometimes it gets far enough to boot the X11 interface - and then crashes, Sometimes it crashes while still in console text mode).
2 leds are blinking: "CapsLock", and the other led which is not NumLock (but I don't know what it is). NumLock is not blinking.

I alread did as root:

    apt clean
    apt install --reinstall linux-image-generic linux-image-4.4.0-83-generic
    update-initramfs -u -k 4.4.0-83-generic

but it stays the same.

(The first time I upgraded to kernel 4.4.0-83 the power went down in the middle of the upgrade, and I fixed the problem more-or-less with the commands above.).

When it crashes, I manage to boot in 4.4.0-81-generic, and it still seems to work fine.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubuntu-release-upgrader-core 1:16.04.21
ProcVersionSignature: Ubuntu 4.4.0-83.106-generic 4.4.70
Uname: Linux 4.4.0-83-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.6
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: Unity
Date: Sat Jul 8 10:01:21 2017
InstallationDate: Installed on 2014-02-15 (1238 days ago)
InstallationMedia: Ubuntu 12.04.4 LTS "Precise Pangolin" - Release amd64 (20140204)
PackageArchitecture: all
 PATH=(custom, no user)
SourcePackage: ubuntu-release-upgrader
Symptom: dist-upgrade
UpgradeStatus: Upgraded to xenial on 2016-10-29 (252 days ago)

Joao Luis (jpluis) wrote :
Joao Luis (jpluis) wrote :

Sorry for the wrong bug category, but it was my 1st contact with "ubuntu-bug" command line tool, and I did not know which category to choose.

Paul White (paulw2u) on 2017-07-08
affects: ubuntu-release-upgrader (Ubuntu) → linux (Ubuntu)

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to . Please test the latest v4.12 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.


Changed in linux (Ubuntu):
importance: Undecided → High
Joseph Salisbury (jsalisbury) wrote :

Also, does this bug go away if you boot the prior kernel version?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-da-key
Joao Luis (jpluis) wrote :

Answering first to note 5, yes.
All the times that kernel 4.4.0-83 crashed, the problem goes away if I boot my previous kernel 4.4.0-81.

kernel 4.4.0-83.106 does not crash during all the boots. Only some times. I could not figure out if they are related to cold/hot boots (in the morning always suceeds, thank goodness), CPU temperature, or any other factor.

Answering to note 4, regarding the 4.12.0-041200.201707022031 kernel it appears to solve the problem, but I can't be 100% sure.

Using the grub Advanced Ubuntu options, I performed 12 reboots, 6 reboots of each kernel 4.4.0-83.106
and 4.12.0-041200.201707022031 interleaved (boot 4.4.0-83.106, then reboot 4.12.0-041200, then reboot 4.4.0-83.106, etc...)

Kernel 4.4.0-83.106 crashed on boot (with the same error) 3 out of 6 times.

Kernel 4.12.0-041200 crashed 0 (zero) out of 6 times.

Not all reboots took a 5 second power-off interval. (The ones that kernel 4.4.0-83 crashed, did wait a few seconds before booting again).

So, the fix looks promising.

Meanwhile, I go back to kernel 4.4.0-83 or 4.4.0-81 because I need virtualbox (but I leave 4.12.0-041200 installed for now).

For my own record, the procedure I followed to install the 4.12.0-041200 was:




    sha1sum *.deb # sums looked ok
    # as root (su -) from now on

    dpkg -i *.deb
    # ...
    # ERROR (dkms apport): kernel package linux-headers-4.12.0-041200-generic is not supported (twice)
    # ...
    # lots of W: Possible missing firmware /lib/firmware/nvidia/...

But it did boot fine afterwards. (I did not attempt to remove or run virtualbox).

Joseph Salisbury (jsalisbury) wrote :

Can you also give the latest upstream 4.4 kernel a test? It is available from:

Joao Luis (jpluis) wrote :

Answering to note 7,

From 12 boot sequences (there was 2 seconds waiting in power-off mode before starting the next boot), the results where:

Kernel 4.4.0-83.106 crashed on boot (with the same error) 5 out of 6 times.

Kernel 4.4.76-040476 crashed 0 (zero) out of 6 times.

Looking good for 4.4.76-040476!

PS: No errors while installing kernel 4.4.76-040476, and virtualbox seems fine running too, although not relevant for now.

Iddo Friedberg (iddo) wrote :

Confirm that same bug also affects Dell Latitude E5450

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Eddie (edward-pimentel) wrote :

Confirm that same bug also affects Dell Precision T3600

Bill Zettler (billzet) wrote :

Confirm that same bug also affects Dell Precision M4600

Kai-Heng Feng (kaihengfeng) wrote :

Please try 4.4.0-87-generic from xenial-proposed, it has several fixes on nouveau.

Bill Zettler (billzet) wrote :

Revised report: 4.4.0-83-generic only affected one out of three Dell Precision M4600s. A quick look at their device compliment didn't reveal anything obvious. That is, the afflicted machine has the same network adapter as the other two, and the same camera device of one of the other two, and nothing unique on the USB bus.

Also, 4.4.0-87-generic seems to have fixed the problems in the affected machine.

Joao Luis (jpluis) wrote :

Replying to note 12, (I'm the guy with the Clevo P150SM)

Kernel 4.4.0-83.106 crashed on boot (with the same error) 4 out of 5 times.

Kernel 4.4.0-87.110 crashed 0 (zero) out of 5 times.

I am keeping 4.4.0-87 for now (and removed 4.4.0-87).

PS: Something weird happening while installing 4.4.0-87.110 using the normal graphical About this computer, Check of updates. The linux-headers were not installed (and virtualbox became broken). I manually installed the headers with

    # apt install linux-headers-`uname -r`

rebooted, and everything was fine afterwards.

PS2: kernel 4.4.76-040476 worked fine all this time (running virtualbox everyday) since note 11 on 2017-07-11:.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers