stack_grow_into_huge in libhugetlbfs failed on 4.4 / 4.8 / 4.10 s390x

Bug #1700123 reported by Po-Hsu Lin on 2017-06-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

There is one new failure found in the libhugetlbfs test suite on s390-zKVM (s2lp6g003) with 4.10.0-25.29

06/23 05:34:34 DEBUG| utils:0153| [stdout] stack_grow_into_huge (1024K: 64): FAIL Child not signalled

This test did not fail on 4.10.0-23

Complete log: http://pastebin.ubuntu.com/24933783/

Po-Hsu Lin (cypressyew) wrote :

This issue can be found on 4.4.0-82, Ubuntu on LPAR (s2lp3) as well.

06/23 06:02:17 DEBUG| utils:0153| [stdout] stack_grow_into_huge (1024K: 64): FAIL Child not signalled

summary: - stack_grow_into_huge in libhugetlbfs failed on 4.10 s390 zKVM
+ stack_grow_into_huge in libhugetlbfs failed on 4.4 / 4.10 s390x

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1700123

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Po-Hsu Lin (cypressyew) on 2017-06-26
summary: - stack_grow_into_huge in libhugetlbfs failed on 4.4 / 4.10 s390x
+ stack_grow_into_huge in libhugetlbfs failed on 4.4 / 4.8 / 4.10 s390x
Po-Hsu Lin (cypressyew) wrote :

This issue can be found on 4.8 Yakkety Ubuntu on LPAR, zKVM as well.

Po-Hsu Lin (cypressyew) wrote :

This test has passed with the re-spinned proposed kernel. Will mark it as Fix-Released

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers