[DP MST] No audio output through HDMI/DP/mDP ports in Dell WD15 and TB15 docking stations

Bug #1694665 reported by Chih-Hsyuan Ho on 2017-05-31
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Xenial
Undecided
Timo Aaltonen

Bug Description

[Impact]
With Ubuntu 16.04, there is no audio (output) interface shows up in Sound settings when connecting an audio capable monitors to the HDMI, mDP and DP ports in Dell WD15 and TB15 docking stations.

Fixed in 4.11-rc1 and up.

[Test case]

Hook up a HDMI/DP monitor, test that audio works.

[Regression potential]

This is a new feature. Regression testing has been conducted on non-MST setups (SKL/KBL which use i915_bpo), where HDMI/DP audio still works. i915 has been tested on BDW and HDMI audio still works.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1694665

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

Did this issue start happening after an update/upgrade? Was there a prior kernel version where you were not having this particular problem?

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.12 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.12-rc3

Changed in linux (Ubuntu):
importance: Undecided → Medium
Timo Aaltonen (tjaalton) wrote :

I have patches for this ready to go.

Changed in linux (Ubuntu Xenial):
assignee: nobody → Timo Aaltonen (tjaalton)
status: New → In Progress
Timo Aaltonen (tjaalton) wrote :

hm, dunno if yakkety/zesty have any sort of priority for this feature, could maybe mark them "wontfix"

Changed in linux (Ubuntu):
status: Incomplete → Triaged
summary: - No audio output through HDMI/DP/mDP ports in Dell WD15 and TB15 docking
- stations
+ [DP MST] No audio output through HDMI/DP/mDP ports in Dell WD15 and TB15
+ docking stations
description: updated
Timo Aaltonen (tjaalton) on 2017-06-02
description: updated
Changed in linux (Ubuntu Xenial):
status: In Progress → Fix Committed

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-xenial' to 'verification-done-xenial'. If the problem still exists, change the tag 'verification-needed-xenial' to 'verification-failed-xenial'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-xenial
ethan.hsieh (ethan.hsieh) wrote :

@klebers

There is still no HDMI/DP/mDP audio output after enabling xenial-proposed.

Test environment:
1) The installed packages (online update): log_0615-1/history.log
2) $ lsb_release -a
Distributor ID: Ubuntu
Description: Ubuntu 16.04.2 LTS
Release: 16.04
Codename: xenial
3) Kernel
4.11.0-041100rc8-generic: can see HDMI/DP/mDP audio output
4.4.0-79-generic: no HDMI/DP/mDP audio output
4.4.0-80-generic: no HDMI/DP/mDP audio output
For details, please check log_0615-1/*.png

Timo Aaltonen (tjaalton) wrote :

ethan, you need alsa daily dkms for it

Timo Aaltonen (tjaalton) wrote :

ask hwang why it failed to build ;)

tags: added: verification-failed-xenial
removed: verification-needed-xenial
Hui Wang (hui.wang) wrote :

@ethan,

I need to change alsa dkms as well, after changing it, I will tell you.

thx.

Hui Wang (hui.wang) wrote :

Just pushed the change to repository. After the version of 0616 is ready, please test with this version alsa dkms.

thx.

ethan.hsieh (ethan.hsieh) wrote :

@Hui Wang,
I ran Software Updater, but there was no 0616 in PPA.
I downloaded the package from the link below, and installed it manually.
oem-audio-hda-daily-dkms (0.201706180301~ubuntu16.04.1)
https://launchpad.net/~ubuntu-audio-dev/+archive/ubuntu/alsa-daily/+packages
I can see HDMI/Display Port in [All Settings][Sound] after installing the package.

$ uname -r
4.4.0-80-generic

Hui Wang (hui.wang) wrote :

@ethan,

OK, good. That is something we expect.

Timo Aaltonen (tjaalton) on 2017-06-21
tags: added: verification-done-xenial
removed: verification-failed-xenial
Launchpad Janitor (janitor) wrote :
Download full text (18.8 KiB)

This bug was fixed in the package linux - 4.4.0-83.106

---------------
linux (4.4.0-83.106) xenial; urgency=low

  * linux: 4.4.0-83.106 -proposed tracker (LP: #1700541)

  * CVE-2017-1000364
    - Revert "UBUNTU: SAUCE: mm: Only expand stack if guard area is hit"
    - Revert "mm: do not collapse stack gap into THP"
    - Revert "mm: enlarge stack guard gap"
    - mm: vma_adjust: remove superfluous confusing update in remove_next == 1 case
    - mm: larger stack guard gap, between vmas
    - mm: fix new crash in unmapped_area_topdown()
    - Allow stack to grow up to address space limit

linux (4.4.0-82.105) xenial; urgency=low

  * linux: 4.4.0-82.105 -proposed tracker (LP: #1699064)

  * CVE-2017-1000364
    - SAUCE: mm: Only expand stack if guard area is hit

  * linux-aws/linux-gke incorrectly producing and using linux-*-tools-
    common/linux-*-cloud-tools-common (LP: #1688579)
    - [Config] make linux-tools-common and linux-cloud-tools-common protection
      consistent

  * CVE-2017-9242
    - ipv6: fix out of bound writes in __ip6_append_data()

  * CVE-2017-9075
    - sctp: do not inherit ipv6_{mc|ac|fl}_list from parent

  * CVE-2017-9074
    - ipv6: Prevent overrun when parsing v6 header options

  * CVE-2017-9076
    - ipv6/dccp: do not inherit ipv6_mc_list from parent

  * CVE-2017-9077
    - ipv6/dccp: do not inherit ipv6_mc_list from parent

  * CVE-2017-8890
    - dccp/tcp: do not inherit mc_list from parent

  * Module signing exclusion for staging drivers does not work properly
    (LP: #1690908)
    - SAUCE: Fix module signing exclusion in package builds

  * extend-diff-ignore should use exact matches (LP: #1693504)
    - [Packaging] exact extend-diff-ignore matches

  * Dell XPS 9360 wifi 5G performance is poor (LP: #1692836)
    - SAUCE: ath10k: fix the wifi speed issue for kill 1535

  * Upgrade Redpine WLAN/BT driver to ver. 1.2.RC12 (LP: #1694607)
    - SAUCE: Redpine: Upgrade to ver. 1.2.RC12

  * [DP MST] No audio output through HDMI/DP/mDP ports in Dell WD15 and TB15
    docking stations (LP: #1694665)
    - drm/i915: Store port enum in intel_encoder
    - drm/i915: Eliminate redundant local variable definition
    - drm/i915: Switch to using port stored in intel_encoder
    - drm/i915: Move audio_connector to intel_encoder
    - drm/i915/dp: DP audio API changes for MST
    - drm/i915: abstract ddi being audio enabled
    - drm/i915/audio: extend get_saved_enc() to support more scenarios
    - drm/i915: enable dp mst audio

  * Xenial update to 4.4.70 stable release (LP: #1694621)
    - usb: misc: legousbtower: Fix buffers on stack
    - usb: misc: legousbtower: Fix memory leak
    - USB: ene_usb6250: fix DMA to the stack
    - watchdog: pcwd_usb: fix NULL-deref at probe
    - char: lp: fix possible integer overflow in lp_setup()
    - USB: core: replace %p with %pK
    - ARM: tegra: paz00: Mark panel regulator as enabled on boot
    - tpm_crb: check for bad response size
    - infiniband: call ipv6 route lookup via the stub interface
    - dm btree: fix for dm_btree_find_lowest_key()
    - dm raid: select the Kconfig option CONFIG_MD_RAID0
    - dm bufio: avoid a possible ABBA deadlock
    - dm bufio: check ...

Changed in linux (Ubuntu Xenial):
status: Fix Committed → Fix Released
Timo Aaltonen (tjaalton) wrote :

artful has 4.11, close as fixed

Changed in linux (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers