Errors: flip_done timed out during boot-up; slow boot

Bug #1685442 reported by Bart Anderson on 2017-04-22
This bug report is a duplicate of:  Bug #1542939: system freeze after vt switching. Edit Remove
60
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I had been running Ubuntu 16.04 LTS on many laptop computers (especially Dell D620, D630, E6400) with no problem.

I created a Live USB with Ubuntu 16.04.2 LTS and tried it on a Dell D630. It was very slow to boot up (about 90 seconds) as opposed to the 30-45 seconds it usually takes. For a few seconds there were error messages that included the phrase "flip_done timed out".

When the Ubuntu desktop appeared, the mouse cursor hung for a while, but then came back to life. I didn't do much testing from there. I did a Live session with the 16.04.2 LTS on a different D630 laptop, and the same problem occureed.

I Googled the problem, and found several hits.
-----------------
On an Arch forum, someone reported the problem on a Dell D630, like mine. It also occured on other laptops:
https://bbs.archlinux.org/viewtopic.php?id=218581

The suggestion was that the bug was related to kernel version 4.8.x and the 965GM chipset, which is what the D630 has.

So I tried Ubuntu Mate 16.04.2 on a Dell D620 (with a 945GM chipset) and the problem DID NOT occur.
-------------------
For a similar boot-up problem, Ubuntu Forum suggested going back to an earlier version of Ubuntu.
https://ubuntuforums.org/showthread.php?t=2348892

I tried Ubuntu Mate 16.04.1 (with the 4.4.0-31-generic kernel), and the problem did NOT occur.

So I'm solving the problem for myself by using Ubuntu Mate 16.04.1 LTS rather than 16.04.2.
---
ApportVersion: 2.20.1-0ubuntu2.5
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: test 2194 F.... pulseaudio
DistroRelease: Ubuntu 16.04
HibernationDevice: RESUME=UUID=a754e82c-72cb-44d1-9fa4-58777803b24d
InstallationDate: Installed on 2017-07-19 (0 days ago)
InstallationMedia: Ubuntu-MATE 16.04.2 LTS "Xenial Xerus" - Release amd64 (20170215)
MachineType: Dell Inc. Latitude D630
Package: linux (not installed)
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 LANGUAGE=en_US
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.8.0-36-generic root=UUID=2a3b3861-8ac7-41e0-86cf-999434bd112e ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 4.8.0-36.36~16.04.1-generic 4.8.11
PulseList:
 Error: command ['pacmd', 'list'] failed with exit code 1: Home directory not accessible: Permission denied
 No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-4.8.0-36-generic N/A
 linux-backports-modules-4.8.0-36-generic N/A
 linux-firmware 1.157.8
Tags: xenial
Uname: Linux 4.8.0-36-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

_MarkForUpload: True
dmi.bios.date: 06/04/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A19
dmi.board.name: 0KU184
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA19:bd06/04/2013:svnDellInc.:pnLatitudeD630:pvr:rvnDellInc.:rn0KU184:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude D630
dmi.sys.vendor: Dell Inc.
---
ApportVersion: 2.20.1-0ubuntu2.5
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: test 2194 F.... pulseaudio
DistroRelease: Ubuntu 16.04
HibernationDevice: RESUME=UUID=a754e82c-72cb-44d1-9fa4-58777803b24d
InstallationDate: Installed on 2017-07-19 (0 days ago)
InstallationMedia: Ubuntu-MATE 16.04.2 LTS "Xenial Xerus" - Release amd64 (20170215)
MachineType: Dell Inc. Latitude D630
Package: linux (not installed)
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 LANGUAGE=en_US
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.8.0-36-generic root=UUID=2a3b3861-8ac7-41e0-86cf-999434bd112e ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 4.8.0-36.36~16.04.1-generic 4.8.11
PulseList:
 Error: command ['pacmd', 'list'] failed with exit code 1: Home directory not accessible: Permission denied
 No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-4.8.0-36-generic N/A
 linux-backports-modules-4.8.0-36-generic N/A
 linux-firmware 1.157.8
Tags: xenial
Uname: Linux 4.8.0-36-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

_MarkForUpload: True
dmi.bios.date: 06/04/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A19
dmi.board.name: 0KU184
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA19:bd06/04/2013:svnDellInc.:pnLatitudeD630:pvr:rvnDellInc.:rn0KU184:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude D630
dmi.sys.vendor: Dell Inc.

I also have a Dell Inspiron 1525. Running on 4.9.0-2-amd64 (the Debian stretch rc2) without the video=SVIDEO-1:d parameter:

$ sudo dmesg|grep -B1 'Modules linked in'|grep -v Modules|grep -v -- --|perl -pe 's/.*?\]//'|sort|uniq -c|sort -nr
     13 encoder detached but still enabled on pipe A.
     13 connector enabled without attached crtc
     10 vblank wait timed out on crtc 1
      2 vblank wait timed out on crtc 0

And with:

$ sudo dmesg|grep -B1 'Modules linked in'|grep -v Modules|grep -v -- --|perl -pe 's/.*?\]//'|sort|uniq -c|sort -nr
      1 encoder detached but still enabled on pipe A.
      1 connector enabled without attached crtc

I can provide the more detailed backtraces if needed, but thought noting the frequency would be interesting. This kernel option stops the freezes for me & makes the computer responsive.

I'd be happy to test any kernel patches to see if they solve these issues, this laptop also has an actualy svideo port (although I don't have a cable, but could get one...)>

95 comments hidden view all 136 comments
Bart Anderson (bart-umate) wrote :
Download full text (5.0 KiB)

System info and dmesg text before error message:

$ inxi -F
System: Host: ubuntu-mate Kernel: 4.8.0-36-generic x86_64 (64 bit)
           Desktop: MATE 1.12.1 Distro: Ubuntu 16.04 xenial
Machine: System: Dell product: Latitude D630
           Mobo: Dell model: 0KU184 Bios: Dell v: A03 date: 07/23/2007
CPU: Dual core Intel Core2 Duo T7100 (-MCP-) cache: 2048 KB
           clock speeds: max: 1801 MHz 1: 1200 MHz 2: 1800 MHz
Graphics: Card: Intel Mobile GM965/GL960 Integrated Graphics Controller (primary)
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa)
           Resolution: 1440x900@60.00hz
           GLX Renderer: Mesa DRI Intel 965GM GLX Version: 2.1 Mesa 12.0.6
Audio: Card Intel 82801H (ICH8 Family) HD Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.8.0-36-generic
Network: Card-1: Broadcom NetXtreme BCM5755M Gigabit Ethernet PCI Express
           driver: tg3
           IF: enp9s0 state: up speed: 100 Mbps duplex: full
           mac: 00:1c:23:1b:d9:49
           Card-2: Intel PRO/Wireless 4965 AG or AGN [Kedron] Network Connection
           driver: iwl4965
           IF: wlp12s0 state: down mac: 00:21:5c:40:17:f1
Drives: HDD Total Size: 96.0GB (2.1% used)
           ID-1: /dev/sda model: FUJITSU_MHV2080B size: 80.0GB
           ID-2: USB /dev/sdb model: Cruzer_Glide size: 16.0GB
Partition: ID-1: swap-1 size: 2.14GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: None detected - is lm-sensors installed and configured?
Info: Processes: 183 Uptime: 6 min Memory: 917.2/1990.4MB
           Client: Shell (bash) inxi: 2.2.35

==========
dmesg
...
[ 20.990839] ------------[ cut here ]------------
[ 20.990864] WARNING: CPU: 0 PID: 114 at /build/linux-hwe-eyfT8D/linux-hwe-4.8
.0/drivers/gpu/drm/drm_irq.c:1224 drm_wait_one_vblank+0x1b6/0x1c0 [drm]
[ 20.990866] vblank wait timed out on crtc 0
[ 20.990867] Modules linked in: uas psmouse usb_storage firewire_ohci firewire
_core i915 crc_itu_t tg3 pata_acpi i2c_algo_bit ptp drm_kms_helper pps_core sysc
opyarea sysfillrect sysimgblt wmi fb_sys_fops drm video
[ 20.990892] CPU: 0 PID: 114 Comm: kworker/u4:3 Tainted: G W 4.8.
0-36-generic #36~16.04.1-Ubuntu
[ 20.990893] Hardware name: Dell Inc. Latitude D630 /0KU184,
 BIOS A03 07/23/2007
[ 20.990897] Workqueue: events_unbound async_run_entry_fn
[ 20.990900] 0000000000000286 0000000087ba6e01 ffff88cff97bb898 ffffffff83c2d7b3
[ 20.990906] ffff88cff97bb8e8 0000000000000000 ffff88cff97bb8d8 ffffffff8388313b
[ 20.990911] 000004c800000296 ffff88cff9a60000 0000000000000000 0000000000000000
[ 20.990916] Call Trace:
[ 20.990920] [<ffffffff83c2d7b3>] dump_stack+0x63/0x90
[ 20.990924] [<ffffffff8388313b>] __warn+0xcb/0xf0
[ 20.990927] [<ffffffff838831bf>] warn_slowpath_fmt+0x5f/0x80
[ 20.990931] [<ffffffff838c7025>] ? finish_wait+0x55/0x70
[ 20.990954] [<ffffffffc01a1b96>] drm_wait_one_vblank+0x1b6/0x1c0 [drm]
[ 20.990957] [<ffffffff838c74d0>] ? wake_atomic_t_function+0x60/0x60
[ 20.991017] [<ffffffffc031fcd7...

Read more...

description: updated
96 comments hidden view all 136 comments

Hi reporters,
can we test latest drm-tip and see if there are still issues seen?

Just looking into this to see if I can help - I'm guessing you want the master branch of https://cgit.freedesktop.org/drm-intel tested, is a Devuan Testing machine with 4.9.13-1 kernel and xserver-xorg 7.7+18 useful for this?

Adding tag into "Whiteboard" field - ReadyForDev
The bug still active
*Status is correct
*Platform is included
*Feature is included
*Priority and Severity correctly set
*Logs included

(In reply to andram from comment #40)
> FWIW, for me I can get around this problem by disabling the SVIDEO-1
> connector. The laptop in question does not even have a physical svideo
> connector, so no functionality is lost for me.
>
> I do this either by my patch above, or alternatively by adding
>
> video=SVIDEO-1:d
>
> to the kernel command line.

I am assuming "SVIDEO-1" stems from the line:

> [ 0.645655] [drm:update_connector_routing] [CONNECTOR:38:SVIDEO-1] using [ENCODER:39:TV-39] on [CRTC:26:crtc-0]

I seem to have the same problem (stack trace is very similar) as I have reported in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1689651.

But the workaround with disabling SVIDEO-1 doesn't work for me. So I was wondering if there are anything else I should be looking for? Or can help out with?

I am suspecting that the problem in effect renders Linux unusable on a whole lot of laptops, particularly for mine, so if there is anything that I can do, I'm happy to.

Even if the device doesn't seem to have a physical S-VIDEO connector, it possibly can be made available by using a docking station. This is the case for the Dell D630.

Nevertheless: I'd thankfully remove the S-VIDEO support in favor to a booting system :)

Maarten - were April updates related to this intended to fix this problem?Folks, do you still see the problem on your systems with the latest kernels (preferable from drm-tip)? If problem still persist please change the status as REOPENED, otherwise one can mark this as resolved.

no longer affects: ubuntu-mate
100 comments hidden view all 136 comments

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1685442

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: xenial

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Bart Anderson (bart-umate) wrote :

I installed Ubuntu Mate 16.04.2 (with no updates) onto hard disk. After reboot, I could log in, but the computer hung. Afte a second reboot, I logged in and the computer seemd to work okay. I entered the command "apport-collect 1685442" as requested. Then I entered the command a second time, since I wasn't sure it worked (I had gotten warning messages). Sorry if this made things comfusing.

I will load all updates now.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Remon Huijts (rahuijts) wrote :

This bug affected me with Ubuntu 17.04 on a Dell D630 laptop as well. I applied the workaround that was suggested on the mentioned Arch forum thread (disabling S-video). Add "video=SVIDEO-1:d" to the kernel boot options in /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=SVIDEO-1:d"

Then run "sudo update-grub" and reboot. It cut my boot time from two minutes to 40 seconds. I have no S-video connector anyway, so this works for me.

73 comments hidden view all 136 comments

I still see the problem with 4.10, 4.11 and 4.12 and I also tried kernels from drm-tip. Can anyone else confirm?

Download full text (4.3 KiB)

If below is the same error, then yes. I just tested with linux-4.13-rc6.

Kernel 3.16 is the last of the ones I tried that ran on this machine (Macbook Air 2011 edition), at least since 4.6 this is broken, and my usual way just to skip one or two releases until these stuff is fixed doesn't work.

Turning of SVIDEO doesn't help, installing microcodes doesn't help, there is no newer BIOS for this machine. And 3.16 starts being an issue with newer mice.

I gladly keep testing what you throw at me to get this finally fixed.

PS: If this is a different kind of error, I'm sorry and I'll open a new bug.

""""""""""""""""
[ 96.023467] fuse init (API version 7.26)
[ 98.449856] [drm:ironlake_crtc_enable [i915]] *ERROR* mode set failed: pipe A stuck
[ 98.504650] pipe A vblank wait timed out
[ 98.504692] ------------[ cut here ]------------
[ 98.504746] WARNING: CPU: 1 PID: 1522 at drivers/gpu/drm/i915/intel_display.c:12844 intel_atomic_commit_tail+0xe46/0xe70 [i915]
[ 98.504748] Modules linked in: fuse rfcomm cmac bnep cpufreq_conservative cpufreq_userspace cpufreq_powersave snd_hda_codec_hdmi snd_hda_codec_cirrus snd_hda_codec_generic binfmt_misc btusb btrtl nls_utf8 btbcm nls_cp437 btintel bluetooth vfat fat arc4 brcmsmac cordic brcmutil b43 sha256_ssse3 sha256_generic hmac drbg ansi_cprng ecdh_generic mac80211 hid_generic cfg80211 usb_storage ssb i915 mmc_core rfkill rng_core intel_rapl pcmcia pcmcia_core x86_pkg_temp_thermal intel_powerclamp coretemp kvm_intel kvm iTCO_wdt joydev hid_apple iTCO_vendor_support evdev irqbypass crct10dif_pclmul uvcvideo applesmc crc32_pclmul ghash_clmulni_intel input_polldev pcbc videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 snd_hda_intel drm_kms_helper videobuf2_core snd_hda_codec videodev efi_pstore aesni_intel drm snd_hda_core
[ 98.504836] aes_x86_64 media snd_hwdep crypto_simd glue_helper snd_pcm cryptd bcma asix snd_timer efivars pcspkr snd usbnet usbhid bcm5974 mii libphy i2c_algo_bit soundcore mei_me hid sg mei lpc_ich shpchp mfd_core sbs battery apple_bl sbshc video ac button acpi_cpufreq sunrpc parport_pc ppdev lp parport efivarfs ip_tables x_tables autofs4 ext4 crc16 mbcache jbd2 sd_mod ahci libahci libata crc32c_intel scsi_mod i2c_i801 i2c_core uhci_hcd ehci_pci ehci_hcd usbcore usb_common
[ 98.504913] CPU: 1 PID: 1522 Comm: Xorg Tainted: G U 4.13.0-rc6 #1
[ 98.504915] Hardware name: Apple Inc. MacBookAir4,2/Mac-742912EFDBEE19B3, BIOS MBA41.88Z.0077.B14.1510261805 10/26/2015
[ 98.504918] task: ffff88016753f040 task.stack: ffffc90000e78000
[ 98.504962] RIP: 0010:intel_atomic_commit_tail+0xe46/0xe70 [i915]
[ 98.504964] RSP: 0018:ffffc90000e7bb08 EFLAGS: 00010296
[ 98.504968] RAX: 000000000000001c RBX: ffff880168000000 RCX: 0000000000000000
[ 98.504971] RDX: ffff88016fa95ab8 RSI: ffff88016fa8ddb8 RDI: ffff88016fa8ddb8
[ 98.504973] RBP: 0000000000000000 R08: 0000000000000001 R09: 0000000000000365
[ 98.504975] R10: ffffc90000e7bb08 R11: 0000000000000000 R12: 0000000000000000
[ 98.504977] R13: 0000000000000000 R14: ffff8801696dd000 R15: 0000000000000001
[ 98.504981] FS: 00007f9fe2e2aa40(0000) GS:ffff88016fa80000(0000) knlGS:0000000000000000
[ 98.504984] CS: ...

Read more...

(In reply to Axel Kittenberger from comment #59)
>
> """"""""""""""""
> [ 96.023467] fuse init (API version 7.26)
> [ 98.449856] [drm:ironlake_crtc_enable [i915]] *ERROR* mode set failed:
> pipe A stuck
> [ 98.504650] pipe A vblank wait timed out
> [ 98.504692] ------------[ cut here ]------------
> [ 98.504746] WARNING: CPU: 1 PID: 1522 at
> drivers/gpu/drm/i915/intel_display.c:12844
> intel_atomic_commit_tail+0xe46/0xe70 [i915]
> ...
Hello Axel, this seems to be a different problem that the one reported in this bug. Could you please file a new case for this problem, including HW and SW information, and dmesg log with debug parameter. Thank you.

My problem seems to be fixed with 4.13.1 i just tried.
4.13.0-rc6 was the last I tried before still having had my issue.
Sorry for noise on this bug.

Hi, unfortunately this problem is still present on current drm-tip (894ff8f6f64647989f77705813b6c69fdb2e21a5, 4.14.0-rc2+).
The video=SVIDEO-1:d workaround works, though.
I spare you the dmesg output, intel_tv_detect and intel_get_load_detect_pipe are still in the trace.

Download full text (4.6 KiB)

OS Fedora 26

lspci | grep -i vga

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)

uname -r
4.13.4-200.fc26.i686

dmesg | grep -i 'warning: cpu'
[ 14.405111] WARNING: CPU: 0 PID: 95 at drivers/gpu/drm/drm_vblank.c:1090 drm_wait_one_vblank+0x1a1/0x1b0 [drm]
[ 14.542111] WARNING: CPU: 0 PID: 95 at drivers/gpu/drm/drm_vblank.c:1090 drm_wait_one_vblank+0x1a1/0x1b0 [drm]
[ 34.885117] WARNING: CPU: 0 PID: 27 at drivers/gpu/drm/drm_vblank.c:1090 drm_wait_one_vblank+0x1a1/0x1b0 [drm]
[ 71.237130] WARNING: CPU: 0 PID: 706 at drivers/gpu/drm/drm_vblank.c:1090 drm_wait_one_vblank+0x1a1/0x1b0 [drm]
[ 81.989128] WARNING: CPU: 0 PID: 706 at drivers/gpu/drm/drm_vblank.c:1090 drm_wait_one_vblank+0x1a1/0x1b0 [drm]
[ 110.149133] WARNING: CPU: 0 PID: 706 at drivers/gpu/drm/drm_vblank.c:1090 drm_wait_one_vblank+0x1a1/0x1b0 [drm]
[ 120.901078] WARNING: CPU: 0 PID: 706 at drivers/gpu/drm/drm_vblank.c:1090 drm_wait_one_vblank+0x1a1/0x1b0 [drm]
[ 131.653135] WARNING: CPU: 0 PID: 706 at drivers/gpu/drm/drm_vblank.c:1090 drm_wait_one_vblank+0x1a1/0x1b0 [drm]
[ 149.061172] WARNING: CPU: 0 PID: 706 at drivers/gpu/drm/drm_vblank.c:1090 drm_wait_one_vblank+0x1a1/0x1b0 [drm]

dmesg | grep -i '*error*'
[ 14.304061] [drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:30:pipe A] flip_done timed out
[ 34.784061] [drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:35:pipe B] flip_done timed out
[ 71.136064] [drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:35:pipe B] flip_done timed out
[ 81.888061] [drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:35:pipe B] flip_done timed out
[ 110.048067] [drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:35:pipe B] flip_done timed out
[ 120.800067] [drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:35:pipe B] flip_done timed out
[ 131.552061] [drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:35:pipe B] flip_done timed out
[ 148.960067] [drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:35:pipe B] flip_done timed out

dmesg not tained report
[ 14.405076] ------------[ cut here ]------------
[ 14.405111] WARNING: CPU: 0 PID: 95 at drivers/gpu/drm/drm_vblank.c:1090 drm_wait_one_vblank+0x1a1/0x1b0 [drm]
[ 14.405112] Modules linked in: i915 i2c_algo_bit drm_kms_helper syscopyarea sysfillrect sysimgblt fb_sys_fops e1000e drm serio_raw ata_generic pata_acpi ptp pps_core video
[ 14.405125] CPU: 0 PID: 95 Comm: kworker/u4:5 Not tainted 4.13.4-200.fc26.i686 #1
[ 14.405130] Hardware name: Hewlett-Packard /30D8, BIOS 68MDU Ver. F.01 07/05/2007
[ 14.405140] Workqueue: events_unbound async_run_entry_fn
[ 14.405144] task: f34733c0 task.stack: f35ce000
[ 14.405161] EIP: drm_wait_one_vblank+0x1a1/0x1b0 [drm]
[ 14.405162] EFLAGS: 00010246 CPU: 0
[ 14.405164] EAX: 0000001f EBX: f6d94000 ECX: f73d8a80 EDX: f73d3fac
[ 14.405165] ESI: 00000000 EDI: 00000000 EBP: f35cfc40 ESP: f35cfc08
[ 14.405167] DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 006...

Read more...

Decreasing priority since there are workarounds, patches and is an old HW for this issue.

I have the same problem on Ubuntu 16.04 in kernel 4.13.0-21.

|[drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:35:pipe B] flip_done timed out

I used `video=SVIDEO-1:d` kernel parameter as a workaround.

79 comments hidden view all 136 comments
ibbrowne3 (browne-allen) wrote :

Thanks Remon! Got me up and running!

RavanH (ravanhagen) wrote :

Confirmed on Mackbook 2008 both the issue (flip_done error and very slow boot) and the work-around (video=SVIDEO-1:d)

Kai-Heng Feng (kaihengfeng) wrote :

Please find the first -rc kernel between v4.5-rc* and v4.8-rc* in [1], regression happens in one of the release.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/

mlx (myxal-mxl) wrote :

Tested yesterday's bionic daily server build, issue is still present on my FSC Esprimo Mobile U9200 (Intel GM965). Hopefully, I'll find time to track down which -rc release introduced the bug.

mlx (myxal-mxl) wrote :

Strange observation - to save my eyes from the strain of looking at the old laptop's screen, I hooked up a monitor over VGA - and the stalls stopped (on both the tested 16.04 and on 18.04!! The message is still there in dmesg, so this had the positive effect of cutting down the time to find "first bad kernel" drastically.

I tested on latest 16.04, and the first kernel with the "vblank wait timed out on crtc 0" message is 4.6-rc1; 4.5-rc7 is OK. I will upload dmesg logs shortly.

mlx (myxal-mxl) wrote :
mlx (myxal-mxl) wrote :
mlx (myxal-mxl) wrote :
mlx (myxal-mxl) wrote :
mlx (myxal-mxl) wrote :

Related: https://bugs.freedesktop.org/show_bug.cgi?id=93782

Some patches are available there.

71 comments hidden view all 136 comments

First of all. Sorry about spam.
This is mass update for our bugs.

Sorry if you feel this annoying but with this trying to understand if bug still valid or not.
If bug investigation still in progress, please ignore this and I apologize!

If you think this is not anymore valid, please comment to the bug that can be closed.
If you haven't tested with our latest pre-upstream tree(drm-tip), can you do that also to see if issue is valid there still and if you cannot see issue there, please comment to the bug.

*** Bug 105878 has been marked as a duplicate of this bug. ***

*** Bug 103812 has been marked as a duplicate of this bug. ***

Download full text (4.7 KiB)

Same issue with GM965/GL960 on kernel 4.13.0-38:

# Video Card
lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 03)

# Kernel trace
[ 6053.340080] [drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:35:pipe B] flip_done timed out
[ 6053.444067] vblank wait timed out on crtc 1
[ 6053.444131] ------------[ cut here ]------------
[ 6053.444170] WARNING: CPU: 1 PID: 3993 at /build/linux-cg_do7/linux-4.13.0/drivers/gpu/drm/drm_vblank.c:1090 drm_wait_one_vblank+0x19b/0x1b0 [drm]
[ 6053.444171] Modules linked in: rfcomm pci_stub vboxpci(OE) vboxnetadp(OE) vboxnetflt(OE) vboxdrv(OE) ccm bnep btusb btrtl btbcm btintel bluetooth ecdh_generic joydev nls_iso8859_1 coretemp kvm_intel applesmc input_polldev kvm irqbypass appletouch snd_hda_codec_realtek snd_hda_codec_generic isight_firmware input_leds snd_hda_intel snd_hda_codec snd_hda_core snd_hwdep snd_pcm arc4 b43 snd_seq_midi bcma snd_seq_midi_event mac80211 lpc_ich snd_rawmidi cfg80211 snd_seq shpchp snd_seq_device snd_timer snd soundcore sbs sbshc mac_hid apple_bl cuse parport_pc ppdev lp parport ip_tables x_tables autofs4 hid_logitech_hidpp hid_apple hid_logitech_dj hid_appleir hid_generic usbhid hid ssb_hcd i915 ahci libahci firewire_ohci i2c_algo_bit drm_kms_helper pata_acpi syscopyarea firewire_core sysfillrect sysimgblt
[ 6053.444262] fb_sys_fops crc_itu_t sky2 ssb drm video
[ 6053.444274] CPU: 1 PID: 3993 Comm: Xorg Tainted: G W OE 4.13.0-38-generic #43-Ubuntu
[ 6053.444276] Hardware name: Apple Inc. MacBook4,1/Mac-F22788A9, BIOS MB41.88Z.00C1.B00.0802091535 02/09/08
[ 6053.444278] task: ffff93871c5bd800 task.stack: ffffbadf81a6c000
[ 6053.444302] RIP: 0010:drm_wait_one_vblank+0x19b/0x1b0 [drm]
[ 6053.444304] RSP: 0018:ffffbadf81a6f978 EFLAGS: 00010286
[ 6053.444308] RAX: 000000000000001f RBX: ffff9387b06a0000 RCX: 0000000000000000
[ 6053.444310] RDX: 0000000000000000 RSI: ffff9387bfd16578 RDI: ffff9387bfd16578
[ 6053.444313] RBP: ffffbadf81a6f9d8 R08: 0000000000000001 R09: 000000000000072f
[ 6053.444315] R10: ffffbadf81a6f978 R11: 0000000000000000 R12: 0000000000000001
[ 6053.444317] R13: 0000000000000170 R14: 000000000b00076a R15: 0000000000000000
[ 6053.444321] FS: 00007f8705758440(0000) GS:ffff9387bfd00000(0000) knlGS:0000000000000000
[ 6053.444324] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[ 6053.444326] CR2: 00007f5d7a5e4ea0 CR3: 000000009c556000 CR4: 00000000000006e0
[ 6053.444328] Call Trace:
[ 6053.444340] ? wait_woken+0x80/0x80
[ 6053.444431] intel_get_load_detect_pipe+0x5c6/0x640 [i915]
[ 6053.444498] intel_tv_detect+0x147/0x510 [i915]
[ 6053.444506] ? __ww_mutex_lock_slowpath+0x16/0x20
[ 6053.444524] drm_helper_probe_detect+0x50/0x90 [drm_kms_helper]
[ 6053.444536] ? drm_helper_probe_detect+0x50/0x90 [drm_kms_helper]
[ 6053.444548] drm_helper_probe_single_connector_modes+0xe1/0x790 [drm_kms_helper]
[ 6053.444553] ? __mark_inode_dirty+0x11a/0x3b0
[ 6053.444579] drm_mode_getconnector+0x159/0x340 [drm]
[ 6053.444605] ? drm_mode_connector_property_set_ioctl+0x60/0x60 [drm]
[ 6053.444626] drm_ioctl_kernel+0x5f/0xb0 [drm]
[ 6053.444647] drm_i...

Read more...

The immediate bug is that the frame counter goes AWOL as soon as the TV encoder gets enabled on 965gm. It also has other issues such as the scanline counter speeding up during the the vertical blanking period and stopping entirely for the duration of the bottom border, which means the timestamp based frame counter emulation of gen2 wouldn't work reliably either.

I have an affected machine and I started to hack together some things to fix these problems. But it's looking like I won't have time to finish that stuff in the immediate future.

Download full text (10.4 KiB)

Just adding output from my machine:

$ uname -a
Linux faxnet 4.16.4-1-ARCH #1 SMP PREEMPT Tue Apr 24 13:21:29 UTC 2018 x86_64 GNU/Linux

$ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 03)

$ dmesg | awk '/\[ cut here \]/{flag=1}/\[ end trace .* \]/{print;flag=0}flag'
[ 18.930181] ------------[ cut here ]------------
[ 18.930188] vblank wait timed out on crtc 0
[ 18.930302] WARNING: CPU: 0 PID: 148 at drivers/gpu/drm/drm_vblank.c:1073 drm_wait_one_vblank+0x169/0x170 [drm]
[ 18.930305] Modules linked in: 8021q mrp snd_hda_codec_realtek snd_hda_codec_generic nls_iso8859_1 snd_hda_intel nls_cp437 coretemp vfat snd_hda_codec fat joydev kvm_intel iTCO_wdt kvm iTCO_vendor_support snd_hda_core b43 applesmc irqbypass bcma input_polldev isight_firmware mac80211 appletouch input_leds snd_hwdep hid_apple mousedev i915 snd_pcm pcspkr cfg80211 i2c_i801 i2c_algo_bit rfkill snd_timer led_class rng_core drm_kms_helper sky2 drm sbs lpc_ich snd sbshc ac intel_agp intel_gtt evdev syscopyarea rtc_cmos soundcore agpgart mac_hid apple_bl sysfillrect shpchp sysimgblt fb_sys_fops acpi_cpufreq ip_tables x_tables crc32c_generic ext4 crc16 mbcache jbd2 fscrypto hid_appleir hid_generic usbhid hid sr_mod cdrom sd_mod ata_generic pata_acpi ssb_hcd ahci ata_piix libahci uhci_hcd libata firewire_ohci
[ 18.930457] scsi_mod firewire_core crc_itu_t ssb pcmcia ehci_pci pcmcia_core ehci_hcd mmc_core usbcore usb_common
[ 18.930484] CPU: 0 PID: 148 Comm: kworker/u4:2 Not tainted 4.16.4-1-ARCH #1
[ 18.930488] Hardware name: Apple Inc. MacBook4,1/Mac-F22788A9, BIOS MB41.88Z.00C1.B00.0802091535 02/09/08
[ 18.930500] Workqueue: events_unbound async_run_entry_fn
[ 18.930540] RIP: 0010:drm_wait_one_vblank+0x169/0x170 [drm]
[ 18.930544] RSP: 0018:ffff9ee98060bab0 EFLAGS: 00010286
[ 18.930549] RAX: 0000000000000000 RBX: ffff9bf5b8c88000 RCX: 0000000000000001
[ 18.930553] RDX: 0000000080000001 RSI: ffffffff8ee6807c RDI: 00000000ffffffff
[ 18.930557] RBP: 0000000000000000 R08: 0000000000000030 R09: 00000000000003e0
[ 18.930560] R10: 0000000000000000 R11: 0000000000000001 R12: 0000000000000000
[ 18.930564] R13: 0000000001000001 R14: ffff9bf57791b808 R15: ffff9bf5b862b400
[ 18.930569] FS: 0000000000000000(0000) GS:ffff9bf5bce00000(0000) knlGS:0000000000000000
[ 18.930574] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[ 18.930577] CR2: 00005572f7a48518 CR3: 000000004800a000 CR4: 00000000000006f0
[ 18.930580] Call Trace:
[ 18.930597] ? wait_woken+0x80/0x80
[ 18.930754] intel_get_load_detect_pipe+0x363/0x3d0 [i915]
[ 18.930889] intel_tv_detect+0x147/0x500 [i915]
[ 18.930927] ? drm_helper_probe_single_connector_modes+0xd8/0x6e0 [drm_kms_helper]
[ 18.930946] drm_helper_probe_single_connector_modes+0xd8/0x6e0 [drm_kms_helper]
[ 18.930973] drm_setup_crtcs+0x13d/0xaf0 [drm_kms_helper]
[ 18.930983] ? dequeue_entity+0x38d/0x970
[ 18.931005] __drm_fb_helper_initial_config_and_unlock+0x39/0x430 [drm_kms_helper]
[ 18.931012] ? finish_task_switch+0x85/0x2c0
[ 18.931144] intel_fbdev_initial_config+0x14/0x30 [i915]
[ 18.931154] async_run_...

*** Bug 106422 has been marked as a duplicate of this bug. ***

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed

For bug 106422 (marked as duplicate as this one) I provided the i915.vbt as requested. I hope doing a sudo cp to /tmp worked ok.

The hardware (Dell Inspiron 1525) has:
- built in screen (1280x800)
- VGA-Out
- HDMI

With the workaround, I could test built-in screen and VGA-Out work fine. As for HDMI, I don't have a cable (no big deal!)

Graphic acceleration is present.

There are no more messages in the log about slow graphics or timeouts, that is even true for 14.04 (3.13 kernel) where we had messages but no timeout.

As for that hardware the workaround is perfect.

I have read the bissect procedure, considering how slow this old hardware is (it takes quite a long time to compile a kernel!) and the fact that the workaround is about one parameter to add in /etc/default/grub and works fine on this PC with no adverse effect, I won't start bissecting. Sorry for those that have a different hardware and might loose features with the workaround.

As far as I am concerned, I am Ok with the "low" urgency on this bug. I'll remove the workaround if you ever find why there is now some timeouts in recent kernels on this "TV detection".

Dear all, as recommended by Ubuntu kernel team, after I posted automated apport messages here https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1774845, I tested:

- last ubuntu drm-tip (as of June 3rd): http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-tip/current/
- suggested patch on comment #12 on this thread (on 4.17 rc3+ kernel I already had the source)

Both tests were unsuccessful to fix the bug (unlike the workaround that makes the time-out disappear).

(In reply to Zakhar from comment #74)
> Dear all, as recommended by Ubuntu kernel team, after I posted automated
> apport messages here
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1774845, I tested:
>
> - last ubuntu drm-tip (as of June 3rd):
> http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-tip/current/
> - suggested patch on comment #12 on this thread (on 4.17 rc3+ kernel I
> already had the source)
>
> Both tests were unsuccessful to fix the bug (unlike the workaround that
> makes the time-out disappear).

Thanks for the update Zakhar, but do we still have other sources that can help us to fix this one? I wonder. Thank you again.

Castro B.
https://webtrafficgeeks.org/

ieee488 (bdwyfan) wrote :

Installed Linux Mint 19 32-bit xfce on HP 2710p.

The bug is still there.

video=SVIDEO-1:d boot option on live USB works

3 comments hidden view all 136 comments

Created attachment 142084
dmesg from old MacBook running lubuntu 18.04

Same problem here on an old MacBook running lubuntu 18.04.

A good workaround is adding "video=SVIDEO-1:d" to the grub kernel parameters.

2 comments hidden view all 136 comments

On Dell Inspiron 1525 auto upgraded from xubuntu 16.04 LTS 64bit to 18.04 LTS. This bug appeared.

Then tried clean install of Xubuntu 18.04.1 The bug appeared from moment of boot of cd. Bug present also in Ubuntu 18.04.1

Grub edit of Video=SVIDEO-1:d works.

As a committed Ubuntu fan of years going on decades, I cannot adequately express my strong disapointment that a bug serious enough to prevent effective installation for many users remains on a live LTS distro some 6 months after release even after revision to 18.04.1 I was able to fix it, (sudo edit of grub) but most affected users would be unable to and simply walk away. How many people walked and therefore never escalated this bug because they never got far enough to be able to?? Come on development team! Please remember that Ubuntu is supposed to be about ease of use and the users!!! Should do better....

This should be bisectable, but I don't think anyone has done it yet...

Thanks @Ryan for the post. I'm not sure in this case that a bisection would be the most effective cure. There must be many many legacy Dell and other machines that are affected but we never know because people give up on the install. I think the suggestion (see somewhere above) of defaulting to having the workaround "Video=SVIDEO-1:d" enabled by default would be much more useful. The probable minority of users who do need to use SVIDEO could be dealt with through release note information and pointed to a legacy driver.

As an enthusiastic and fervent champion of Ubuntu I cannot emphasize enough the negatives a fraught install/upgrade process for non-IT users inflicts upon the reputation of the project. Far better to have a few non-working features than to alienate a whole section of users with legacy machines. After all, is Ubuntu not supposed to be "Great for use with legacy machines."?? My experience rendered a working system on 16.04 LTS totally unusable by the automatic upgrade to 18.04 LTS. I am surely not alone!!!??

1 comments hidden view all 136 comments

*** Bug 108728 has been marked as a duplicate of this bug. ***

Download full text (4.2 KiB)

My vintage MacBook4,1 is obviously also affected by this:

[ 0.000000] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
[ 0.000000] ------------[ cut here ]------------
[ 0.000000] vblank wait timed out on crtc 1
[ 0.000000] WARNING: CPU: 0 PID: 1158 at drivers/gpu/drm/drm_vblank.c:1084 drm_wait_one_vblank+0x15c/0x170 [drm]
[ 0.000000] Modules linked in: ipv6 kvm_intel kvm irqbypass btusb btintel btbcm btrtl bluetooth ecdh_generic b43 mac80211 deflate efi_pstore mcryptd sha256_ssse3 joydev i915 snd_hda_codec_realtek sha256_generic snd_hda_codec_generic gpio_ich snd_hda_intel snd_hda_codec snd_hda_core applesmc input_leds drm_kms_helper hwmon appletouch isight_firmware snd_hwdep input_polldev cfg80211 drm fb_sys_fops sysimgblt sysfillrect rfkill syscopyarea snd_pcm i2c_algo_bit bcma snd_timer i2c_i801 rng_core snd pcspkr i2c_core intel_agp led_class ssb_hcd lpc_ich intel_gtt soundcore efivars apple_bl acpi_cpufreq dm_crypt ecb glue_helper crypto_simd cryptd aes_x86_64 xts algif_skcipher af_alg hid_apple dm_mod xfs udf reiserfs ntfs jfs isofs vfat msdos fat ext4 jbd2 crc16 ext2 mbcache dlm fscrypto configfs btrfs raid6_pq
[ 0.000000] zstd_compress xor libcrc32c raid1 md_mod sr_mod ide_gd_mod hid_appleir hid_generic usbhid hid uas usb_storage ide_generic firewire_sbp2 sg sd_mod ide_cd_mod cdrom pata_acpi ide_pci_generic ata_generic ata_piix ahci libahci ehci_pci ehci_hcd uhci_hcd firewire_ohci firewire_core crc_itu_t piix ssb sky2 libata usbcore usb_common
[ 0.000000] CPU: 0 PID: 1158 Comm: X Tainted: G W 4.17.6-dist #1
[ 0.000000] Hardware name: Apple Inc. MacBook4,1/Mac-F22788A9, BIOS MB41.88Z.00C1.B00.0802091535 02/09/08
[ 0.000000] RIP: 0010:drm_wait_one_vblank+0x15c/0x170 [drm]
[ 0.000000] RSP: 0018:ffffa36d402f7a08 EFLAGS: 00010286
[ 0.000000] RAX: 0000000000000000 RBX: ffff95732e4b0000 RCX: 0000000000000006
[ 0.000000] RDX: 0000000000000007 RSI: 0000000000000096 RDI: ffff95733fc15390
[ 0.000000] RBP: 0000000000000001 R08: 0000000000000030 R09: 0000000000000512
[ 0.000000] R10: 0000000000000000 R11: 0000000000000001 R12: 0000000000000000
[ 0.000000] R13: 000000000b000009 R14: ffff95732e661968 R15: ffff9573297fa800
[ 0.000000] FS: 00007f84795bbcc0(0000) GS:ffff95733fc00000(0000) knlGS:0000000000000000
[ 0.000000] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[ 0.000000] CR2: 0000000001684038 CR3: 000000012b90a000 CR4: 00000000000006f0
[ 0.000000] Call Trace:
[ 0.000000] ? wait_woken+0x80/0x80
[ 0.000000] intel_get_load_detect_pipe+0x365/0x3b0 [i915]
[ 0.000000] intel_tv_detect+0x126/0x490 [i915]
[ 0.000000] ? merge+0x59/0xb0
[ 0.000000] ? drm_modeset_lock+0x2b/0xa0 [drm]
[ 0.000000] drm_helper_probe_single_connector_modes+0xce/0x6b0 [drm_kms_helper]
[ 0.000000] drm_mode_getconnector+0x2c3/0x2f0 [drm]
[ 0.000000] ? _cond_resched+0x10/0x20
[ 0.000000] ? mutex_lock+0x9/0x30
[ 0.000000] ? drm_mode_connector_property_set_ioctl+0x50/0x50 [drm]
[ 0.000000] drm_ioctl_kernel+0x56/0xb0 [drm]
[ 0.000000] drm_ioctl+0x18d/0x350 [drm]
[ 0.000000] ? drm_mode_connector_...

Read more...

(In reply to Ville Syrjala from comment #78)
> Fixes posted:
> https://patchwork.freedesktop.org/series/52378/

Awesome, big thanks! Works for me, tested on MacBook4,1 https://www.youtube.com/watch?v=GqH21-KcFzU

(In reply to Ville Syrjala from comment #78)
> Fixes posted:
> https://patchwork.freedesktop.org/series/52378/

I can confirm that building from your git branch fixes the hangs/dmesg traces that I was seeing at boot or when switching virtual terminals. Thanks for looking into this!

*** Bug 108747 has been marked as a duplicate of this bug. ***

(In reply to Ville Syrjala from comment #78)
> Fixes posted:
> https://patchwork.freedesktop.org/series/52378/

Likewise, building the `tvout_fixes` branch results in a kernel that fixes the issue on my MacBook, which is a great result! As a complete outsider to the DRI/DRM process, how does this then get moved into the mainline kernel?

Same bug with Linux Mint MATE, kernel 4.15.0-42, GPU Intel Mobile GM965/960, module i915.
Adding "video=SVIDEO-1:d" works.

Affects also Lenovo Thinkpad R61 with Ubuntu 16.04.5 LTS.

Fix merged.

commit ed20151a7699bb2c77eba3610199789a126940c4
Author: Ville Syrjälä <email address hidden>
Date: Tue Nov 27 20:20:04 2018 +0200

    drm/vblank: Allow dynamic per-crtc max_vblank_count

commit 32db0b6501d97b09e92e70caefc74fa35aa9a8d6
Author: Ville Syrjälä <email address hidden>
Date: Tue Nov 27 22:05:50 2018 +0200

    drm/i915: Don't try to use the hardware frame counter with i965gm TV output

Should land in 5.0 hopefully.

Changed in linux:
status: Confirmed → Fix Released
Displaying first 40 and last 40 comments. View all 136 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.