touchpad not working (elan_i2c invalid report id data)

Bug #1683508 reported by Greg Lutostanski on 2017-04-17
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Sometimes upon boot mouse is not responsive. I get spammed the following in syslog every time I move the pointer:
elan_i2c i2c-ELAN1000:00: invalid report id data (1)

workaround:
sudo rmmod elan_i2c
sudo modprobe elan_i2c

fixes it until next reboot, then it is a crapshoot about whether that problem will arise after boot or not.

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: linux-image-4.10.0-19-generic 4.10.0-19.21
ProcVersionSignature: Ubuntu 4.10.0-19.21-generic 4.10.8
Uname: Linux 4.10.0-19-generic x86_64
NonfreeKernelModules: zfs zunicode zavl zcommon znvpair
ApportVersion: 2.20.4-0ubuntu4
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: lutostag 4214 F.... pulseaudio
CurrentDesktop: Unity:Unity7
Date: Mon Apr 17 16:26:12 2017
HibernationDevice: RESUME=UUID=f32bc2f0-9063-4554-8204-936f2f51ffb3
InstallationDate: Installed on 2016-09-20 (209 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 8087:0a2a Intel Corp.
 Bus 001 Device 002: ID 0bda:57cb Realtek Semiconductor Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: ASUSTeK COMPUTER INC. UX305CA
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.10.0-19-generic.efi.signed root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-4.10.0-19-generic N/A
 linux-backports-modules-4.10.0-19-generic N/A
 linux-firmware 1.164
SourcePackage: linux
UpgradeStatus: Upgraded to zesty on 2017-03-27 (20 days ago)
dmi.bios.date: 09/11/2015
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: UX305CA.201
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: UX305CA
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrUX305CA.201:bd09/11/2015:svnASUSTeKCOMPUTERINC.:pnUX305CA:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnUX305CA:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: UX305CA
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

Greg Lutostanski (lutostag) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Did this issue start happening after an update/upgrade? Was there a prior kernel version where you were not having this particular problem?

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.11 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.11-rc7

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired

Same thing with 17.10
 elan_i2c i2c-ELAN060B:00: invalid report id data (ff)
same fix

Changed in linux (Ubuntu):
status: Expired → Confirmed
Kai-Heng Feng (kaihengfeng) wrote :

Hi, can you add "elan_i2c.dyndbg=+p" to kernel parameter, and attach dmesg here?

used livecd (usb stick) of 17.10 this time
edited command before boot

cat /proc/cmdline
BOOT_IMAGE=/casper/vmlinuz.efi elan_i2c.dyndbg=+p file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash ---

last few lines (time > 1000) i tried
sudo rmmod elan_i2c
sudo modprobe elan_i2c

the workaround doesn't work anymore

Kai-Heng Feng (kaihengfeng) wrote :

What's the output of `cat /sys/class/dmi/id/product_name`?

Also, please try kernel here: http://people.canonical.com/~khfeng/lp1683508/

correction info for workaround, it doesn't work every time
output of product name is
80XS
(it is lenovo 320-15ABR notebook with AMD FX-9800P, and 8 GBram)
Can you help me how to replace kernel on live usb disk (created with startap disk creator from 17.10 iso image)

Kai-Heng Feng (kaihengfeng) wrote :

I don't know. Maybe just install Ubuntu to local disk and install the kernel?

I can confirm that this bug affects kernels up to 4.13.0-17 but it is a little better on that one.
Tested it on Ubuntu 16.04.3, Ubuntu Mate 17.10 and Linux Mint 18.3.

I have: Lenovo Ideapad 320 (very similar to @Vasilj). Today I tried to fix this bug with different methods with no results.
I tried:
All workaround provided on this site, puting different set of options into grub configuration (i8042.reset, nopnp, nomux), switching on and off elan_i2c module. Even tried changing libinput to synaptics.

In kernel lower than 4.13 xinput did not show any signs of Elana Touchpad. In kernel 4.13.0-17 xinput shows Elan Touchpad.
But the biggest improvement is that my pointer actually works for a very brief moment (30-60 sec). In this time syslog is massively flooded with "invalid report id data".

Kai-Heng Feng (kaihengfeng) wrote :

@vasilj-davidovic,
Yours seems to be the same one as LP: #1732056.

@teodor-sobczak,
If yours is not 15ABR, file a separate bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers