GPU problems on HP 15-ba009ng

Bug #1683184 reported by Paul Sonnenschein on 2017-04-16
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-amdgpu (Ubuntu)
Undecided
Unassigned

Bug Description

Problem description:
The notebook does not work when not booted using nomodeset:
It is not possible to login - after logging in the login screen shows up (sometimes the computer also shuts down, or shows information similiar to the shutdown screen (not using quiet splash boot options, so it is white text on black background)), until the login screen shows up again, only the background image is shown.

When using an USB stick, plymouth hangs after some time.

When using a text console to login instead of a graphical session, one can login, but sees how the console gets spammed with the following lines repeating itself frequently:
[ XXX.XXXXXX] AMD-Vi: Event logged [ (usually once)
[ XXX.XXXXXX] AMD-Vi: Completion-Wait loop timed out (usually twice)

When using nomodeset, things work fine, but I only get software rendering (I do not intend using the notebook as a loud heating).

During startup I found the following, potentially related messages:
(...)
[ 0.718421] ACPI Error: Method parse/execution failes [\_SB.WLBU._STA] (Node
ffff94cad68b6b68), AE_NOT_FOUND (20160930/psparse-543)
[ 6.291431] amd_gpio AMD0030:00: Failed to get gpio IRQ.
(plymouth started showing some boot screen)

And, during a different startup (please note this is transcribed from an older photo, Ubuntu version can be an early version of zesty, but also might be yakkety):
(...)
[ 12.950688] amdgpu 0000:05:00.0:fence driver on ring 10 use gpu addr 0x00000001000000b0, cpu addr 0xffff8a4fcb63d0b0
[ 12.954029] can't get the mac of 5
[ 12.960416] [drm] ring test on 0 succeeded in 16 usecs
(other ring tests, until:)
[ 12.966726] [drm] ring test on 10 succeeded in 6 usecs
[ 12.967789] [drm] ib test on ring 0 succeeded
(other ib test, until:)
[ 12.985277] [drm] ib test on ring 10 succeeded
[ 12.985277] [drm] Initialized amdgpu 3.9.0 20150101 for 0000:05:00.0 on minor 1
Begin: Loading essential drivers ... done.
(...)

Ubuntu version:
Ubuntu 17.04
(16.04 had less problems, with 16.10 installation failed)

Hardware:
Notebook: HP 15-ba009ng
CPU: AMD A10-9600P
GPU: AMD Radeon R7 M440 4 GB DDR3-RAM
(according to the web page of the vendor)

xorg version: 1:7.7+16ubuntu3

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: xorg 1:7.7+16ubuntu3
ProcVersionSignature: Ubuntu 4.10.0-19.21-generic 4.10.8
Uname: Linux 4.10.0-19-generic x86_64
.tmp.unity_support_test.1:

ApportVersion: 2.20.4-0ubuntu4
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity:Unity7
Date: Sun Apr 16 22:24:26 2017
DistUpgraded: 2017-03-11 13:02:33,428 DEBUG apt btrfs snapshots supported: True
DistroCodename: zesty
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] Carrizo [1002:9874] (rev ca) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Carrizo [103c:81fa]
   Subsystem: Hewlett-Packard Company Topaz XT [Radeon R7 M260/M265 / M340/M360 / M440/M445] [103c:81fa]
InstallationDate: Installed on 2016-12-25 (112 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
MachineType: HP HP Notebook
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.10.0-19-generic.efi.signed root=UUID=af212aa7-7cfe-4e46-a312-da2a25fb0df1 ro rootflags=subvol=@ nomodeset
Renderer: Software
SourcePackage: xorg
UpgradeStatus: Upgraded to zesty on 2017-03-11 (36 days ago)
dmi.bios.date: 09/01/2016
dmi.bios.vendor: Insyde
dmi.bios.version: F.17
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: 81FA
dmi.board.vendor: HP
dmi.board.version: 67.34
dmi.chassis.type: 10
dmi.chassis.vendor: HP
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsyde:bvrF.17:bd09/01/2016:svnHP:pnHPNotebook:pvrType1ProductConfigId:rvnHP:rn81FA:rvr67.34:cvnHP:ct10:cvrChassisVersion:
dmi.product.name: HP Notebook
dmi.product.version: Type1ProductConfigId
dmi.sys.vendor: HP
version.compiz: compiz 1:0.9.13.1+17.04.20170109-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.76-1
version.libgl1-mesa-dri: libgl1-mesa-dri 17.0.3-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 17.0.3-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.19.3-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.5-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.9.0-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20170309-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.14-0ubuntu1
xserver.bootTime: Sun Apr 16 22:14:33 2017
xserver.configfile: default
xserver.errors:
 open /dev/dri/card0: No such file or directory
 open /dev/dri/card0: No such file or directory
 Screen 0 deleted because of no matching config section.
 AIGLX: reverting to software rendering
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.19.3-1ubuntu1

I think this package matches my report better.
Sorry for eventually caused inconvenience.

affects: xorg (Ubuntu) → xserver-xorg-video-amdgpu (Ubuntu)
description: updated
Craig Stein (whitebunnyflock) wrote :

I can confirm that I have this exact same issue with and AMD APU A10-8700P in an Acer E5-552G-T324 with the two graphics cards (the second being a Topaz XT [Radeon R7 M260/M265 / M340/M360 / M440/M445]).

When i take out nomodeset in the grub config and run sudo update-grub and then reboot my screen gets spammed multiple times with "AMD-Vi: Completion-Wait loop timed out". As Paul Sonnenschein reported nomodeset kills my 3D rendering and I would very much like to be able to have that. Also this machine mostly works good under Ubuntu Mate 16.04.2 except my screen flickers when switching to the screensaver and on boot up.

Please let me know if I should upload further information in relation to this as I am new at reporting bugs.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-amdgpu (Ubuntu):
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :

it's a kernel bug

Test a newer mainline kernel from

http://kernel.ubuntu.com/~kernel-ppa/mainline/

v4.11 and if it's still bad, try drm-next. Download linux-image-...-generic...amd64.deb and install manually, then reboot.

Changed in linux (Ubuntu):
status: New → Incomplete
Craig Stein (whitebunnyflock) wrote :

Ok I tried two kernel packages both with and without nomodeset enabled in the grub file, first tried the v4.11 image and specifically file named linux-image-4.11.0-041100-generic_4.11.0-041100.201705041534_amd64.deb. This gave me errors similar to the above including multiple "AMD-Vi: Completion-Wait loop timed out" and a bunch of disk checks that kept failing. I then uninstalled the above package and tried a kernel image from drm-next and specifically package "linux-image-4.11.0-996-generic_4.11.0-996.201705122201_amd64.deb". Without nomodeset enabled in the grub config it provided the same errors as above. For both packages I simply used the command sudo dpkg -i packagename.deb. And to uninstall the first kernel I used sudo apt-get purge linux-image.....

Timo Aaltonen (tjaalton) wrote :

thanks for testing, would you mind filing this upstream?

https://bugs.freedesktop.org/

product DRI, component DRM/amdgpu

Changed in linux (Ubuntu):
status: Incomplete → Triaged
Timo Aaltonen (tjaalton) wrote :

thanks!

I have made an interesting observation:
When booting disabling IOMMU with amd_iommu=off in the kernel command line the system seems to work fine yet.
I haven't extensively tested this, but yet I have no crash while creating this comment, multiple successful reboots, and

  $ glxinfo | grep Open

reports:
OpenGL renderer string: Gallium 0.4 on AMD CARRIZO (DRM 3.9.0 / 4.10.0-20-generic, LLVM 4.0.0)

Also, glxgears supports vsync now, and when executing

  $ vblank_mode=0 glxgears

the reported framerate is about ~10 times higher then with software rendering.

The idea comes from a different bug, which however also differs in its description: https://bugs.freedesktop.org/show_bug.cgi?id=100591

Changed in linux:
importance: Unknown → Critical
status: Unknown → Confirmed
Craig Stein (whitebunnyflock) wrote :

thanks Timo and Paul

Craig Stein (whitebunnyflock) wrote :

I can now confirm that the patch provided in the https://bugs.freedesktop.org/show_bug.cgi?id=101029 fixes my problem, i was finally able to patch and compile the source code for the kernel and was able to boot into the system without crashing. What is the process now to get this patch applied in Ubuntu? How long will it be until it is applied? Also how can i stay in the loop as i will wait to upgrade my main drive until this is in the ubuntu kernel?

Craig Stein (whitebunnyflock) wrote :

I can confirm that Kernel 4.13 in ubuntu 17.10 beta 2 fixes this problem. No work around is needed to boot into the system or live media.

dino99 (9d9) wrote :
Changed in linux (Ubuntu):
status: Triaged → Fix Released
Changed in xserver-xorg-video-amdgpu (Ubuntu):
status: Confirmed → Invalid
Changed in linux:
importance: Critical → Undecided
status: Confirmed → New
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.