ubuntu_bpf test fail to build on aarch64 system

Bug #1675395 reported by Po-Hsu Lin on 2017-03-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned
Nominated for Artful by Po-Hsu Lin
Nominated for Bionic by Po-Hsu Lin
Zesty
Medium
Unassigned

Bug Description

# make
for TARGET in bpf; do \
 make -C $TARGET; \
done;
make[1]: Entering directory '/home/ubuntu/autotest-client-tests/ubuntu_bpf/linux/tools/testing/selftests/bpf'
gcc -Wall -O2 -I../../../../usr/include test_verifier.c -o test_verifier
In file included from test_verifier.c:23:0:
/usr/include/linux/bpf_perf_event.h:13:17: error: field ‘regs’ has incomplete type
  struct pt_regs regs;
                 ^~~~
<builtin>: recipe for target 'test_verifier' failed
make[1]: *** [test_verifier] Error 1
make[1]: Leaving directory '/home/ubuntu/autotest-client-tests/ubuntu_bpf/linux/tools/testing/selftests/bpf'
Makefile:18: recipe for target 'all' failed
make: *** [all] Error 2

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: linux-image-4.10.0-13-generic 4.10.0-13.15
ProcVersionSignature: Ubuntu 4.10.0-13.15-generic 4.10.1
Uname: Linux 4.10.0-13-generic aarch64
AlsaDevices:
 total 0
 crw-rw---- 1 root audio 116, 1 Mar 23 04:39 seq
 crw-rw---- 1 root audio 116, 33 Mar 23 04:39 timer
AplayDevices: Error: [Errno 2] No such file or directory: 'aplay'
ApportVersion: 2.20.4-0ubuntu2
Architecture: arm64
ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord'
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
Date: Thu Mar 23 12:23:15 2017
IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig'
Lsusb: Error: command ['lsusb'] failed with exit code 1:
PciMultimedia:

ProcFB:

ProcKernelCmdLine: console=ttyS0,9600n8r ro
RelatedPackageVersions:
 linux-restricted-modules-4.10.0-13-generic N/A
 linux-backports-modules-4.10.0-13-generic N/A
 linux-firmware 1.164
RfKill: Error: [Errno 2] No such file or directory: 'rfkill'
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)

Po-Hsu Lin (cypressyew) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Seth Forshee (sforshee) wrote :

I note that the test uses the master branch of the upstream linux repo (which I'll point out is not ideal for getting reliable test results), and that there's a commit to fix build errors with this test introduced during 4.11.

commit 1da8ac7c49fb2879ba95006d8bd1095e6870ea1a
Author: Alexei Starovoitov <email address hidden>
Date: Fri Mar 10 22:05:55 2017 -0800

    selftests/bpf: fix broken build

    Recent merge of 'linux-kselftest-4.11-rc1' tree broke bpf test build.
    None of the tests were building and test_verifier.c had tons of compiler errors.
    Fix it and add #ifdef CAP_IS_SUPPORTED to support old versions of libcap.
    Tested on centos 6.8 and 7

When I tried running the steps manually in a VM with the current upstream master branch it built fine. So maybe this was a transient error caused by an upstream bug; I'd suggest retrying to see if the problem has been fixed.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Po-Hsu Lin (cypressyew) wrote :

Hi Seth,

I checked in both of our kernel repositories (launchpad[1] and kernel.ubuntu.com[2]), they didn't include this patch.

So, I tried to build this bpf test from upstream repo [3], this issue is still affecting me with the same error message on aarch64 system. (You will need to install libelf-dev and libcap-dev)

[1] https://git.launchpad.net/~ubuntu-kernel/ubuntu/+source/linux/+git/zesty
[2] git://kernel.ubuntu.com/ubuntu/ubuntu-zesty.git
[3] https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: kernel-da-key
Changed in linux (Ubuntu Zesty):
status: Incomplete → Triaged
Po-Hsu Lin (cypressyew) on 2018-02-23
tags: added: bionic
Po-Hsu Lin (cypressyew) wrote :

It can be built on Bionic now. But still not working on Artful
I will keep this bug open.

tags: removed: bionic
Po-Hsu Lin (cypressyew) on 2018-06-12
Changed in linux (Ubuntu Zesty):
status: Triaged → Won't Fix
Sean Feole (sfeole) wrote :

Hi Sam, any reason to keep this open , asking because of your comment #5.

 very old bug, with no action on it, marking bug as incomplete and will close in 5 days if no update.

Changed in ubuntu-kernel-tests:
status: New → Incomplete
Changed in linux (Ubuntu):
status: Triaged → Incomplete
Po-Hsu Lin (cypressyew) wrote :

Hi Sean,

I was keeping this for Artful, since it has EOL'd and fixed in Bionic,
we can close this one.

Thanks

Changed in ubuntu-kernel-tests:
status: Incomplete → Fix Released
Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
status: Won't Fix → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers