Zesty update to v4.10.3 stable release

Bug #1673118 reported by Tim Gardner on 2017-03-15
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Zesty
Undecided
Unassigned

Bug Description

SRU Justification

    Impact:
       The upstream process for stable tree updates is quite similar
       in scope to the Ubuntu SRU process, e.g., each patch has to
       demonstrably fix a bug, and each patch is vetted by upstream
       by originating either directly from a mainline/stable Linux tree or
       a minimally backported form of that patch. The v4.10.3 upstream stable
       patch set is now available. It should be included in the Ubuntu
       kernel as well.

       git://git.kernel.org/

    TEST CASE: TBD

       The following patches from the v4.10.3 stable release shall be applied:

serial: 8250_pci: Add MKS Tenta SCOM-0800 and SCOM-0801 cards
KVM: s390: Disable dirty log retrieval for UCONTROL guests
KVM: VMX: use correct vmcs_read/write for guest segment selector/base
Bluetooth: Add another AR3012 04ca:3018 device
phy: qcom-ufs: Don't kfree devres resource
phy: qcom-ufs: Fix misplaced jump label
s390/qdio: clear DSCI prior to scanning multiple input queues
s390/dcssblk: fix device size calculation in dcssblk_direct_access()
s390/kdump: Use "LINUX" ELF note name instead of "CORE"
s390/chsc: Add exception handler for CHSC instruction
s390: TASK_SIZE for kernel threads
s390/topology: correct allocation of topology information
s390: make setup_randomness work
s390: use correct input data address for setup_randomness
net: mvpp2: fix DMA address calculation in mvpp2_txq_inc_put()
cxl: Prevent read/write to AFU config space while AFU not configured
cxl: fix nested locking hang during EEH hotplug
brcmfmac: fix incorrect event channel deduction
mnt: Tuck mounts under others instead of creating shadow/side mounts.
IB/ipoib: Fix deadlock between rmmod and set_mode
IB/IPoIB: Add destination address when re-queue packet
IB/mlx5: Fix out-of-bound access
IB/SRP: Avoid using IB_MR_TYPE_SG_GAPS
IB/srp: Avoid that duplicate responses trigger a kernel bug
IB/srp: Fix race conditions related to task management
Btrfs: fix data loss after truncate when using the no-holes feature
orangefs: Use RCU for destroy_inode
memory/atmel-ebi: Fix ns <-> cycles conversions
tracing: Fix return value check in trace_benchmark_reg()
ktest: Fix child exit code processing
ceph: remove req from unsafe list when unregistering it
target: Fix NULL dereference during LUN lookup + active I/O shutdown
drivers/pci/hotplug: Handle presence detection change properly
drivers/pci/hotplug: Fix initial state for empty slot
nlm: Ensure callback code also checks that the files match
pwm: pca9685: Fix period change with same duty cycle
xtensa: move parse_tag_fdt out of #ifdef CONFIG_BLK_DEV_INITRD
nfit, libnvdimm: fix interleave set cookie calculation
mac80211: flush delayed work when entering suspend
mac80211: don't reorder frames with SN smaller than SSN
mac80211: don't handle filtered frames within a BA session
mac80211: use driver-indicated transmitter STA only for data frames
drm/amdgpu: add more cases to DCE11 possible crtc mask setup
drm/amdgpu/pm: check for headless before calling compute_clocks
Revert "drm/amdgpu: update tile table for oland/hainan"
drm/ast: Fix AST2400 POST failure without BMC FW or VBIOS
drm/radeon: handle vfct with multiple vbios images
drm/edid: Add EDID_QUIRK_FORCE_8BPC quirk for Rotel RSX-1058
drm/ttm: Make sure BOs being swapped out are cacheable
drm/vmwgfx: Work around drm removal of control nodes
drm/imx: imx-tve: Do not set the regulator voltage
drm/atomic: fix an error code in mode_fixup()
drm/i915/gvt: Disable access to stolen memory as a guest
drm: Cancel drm_fb_helper_dirty_work on unload
drm: Cancel drm_fb_helper_resume_work on unload
drm/i915: Recreate internal objects with single page segments if dmar fails
drm/i915: Avoid spurious WARNs about the wrong pipe in the PPS code
drm/i915: Check for timeout completion when waiting for the rq to submitted
drm/i915: Pass timeout==0 on to i915_gem_object_wait_fence()
drm/i915: Fix not finding the VBT when it overlaps with OPREGION_ASLE_EXT
libceph: use BUG() instead of BUG_ON(1)
x86, mm: fix gup_pte_range() vs DAX mappings
x86/tlb: Fix tlb flushing when lguest clears PGE
thp: fix another corner case of munlock() vs. THPs
mm: do not call mem_cgroup_free() from within mem_cgroup_alloc()
kasan: resched in quarantine_remove_cache()
fat: fix using uninitialized fields of fat_inode/fsinfo_inode
drivers: hv: Turn off write permission on the hypercall page
Linux 4.10.3

Tim Gardner (timg-tpi) on 2017-03-15
tags: added: kernel-stable-tracking-bug
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :
Download full text (17.1 KiB)

This bug was fixed in the package linux - 4.10.0-14.16

---------------
linux (4.10.0-14.16) zesty; urgency=low

  [ Tim Gardner ]

  * Release Tracking Bug
    - LP: #1673805

  * msleep() bug causes Nuvoton I2C TPM device driver delays (LP: #1667567)
    - tpm: msleep() delays - replace with usleep_range() in i2c nuvoton driver
    - SAUCE: tpm: add sleep only for retry in i2c_nuvoton_write_status()

  * C++ demangling support missing from perf (LP: #1396654)
    - [Config] added binutils-dev to Build-deps

  * dm-queue-length module is not included in installer/initramfs (LP: #1673350)
    - [Config] d-i: Also add dm-queue-length to multipath modules

  * move aufs.ko from -extra to linux-image package (LP: #1673498)
    - [config] aufs.ko moved to linux-image package

  * Using an NVMe drive causes huge power drain (LP: #1664602)
    - nvme: Add a quirk mechanism that uses identify_ctrl
    - nvme: Enable autonomous power state transitions

  * Broadcom bluetooth modules sometimes fail to initialize (LP: #1483101)
    - Bluetooth: btbcm: Add a delay for module reset

  * Need support of Broadcom bluetooth device [413c:8143] (LP: #1166113)
    - Bluetooth: btusb: Add support for 413c:8143

  * Zesty update to v4.10.3 stable release (LP: #1673118)
    - serial: 8250_pci: Add MKS Tenta SCOM-0800 and SCOM-0801 cards
    - KVM: s390: Disable dirty log retrieval for UCONTROL guests
    - KVM: VMX: use correct vmcs_read/write for guest segment selector/base
    - Bluetooth: Add another AR3012 04ca:3018 device
    - phy: qcom-ufs: Don't kfree devres resource
    - phy: qcom-ufs: Fix misplaced jump label
    - s390/qdio: clear DSCI prior to scanning multiple input queues
    - s390/dcssblk: fix device size calculation in dcssblk_direct_access()
    - s390/kdump: Use "LINUX" ELF note name instead of "CORE"
    - s390/chsc: Add exception handler for CHSC instruction
    - s390: TASK_SIZE for kernel threads
    - s390/topology: correct allocation of topology information
    - s390: make setup_randomness work
    - s390: use correct input data address for setup_randomness
    - net: mvpp2: fix DMA address calculation in mvpp2_txq_inc_put()
    - cxl: Prevent read/write to AFU config space while AFU not configured
    - cxl: fix nested locking hang during EEH hotplug
    - brcmfmac: fix incorrect event channel deduction
    - mnt: Tuck mounts under others instead of creating shadow/side mounts.
    - IB/ipoib: Fix deadlock between rmmod and set_mode
    - IB/IPoIB: Add destination address when re-queue packet
    - IB/mlx5: Fix out-of-bound access
    - IB/SRP: Avoid using IB_MR_TYPE_SG_GAPS
    - IB/srp: Avoid that duplicate responses trigger a kernel bug
    - IB/srp: Fix race conditions related to task management
    - Btrfs: fix data loss after truncate when using the no-holes feature
    - orangefs: Use RCU for destroy_inode
    - memory/atmel-ebi: Fix ns <-> cycles conversions
    - tracing: Fix return value check in trace_benchmark_reg()
    - ktest: Fix child exit code processing
    - ceph: remove req from unsafe list when unregistering it
    - target: Fix NULL dereference during LUN lookup + active I/O shutdown
    - drivers/pci/hotplug: Han...

Changed in linux (Ubuntu Zesty):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers