Zesty update to v4.10.2 stable release

Bug #1672544 reported by Tim Gardner on 2017-03-13
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Zesty
Undecided
Unassigned

Bug Description

SRU Justification

    Impact:
       The upstream process for stable tree updates is quite similar
       in scope to the Ubuntu SRU process, e.g., each patch has to
       demonstrably fix a bug, and each patch is vetted by upstream
       by originating either directly from a mainline/stable Linux tree or
       a minimally backported form of that patch. The v4.10.2 upstream stable
       patch set is now available. It should be included in the Ubuntu
       kernel as well.

       git://git.kernel.org/

    TEST CASE: TBD

       The following patches from the v4.10.2 stable release shall be applied:

MIPS: pic32mzda: Fix linker error for pic32_get_pbclk()
MIPS: Fix special case in 64 bit IP checksumming.
MIPS: BCM47XX: Fix button inversion for Asus WL-500W
MIPS: OCTEON: Fix copy_from_user fault handling for large buffers
MIPS: Lantiq: Keep ethernet enabled during boot
MIPS: Clear ISA bit correctly in get_frame_info()
MIPS: Prevent unaligned accesses during stack unwinding
MIPS: Fix get_frame_info() handling of microMIPS function size
MIPS: Fix is_jump_ins() handling of 16b microMIPS instructions
MIPS: Calculate microMIPS ra properly when unwinding the stack
MIPS: Handle microMIPS jumps in the same way as MIPS32/MIPS64 jumps
mmc: sdhci-acpi: support deferred probe
am437x-vpfe: always assign bpp variable
uvcvideo: Fix a wrong macro
media: fix dm1105.c build error
cxd2820r: fix gpio null pointer dereference
dvb-usb: don't use stack for firmware load
lirc_dev: LIRC_{G,S}ET_REC_MODE do not work
media: Properly pass through media entity types in entity enumeration
ext4: fix deadlock between inline_data and ext4_expand_extra_isize_ea()
spi: s3c64xx: fix inconsistency between binding and driver
ARM: at91: define LPDDR types
ARM: dts: at91: Enable DMA on sama5d4_xplained console
ARM: dts: at91: Enable DMA on sama5d2_xplained console
ALSA: hda/realtek - Cannot adjust speaker's volume on a Dell AIO
ALSA: hda - fix Lewisburg audio issue
ALSA: timer: Reject user params with too small ticks
ALSA: ctxfi: Fallback DMA mask to 32bit
ALSA: seq: Fix link corruption by event error handling
ALSA: hda - Add subwoofer support for Dell Inspiron 17 7000 Gaming
ALSA: hda - Fix micmute hotkey problem for a lenovo AIO machine
hwmon: (it87) Do not overwrite bit 2..6 of pwm control registers
hwmon: (it87) Ensure that pwm control cache is current before updating values
staging: greybus: loopback: fix broken udelay
staging/lustre/lnet: Fix allocation size for sv_cpt_data
staging: rtl: fix possible NULL pointer dereference
coresight: STM: Balance enable/disable
coresight: fix kernel panic caused by invalid CPU
regulator: Fix regulator_summary for deviceless consumers
tpm_tis: use default timeout value if chip reports it as zero
tpm_tis: fix the error handling of init_tis()
iommu/vt-d: Fix some macros that are incorrectly specified in intel-iommu
iommu/vt-d: Tylersburg isoch identity map check is done too late.
CIFS: Fix splice read for non-cached files
mm, devm_memremap_pages: hold device_hotplug lock over mem_hotplug_{begin, done}
mm/page_alloc: fix nodes for reclaim in fast path
mm: vmpressure: fix sending wrong events on underflow
mm: do not access page->mapping directly on page_endio
mm balloon: umount balloon_mnt when removing vb device
mm, vmscan: cleanup lru size claculations
mm, vmscan: consider eligible zones in get_scan_count
sigaltstack: support SS_AUTODISARM for CONFIG_COMPAT
ipc/shm: Fix shmat mmap nil-page protection
ima: fix ima_d_path() possible race with rename
PM / devfreq: Fix available_governor sysfs
PM / devfreq: Fix wrong trans_stat of passive devfreq device
dm cache: fix corruption seen when using cache > 2TB
dm stats: fix a leaked s->histogram_boundaries array
dm round robin: revert "use percpu 'repeat_count' and 'current_path'"
dm raid: fix data corruption on reshape request
scsi: qla2xxx: Cleaned up queue configuration code.
scsi: qla2xxx: Fix response queue count for Target mode.
scsi: qla2xxx: Fix Regression introduced by pci_alloc_irq_vectors_affinity call.
Revert "scsi: aacraid: Reorder Adapter status check"
scsi: aacraid: Reorder Adapter status check
scsi: use 'scsi_device_from_queue()' for scsi_dh
power: reset: at91-poweroff: timely shutdown LPDDR memories
Fix: Disable sys_membarrier when nohz_full is enabled
jbd2: don't leak modified metadata buffers on an aborted journal
block/loop: fix race between I/O and set_status
loop: fix LO_FLAGS_PARTSCAN hang
ext4: Include forgotten start block on fallocate insert range
ext4: do not polute the extents cache while shifting extents
ext4: trim allocation requests to group size
ext4: fix data corruption in data=journal mode
ext4: fix use-after-iput when fscrypt contexts are inconsistent
ext4: fix inline data error paths
ext4: preserve the needs_recovery flag when the journal is aborted
ext4: return EROFS if device is r/o and journal replay is needed
ext4: fix fencepost in s_first_meta_bg validation
samples/seccomp: fix 64-bit comparison macros
mei: remove support for broken parallel read
ath10k: fix boot failure in UTF mode/testmode
ath5k: drop bogus warning on drv_set_key with unsupported cipher
ath9k: fix race condition in enabling/disabling IRQs
ath9k: use correct OTP register offsets for the AR9340 and AR9550
PCI: hv: Fix wslot_to_devfn() to fix warnings on device removal
PCI: altera: Fix TLP_CFG_DW0 for TLP write
Drivers: hv: vmbus: Raise retry/wait limits in vmbus_post_msg()
crypto: xts - Add ECB dependency
crypto: testmgr - Pad aes_ccm_enc_tv_template vector
crypto: xts - Propagate NEED_FALLBACK bit
crypto: api - Add crypto_requires_off helper
fuse: add missing FR_FORCE
x86/pkeys: Check against max pkey to avoid overflows
arm/arm64: KVM: Enforce unconditional flush to PoC when mapping to stage-2
arm64: dma-mapping: Fix dma_mapping_error() when bypassing SWIOTLB
arm64: fix erroneous __raw_read_system_reg() cases
KVM: arm/arm64: vgic: Stop injecting the MSI occurrence twice
Revert "arm64: mm: set the contiguous bit for kernel mappings where appropriate"
iio: pressure: mpl115: do not rely on structure field ordering
iio: pressure: mpl3115: do not rely on structure field ordering
can: gs_usb: Don't use stack memory for USB transfers
can: usb_8dev: Fix memory leak of priv->cmd_msg_buffer
w1: don't leak refcount on slave attach failure in w1_attach_slave_device()
w1: ds2490: USB transfer buffers need to be DMAable
usb: musb: da8xx: Remove CPPI 3.0 quirk and methods
usb: dwc3: gadget: skip Set/Clear Halt when invalid
usb: host: xhci: plat: check hcc_params after add hcd
usb: gadget: udc-core: Rescan pending list on driver unbind
usb: gadget: udc: fsl: Add missing complete function.
usb: gadget: f_hid: fix: Free out requests
usb: gadget: f_hid: fix: Prevent accessing released memory
usb: gadget: f_hid: Use spinlock instead of mutex
usb: gadget: f_hid: fix: Move IN request allocation to set_alt()
hv: allocate synic pages for all present CPUs
hv: init percpu_list in hv_synic_alloc()
Drivers: hv: vmbus: Prevent sending data on a rescinded channel
Drivers: hv: vmbus: Fix a rescind handling bug
Drivers: hv: util: kvp: Fix a rescind processing issue
Drivers: hv: util: Fcopy: Fix a rescind processing issue
Drivers: hv: util: Backup: Fix a rescind processing issue
RDMA/core: Fix incorrect structure packing for booleans
rdma_cm: fail iwarp accepts w/o connection params
gfs2: Add missing rcu locking for glock lookup
remoteproc: qcom: mdt_loader: Don't overwrite firmware object
rtlwifi: Fix alignment issues
rtlwifi: rtl8192c-common: Fix "BUG: KASAN:
VME: restore bus_remove function causing incomplete module unload
nfsd: minor nfsd_setattr cleanup
nfsd: special case truncates some more
NFSv4: Fix memory and state leak in _nfs4_open_and_get_state
NFSv4: Fix reboot recovery in copy offload
pNFS/flexfiles: If the layout is invalid, it must be updated before retrying
Revert "NFSv4.1: Handle NFS4ERR_BADSESSION/NFS4ERR_DEADSESSION replies to OP_SEQUENCE"
NFSv4: fix getacl head length estimation
NFSv4: fix getacl ERANGE for some ACL buffer sizes
f2fs: fix a problem of using memory after free
f2fs: fix multiple f2fs_add_link() calls having same name
f2fs: add ovp valid_blocks check for bg gc victim to fg_gc
f2fs: avoid to issue redundant discard commands
f2fs: Fix zoned block device support
rtc: sun6i: Disable the build as a module
rtc: sun6i: Add some locking
rtc: sun6i: Switch to the external oscillator
md linear: fix a race between linear_add() and linear_congested()
bcma: use (get|put)_device when probing/removing device driver
mtd: nand: ifc: Fix location of eccstat registers for IFC V1.0
dmaengine: ipu: Make sure the interrupt routine checks all interrupts.
xprtrdma: Fix Read chunk padding
xprtrdma: Per-connection pad optimization
xprtrdma: Disable pad optimization by default
xprtrdma: Reduce required number of send SGEs
powerpc/xmon: Fix data-breakpoint
powerpc/mm: Add MMU_FTR_KERNEL_RO to possible feature mask
module: fix memory leak on early load_module() failures
MIPS: IP22: Reformat inline assembler code to modern standards.
MIPS: IP22: Fix build error due to binutils 2.25 uselessnes.
ceph: update readpages osd request according to size of pages
Linux 4.10.2

Tim Gardner (timg-tpi) on 2017-03-13
tags: added: kernel-stable-tracking-bug
description: updated
Launchpad Janitor (janitor) wrote :
Download full text (17.1 KiB)

This bug was fixed in the package linux - 4.10.0-14.16

---------------
linux (4.10.0-14.16) zesty; urgency=low

  [ Tim Gardner ]

  * Release Tracking Bug
    - LP: #1673805

  * msleep() bug causes Nuvoton I2C TPM device driver delays (LP: #1667567)
    - tpm: msleep() delays - replace with usleep_range() in i2c nuvoton driver
    - SAUCE: tpm: add sleep only for retry in i2c_nuvoton_write_status()

  * C++ demangling support missing from perf (LP: #1396654)
    - [Config] added binutils-dev to Build-deps

  * dm-queue-length module is not included in installer/initramfs (LP: #1673350)
    - [Config] d-i: Also add dm-queue-length to multipath modules

  * move aufs.ko from -extra to linux-image package (LP: #1673498)
    - [config] aufs.ko moved to linux-image package

  * Using an NVMe drive causes huge power drain (LP: #1664602)
    - nvme: Add a quirk mechanism that uses identify_ctrl
    - nvme: Enable autonomous power state transitions

  * Broadcom bluetooth modules sometimes fail to initialize (LP: #1483101)
    - Bluetooth: btbcm: Add a delay for module reset

  * Need support of Broadcom bluetooth device [413c:8143] (LP: #1166113)
    - Bluetooth: btusb: Add support for 413c:8143

  * Zesty update to v4.10.3 stable release (LP: #1673118)
    - serial: 8250_pci: Add MKS Tenta SCOM-0800 and SCOM-0801 cards
    - KVM: s390: Disable dirty log retrieval for UCONTROL guests
    - KVM: VMX: use correct vmcs_read/write for guest segment selector/base
    - Bluetooth: Add another AR3012 04ca:3018 device
    - phy: qcom-ufs: Don't kfree devres resource
    - phy: qcom-ufs: Fix misplaced jump label
    - s390/qdio: clear DSCI prior to scanning multiple input queues
    - s390/dcssblk: fix device size calculation in dcssblk_direct_access()
    - s390/kdump: Use "LINUX" ELF note name instead of "CORE"
    - s390/chsc: Add exception handler for CHSC instruction
    - s390: TASK_SIZE for kernel threads
    - s390/topology: correct allocation of topology information
    - s390: make setup_randomness work
    - s390: use correct input data address for setup_randomness
    - net: mvpp2: fix DMA address calculation in mvpp2_txq_inc_put()
    - cxl: Prevent read/write to AFU config space while AFU not configured
    - cxl: fix nested locking hang during EEH hotplug
    - brcmfmac: fix incorrect event channel deduction
    - mnt: Tuck mounts under others instead of creating shadow/side mounts.
    - IB/ipoib: Fix deadlock between rmmod and set_mode
    - IB/IPoIB: Add destination address when re-queue packet
    - IB/mlx5: Fix out-of-bound access
    - IB/SRP: Avoid using IB_MR_TYPE_SG_GAPS
    - IB/srp: Avoid that duplicate responses trigger a kernel bug
    - IB/srp: Fix race conditions related to task management
    - Btrfs: fix data loss after truncate when using the no-holes feature
    - orangefs: Use RCU for destroy_inode
    - memory/atmel-ebi: Fix ns <-> cycles conversions
    - tracing: Fix return value check in trace_benchmark_reg()
    - ktest: Fix child exit code processing
    - ceph: remove req from unsafe list when unregistering it
    - target: Fix NULL dereference during LUN lookup + active I/O shutdown
    - drivers/pci/hotplug: Han...

Changed in linux (Ubuntu Zesty):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers